VNC Dateien erstellen

borgadmin
Goto Top
Guten Abend allerseits,

ich habe in meinem Netzwerk auf sämtlichen Clients das aktuelle UltraVNC installiert. Ich möchte nun für jeden Client auf meinem Server eine Datei haben die ich einfach nur ausführen muss, damit eine VNC Verbindung mit dem entsprechenden Client aufgebaut wird. Das Passwort muss dabei nicht einmal mit angegeben werden (Ist optional.)

Ich habe schon versucht eine Verbindung über den Viewer zu einem Client manuell aufzubauen ( hat geklappt) und diese dann zu speichern. Er legt mir dann eine .vnc Datei an, allerdings wirft diese einen Fehler wenn ich sie per Doppelklick ausführen möchte. Hat jemand eine Idee wie ich das lösen könnte ?

Content-Key: 104850

Url: https://administrator.de/contentid/104850

Ausgedruckt am: 22.05.2022 um 13:05 Uhr

Mitglied: DerWoWusste
DerWoWusste 28.12.2008 um 20:24:04 Uhr
Goto Top
Welchen Fehler "wirft" sie denn? Klappt normalerweise. Diese Dateien können vervielfältigt werden und dann per notepad angepasst werden.
Mitglied: D3S3RT
D3S3RT 28.12.2008 um 20:27:02 Uhr
Goto Top
wahrscheinlich ein "ist mit keinem Programm verknüpft" Fehler , also öffnen mit: VNC angeben, und fertig.

Ich hab hier auch 6 Links aufm Desktop :) face-smile
Mitglied: borgadmin
borgadmin 28.12.2008 um 21:50:57 Uhr
Goto Top
Er wirft:

Invalid VNC Server specified
Usage includes:
vncviewer[/8bit][/swapmouse]..........
Mitglied: DerWoWusste
DerWoWusste 28.12.2008 um 23:10:43 Uhr
Goto Top
Aha... danach solltest Du Googlen. Es gibt auch UVNC Foren.
Du könntest zum Einstieg
A mal Deine vnc-Datei per notepad öffnen und hier reinkopieren
B statt des Namens testhalber eine IP verwenden.
Mitglied: D3S3RT
D3S3RT 29.12.2008 um 10:10:33 Uhr
Goto Top
dann stell testweise mal von 8bit farbtiefe auf 16bit farbtiefe hoch. Und Mouseemulation auf "zwei tasten maus"
Mitglied: 60730
60730 29.12.2008, aktualisiert am 18.10.2012 um 18:36:43 Uhr
Goto Top
Servus,

schau dir mal diese Anleitung an, anstatt von allen Clients eine Verknüpfung auf den Desktop anzulegen.

Gruß
Mitglied: borgadmin
borgadmin 30.12.2008 um 11:19:15 Uhr
Goto Top
Hi, danke für den Tipp,

ich will das ganze aber noch weiter ausbauen und in eine Webanwendung integrieren, es ist also kein Probleme mehrere vnc Verknüpfungen zu haben. Leider Funktioniert es immer noch nicht, hier ist mal die .vnc Datei:



[connection]
host=192.168.2.37
port=5900
proxyhost=
proxyport=5900
password=aefa7fcd9b90859c
[options]
use_encoding_0=1
use_encoding_1=1
use_encoding_2=1
use_encoding_3=0
use_encoding_4=1
use_encoding_5=1
use_encoding_6=1
use_encoding_7=1
use_encoding_8=1
use_encoding_9=1
use_encoding_10=0
use_encoding_11=0
use_encoding_12=0
use_encoding_13=0
use_encoding_14=0
use_encoding_15=0
use_encoding_16=1
use_encoding_17=1
preferred_encoding=5
restricted=0
viewonly=0
nostatus=0
nohotkeys=0
showtoolbar=1
AutoScaling=0
fullscreen=0
autoDetect=1
8bit=0
shared=1
swapmouse=0
belldeiconify=0
emulate3=1
JapKeyboard=0
emulate3timeout=100
emulate3fuzz=4
disableclipboard=0
localcursor=1
Scaling=0
scale_num=100
scale_den=100
cursorshape=1
noremotecursor=0
compresslevel=6
quality=6
ServerScale=1
Reconnect=0
EnableCache=0
QuickOption=1
UseDSMPlugin=0
UseProxy=0
sponsor=0
DSMPlugin=NoPlugin
ExitCheck=0
FileTransferTimeout=60



Als Fehlermeldung erhalte ich stets:

Invalid VNC server specified.
Usage includes:
vncviewer [/8bit][/swapmouse][/shared][/belldeiconify]
[/listen][/portnum][/fullscreen][/viewonly][/notoolbar]
[/scale a/a][/config configfile][/server:display]
[/emulate3][/]quickoption n[/serverscale n]
[/askexit][/user msuser][/password clearpassword]
[/nostatus][/dsmplugin pluginfilename.dsm][/autoscaling]
[/autoreconnect delayInSeconds]
[/nothotkeys][/proxy proxyhost[portnum][/256colors][/64colors]
[/encoding[zrle | zywrle |zlib |zlibhex | ultra]]
For full details see documentation



Vielleicht kann mir jemand helfen?
Mitglied: DerWoWusste
DerWoWusste 30.12.2008 um 11:48:06 Uhr
Goto Top
Hattest Du andere Versionen in Benutzung, also andere Unterversionen von UVNC oder Real-/TightVNC? Die könnten noch in der Registry rumgurken, das scheint der einzig mögliche Auslöser für die Meldung zu sein. Schau Dir http://forum.ultravnc.info/viewtopic.php?p=46073 ... an, da hat jemand Dein Problem gelöst. Du könntest als Schnellschuss auf Deinem Viewer-Rechner mal eine aktuelle UVNC installieren und den Haken bei "delete VNC-Registry key" oder so ähnlich beim Setup wählen.
Mitglied: borgadmin
borgadmin 30.12.2008 um 15:18:27 Uhr
Goto Top
hey,

vielen Dank für den Tipp! Damit hats hingehauen!

Vielen Dank!!!