VPN Leitungsproblem

Mitglied: yumper

yumper (Level 2) - Jetzt verbinden

26.04.2021, aktualisiert 20:18 Uhr, 914 Aufrufe, 12 Kommentare

Hallo

ich habe folgendes Problem mit einem Homeoffice Notebook.

Das Notebook ist über einen Router der Telekom mit einem Lan Kabel verbunden.

Der VPN Kanal zum Firmennetz wird einwandfrei aufgebaut. Pings zum Firmen DNS Server gehen durch - IPconfig /renew bekommt vom DHCP Server eine IP Adresse
DNS Abfragen und andere Ports auf unser Firmennetz gehen jedoch nicht durch den VPN Kanal.
Das Ganze hat lange Zeit funktioniert, ist also keine Neukonfiguration.

Verbindet man das Notebook über den Wifi Hotspot eines IPhone mit dem Internet funktioniert die VPN Verbindung ins Firmennetz.

Any hints?

so long

Yumper
Mitglied: tikayevent
26.04.2021 um 20:29 Uhr
Schalt mal testweise IPv6 auf der Schnittstelle aus, mit der du mit deinem Router verbunden bist.

IPv6 hat nämlich gegenüber IPv4 Vorrang und wenn der DNS-Server im VPN nur per IPv4 erreicht werden kann und es der VPN-Client nicht anderweitig verhindert, dann bekommt der IPv6-DNS-Server des Providers Vorrang.
Bitte warten ..
Mitglied: yumper
26.04.2021 um 22:00 Uhr
Hallo

es wird nur IPv4 verwendet. IPv6 ist auf dem Notebook deaktiviert.
IPConfig zeigt auch nur IPv4 an.

so long

Yumper
Bitte warten ..
Mitglied: aqui
26.04.2021, aktualisiert um 22:48 Uhr
Hast du auf dem LAN Port ggf. einen statischen DNS Server eingestellt ?
Ist ja ein reines DNS Problem, denn dein Client nimmt den dir dynamisch per VPN mitgeteilten DNS Server auf dem LAN Port nicht an.
Was auch möglich ist das du LAN und WLAN beides aktiv hast am Heimnetz. Das geht nicht, weil du auf beiden Interfaces dann gleiche IP Netze hast. Hier also immer das WLAN mit dem Quickbutton deaktivieren.
2 Dinge wären hilfreich:
  • ipconfig -all Output ohne aktiven VPN Client
  • ipconfig -all Output mit aktiven VPN Client
Bitte warten ..
Mitglied: SeaStorm
26.04.2021 um 23:55 Uhr
Hi,

Wird dir denn vom VPN DHCP auch der entsprechende DNS Server zugeteilt?

Und wie pingst du? Mit dem Hostnamen oder mit dem FQDN.
Wenn du nur den Hostnamen eingibst, dann frägt der Rechner evtl. Nur bei deinem internen DNS an und bekommt da halt irgendwas zurück.
Du musst den Domainnamen beim VPN-Interface als Suffix mitgeben, das er den richtigen Server nimmt und das er auch den Suffix an den Hostnamen anhängt
Bitte warten ..
Mitglied: yumper
27.04.2021, aktualisiert um 03:15 Uhr
Zitat von @SeaStorm:

Hi,

Wird dir denn vom VPN DHCP auch der entsprechende DNS Server zugeteilt?

Und wie pingst du? Mit dem Hostnamen oder mit dem FQDN.
Wenn du nur den Hostnamen eingibst, dann frägt der Rechner evtl. Nur bei deinem internen DNS an und bekommt da halt irgendwas zurück.
Du musst den Domainnamen beim VPN-Interface als Suffix mitgeben, das er den richtigen Server nimmt und das er auch den Suffix an den Hostnamen anhängt

Hallo

das Domainsuffix ist im Windows bei den IPv4 Einstellungen eingetragen.

Der DHCP gibt dem Client die IP Adresse 172.10.0.15 mit 172.17.0.1 als DNS und Gateway zurück

Ping 172.10.0.1 kommt zurück

nslookup 172.10.0.1 geht ins Leere
nslookup 172.10.0.15 geht ins Leere - ebenso nslookup 172.10.0.15 172.10.0.1

wenn ich anstatt lan wifi über das Iphone (Hotspot) beides mit dhcp nutze funktioniert es. Es ist immer nur Wifi oder LAN aktiv nie beides.

so long

yumper
Bitte warten ..
Mitglied: em-pie
27.04.2021, aktualisiert um 08:49 Uhr
Moin,

Tritt dem VPN-Admin bitte mal vors Schienbein.

Das von dir genannte Netz 172.10.0.0/24 ist ein öffentliches Netz, welches den Russen gehört:

https://ipinfo.io/172.10.0.1


Dass die IP aus dem öffentlichen Raum stammt könnte Deine Probleme erklären.

Es muss eine aus dem Bereich des RFC1918 sein, also
10.0.0.0/8
172.16.0.0/ 12
192.168.0.0/ 2416


Gruß
em-pie
Bitte warten ..
Mitglied: tikayevent
27.04.2021, aktualisiert um 07:54 Uhr
@em-pie 192.168.0.0/16 nicht /24
Bitte warten ..
Mitglied: gilligan
27.04.2021 um 08:26 Uhr
IPv6 am Windows deaktivieren ist auch nicht so toll, das führt zu den verrücktesten Problemen
Bitte warten ..
Mitglied: em-pie
27.04.2021, aktualisiert um 10:35 Uhr
Moin,

Du hast natürlich recht. Bein 192.168er Bereich passiert mir das ständig….
Hab beim Schreiben noch gedacht „denk dran“ -.-
Bitte warten ..
Mitglied: aqui
27.04.2021, aktualisiert um 11:39 Uhr
Wird dir denn vom VPN DHCP auch der entsprechende DNS Server zugeteilt?
Im VPN gibt es kein DHCP !
Der DHCP gibt dem Client die IP Adresse 172.10.0.15 mit 172.17.0.1 als DNS und Gateway zurück
Mit "DHCP" meinst du jetzt aber die IP Adressierung am LAN Port sprich am lokalen Kupferport und NICHT am VPN Port, richtig ?!
Deshalb nochmals die dringende Bitte die 2 hilfreichen Outputs zu checken:
  • ipconfig -all Output ohne aktiven VPN Client
  • ipconfig -all Output mit aktiven VPN Client
  • Ein route print mit aktiven VPN Client
  • Dann MIT aktivem Client einmal die per VPN mitgeschickte, interne DNS Server zu pingen ! Klappt das ?
Wenn ein Ping, Traceroute, Pathping (mit "-n" !) oder ein nslookup auf den internen DNS Server nicht klappt, dann kann dieser physisch nicht erreicht werden und damit ist dann natürlich eine lokale DNS Namensauflösung völlig unmöglich.
Dass die IP aus dem öffentlichen Raum stammt könnte Deine Probleme erklären.
Könnte, muss aber nicht. Natürlich ist diese öffentliche IP im internen Netz ein NoGo und zeugt eher vom KnowHow des Netzwerk Admins. Es muss aber nicht zwangsläufig der Fehler sein sofern es eine Route in dieses Netz bei aktivem VPN Client über den Tunnel gibt. Genau deshalb das route print was das sofort zeigt !
Der TO schreibt ja zudem das es mit dem gleichen Rechner an einem Teathering Anschluss fehlerlos klappt. Folglich kann es also primär nicht am Rechner liegen.
Vermutung ist immer noch das es am LAN Port einen statischen DNS gibt der den dynamisch gelernten "überstimmt".
Dafür spricht das es übers WLAN klappt. Spannend wäre mal der Test es übers Speedport WLAN zu versuchen OHNE das das LAN angeschlossen ist. ;-) face-wink
Bitte warten ..
Mitglied: yumper
27.04.2021, aktualisiert um 18:28 Uhr
Hallo
.
Vermutung ist immer noch das es am LAN Port einen statischen DNS gibt der den dynamisch gelernten "überstimmt".
Dafür spricht das es übers WLAN klappt. Spannend wäre mal der Test es übers Speedport WLAN zu versuchen OHNE das das LAN angeschlossen ist. ;-) face-wink

Die 172.17 IPs sind historisch. 172.10 ist ein Tippfehler

Schon klar das DHCP vom Firmen-DHCP kommt und nicht vom VPN.

über das Speedport W-Lan funktioniert es ebenfalls nicht.

Muss wohl doch an der Telekom Leitung liegen.

Ich versuche es demnächst mit einem anderen Firmennotebook an diesem Anschluss. Komisch ist das ja schon.



so long

yumper
Bitte warten ..
Mitglied: HansDampf06
28.04.2021 um 10:57 Uhr
Also wenn die VPN-Verbindung aufgebaut wird und ein Ping durchgeht, indes DNS-Abfragen etc. scheitern, dann würde ich mir neben den bereits erteilten Hinweisen, insbesondere von @aqui, einmal im VPN-Client anschauen, ob ein Splitt-Tunneling aktiviert ist und wie. Nicht selten kann dort der eigentliche Fehler für DNS-Abfragen liegen.

Leider postest Du keine Ausdrucke zu ipconfig etc. Auch fehlen Angaben zum VPN-Client, so dass wir alle hier nur im Nebel stochern können.

Viele Grüße
HansDampf06
Bitte warten ..
Heiß diskutierte Inhalte
LAN, WAN, Wireless
Unterschiedliche IP-Adressbereiche im Netzwerk
achkleinVor 1 TagFrageLAN, WAN, Wireless17 Kommentare

Hallo, ich stehe vor einem Problem mit der WLAN-Verbindung zum Router (Fritzbox Cable 6490). Das verbundene Notebook hat die Adresse 192.168.0.164, Gateway ist 192.168.0.149: ...

Off Topic
Microsoft und der (leidige) Datenschutz
Franz-Josef-IIVor 1 TagAllgemeinOff Topic18 Kommentare

Hello Ich möchte vorausschicken, daß ich rein prinzipiell nichts gegen Microsoft habe, eher gegen die US-amerikanische Politik 😊 Microsoft bietet die Datenverarbeitung in der ...

Off Topic
32 bit Problem
brammerVor 1 TagAllgemeinOff Topic9 Kommentare

Hallo, also das ist mal ein Problem das ich auch haben möchte eine Aktie ist mehr Wert als das die Börsensoftware darstellen kann. brammer

Hardware
Thin- oder Zero-Client für RDP und Dual-Monitor im LAN gesucht
FestplattenaufzieherVor 1 TagFrageHardware9 Kommentare

Hallo, Kurzfassung meiner Frage: Ich suche Thin/Zero-Clients (4 Stück) mit Dual-Monitor-Unterstützung für den RDP-Zugriff auf PCs in einem LAN - idealerweise lautlos und relativ ...

Windows Server
Lizenzen für Virtualisierungshost
TakworianVor 11 StundenFrageWindows Server15 Kommentare

Hallo, ich werde demnächst einen HA-Cluster aus 3 x HP DL580 in Betrieb nehmen. Der Cluster wird unter Proxmox betrieben und es sollen diverse ...

Windows 10
Windows 10 2021-04 end of life?
gelöst Paedi12Vor 1 TagFrageWindows 103 Kommentare

Hi Leute! Ich bin gerade auf der Suche, wie lange die Windows Version 2021-04 unterstützt wird. Kann aber nichts finden. Hat jemand eine Ahnung, ...

Switche und Hubs
Netgear Switch Problem bei VLAN Konfiguration
gelöst meltersVor 1 TagFrageSwitche und Hubs15 Kommentare

Hallo, ich habe einen Netgear XS716T Switch zum Testen in Betrieb genommen, komme aber mit der VLAN Konfiguration nicht so ganz klar. Bislang habe ...

Router & Routing
Suche Tipps für Selfmade-Load-Balancing-Router auf HP MicroServer Gen10+
gelöst MagicChris86Vor 1 TagFrageRouter & Routing7 Kommentare

Hi Leute, ich habe einen HP MicroServer Gen10+ Performance übrig, der bei einer Kundin rausgeflogen ist, weil sie mehr Power brauchte für Desktopvirtualisierung für ...