Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Probleme mit Windows 2003 Server (Media Server und FTP)

Mitglied: 9218
Hallo,

ich muss mich gerade mit meinem ersten Windows 2003 Webserver vertraut
machen. Momentan leider noch absolut Newbiemäßig. Debian ist mein eigentliches
Feld. Unser Unternehmen benötigt jedoch einen Streamserver für .wmv Dateien. Daher
diese Entscheidung.


Meine Probleme: Ich habe nun erstmal nach und nach alle Dienste installiert. U.a.
den Media Server, IIS 6.0, etc. Auch eine Domain habe ich schon eingerichtet.
Neues Verzeichnis unter C:\Inetpub\wwwroot\ erstellt, dann mit IIS die Domain
angelegt.

Jetzt sehe ich jedoch nichts von einer FTP-Möglichkeit? FTP Zugang ist nämlich zwingend
notwendig für den Upload der Video-Inhalte. Und da suche ich jetzt nach einer Möglichkeit
einen FTP-Zugang für das Web anzulegen. Welche Möglichkeiten / Anleitungen gibt es dazu?

Das nächste Problem ist der Media Server. Wir wollen die Inhalte alle direkt unter der Domain
ablegen. Also in diesem Fall unter C:\Inetpub\wwwroot\domain.de\wmv_files
Jetzt gibt es ja die Sache mit den Publishingpoints. Da ist schon einer eingetragen mit:
<standard> on-demand. Das sollte ja auch so richtig sein, ist ja on-demand. Jedoch
war das Verzeichnis auf C:\WMPub\wmroot gestellt. Das habe ich geändert auf das
o.g. Verzeichnis in denen die Files liegen sollen.

Welche Einstellungen sind da noch nötig? Ich habe dann eine Playlist erstellt (.wsx)
und einen Testfile eingegeben. Diese wsx-Datei habe ich stream.wsx genannt und unter
C:\Inetpub\wwwroot\domain.de abgelegt.

Rufe ich nun: http://www.domain.de/stream.wsx auf, bietet mir der Browser die wsx-Datei
zum Download an. In dieser ist ja der gesamte Pfad zum File, etc. verzeichnet, das kann ja
so also nicht korrekt sein? Rufe ich mms://www.domain.de/stream.wsx wird der File gestreamt,
dass funktioniert.

Was gibt es im Bezug auf den Media Server noch zu beachten? Eventuell hilfreiche deutsche
Tutorials, etc.? Ich würde mich sehr über Antworten freuen.

Content-Key: 6475

Url: https://administrator.de/contentid/6475

Ausgedruckt am: 01.08.2021 um 22:08 Uhr

Mitglied: moenni
moenni 03.02.2005 um 20:25:16 Uhr
Goto Top
Zum FTP Problem:
Der IIs installiert ftp nicht von Haus aus mit, sondern dieser Dienst muss extra nachinstalliert werden.
Mitglied: 9218
9218 03.02.2005 um 20:51:27 Uhr
Goto Top
Wenn ich mal finden würde WO ich das nachinstallieren kann...
Ich habe mir schon einen Wolf gesucht und nichts gefunden. Im
IIS ist es nicht drin, das steht fest.

Wenn ich Dienste hinzufügen möchte, steht da auch nichts von FTP.
Wo ist das also zu finden?
Mitglied: moenni
moenni 04.02.2005 um 09:53:03 Uhr
Goto Top
Systemsteuerung - Software - Windowskomponenten - IIS.... - FTP...
Mitglied: 9218
9218 04.02.2005 um 16:14:56 Uhr
Goto Top
Danke, habe ich jetzt gefunden und ist auch installiert, jedoch hapert es noch
an der Konfiguration, ich bekomme einfach keinen Connect per Ws_ftp. Folgendes
habe ich gemacht, bzw. möchte ich machen:

- Neue ftp Seite
- Verzeichnis C:\Inetpub\wwwroot\domain.de soll per ftp erreichbar sein
- Hier wurde nun ein User IUSR_SERVERNAME und ein Passwort angelegt

Jetzt versuche ich einen Connect auf die IP mit dem Usernamen und dem Passwort.
Ws_ftp gibt jedoch nur: 530 User IUSER_SERVERNAME cannot log in.
!Login failure, so quitting.

Gibt es eventuell ein Tutorial zum einrichten des FTP-Zugangs?
Mitglied: moenni
moenni 04.02.2005 um 18:56:07 Uhr
Goto Top
Ich habe bei mir die Einstellung "anonyme Verbindung zulassen" nicht aktiviert. Stattdessen habe für den FTP Zugang spezielle Benutzer angelegt, und die dann in den FTP-Ordnern unter Sicherheit Zugriffsrechte erteilt.
Diese Ordner sind von der Vererbung ausgeschlossen.
Für alle vorhergehenden Ordner hat "jeder" Leserechte. Diese sind aber über FTP nicht erreichbar.

Im IExplorer passives FTP abwählen und Ordneransicht für FTP anwählen.
Den FTP kannst Du im LAN unter ftp://<ServerName> erreichen.

Jezt sollte ein Anmeldebildschirm erscheinen.

Vom Inernet aus gehts genauso. Anstatt <Server Name> IP oder Domänennamen eingeben.
Heiß diskutierte Beiträge
question
Welche VSCode Version?TckDEVVor 1 TagFrageIDE & Editoren1 Kommentar

Guten Abend zusammen! Ich habe vor ein paar Tagen meinen PC zurückgesetzt. Aktuell bin ich dabei alle Programme wieder zu Installieren. Ich bin nun auf ...

question
USB Adapter wie PoE? gelöst HournenharmaVor 1 TagFrageHardware4 Kommentare

Ich habe einen Kunden, der will in seinem Ford mit SYNC2 sein RazerPhone 2 nutzen. Das Problem ist, dass die USB-A Anschlüsse max. 5W geben, ...

question
Fritzbox 6591 - cable gigabit - Fax einrichten wie lösbar ? gelöst daswinimramVor 1 TagFrageRouter & Routing11 Kommentare

Hallo Community und Admins ! Folgende Hardware : FRITZBOX 6591 an Vodafone Gigabit Kabelanschluss. 1 Rufnummer (SIP) eingetragen, funktioniert seit Jahren. Hintergrundwissen : Bei YodasPhone ...

question
BIOS.UEFI verliert Datum und Uhrzeitc0d3.r3dVor 1 TagFrageCPU, RAM, Mainboards6 Kommentare

Mahlzeit, mein privat Rechen zuhause verliert in letzter Zeit regelmäßig nach einem Kaltstart das aktuelle Datum sowie die Uhrzeit. Alle anderen BIOS bzw. UEFI-Einstellungen bleiben ...

question
Einige AD-User bekommen bei Anmeldung ein TEMP-ProfilgoRainiVor 1 TagFrageWindows Netzwerk6 Kommentare

Wir haben eine Domäne inkl. servergespeicherten Profilen mit u.a. mehreren Citrix-Terminal-Servern, die jede Nacht neustarten. Auf einer der Citrix-Maschinen lief heute früh die Festplatte voll, ...

question
Wav to mp3 mit LameMPFGVor 1 TagFrageBatch & Shell3 Kommentare

Hallo, versuche gerade mehre tausend wav´s im mp3 umzuwandeln Alle liegen in einem Hauptordner mit vielen Unterordnern. Das ganze soll über Lame funktionieren. lame -b ...

question
USB 3 beißt sich mit 2,4Ghz Funkperipherie gelöst O-Two06Vor 13 StundenFragePeripheriegeräte3 Kommentare

Hiho, ich habe nun schon einige Artikel über das leidige Thema gelesen, komme aber zu keiner Lösung. Ich habe Mini-PCs, bei denen nun leider mal ...

question
Hyper-V - verwaiste Snapshots löschenbasdschoVor 6 StundenFrageHyper-V15 Kommentare

Hallo, mein Veeam machte bei einer installation Probleme und konnte plötzlich die Snapshots nicht mehr löschen. Kein Problem, Disks konsolidiert, alte Snapshot Dateien gelöscht. Nun ...