alchimedes
Goto Top

Debian, Homeverzeichnisse fuer root nicht sichtbar

Hallo,

fuer Testzwecken habe ich diverse User mittels:

adduser test --home /pfad/zum/workverzeichniss
angelegt.
Der User wird angelegt, das Homeverzeichniss auch, aber es ist nur fuer den User sichtbar und beschreibbar nicht jedoch fuer root.

Debianversion 9.2 neu angelegt.

Kollege hat das getestet der hat dieses Phänomen nicht !
Zur Verwaltung einer handvoll User spielt das keine Rolle aber bei Hundert ?
Wenn ich den User ohne eigenen Homepfad anlege wird dieses unter /home/test angelegt und ist auch fuer root sichtbar !

Woran kann das liegen ?

Gruss

Content-Key: 353468

Url: https://administrator.de/contentid/353468

Printed on: April 16, 2024 at 17:04 o'clock

Member: Lochkartenstanzer
Solution Lochkartenstanzer Nov 02, 2017 at 16:03:39 (UTC)
Goto Top
Zitat von @Alchimedes:

Der User wird angelegt, das Homeverzeichniss auch, aber es ist nur fuer den User sichtbar und beschreibbar nicht jedoch fuer root.

Was heißt nicht sichtbar? meinst Du das verzeichnis selbst oder den Inhalt? Mal mit ls -lsaF o.ä geschaut? Oder hast Du verschlüsseltze Homeverzeichnisse angelegt? Ist letzteres der fall, hat selbst root ohne passwort kein ZUgriff auf die Homeverzeichnisse.

lks
Member: Alchimedes
Alchimedes Nov 02, 2017 at 22:05:13 (UTC)
Goto Top
Hallo LKS,

also das sieht nach einem Bug aus.
Die Partitionen sind nicht verschluesselt.
Je nachdem wie ich mich anmelde also ueber die Login Shell als Root sehe ich die Verzeichnisse nicht !
Gehe ich ueber su in den root account sehe ich die Verzeichnisse.
Werde morgen mal eine neue Debian vm anschmeissen und das dort nochmals Testen, kann ja sein das sich da was verbogen hat.

Gruss und Danke
Member: Alchimedes
Alchimedes Nov 11, 2017 at 15:12:01 (UTC)
Goto Top
Hallo lks,

ich hab den Fehler gefunden.
Es gab 2 Verzeichnisstrukturen, die eine im Wurzelsystem also unter ># /# und das andere darueber ># also im Homeverzeichnis root, wenn man es den so nennen will.

Wie das zustande kam keine Ahnung, denke das ich beim anlegen des Verzeichnisse im falschen Pfad rumschwirrte.

Gruss