tetranet
Goto Top

Exchange 2019 - Zugriff auf OWA und ECP schlägt fehl

Hallo Community,

da mein Exchange gehackt wurde, musste ich ihn neu aufsetzen, was ich gemäß der Anleitung von Frankys Web ( https://www.frankysweb.de/exchange-server-neuinstallation-ohne-datenverl ... ) durchgeführt habe.
Nach der Installation (sowohl die alte als auch die neue Installation liefen/laufen auf Exchange 2019 CU12) hat der ECP-Zugriff nie funktioniert.
Der Exchange läuft, jedoch ist der Server nur über die Powershell administrierbar, da beim Aufruf von ECP und OWA folgender Fehler ausgegeben wird:

Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.
Beschreibung: Unbehandelte Ausnahme beim Ausführen der aktuellen Webanforderung. Überprüfen Sie die Stapelüberwachung, um weitere Informationen über diesen Fehler anzuzeigen und festzustellen, wo der Fehler im Code verursacht wurde.

Ausnahmedetails: System.NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.

Quellfehler:

Beim Ausführen der aktuellen Webanforderung wurde einen unbehandelte Ausnahme generiert. Informationen über den Ursprung und die Position der Ausnahme können mit der Ausnahmestapelüberwachung angezeigt werden.

Stapelüberwachung:


[NullReferenceException: Der Objektverweis wurde nicht auf eine Objektinstanz festgelegt.]
Microsoft.Exchange.HttpProxy.FbaModule.ParseCadataCookies(HttpApplication httpApplication) +2346
Microsoft.Exchange.HttpProxy.FbaModule.OnBeginRequestInternal(HttpApplication httpApplication) +234
Microsoft.Exchange.HttpProxy.<>c__DisplayClass20_0.<OnBeginRequest>b__0() +1749
Microsoft.Exchange.Common.IL.ILUtil.DoTryFilterCatch(Action tryDelegate, Func`2 filterDelegate, Action`1 catchDelegate) +35
System.Web.SyncEventExecutionStep.System.Web.HttpApplication.IExecutionStep.Execute() +142
System.Web.HttpApplication.ExecuteStepImpl(IExecutionStep step) +75
System.Web.HttpApplication.ExecuteStep(IExecutionStep step, Boolean& completedSynchronously) +93

Versionsinformationen: Microsoft .NET Framework-Version:4.0.30319; ASP.NET-Version:4.8.4676.0

Bisher konnte ich keine korrespondieren Einträge in den Ereignisprotokollen finden, die weitere Informationen liefern würden.
In einem MS KB-Artikel ( https://learn.microsoft.com/de-de/exchange/troubleshoot/administration/c ... ) habe ich zu diesem Fehler gefunden, dass das OAuth-Zertifikat angeblich abgelaufen sei und erneuert werden müsste, dies ist aber nicht der Fall; das Zertifikat ist noch gültig.

Hat jemand eine Idee was die Fehlerursache sein könnte?

Grüße
Tobias

Content-Key: 4641101432

Url: https://administrator.de/contentid/4641101432

Printed on: February 21, 2024 at 04:02 o'clock

Member: radiogugu
radiogugu Dec 07, 2023 updated at 18:29:39 (UTC)
Goto Top
Nabend.

Was sagen denn die Daten des OAuth Zertifikat auf dem neuen Exchange?

Get-ExchangeCertificate | select Thumbprint, Services, NotAfter, Subject, CertificateDomains

Hast du mal das HealthChecker.ps1 Skript ausgeführt?

Wenn dein Exchange Server einem Angriff unterlegen war, dann wird mit hoher Wahrscheinlichkeit deine AD Umgebung kompromittiert worden sein.

Das Installieren und Deinstallieren eines Exchange Servers hat immer weitreichende Änderungen im AD zur Folge.

Daher sollte man immer Datensicherungen der Domain Controller vor der Installation eines Exchange haben.

Gruß
Marc
Member: NordicMike
NordicMike Dec 08, 2023 at 04:32:53 (UTC)
Goto Top
Ich hoffe du hast die selbst erstellen Zertifikate im Backend gelassen. Nur das Frontend kann neue Zertifikate gebrauchen.
Member: tetranet
tetranet Dec 11, 2023 at 07:30:30 (UTC)
Goto Top
Hallo,
das Problem hat sich seltsamerweise durch die Ausführung von Windows Update gelöst.
Vielen Dank für die Hinweise von Euch allen.

Grüße
Tobias