sat-fan
Goto Top

Fritz!Repeater an Cisco AP ohne DHCP

Hallo, leider reicht mein Aironet 2700 Signal nicht bis ins letzte Eck vom Keller wo noch ein paar IoT´s stehen.

Wollte nun meine Fritz Repeater dazu nutzen. Bekomme sie auch verbunden und komme von Überall auf den Repeater und kann ihn konfigurieren.

Das Problem ist, das kein DHCP von Repeater zur Verfügung gestellt wird, da die Ciscos ja selbst clients sind und ihr DHCP vom Hex Router bekommen. Auf dem Repeater kann ich keinen expliziten DHCP Server festlegen, sondern nur Gateway und DNS. Gibt es da eine Lösung für ?

Danke !

Content-Key: 81680420525

Url: https://administrator.de/contentid/81680420525

Printed on: December 8, 2023 at 04:12 o'clock

Member: aqui
aqui Nov 10, 2023 updated at 09:41:34 (UTC)
Goto Top
leider reicht mein Aironet 2700 Signal nicht bis ins letzte Eck vom Keller wo noch ein paar IoT´s stehen.
Warum nicht einen weiteren 2702 per WLAN Bridge ankoppeln statt mit Fritz Repeatern rumzufrickeln und das WLAN lahm machen?!
Guckst du hier:
Cisco AP Workgroup Bridge
Die Bridge realisierst du mit dem 5 GHz Radio und das 2,4GHz Radio lässt du dort als AP laufen.
Quasi das Mesh von Cisco. face-wink
das kein DHCP von Repeater zur Verfügung gestellt wird, da die Ciscos ja selbst clients
Das ist natürlich Quatsch, denn der DHCP Request wird im Layer 2 immer geforwardet egal ob Kupfer oder WLAN und egal ob Repeater oder AP.
Auf dem Repeater kann ich keinen expliziten DHCP Server festlegen
Wozu auch, denn der DHCP Request ist bekanntlich ein All Net Broadcast (Destination IP 255.255.255.255) den jede Bridge, Repeater usw. immer automatisch forwarden muss im Layer 2 Netz!
Member: sat-fan
sat-fan Nov 10, 2023 at 14:20:00 (UTC)
Goto Top
@aqui Ok. Dann teste ich das Cisco Mesh ;)

Wenn deine Thesen oben stimmen, dann sind die kleine Fritz!Repeater 600 definitiv inkompatibel zum Cisco AP
Er verbindet einwandfrei, gibt aber seinen clients keine IP ..

Hab ja ne andere Lösung ... thx
Member: aqui
aqui Nov 10, 2023 updated at 15:33:36 (UTC)
Goto Top
dann sind die kleine Fritz!Repeater 600 definitiv inkompatibel zum Cisco AP
Nein, das ist natürlich Unsinn. WLAN Standards gelten natürlich weltweit und sind immer herstellerübergreifend kompatibel.

Kleine dumme Repeater sind aber Schrott in einem WLAN, denn sie halbieren durch ihr erzwungendes Half Duplex Verfahren die Bandbreite. Die [ hidden node Problematik] gibt so einem Repeater WLAN dann meist den Rest. Wenn überhaupt sollte man immer nur Mesh Repeater nutzen wo ein dediziertes Radio das Backbone realisiert. Aber auch da ist das immer nur eine üble Krücke, denn man hängt mit Funk immer an einem bandbreitenschwachen, instabilen Infrastruktur.
Es ist immer besser Kabel für einen AP zu verlegen um eine gesicherte bandbreite zu bekommen. Oder als Kompromiss ggf. Power LAN wenn man partout kein Kabel für einen AP verlegen kann.
gibt aber seinen clients keine IP ..
Das ist auch Unsinn, denn der Repetae rist nur ein dummer Papagei der die WLAN Pakete zeitversetzt einfach nur an den AP weitergibt (repeated). Der AP forwardet das ins Kupfernetz und der dortige DHCP Server vergibt die IP. Ein Repeater ist ein reines dummes L2 Device und vergibt in der Regel niemals eigenständig IPs. Ist auch logisch denn so bestünde die Gefahr das man dann mit einmal 2 konkurrierende DHCP Server haben die Adress Chaos verursachen... face-wink
Member: sat-fan
sat-fan Nov 12, 2023 at 21:32:53 (UTC)
Goto Top
Tja .. aber leider funktioniert es nicht, habe hier noch 4 kleine Repeater von Fritz rumliegen, die nur über 2.4 Ghz ein paar shellys im Keller überwachen sollen.
Bei allen habe ich das gleich Problem, das angemeldete Geräte an den Dingern keine IP bekommen. Mit einer Fritzbox ging das immer. Theorie hin oder her ... Kann nicht mehr als an den Repeater eine IP und eine GW und Netmask einstellen. Und natürlich noch das Wlan netz einrichten. Egal ... Schieße ich wohl mit Kanonen ( Cisco APs) auf die Spatzen im Keller
Member: aqui
aqui Nov 13, 2023 updated at 08:04:14 (UTC)
Goto Top
Was passiert denn am AP mit dem Repeater?? Kann der sich zumindestens mit dem AP assoziieren? Wie immer helfen hier die üblichen "show" Kommandos.
Kann dann höchstens nur sein das die noch sowas Altes wie TKIP machen oder du Umlaute oder Sonderzeichen in deinen SSIDs oder Passwörtern hast.

Im Zweifel besorg dir für 20 Euro immer einen weiteren 2702 und binde den mit einer Workgroup Bridge an im Keller. Ist eh besser als die technisch miese Repeater Krücke.
Member: sat-fan
sat-fan Nov 14, 2023 at 22:53:08 (UTC)
Goto Top
werde ich machen... keine Lust mehr auch das Fritz zeug ;)
Member: sat-fan
sat-fan Nov 21, 2023 at 15:36:03 (UTC)
Goto Top
irgendwie war mit klar das ich wieder mal zu doof bin oder auf dem Schlauch stehe.
Habe versucht nach der o.g. anleitung zu arbeiten:
Cisco AP Workgroup Bridge
da die AP einwandfrei mit Ethernet laufen, habe ich die Unterschiede gesucht.
Dabei ist mir nur der Fett gedruckte Eintag im AP2 aufgefallen:
station-role workgroup-bridge
Leider sehe ich AP2 mit seiner IP nicht im Netz und da ich gerade kein consolenkabel da habe,
kann ich auch nicht nach:
14:57:05 CET: %DOT11-4-UPLINK_ESTABLISHED: Interface Dot11Radio0, Associated To AP ap2702 286f.7f32.7ca0 [None WPAv2 PSK]
14:57:06 CET: %LINEPROTO-5-UPDOWN: Line protocol on Interface Dot11Radio0, changed state to up
14:57:12 CET: %DHCP-6-ADDRESS_ASSIGN: Interface BVI1 assigned DHCP address 10.99.1.133, mask 255.255.255.0, 
suchen.

Hier noch mal die AP config:
!
! Last configuration change at 18:37:41 CET Thu Nov 2 2023
! NVRAM config last updated at 18:37:41 CET Thu Nov 2 2023
! NVRAM config last updated at 18:37:41 CET Thu Nov 2 2023
version 15.3
no service pad
service tcp-keepalives-in
service tcp-keepalives-out
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname AP-Laufband
!
!
logging rate-limit console 9
enable secret 5 $1$NAxg$Rmt1385/igJFp8AhpcgT..
!
aaa new-model
!
!
!
!
!
!
!
aaa session-id common
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
no ip source-route
no ip cef
!
!
!
!
dot11 pause-time 100
dot11 syslog
dot11 vlan-name VLAN-10-Gast vlan 10
dot11 vlan-name VLAN-100-Privat vlan 100
dot11 vlan-name VLAN-20-IoT vlan 20
dot11 vlan-name VLAN-200-Admin vlan 200
!
dot11 ssid Cisco-Admin
   vlan 200
   band-select
   authentication open 
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii 0 xxxxxxxxxxxxxxxxxxxxxx
!
dot11 ssid Cisco-Gast
   vlan 10
   band-select
   authentication open 
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii 0 xxxxxxxxxxxxxxxxxxxxxxxxxxxx
!
dot11 ssid Cisco-IoT
   vlan 20
   authentication open 
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii 0 xxxxxxxxxxxxxxxxx
!
dot11 ssid Cisco-Privat
   vlan 100
   band-select
   authentication open 
   authentication key-management wpa version 2
   mbssid guest-mode
   wpa-psk ascii 0 xxxxxxxxxxxxxxxxxxxxxxxxxx
!
!
!
power inline negotiation injector 744d.28c6.ddd8
power inline negotiation prestandard source
no ipv6 cef
!
!
username Cisco privilege 15 password 0 xxxxxxxxxxxxxxxxxxxxxxxx
!
!
!
!
!
interface Dot11Radio0
 no ip address
 !
 encryption vlan 10 mode ciphers aes-ccm 
 !
 encryption vlan 100 mode ciphers aes-ccm 
 !
 encryption vlan 20 mode ciphers aes-ccm 
 !
 encryption vlan 200 mode ciphers aes-ccm 
 !
 ssid Cisco-Admin
 !
 ssid Cisco-Gast
 !
 ssid Cisco-IoT
 !
 ssid Cisco-Privat
 !
 antenna gain 0
 stbc
 mbssid
 speed  basic-1.0 2.0 5.5 11.0 6.0 9.0 12.0 18.0 24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15. m16. m17. m18. m19. m20. m21. m22. m23.
 channel least-congested 2412 2417 2422 2427 2432 2437 2442 2447 2452 2457 2467 2472
 station-role root
 dot11 dot11r pre-authentication over-air
 dot11 dot11r reassociation-time value 300
 world-mode dot11d country-code DE both
!
interface Dot11Radio0.10
 encapsulation dot1Q 10
 bridge-group 10
 bridge-group 10 subscriber-loop-control
 bridge-group 10 spanning-disabled
 bridge-group 10 block-unknown-source
 no bridge-group 10 source-learning
 no bridge-group 10 unicast-flooding
!
interface Dot11Radio0.20
 encapsulation dot1Q 20
 bridge-group 20
 bridge-group 20 subscriber-loop-control
 bridge-group 20 spanning-disabled
 bridge-group 20 block-unknown-source
 no bridge-group 20 source-learning
 no bridge-group 20 unicast-flooding
!
interface Dot11Radio0.100
 encapsulation dot1Q 100
 bridge-group 100
 bridge-group 100 subscriber-loop-control
 bridge-group 100 spanning-disabled
 bridge-group 100 block-unknown-source
 no bridge-group 100 source-learning
 no bridge-group 100 unicast-flooding
!
interface Dot11Radio0.200
 encapsulation dot1Q 200
 bridge-group 200
 bridge-group 200 subscriber-loop-control
 bridge-group 200 spanning-disabled
 bridge-group 200 block-unknown-source
 no bridge-group 200 source-learning
 no bridge-group 200 unicast-flooding
!
interface Dot11Radio1
 no ip address
 !
 encryption vlan 10 mode ciphers aes-ccm 
 !
 encryption vlan 100 mode ciphers aes-ccm 
 !
 encryption vlan 20 mode ciphers aes-ccm 
 !
 encryption vlan 200 mode ciphers aes-ccm 
 !
 ssid Cisco-Admin
 !
 ssid Cisco-Gast
 !
 ssid Cisco-Privat
 !
 antenna gain 0
 peakdetect
 no dfs band block
 stbc
 mbssid
 speed  basic-6.0 9.0 basic-12.0 18.0 basic-24.0 36.0 48.0 54.0 m0. m1. m2. m3. m4. m5. m6. m7. m8. m9. m10. m11. m12. m13. m14. m15. m16. m17. m18. m19. m20. m21. m22. m23. a1ss9 a2ss8 a3ss9
 channel dfs
 station-role root
 dot11 dot11r pre-authentication over-air
 dot11 dot11r reassociation-time value 300
!
interface Dot11Radio1.10
 encapsulation dot1Q 10
 bridge-group 10
 bridge-group 10 subscriber-loop-control
 bridge-group 10 spanning-disabled
 bridge-group 10 block-unknown-source
 no bridge-group 10 source-learning
 no bridge-group 10 unicast-flooding
!
interface Dot11Radio1.20
 encapsulation dot1Q 20
 bridge-group 20
 bridge-group 20 subscriber-loop-control
 bridge-group 20 spanning-disabled
 bridge-group 20 block-unknown-source
 no bridge-group 20 source-learning
 no bridge-group 20 unicast-flooding
!
interface Dot11Radio1.100
 encapsulation dot1Q 100
 bridge-group 100
 bridge-group 100 subscriber-loop-control
 bridge-group 100 spanning-disabled
 bridge-group 100 block-unknown-source
 no bridge-group 100 source-learning
 no bridge-group 100 unicast-flooding
!
interface Dot11Radio1.200
 encapsulation dot1Q 200
 bridge-group 200
 bridge-group 200 subscriber-loop-control
 bridge-group 200 spanning-disabled
 bridge-group 200 block-unknown-source
 no bridge-group 200 source-learning
 no bridge-group 200 unicast-flooding
!
interface GigabitEthernet0
 duplex auto
 speed auto
!
interface GigabitEthernet0.10
 encapsulation dot1Q 10
 bridge-group 10
 bridge-group 10 spanning-disabled
 no bridge-group 10 source-learning
!
interface GigabitEthernet0.20
 encapsulation dot1Q 20
 bridge-group 20
 bridge-group 20 spanning-disabled
 no bridge-group 20 source-learning
!
interface GigabitEthernet0.100
 encapsulation dot1Q 100
 bridge-group 100
 bridge-group 100 spanning-disabled
 no bridge-group 100 source-learning
!
interface GigabitEthernet0.200
 encapsulation dot1Q 200
 bridge-group 200
 bridge-group 200 spanning-disabled
 no bridge-group 200 source-learning
!
interface GigabitEthernet1
 shutdown
 duplex auto
 speed auto
!
interface BVI1
 description LAN-WLAN Bridge
 mac-address 00fe.c870.0080
 mtu 1514
 ip address dhcp client-id GigabitEthernet0
 ipv6 address dhcp
 ipv6 address autoconfig
 ipv6 enable
!
ip forward-protocol nd
ip http server
no ip http secure-server
ip http help-path http://www.cisco.com/warp/public/779/smbiz/prodconfig/help/eag
!
!
!
!
!
!
line con 0
line vty 0 4
 transport input all
!
sntp server de.pool.ntp.org
end


Außerdem habe ich noch 2 allgemeine Fragen zum AP

1.) kann ich die LED iwi abschalten ?
2.) kann ich Netzwerke unsichtbar machen ? z.B Mein IOT Netz muss ja nicht sichtbar sein, wenn alle Geräte online sind

Danke !
Member: aqui
Solution aqui Nov 21, 2023 updated at 16:04:03 (UTC)
Goto Top
Kannst du den AP per Telnet oder SSH erreichen? Laut deines Logs hat er ja die lokale IP 10.99.1.133 bekommen die du ja dann telnetten oder sshen kannst.

1.)
AP(config)#led display ?
dim Turn LED display dim.
off Turn LED display off.
2.)
AP(config-if-ssid)#no guest-mode
Member: sat-fan
sat-fan Nov 21, 2023 at 19:36:12 (UTC)
Goto Top
nein kann ich leider nicht. habe kein serielles kabel gerade. der log von oben ist der aus der anleitung ;) das wollte ich eben haben um etwas zu prüfen. Dementsprechend ist meine IP eine andere .. die ich aber auch nicht erreichen kann ohen eth. Kabel