Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Geschwindigkeit Datenwiederherstellung

Mitglied: Henere

Henere (Level 3) - Jetzt verbinden

05.03.2017 um 02:15 Uhr, 1737 Aufrufe, 10 Kommentare, 1 Danke

Servus zusammen,

nach einem Festplattencrash bin ich nun dabei 6TB an Daten wieder herzustellen.

Server hat ein Raid0 aus 2x 4TB HDDs und läuft unter 2012R2
NAS ist ein QNAP TS 563 mit 4.2.2er Firmware, 5x 4TB im RAID5
Verbunden sind die beiden mit 10GBe direkt ohne Switch per iSCSI.


Gesichert wurde mit der Windows Serversicherung .

Nun fallen mir beim Restore massive Geschwindigkeitsunterschiede auf.

Er schreibt mit ca 200MB/s die Daten zurück. Soweit so gut. Mehr nimmt das RAID0 nicht auf.
Aber: bei .mp4 Dateien fällt die Geschwindigkeit auf 3-4MB/s zurück ?
Virenscanner ist aus (Dienst nicht gestartet), das kann ich ausschliessen.

Kann mir jemand erklären, warum das bei .mp4 so langsam geht ? Weder sind irgendwelche HDDs ausgelastet, noch die Netzwerkverbindung.

Danke und Grüße, Henere
Mitglied: certifiedit.net
05.03.2017 um 04:19 Uhr
Sind die mp4 fragmentierte (kleine) Daten? -> Ein Datenstream, der "so" auf der Platte liegt ist natürlich von a-z durchles und leitbar. Bei wild verstreuten Dateien muss die Logik erst "ordnen", bevor Sie sie rausschickt. Aber das ist doch das kleine 1x1?
Bitte warten ..
Mitglied: Henere
05.03.2017 um 04:21 Uhr
Die haben alle so um die 100mb und mehr.
Bei den über 25000 Fotos würde ich es ja verstehen.
Bitte warten ..
Mitglied: Vision2015
05.03.2017 um 09:24 Uhr
Guten Morgen,

was schaust du auch beim Restore zu ?

was denkst du eigentlich, was dein Software Raid im Server kann?
was glaubst du, was dein Qnap kann ?
dein QNAP kommt zwar mit 5x 4TB im RAID5 --->10GB aus der Dose, wobei da fraglich ist- ob deine HDD´s im NAS auch die theoretisch 8000 Mbit/s liefern können! und ich rede nicht vom Burstmodus, sondern lineare transferleistung!
also wenn du nicht grade SSD´s im Qnap dein eigen nennst- wo soll die leistung herkommen.
selbst WD´s Red pro 4TB 7200rpm kommen da schon mal an ihre grenzen...
hast du die vollen 8GB Ram im Qnap ? wenn nicht- bei 2 GB-ist schnell der Cache alle- und im Raid 5
ist schnell die CPU auf last- die 10GBE Nic braucht da auch etwas CPU zeit...

dein Server hat ein Software Raid- bedeutet die CPU ist am rechnen wie blöd.. zuzüglich hat dein Raid keinen Cache- also bleibt der Platten Cache mit sagen wir mal mit 64 bis 128 MB.. der ist schnell voll.. und da kommst du mit .mp4 dateien, die eh schon hoch komprimiert sind... da kommt dein software schreib cache ordentlich in´s schleudern....
besorg dir mal nen richtigen Raid Controller, und 15K Hdd´s oder schreib mal auf SSD zurück!

nur so mal am rande...

Frank
Bitte warten ..
Mitglied: keine-ahnung
05.03.2017 um 10:45 Uhr
Moin,
Kann mir jemand erklären, warum das bei .mp4 so langsam geht ?
das NAS guggt in Echtzeit mit!

LG, Thomas
Bitte warten ..
Mitglied: GrueneSosseMitSpeck
05.03.2017, aktualisiert um 11:06 Uhr
1.) die Qnap wird wohl eher 100 -150MB pro Sekunde wegschreiben und hat einen write buffer der erstmal schneller voll ist als es die Platten wegsvhreiben können... ich hab ein verwandtes Modell von Synology und das ist nur mit Raid 1/0 theoretisch in der Lage mit voller IO Geschwindigkeit der Platten zu schreiben. Die älteren Modelle gaben 2 oder 3 x 1 Gbit und können über link aggregation zumindestens mit dem Mac Os X auch solche Datentransferraten liefern. Raid 5 ist in der Geräteklasse immer in Software und bei den schwächlichen CPUs ist nicht mehr drin. Außerdem - trau nie einem Microsoft Dialog der die Dauer eines Kopiervorganges schätzt.

2.) vermutlich ist aber nicht das Software Raid schuld an dem langsamen Restore von mp4 Datein sondern die Tatsache daß sie vor dem Backup komprimiert wurden was bei eigentlich schon hochkomprimierten Formaten nur noch Rechenleistung verschwendet. Das kostet beim Dekomprimieren halt nochmal Zeit. Die Zeiz sollte aber banane sein... ehrlich... oder das Filesystem in der Qnap ist komprimiert was bei Mp4 Dateien ebenso überflüssig ist.
Bitte warten ..
Mitglied: Penny.Cilin
05.03.2017 um 14:32 Uhr
Zitat von Henere:

Servus zusammen,

Hallo
nach einem Festplattencrash bin ich nun dabei 6TB an Daten wieder herzustellen.
OK, kann passieren.

Server hat ein Raid0 aus 2x 4TB HDDs und läuft unter 2012R2
Du weißt schon, daß ein RAID0 ein Stripeset ist? - Also nix mit Redundanz!!!
Warum keine RAID1 oder RAID5?

Er schreibt mit ca 200MB/s die Daten zurück. Soweit so gut. Mehr nimmt das RAID0 nicht auf.
Also machst Du ein Restore von der QNAP zum Server, richtig?

Danke und Grüße, Henere


Gruss Penny
Bitte warten ..
Mitglied: Henere
05.03.2017 um 15:23 Uhr
Mahlzeit.

Klar ist ein Raid0 ein Stripeset. Ist ja auch Absicht. Deshalb ja das QNAP zum Daten sichern.

Das Raid0 im Server ist über den Intel-Onboard-Raider angelegt, somit sollte eigentlich die CPU entlastet sein. Laut Resmon dümpelt der Xeno mit seinen 12 Kernen nur so vor sich hin.

Raid1 oder 5 im Server halte ich im privaten Bereich für überflüssig bei regelmäßigem Backup.

Die Toshibe X300 haben 128MB Cache und sollten bis zu 180MB/s jeweils schaffen, also im Server mit (rechnerischen) 350MB+ je Sekunde schreiben können. Ist die NVM im Server Quelllaufwerk, komme ich auf diese Werte.

Das QNAP hat 16GB Ram und nen (AMD) 4-Kerner und dümpelt laut den Systemwerten auch nur vor sich hin. Selbst die HDD-LEDs sidn nicht konstant am leuchten. Rechnerisch sollten da bis zu 4x180MB Lesen / Sek drin sein.

Komprimierung ist weder per NTFS noch auf dem QNAP aktiviert.

Ich habe den beiden ja extra noch ne 10GBe Verbindung verpasst, also im Server eine Mellanox und im QNAP eine dafür freigegebene Karte (Name weiss ich grad nicht mehr). Kabel geht direkt, also ohne Switch.

Das einzige was mir auffällt ist im Resmon die Warteschlange (blaue Linie) des per iSCSI angebundenen QNAPs. Diese liegt ziemlich weit oben und auf der QNAP sind die IOPs ziemlich klein bei den Filmen wie auch bei den Massen an JPGs.

Naja, die 99% sind erreicht, denke er ist gleich fertig. Der Virenscanner hat auch gleich mal ein paar uralte Keygens entfernt.

Toshiba gibt 2 Jahre Garantie auf die Platten, UPS holt morgen kostenlos ab. Hoffe, dass die Ersatz-HDD dann schnell wieder im Schrank liegt.

Schönen Sonntag euch allen.

Henere
Bitte warten ..
Mitglied: scout71
06.03.2017 um 09:05 Uhr
Hallo Henere,

ein ähnliches Thema hatte ich letztens auch.

Server Windows 2012 R2, NAS per iSCSI ohne Switch verbunden - langsame Geschwindigkeit.

Eine Ursache war bei dem DELL Server an der Netzwerkschittstelle die Einstellung Flow Control Auto Negoation. Umgestellt auf Rx & Tx Enabled und schon eine bessere Geschwindigkeit.

Eine andere Ursache war der Kasperksy Virenscanner und die Scannung der Dateien sowie die Kaspersky Firewall.

Nette Grüße
Scout71
Bitte warten ..
Mitglied: Henere
06.03.2017 um 16:31 Uhr
Servus Scout,

Ich hab ne 10GB-Direktverbindung. Im Normalfall laufen da bis zu 400 und mehr MB/s beim sichern durch die Leitung und auch der Restore erfolgte ja in überwiegend maximaler Geschwindigkeit. Nur eben bei MP4 und später auch bei JPG (da waren es dann 25000 "kleine" Dateien) wurde es extrem langsamer

Ähem, ne Firewall die Dateien scannt ???

Grüße
Bitte warten ..
Mitglied: scout71
07.03.2017 um 12:29 Uhr
Hallo Henere,

nee der Kaspersky Virenclient enthält eine Firewall.

Heute konnte ich mit der Einstellung EEE Control Polices meine Netzwerkgeschwindigkeit zum NAS erhöhen können.
Die Std. Einstellung war opti. Power und Perf. eine Umstellung auf max. Performance bringt mehr Datendurchsatz.

Diese Geschwindigkeitsprobleme hatte ich mit den Tarox Server unter Windows 2008 R2 nicht.

Nette Grüße
Scout71
Bitte warten ..
Ähnliche Inhalte
Erkennung und -Abwehr

Geschwindigkeit Verschlüsselungstrojaner

Frage von theoberlinErkennung und -Abwehr17 Kommentare

Hallo zusammen, hat jemand eine Erfahrungswert (mein Beileid wenn aus erster Hand) wie schnell Verschlüsselungstrojaner álá Wannacry etc. Dateien ...

LAN, WAN, Wireless

WLAN Geschwindigkeit

gelöst Frage von keine-ahnungLAN, WAN, Wireless28 Kommentare

Hallo all, ich habe mir zuhause einen ftth-Zugang der Telekomiker aufschwatzen lassen. Zugang ins heimische WLAN erfolgt via pppoe ...

Batch & Shell

Powershell - Geschwindigkeit Dateisuche

gelöst Frage von internet2107Batch & Shell16 Kommentare

Ich habe das Problem, dass eine Suche nach einer Datei extrem lange dauert, obwohl ich dem Befehl schon Grundsätze ...

Windows XP

Virtualbox eingeschränkte Geschwindigkeit

Frage von 100100010011101Windows XP12 Kommentare

Einen wunderschönen Tag, wir haben einen WinXp Rechner durch eine Virtualbox ersetzt. Das System hat nun mehr Leistung als ...

Neue Wissensbeiträge
iOS

iOS-Bug unterbindet vollständiges VPN-Tunneling

Information von transocean vor 15 StundeniOS

Moin, seit dem letzten Update hat iOS für iPhone und iPad ein Problem mit der Verschlüsselung. Lest selbst. Grüße ...

Sicherheit
Corona Malware über manipulierte Router
Information von sabines vor 18 StundenSicherheit

Heise berichtet über Malware, die in Zusammenhang zum Suchethema Corona steht und über DNS Einstellungen bei D-Link und Linksys ...

Windows 10
Windows 10 Update KB4535996 fehlerhaft
Information von Frank vor 1 TagWindows 101 Kommentar

Laut Microsoft ist das Update KB4535996 die Ursache für aktuelle Verbindungsprobleme bei Virtual Private Networks (VPNs). Microsoft arbeitet bereits ...

Administrator.de Feedback
Entwicklertagebuch: Der neue Ticker ist da
Information von admtech vor 1 TagAdministrator.de Feedback3 Kommentare

Hallo User, mit dem aktuellen Release haben wir den neuen "Ticker" zur Seite hinzugefügt. Oben im Hauptmenü findet ihr ...

Heiß diskutierte Inhalte
SAN, NAS, DAS
Hilfe bei der Einrichtung vom QNAP Nas Server
gelöst Frage von Chris.21SAN, NAS, DAS16 Kommentare

Hallo, ich benötige Hilfe bei der Einrichtung meines neuen NAS Servers von QNAP. ich möchte eine Verbindung vom Internet ...

Drucker und Scanner
OCR Erkennung auf Server
Frage von KodaCHDrucker und Scanner14 Kommentare

Guten Morgen Bisher habe ich einen HP LaserJet Pro MFP M426fdw. Da es nicht viele Dokumente zum Scannen gibt ...

Firewall
PFsense OPENVPN nur RDP zulassen
gelöst Frage von schicksalFirewall13 Kommentare

Hallo zusammen, ich will folgendes konfigurieren: Ich habe einige OPENVpn Cilents bei diesen funktioniert der Tunnel. Nur folgendes, es ...

Windows Server
Erreichbarkeit von Freigaben auf Server 2019 durch ältere Linux-basierte Geräte
gelöst Frage von SarekHLWindows Server13 Kommentare

Hallo zusammen, ich habe hier zwei Geräte, einen Kopierer (Ricoh MP2554) und eine WebCam (Trendnet TV-IP311IP), die trotz korrekter ...