HyperV-Host Fehlermeldung

supernooby
Goto Top
Moin Community!

Ich hätte gerne wieder ein Problem, und zwar findet sich in der Ereignisanzeige des Host-Servers folgender Fehler, und zwar sehr oft und stets zu unterschiedlichen Zeiten. Die entsprechende VM läuft aber problemlos, nur dass im Ereignisprotokoll der VM zur selben Zeit eine Warnung angezeigt wird.

Es handelt sich dabei stets um dieselbe VM und um WinServer 2019 (Host & VMs).

bild_01
bild_02

Das Problem haben anscheinend auch andere, aber ebenfalls keine Lösung. Vielleicht wisst Ihr ja mehr!

Content-Key: 3206050199

Url: https://administrator.de/contentid/3206050199

Ausgedruckt am: 19.08.2022 um 13:08 Uhr

Mitglied: dertowa
dertowa 29.06.2022 um 08:25:40 Uhr
Goto Top
Ist die Meldung immer identisch, also betrifft es immer Datenträger "0"?
Die Meldung sagt ja nur aus, dass der Zugriff auf die Adresse auf diesem Datenträger nicht möglich war und wiederholt wurde.
Sollte natürlich beim Storage nicht vorkommen, kann aber vieles sein wie ist denn der Systemaufbau, also gib mal ein paar Details zum Datenträger "0".
Mitglied: SuperNooby
SuperNooby 29.06.2022 aktualisiert um 08:34:41 Uhr
Goto Top
Ja, es ist stets der selbe Datenträger und auf der VM die einzige virtuelle Platte (Systemlaufwerk). Auf dem Host ist es eine von vielen 'Datenträgern'.
Mitglied: dertowa
dertowa 29.06.2022 um 08:37:16 Uhr
Goto Top
Zitat von @SuperNooby:

Auf dem Host ist es eine von vielen 'Datenträgern'.
Auch das sagt nun leider nicht viel, lässt nur die Interpretation zu, dass es sich um einen Raidcontroller und ein Raidset handelt... Details bitte.

Grüße
Mitglied: Avoton
Avoton 29.06.2022 um 08:50:29 Uhr
Goto Top
Bei einem RAID dürfte Windows aber nichts mehr von den einzelnen Platten "sehen" können.
Dann wäre Datenträger 0 das ganze RAID Set und der Controller bzw. Dessen Software müssten einen defekten Datenträger melden.
Mitglied: SuperNooby
SuperNooby 29.06.2022 aktualisiert um 09:08:29 Uhr
Goto Top
Auf dem Host werden mittels eines RAID-Controllers (Raid Broadcom - LSI MegaRAID SAS 9460-16i) vier NVMe's (Intel DC P4610; 3,2TB) im RAID-5-Verbund betrieben. Es ist ein weiterer RAID-Controller (Raid Broadcom - LSI MegaRAID SAS 9440-8i) als Ersatz/Erweiterung vorhanden.
Mitglied: Coreknabe
Coreknabe 29.06.2022 um 09:23:38 Uhr
Goto Top
Moin,

das liegt alles lokal auf einem Host? Für Storage, das über Netzwerk angebunden ist, könnte es an den NICs liegen:
https://www.mcseboard.de/topic/219908-failed-to-map-guest-io-buffer/

Treiber und Firmware der RAID-Controller sind aktuell? Einstellungen der RAID-Controller gecheckt?
Passiert auf der VM zu den angegebenen Zeiten etwas besonderes? Erhöhte Last / Backup?

Gruß
Mitglied: C.R.S.
C.R.S. 29.06.2022 um 11:33:20 Uhr
Goto Top
Hi,

du musst die Disk-Fehler hier rauslesen, um mehr zu erfahren: https://github.com/tpn/winsdk-10/blob/master/Include/10.0.14393.0/shared ...
Siehe: https://docs.microsoft.com/en-us/archive/blogs/ntdebugging/interpreting- ...

Ein RAID-Controller kann diverse Disk-Fehler nicht erkennen oder zusätzlich einfügen, etwa wenn die Firmware keine Instruktionen für den Umgang mit unrichtigen Daten bzw. einer bestimmten Menge davon enthält (normalerweise Neuberechnung der Paritätsdaten).

Grüße
Richard
Mitglied: MysticFoxDE
MysticFoxDE 29.06.2022 um 11:50:54 Uhr
Goto Top
Moin SuperNooby:

Ich hätte gerne wieder ein Problem, und zwar findet sich in der Ereignisanzeige des Host-Servers folgender Fehler, und zwar sehr oft und stets zu unterschiedlichen Zeiten. Die entsprechende VM läuft aber problemlos, nur dass im Ereignisprotokoll der VM zur selben Zeit eine Warnung angezeigt wird.

Es handelt sich dabei stets um dieselbe VM und um WinServer 2019 (Host & VMs).

bild_01
bild_02

Das Problem haben anscheinend auch andere, aber ebenfalls keine Lösung. Vielleicht wisst Ihr ja mehr!

Hast du schon chkdsk drüber gejagt?
Ist die vhdx dynamisch oder fix?
Ist das Grundvolume auf dem die VM's liegen mit ReFS oder NTFS formatiert?

Beste Grüsse aus BaWü
Alex
Mitglied: SuperNooby
SuperNooby 29.06.2022 aktualisiert um 12:11:52 Uhr
Goto Top
Zitat von @Coreknabe:

das liegt alles lokal auf einem Host?

Treiber und Firmware der RAID-Controller sind aktuell? Einstellungen der RAID-Controller gecheckt?
Passiert auf der VM zu den angegebenen Zeiten etwas besonderes? Erhöhte Last / Backup?

Ja, ist doch nichts Besonderes! Und nein, zu besagten Zeiten passiert nichts, da die Uhrzeiten auch unterschiedlich sind.

Ich habe mir mal den RAID-Controller angesehen und im EventLog ist folgendes aufgeführt, wobei ich aber denke, dass das nichts mit dem Problem an sich zu tun hat, da die Meldung ganz frisch ist. Davor ist alles im grünen Bereich.

bild


EDIT:
Die Meldung ist bei beiden RAID-Controllern vorhanden.
Mitglied: Coreknabe
Coreknabe 29.06.2022 um 12:33:56 Uhr
Goto Top
Ja, ist doch nichts Besonderes! Und nein, zu besagten Zeiten passiert nichts, da die Uhrzeiten auch unterschiedlich sind.

Sagt ja auch niemand, dass das etwas Besonderes ist, das war einfach nur eine Frage face-wink

Mit der RAID-Meldung bist Du doch schon einmal weiter, leider hast Du die Frage nach aktueller Firmware und Treibern nicht beantwortet.

Testweise kannst Du Snapdump einmal deaktivieren und schauen, ob sich etwas ändert:
https://docs.broadcom.com/doc/MR-TM-SW-UG

(Seite 152: SnapDump Support Commands)

Gruß
Mitglied: SuperNooby
SuperNooby 29.06.2022 aktualisiert um 13:19:52 Uhr
Goto Top
Zitat von @MysticFoxDE:

Hast du schon chkdsk drüber gejagt?
Ist die vhdx dynamisch oder fix?
Ist das Grundvolume auf dem die VM's liegen mit ReFS oder NTFS formatiert?

Nein, fix und NTFS.


@Coreknabe:
Ich habe jetzt mal die SnapDump geleert und bzgl. der Firmware bin ich am schauen.
Mitglied: MysticFoxDE
MysticFoxDE 29.06.2022 aktualisiert um 13:23:22 Uhr
Goto Top
Moin SuperNooby,

Nein

Wenn das für chkdsk gilt, dann mach das mal bitte.

Wenn das Problem nur auf einer VM auftritt, dann hat es meistens nichts mit dem RAID-Controller, dessen Konfiguration oder den Treibern zu tun. Da muss man in der VM suchen.

Kann es sein, dass zu dieser Zeit von dieser VM Snapshots oder Backups gemacht werden?

Gruss Alex
Mitglied: SuperNooby
SuperNooby 29.06.2022 aktualisiert um 13:51:56 Uhr
Goto Top
Es werden zwar Backups (Veeam) von der VM bzw. den VM's gefahren, aber nur spätabends.
Mitglied: SuperNooby
SuperNooby 30.06.2022 aktualisiert um 08:02:15 Uhr
Goto Top
Ich habe vor, den RAID-Controller upzudaten, wobei ich aber annehme, dass das nichts mit 'meinem' Problem zu tun haben wird.

Die aktuelle genutzte FW-Version ist die 5.120.xxxxxx und die neueste, die ich über thomas-krenn auftreiben konnte, ist die 5.190.xxxxxx. Das Flashen der FW an sich erfolgt ja über die Weboberfläche des Controllers und ein Reboot scheint nicht nötig zu sein (jedenfalls nicht laut der Erklärung).

Falls ein Reboot nicht nötig ist, könnte ich das FW-Update im produktiven Betrieb on-the-fly durchführen, ohne dass die User etwas bemerken? Denke eher nicht, oder?

Und wie ist es mit dem Treiber an sich, welchen ich ebenfalls upzudaten gedenke? - Das Updaten wird wohl über die Kommandozeile initiiert und ein Reboot ist wohl auch fällig. Oder kann ich es auch direkt über den Gerätemanager handhaben?

Ergo müsste ich das Ganze aufs WE verschieben, da die VM's vorher runtergefahren werden müssen (was ich aber sowieo machen muss, da ich die virtuellen Server und auch den Host updaten möchte).
Mitglied: dertowa
dertowa 30.06.2022 um 09:09:02 Uhr
Goto Top
Zitat von @SuperNooby:

Ich habe vor, den RAID-Controller upzudaten, wobei ich aber annehme, dass das nichts mit 'meinem' Problem zu tun haben wird.

Wie @MysticFoxDE korrekt schrieb wird der Host nicht das Problem darstellen wenn die Ereignislogs nur in einer VM auftauchen.
Ich hatte mich da vom Titel des Threads täuschen lassen "Hyper-V Host Fehlermeldung"...

Die Aktualisierung von Firmware und Treiber kannst du natürlich dennoch angehen, die Firmware lässt sich bei den meisten Controllern im laufenden Betrieb aktualisieren, wird aber erst nach einem Reboot aktiviert.
Beim Treiber am Host ist das genauso, der wird einen Neustart verlangen, den kannst du aber auch später machen - hilft dir letztlich aber nicht weiter.
Ich würde die Aktualisierung vornehmen wenn der Reboot auch erfolgen kann.

Geräte-Manager für den Treiber ist das Werkzeug deiner Wahl wenn du eine GUI am Host hast.
Mitglied: SuperNooby
SuperNooby 30.06.2022 um 09:27:16 Uhr
Goto Top
Ja, eine GUI am Host und am RAID-Controller sind vorhanden:

bild

Bzgl. der FW habe ich noch eine Frage: Vorhanden sind zwei .rom-Dateien, einmal nur 128KB groß und einmal 7MB.

Flashen werde/will ich die größere, wozu ist aber die kleinere gedacht?
Mitglied: Coreknabe
Coreknabe 30.06.2022 um 09:45:48 Uhr
Goto Top
@alex
Wenn das Problem nur auf einer VM auftritt, dann hat es meistens nichts mit dem RAID-Controller, dessen Konfiguration oder den Treibern zu tun. Da muss man in der VM suchen.

Jein, zum einen sind die Möglichkeiten in der VM arg begrenzt (was soll ich denn da machen, außer sicherzustellen, dass die HyperV-Integration auf dem neuesten Stand ist?). Zum anderen könnte sich das Fehlerbild allein auf einer VM dadurch erklären, dass auf dieser evtl. mehr Last gefahren wird / die I/O-Last durch Datenbanken o.ä. höher ist und der Fehler erst unter Last auftritt. Dazu äußert sich der TO ja aber leider nicht.

Gruß
Mitglied: SuperNooby
SuperNooby 30.06.2022 aktualisiert um 11:43:39 Uhr
Goto Top
Die betroffene VM ist ein DATEV-Terminalserver, wobei die SQL-Datenbanken auf einer anderen VM liegen. Des Weiteren ist besagter Terminalserver max. von 3-4 Leuten gleichzeitig in Nutzung. Die CPU-Auslastung der VM liegt zw. 5 und max. 15% (und falls von Belang: 4 vCores mit 16GB RAM).
Mitglied: Coreknabe
Coreknabe 30.06.2022 um 10:28:07 Uhr
Goto Top
Die betroffene VM ist ein DATEV-Terminalserver

OK, das könnte dann doch wieder in die VM-Richtung weisen. Mal ins Blaue gefragt, ist ein Virenscanner für die VMs im Einsatz? Hast Du dort entsprechend für den SQL-Server Ausnahmen generiert? Ist zusätzlich der Defender aktiv?

Gruß
Mitglied: SuperNooby
SuperNooby 30.06.2022 um 11:54:08 Uhr
Goto Top
Auf dem DATEV- und SQL-Server ist der DATEV-eigene Virenscanner VIWAS im Einsatz und auf den restlichen VM's Sophos. Entsprechende Ausnahmen sind generiert und der Defender ist nicht aktiv.
Mitglied: MysticFoxDE
MysticFoxDE 01.07.2022 um 06:55:02 Uhr
Goto Top
Moin SuperNooby,

Auf dem DATEV- und SQL-Server ist der DATEV-eigene Virenscanner VIWAS im Einsatz und auf den restlichen VM's Sophos. Entsprechende Ausnahmen sind generiert und der Defender ist nicht aktiv.

ich habe mal gestern auf einem Datev-RDS (2019) bei einem unserer Kunden nachgeschaut,
habe auf diesem aber nicht denselben Fehler finden können.

Auf dem RDS ist Sophos-AV drauf.

Gruss Alex
Mitglied: SuperNooby
Lösung SuperNooby 04.07.2022 um 09:27:08 Uhr
Goto Top
Die Fehlermeldung ist in den letzten Tagen nicht mehr aufgetreten. Außer die RAID-Controller und den Host aufgrund der WinUpdates zu rebooten, wurde nichts getan.

In diesem Sinne.....THX & case closed!