orcape
Goto Top

Kein Scannen Subnetzübergreifend

Hi Leute,
mein NAS/OpenMediaVault befindet sich in einer DMZ an einer pfSense .
Die DMZ liegt in einem anderen IP-Range, vom LAN (reines Debian Netz)getrennt.
Seit vor einigen Tagen mit einem Upgrade OpenMediaVault 0.5.28 die Cups-Unterstützung möglich geworden ist,
habe ich meinen HP_Officejet_5600 USB-Multifunktionsdrucker ans NAS gehängt.
Das ganze funktioniert jetzt per Cups, Netzwerk übergreifend absolut problemlos aus LAN- und WLAN-Netz.
Leider habe ich mit Sane weniger Glück.
Nach folgendem Tutorial habe ich versucht das Scannen einzurichten...
http://wiki.ubuntuusers.de/SANE-Scanserver_im_Netzwerk
...leider bis jetzt ohne Erfolg.
Port 6566 habe ich auf der pfSense Freigeschaltet, testweise komplett offen.
Xsane findet keinen Scanner, "scanimage -L" ebenfalls ohne Ergebnis.
Jemand ´ne Idee wie ich an das Problem rangehen kann ?
Gruß orcape

Content-Key: 227062

Url: https://administrator.de/contentid/227062

Printed on: June 24, 2024 at 17:06 o'clock

Member: aqui
Solution aqui Jan 18, 2014, updated at Jan 19, 2014 at 12:40:08 (UTC)
Goto Top
Hallo Orcape
Gehen wir mal davon aus das der saned Server vom Xsane Client anpingbar ist usw. Wenn du testweise die FW Regeln deaktiviert hast hast du ja einen einfachen Router. Da saned TCP 6566 nutzt und nirgendwo von Broadcasts die Rede sollte es auch routebar sein.
Du solltest mal strategisch vorgehen und einen Client direkt in das Segment des NAS / saned Servers hängen und dort mal checken ob eine Verbindung direkt im LAN ohne Routing zustandekommt.
Ist das der Fall solltest du mit tcpdump oder dem Kabelhai mal genau sehen wie die Kommunikation abläuft um genau zu sehen welche Ports verwendet werden um nachher die Firewall richtig zu customizen.
Sollte auch da die Verbindung nicht zustandekommen hast du ja erstmal ein generelles Problem mit dem NAS bzw. dem saned dadrauf was du fixen musst.
OK mehr oder weniger Binsenweisheiten für einen Netzwerker face-smile
Falls es am detecten des Scanners hapert hilft ggf. das:
https://help.ubuntu.com/community/SANE%20-%20Installing%20a%20scanner%20 ...
das kennst du sicher:
https://help.ubuntu.com/community/ScanningHowTo
Member: orcape
orcape Jan 18, 2014 at 18:24:58 (UTC)
Goto Top
Hi Aqui,
auf die Idee, das ganze erst mal in der DMZ zu testen bin ich natürlich nicht gekommen.
Wie war das mit den Wald vor lauter Bäumen nicht sehen...face-sad
Ansonsten wie immer fachlich kompetent.
Danke für die Denkanstöße und die Links, ich melde mich..face-wink
Gruß orcape
Member: orcape
orcape Jan 19, 2014 at 12:40:00 (UTC)
Goto Top
Hi,
wie Aqui schon richtig vermutet hat, lag das Problem nicht beim Routing.
Ein, in die DMZ integrierter Laptop brachte dem HP_Officejet_5600 leider auch nicht das Scannen bei.
Auch das Ubuntu-HowTo brachte mich nicht ans Ziel.
OpenMediaVault (0.5.31 Saudarkar Linux3.2.0-0.bpo.4-amd64/Debian Squeeze) verfügt zwar jetzt über eine Druckerunterstützung,
Sane mit seinen Abhängigkeiten hatte ich aber nachinstalliert.
Ein "scanimage -L" brachte mir aber kein Ergebnis. "sane-find-scanner" brachte dann zumindest die Daten
des am USB befindlichen HP zu Tage.
Der händische Eintrag in die Systemdatei von "sane.d" war dann auch noch nicht ausreichend.
Erst das Nachinstallieren von "hplip" mit seinen Abhängigkeiten brachte den gewünschten Erfolg.
Für die Portfreischaltung muss zwingend der Port 6566 freigeschaltet werden. Ausserdem braucht Sane noch Datenports.
Da diese je nach Anforderung von Sane wechseln, habe ich noch den Portrange 35000-59000 freigegeben.
Gruß orcape
Member: aqui
aqui Jan 19, 2014 at 14:04:30 (UTC)
Goto Top
Dank fürs Feedback ! Gut das nun alles klappt wie es soll...