spirit-of-eli
Goto Top

Mikrotik SwitchOS Downgrade 2.12 zu 2.11

Moin zusammen,

hat jemand Erfahrung damit einen Mikrotik RB260GS (CSS106) von 2.12 zu 2.11 down zu graden?
Seid dem ich das Update installiert habe, funktioniert RSTP nicht mehr und ich habe alle zwei Sekunden eine Neuaushandlung ausgehen von dem RB260GS.

Das Image habe ich mir bereits geladen. Allerdings führt der Upload und anschließende "Upgrade" nicht zum gewünschten Ergebnis.

Edit: anscheinend ist der einzig gangbare Weg über reset Taste in das Backup Image zu Boot und alles von vorne durchzuführen. Oder gibt es noch eine Option?

Gruß
Spirit

Content-Key: 589103

Url: https://administrator.de/contentid/589103

Printed on: February 29, 2024 at 08:02 o'clock

Member: aqui
aqui Jul 19, 2020 updated at 12:26:43 (UTC)
Goto Top
und ich habe alle zwei Sekunden eine Neuaushandlung ausgehen von dem RB260GS.
Woran machst du das fest ??
Bedenke das der MT nur ein Single Span RSTP kann ! Auch sollte man in einem Singel Spanning Tree Umfeld zwingend die Priority der Root Bridge statisch festlegen (z.B. 8192) !!

Wenn du auf der anderen Seite Router oder Switches hast die z.B. PVRSTP oder PVRSTP+ machen (Cisco, Juniper, Ruckus usw.) dann kann sowas auch passieren ?!
Diese STP Verfahren sind inkompatibel untereinander !

Es ist zu bezweifeln und wäre sehr ungewöhnlich das Mikrotik in solch einer Standard, Basis Funktionen wie Spanning Tree einen Bug haben sollte.
Die Changelogs der letzten 3 Releases 2.10 bis 2.12 zeigen auch dementsprechend keinerlei Changes im STP Code !
Member: Spirit-of-Eli
Spirit-of-Eli Jul 19, 2020 at 12:31:42 (UTC)
Goto Top
Die Prority ist fest definiert und alles hat wie erwartet funktioniert bevor ich das Upgrade durchführt habe.

Das verhalten nun lässt sich beheben sobald ich RST an besagtem Switch ausschalte.

Auf der Gegenseite ist ein Mikrotik Audienz. In Verbindung mit diesem und eben SwitchOS 2.12 habe ich alle zwei Sekunden Abbrüche über mehrere Sekunden. Nur debuggen lässt sich dies am SwOS nur spärlich.
Member: Spirit-of-Eli
Spirit-of-Eli Jul 19, 2020 at 12:58:46 (UTC)
Goto Top
Zitat von @109961:

einfach mal google fragen?!

Dann schieß mal los.
Bis auf meine genannte Option konnte ich bisher nichts finden. Daher sehr hilfreicher Kommentar..
Member: aqui
aqui Jul 19, 2020 at 14:46:49 (UTC)
Goto Top
Ist das gesamte Netz ein reines Mikrotik Netz also rein MT Hardware oder werkelt da ggf. noch was anderes.
Gut, wenns vorher fehlerlos funktioniert bei exakt gleichem Setup funktioniert hat ist das natürlich ein Argument.
Ist nur komisch woher dann diese zyklischen Topology Changes herkommen...?!
Ich habe hier einen CRS305 mit SwOS 2.12 in einem gemischten Single Span Netz mit HP und Ruckus Switches und da nichts Auffälliges gesehen. Gut, rennt auch kein Produktivtraffic und ich habe nicht detailiert in die Logs gesehen. Ich lasse das mal länger laufen und setze den MT mit hex 4000 Prio mal als Root Switch.
Member: Spirit-of-Eli
Spirit-of-Eli Jul 19, 2020 at 15:34:52 (UTC)
Goto Top
Ich hatte den Audienz als root gesetzt.
Die komplette Netzwerk Hardware besteht aus Mikrotik Geräten und ich hatte die Prio auch nur bei dem Audienz runter gesetzt da dieser zentrale zwischen den paar geräten hängt.

Ein test hat ergeben das alles wieder läuft sobald ich den Audienz aus dem Netz heraus nehme oder am RB260GS RSTP auf dem uplink zum Audienz deaktiviere.

Erklären kann ich mir das gerade nicht. Sicher ist, das diese Phänomen mit der neuen Firmware auftrat. Gefühlt ist es ein ganz normales spanning tree Thema. Das kann ich aber nicht nachweisen. Ich habe auch schon am logging gedreht und keinerlei Meldungen erhalten. Das SwitchOS kann ich anscheinend nicht in der Hinsicht prüfen.
Member: aqui
aqui Jul 19, 2020 at 16:06:33 (UTC)
Goto Top
Ich hatte den Audienz als root gesetzt.
Das ist ja eigentlich ein Endgerät und sollte niemals irgendwelche Infrastruktur darstellen ! Root Switch sollte generell immer die Switch Infrastruktur halten aber niemals Endgeräte auch wenn sie einen embeddeten Switch haben.
Das Teil reisst dann beim Anschluss immer die Root Bridge weg und erzwingt dann einen Topology Change im gesamten Netz.
Von meiner Perspektive falsch das so zu machen... Root sollte immer ein Switch sein der permanent im Netz ist.
ein ganz normales spanning tree Thema. Das kann ich aber nicht nachweisen.
Wireshark ist dein Freund ! face-wink
Member: Spirit-of-Eli
Spirit-of-Eli Jul 19, 2020 at 16:09:24 (UTC)
Goto Top
Ich werde nachher mal testen die Root auf den RB260 zu legen. Ansonsten spielt in meinem privaten Setup keine große Rolle.
Member: aqui
aqui Jul 19, 2020 at 16:28:12 (UTC)
Goto Top
Wenn man mit Spanning Tree arbeitet spielt das immer eine Rolle, auch wenns nur ein Switch ist. face-wink
Ansonsten kann dir ja jeder mit einem Billigswitch das ganze Netz kapern...