MS-DOS 6.22 - Tastaturlayout

Mitglied: geTuemII

geTuemII (Level 3) - Jetzt verbinden

21.01.2009, aktualisiert 14:56 Uhr, 12785 Aufrufe, 6 Kommentare

Hallo @all,

ich konfiguriere gerade eine DOSE 6.22 (ja, wirklich!) in einem Virtuell PC. Dabei bereitet mir das Tastaturlayout einige Sorgen. Ich habe Country und Tastatur auf deutsch konfiguriert, das scheint auch zunächst funktioniert zu haben: keyb liefert Layout gr, Codepage 850, CON Codepage 850. Die Umlaute funktionieren und das Datumsformat ist deutsch (zb. mit dir).

Allerdings kann ich kein Backslash "\" eingeben, offensichtlich tun alle Tasten, die über AltGr gesteuert werden nicht. Gelagen sind übrigens ega.cpi und keyboard.sys

Kann sich von euch noch jemand erinnern, wie das funktioniert?

Ist das lange her...
geTuemII
Mitglied: 60730
60730 (Level 5)
21.01.2009 um 15:06 Uhr
Servus,

mir ist folgendes aufgefallen:

[ALT Gr] und Numtastatur 92 = \ (alter Hut - nichts besonderes)
Aber bei meinen VMware Server Clients funktioniert die 10+Tastatur nicht - bzw. da ich die eh nicht brauche - mußte ich mir noch keine Gedanken darum machen warum weshlab.

Von daher - funktioniert bei deinem Client der 10er Block?


Gruß
Bitte warten ..
Mitglied: geTuemII
21.01.2009 um 15:32 Uhr
Hi House,

der Nummernblock tut bei mir, aber AltGr+92 hilft nicht wirklich, da offensichtlich das Problem in der AltGr-Taste zu suchen ist. Ein Host-Problem kann es eigentlich auch nicht sein, habe gerade den zweiten getestet. --> dieselben Symtome

geTuemII
Bitte warten ..
Mitglied: telefix1
21.01.2009 um 15:47 Uhr
...ja ja...

Versuche es mal bitte mit dem Zeichensatz 437 statt mit 850...

config.sys
country=049,850 oder 437,Pfad der country.sys
mode con 850 oder 437
keyb gr,850 oder 437,Pfad der keyboard.sys


mfg telefix1
Bitte warten ..
Mitglied: n.o.b.o.d.y
21.01.2009 um 16:09 Uhr
Moin!

Beim VirtuallPC ist die AltGr-Taste doch die Hosttaste (für Vollbild und so). Leg die doch einfach um, dann sollte es auch in der VM gehen.

Datei > Optionen > Tastatur
Bitte warten ..
Mitglied: geTuemII
21.01.2009 um 17:05 Uhr
<aua><aua><aua><aua><aua><aua>

Moin n.o.b.o.d.y,

da habe ich wohl den Wald wieder einmal nicht vor Bäumen... Weil ich wegen des DOSEN-Setups schon ganz tief in längst verschütteten Erinnerungen graben mußte, hatte ich geglaubt, es müsse sich um ein Problem in der DOS-Config handeln.

Und kaum mache ich, was du sagst, tut auch schon alles :-) face-smile

Danke,
geTuemII
Bitte warten ..
Mitglied: geTuemII
21.01.2009 um 17:06 Uhr
Hallo telefix1,

danke für die Idee, das hatte ich vorher schon probiert - tat auch nicht. Die Lösung findest du unten.

geTuemII
Bitte warten ..
Heiß diskutierte Inhalte
Viren und Trojaner
Emotet angeblich unschädlich gemacht
DoskiasVor 1 TagInformationViren und Trojaner15 Kommentare

Hallo zusammen, kam grade rein. Wir werden sehen ob es stimmt: Eilmeldung Bundeskriminalamt: Weltweit gefährlichste Schadsoftware unschädlich gemacht Stand: 27.01.2021 13:18 Uhr Deutsche Ermittler ...

Router & Routing
Erklärung zu diesen Geräten
RoadmaxVor 1 TagFrageRouter & Routing7 Kommentare

Hallo Zusammen, bei uns war heute spontan das Internet weg und wir mussten die Carrier Geräte neu starten. Mir stellt sich die Frage, welches ...

Windows Update
Clients melden sich nicht selbständig am WSUS Server
gelöst BPeterVor 1 TagFrageWindows Update12 Kommentare

Hallo, ich habe einen Windows Server 2019 WSUS in unserem AD eingerichtet. Die Clientkonfig übertrage ich per Group Policy. Sie wird auch vom Client ...

Firewall
PfSense als Exposed Host hinter FritzBox 6591 Cable
SMT000Vor 1 TagFrageFirewall7 Kommentare

Hallo zusammen, ich kenne mich mit dem Thema leider nicht gut aus und habe deshalb einige Verständnisfragen. Vorab, ich hab hier eine FritzBox 6591 ...

Exchange Server
5.4.1 Recipient address rejected: Access denied. AS(201806281)
gelöst DeclarationVor 1 TagFrageExchange Server5 Kommentare

Hallo im Unternehmen ist Microsoft 365 business installiert inclusice AD Syncronisierung bei 10 MA . Bis Samstag lief der Exchange perfekt. Seitdem bekommt ein ...

Windows 10
System Backup als ISO-Datei(Image) erstellen
Ramin-sVor 23 StundenFrageWindows 1011 Kommentare

Hallo zusammen, Wir haben eine Mitarbeiterin bei der Arbeit, die für die längere Zeit nach Ausland geht und wird von Ausland arbeiten. Ich bin ...

Windows Server
Benutzer und Postfach über AD erstellen
Igdirli76Vor 1 TagFrageWindows Server10 Kommentare

Hallo Leute, bitte erschießt mich nicht gleich wegen meiner frage. Ich habe einen Windows Server 2019 Datacenter installiert und wollte beim User erstellen, dass ...

LAN, WAN, Wireless
Cisco AIR LAP1142NEK9 LW zu AN
gelöst bySwiftVor 1 TagFrageLAN, WAN, Wireless18 Kommentare

Hallo Zusammen, Ich habe mir einen Cisco AIR-LAP1142N-E-K9 geholt der aktuell noch im Lightweight Mode läuft. Diesen möchte ich auf Autonomouse umstellen sodass ich ...