Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Server 2003 - Internet für Clients (10.x.x.x) über Server - Router (192.168.1.100) an Server angeschlossen

Mitglied: m-jelinski

Clients befinden sich im 10er Netz und der billig DSL Router hat 192.168.1.100
MS Server 2003 hat 2 Netzwerkkarten, Active Directory und DHCP

Hallo,

kann mir jemand helfen? Mein billig DSL Router (IP 192.168.1.100; SubNetz 255.255.255.0) ist an eine Netzwerkkarte (IP 192.168.1.1; SubNetz 255.255.255.0) des Servers angeschlossen.

Meine Clients hängen an an einer anderen Netzwerkkarte vom Server (IP 10.0.0.1; SubNetz 255.0.0.0) und bekommen ihre IP vom DHCP Server (Adressbereich 10.1.x.x; Gateway: 192.168.1.1 = andere Netzwerkkarte im Server).

Routing ist im Server aktiviert. Vom Client kann ich auf beide Karten im Server pingen.
NAT aktivieren hat nichts gebracht.

1.) Wie schaffe ich es, das die Clients Internet über den Server bekommen?

2.) Sollte das geschafft sein: Kann ich sagen, das User x Internetzugang hat und User y keinen Zugang hat? Wie?

Bin über jede Hilfe dankbar!!!!

Content-Key: 1441

Url: https://administrator.de/contentid/1441

Ausgedruckt am: 25.10.2021 um 10:10 Uhr

Mitglied: GPO
GPO 06.07.2004 um 12:40:36 Uhr
Goto Top
Hallo,

>1.) Wie schaffe ich es, das die Clients Internet über den Server bekommen?
Dir ist anscheinend klar, daß Dein Windows 2003 Server auch die Aufgabe des Routers übernehmen muß, daher sprichst Du davon, daß Routing am Server aktiviert ist.
Was zeigt Start->Ausführen->cmd->ipconfig/all auf den Clients an?
Warum verwendest Du einmal ein Class A (10.x.x.x) und einmal ein Class C (192.168.x.x) Netz?


2.) Sollte das geschafft sein: Kann ich
sagen, das User x Internetzugang hat und
User y keinen Zugang hat? Wie?
Du könntest eine GPO für Softwareeinschränkung bei Windows XP Clients machen. Dort kannst Du Internetzonenregeln festlegen.
Was für Clients hast Du?


GPO
Mitglied: m-jelinski
m-jelinski 12.07.2004 um 11:51:02 Uhr
Goto Top
Ich nutze die 2 Netze, weil der SOHO DSL-Router nur ein Class C Netz unterstützt (Subnet-Mask fest auf 255.255.255.0). Meine Clients müssen aber im Class A Netz arbeiten, da ich die Adressevielfalt benötige. Auf den Clients ist als Gateway die Adresse der NIC im Server angegeben. Die dann per IP Routing ja Zugriff auf die andere hat. Diese hat als Gateway den SOHO Router. Funktioniert trotzdem nicht. Ich weiß nur nicht warum.

Ich wäre auch bereit einen neuen SOHO Router zu kaufen (der CLASS A Netze unterstützt). Leider habe ich noch keinen passenden gefunden.

Vielen Dank für die Hilfe.

Die Clients sind übrigends WinXP und Win2000 Rechner.
Mitglied: Kaktoos
Kaktoos 08.08.2004 um 15:54:26 Uhr
Goto Top
Hallo,

kann mir jemand helfen?

hi, ich kanns versuchen ;-) face-wink
Mein billig DSL
Router (IP 192.168.1.100; SubNetz
255.255.255.0) ist an eine Netzwerkkarte (IP
192.168.1.1; SubNetz 255.255.255.0) des
Servers angeschlossen.


hab ich ca. auch...

Meine Clients hängen an an einer anderen
Netzwerkkarte vom Server (IP 10.0.0.1;
SubNetz 255.0.0.0)

hmm? ich glaub nicht. daß es relevant ist, aber wenn du nicht gerade mehrere Subnetze benutzt... also 10.1.x.y und/oder 10.2.x.y usw.
kannste die Subnetzmaske ein wenig einschrenken... ist aber glaub ich für das Routing-Problem auch nicht so wirchtig.

>und bekommen ihre IP vom
DHCP Server (Adressbereich 10.1.x.x;
Gateway: 192.168.1.1 = andere Netzwerkkarte
im Server).


lass mal den Gateway der internen NIC einfach leer.

Routing ist im Server aktiviert. Vom Client
kann ich auf beide Karten im Server pingen.
NAT aktivieren hat nichts gebracht.


Also das NAT ist schon wichtig in dieser Konstellation. Du musst dir vor auchen führen, daß der DSL-Router die 10er IPs gar nicht wahr nimmt... er sieht diese einfach gar nicht.

1.) Wie schaffe ich es, das die Clients
Internet über den Server bekommen?

Du mußt bei Routing und RAS BEIDE Netzwerkkarten einfügen und bei der "externen" 192er... in den Eigenschaften NAT aktivieren, die 10er lässt du einfach so darin.
Als Gateway an den Clients muss dann aber auch die 10er Adresse des Server eingetragen sein. Damit steht zumindest fest, daß die Pakete über den Server gehen und samit für den DSL-Router von der 192.168.1.1 kommen... damit weiß er wohin er die Antworten schicken muss...
der Server übernimmt dann die Verteilung der Rückpakete an die Clients.

Ach so, wenn du auf deinem Server keinen DNS-Dienst laufen hast, musst du den Clients die IP des DSL-Routers als DNS-Adresse geben, oder direkt, den DNS-Server deines Providers.
Damit sollte es eigentlich laufen, ich habe diese Kombination auch, wobei nur mit einem Class-A Netzwerk(bevor gleich einer fragt, wegen der Laptop IP, die ich dann nicht immer ändern muss).

2.) Sollte das geschafft sein: Kann ich
sagen, das User x Internetzugang hat und
User y keinen Zugang hat? Wie?


wie man es Userweise beschränken könnte, weiß ich nicht.
Eine Möglichkeit wäre, daß du dann bei RAS die IPs auf der Intenen NIC filterst, aber da du ja DHCP benutzt stellt sich das doch schwieriger dar...

Bin über jede Hilfe dankbar!!!!

Ich hoffe es hilft dir. Gruß Kaktoos
Mitglied: DschinN
DschinN 08.03.2013 um 19:12:39 Uhr
Goto Top
Ich würd mal als Gateway die Server IP nehmen anstatt die vom router ........
wenn du schon Routing und RAS Installiert hast und Konfiguriert hast ........

Deine Clients kommen unmöglich ins internet über deinen Gateway


INET --> 192er Router ---> 10er Server (2 IPs auf der NIC einmal die 10er und einmal die 192er) --> Clients auf die 10er vom server verweisen als Gateway ->> Freuen am Internet
Mitglied: m-jelinski
m-jelinski 11.03.2013 um 07:00:10 Uhr
Goto Top
Hallo DschinN,

vielen Dank für Deine Antwort. Allerdings war der Beitrag aus dem Jahr 2004 :-) face-smile

Schöne Grüße
Michael
Mitglied: DschinN
DschinN 11.03.2013 um 16:26:01 Uhr
Goto Top
hab ich gestern auch gemerkt :P
Heiß diskutierte Beiträge
question
Realistische Zeiterfassung für undisziplinierten Mitarbeiter? gelöst istike2Vor 19 StundenFrageWindows 1014 Kommentare

Hallo, ab Januar bin ich fest angestellt und wurde mir u. A. mitgeteilt, dass wir die Arbeitszeiten in einem Android-App erfassen sollen. Soweit OK. Das ...

question
PC zeigt kein Bild mehrben1300Vor 1 TagFrageHardware14 Kommentare

Hallo zusammen, mein PC geht zwar noch an (LED leuchten und Lüfter laufen), aber ich erhalte kein Bild mehr. Mainboard: MSI B450M Mortar Max Mainboard ...

question
Browserverhalten bei nicht offizieller TLD im privaten NetzSiegfried36Vor 1 TagFrageDNS21 Kommentare

Moin, ich hoffe ihr könnt mir helfen Licht ins Dunkel zu bringen. So ganz verstehe ich diesen ganzen Zusammenhang nicht. Ich will in meinem internen ...

question
Netzwerkproblem Feuerwehr EinsatzleitfahrzeugTorstenWeVor 20 StundenFrageNetzwerke4 Kommentare

Hallo Zusammen, Ich bin Mitglied in einer Feuerwehr mit einem Einsatzleitwagen. In diesem LKW sind mehre Computer-Arbeitsplätze mit einem eigenen Netzwerk verbaut. Wir haben ein ...

question
JBOD - Platte kopieren möglich? gelöst DoKi468Vor 1 TagFrageFestplatten, SSD, Raid2 Kommentare

Hallo zusammen, eine Frage: Ich habe eine Synology NAS und habe dort ein JBOD eingerichtet mit 2 4TB Platten Allerdings springt bei einer Platte teilweise ...

question
Benötige Empfehlung für Komponenten - Umstieg von Ubiquiti auf welches System??Dominik187Vor 8 StundenFrageNetzwerke13 Kommentare

Guten Tag liebe Community, aktuell habe ich einige Produkte von Ubiquiti im Einsatz und überlege, das System zu wechseln, denn leider habe ich mich schon ...

question
Wordpress bereitstellenWolf6660Vor 16 StundenFrageHosting & Housing7 Kommentare

Hi, ich habe eine Domain ohne Webspace gekauft und diese auf meine IP umgeleitet. Nun würde ich gerne eine Wordpress Seite erstellen und diese Online ...

question
Mit SSH auf Android - Fehler mit "mount"PeterGygerVor 20 StundenFrageNetzwerke16 Kommentare

Hallo Ich bin über SSH auf einem Android Device (Nvidia Shield). Das Device funktioniert im LAN. D.h. der Zugriff auf Dateien auf dem NAS über ...