Terminalserver: kryptische Startmenüanzeige

devil5
Goto Top
Hallo an alle ;)

Zuerst hoffe ich mal, dass alles Gesund sind das auch bleiben.

Nun zu meinem Problem:

Ich verwende einen Windows Server 2019 Std. (1809) als Terminalserver.
Seit einiger Zeit habe ich Probleme beim Login der User (siehe Screenshot).

Mit etwas Glück vergeht dies automatisch nach 10-20 Minuten und es werden wieder die Programme richtig angezeigt.
Meistens ist es aber eher so, dass es so bleibt und damit keine Programme über das Startmenü gestartet werden können.

Jetzt wo doch viele auf Home Office unterwegs sind und mal darauf zugreifen ist das natürlich sehr Nervig wenn mal die Programme nicht ordentlich gestartet werden können.
Neu aufsetzen würde ich mir aktuell gerne ersparen, da die Zeit aktuell sehr rar ist und andere Projekte gerade höher priorisiert sind. Ich würde aber gerne meinen Usern ein "normales" Nutzererlebnis bieten ;)

Danke für eure Hlfe schon vorab,
Gesund bleiben
Liebe Grüße aus Wien
Greg
terminalserver

Content-Key: 563532

Url: https://administrator.de/contentid/563532

Ausgedruckt am: 16.05.2022 um 22:05 Uhr

Mitglied: DerWoWusste
Lösung DerWoWusste 07.04.2020 um 21:13:35 Uhr
Goto Top
Hi.

Teste im Fehlerzustand einmal einen Neustart der explorer.exe - hat das eine Auswirkung?
Wenn nein: tritt es auch bei leerrn lokalen Profilen auf (lokalen Testnutzer einrichten)?
Mitglied: DeViL5
DeViL5 07.04.2020 um 21:29:52 Uhr
Goto Top
Hi,

Danke für deine rasche Antwort,

1) Neustart der explorer.exe hat das Problem behoben, nachdem ich im Task Manager den explorer wieder gestartet habe waren die Icons wieder da.
2) Habe trotzdem einen neuen User angelegt, auch hier ist das Problem nicht vorhanden.

Kann ich die explorer.exe "reparieren" ?
Mitglied: DerWoWusste
Lösung DerWoWusste 07.04.2020 um 21:33:11 Uhr
Goto Top
Schön, dass du dem Problem schon näher gekommen bist.
Die explorer.exe ist nicht defekt. Vermutlich sind es Nebeneffekte von User-GPOs.
Nimm einen betroffenen User aus seiner angestammten OU in eine neue Test-OU und verweigere bei dieser OU die Vererbung der GPOs, so dass der Nuzter bei der nächsten Anmeldung gar keine GPOs bekommt. Geht es dann zuverlässig?
Mitglied: DeViL5
DeViL5 08.04.2020 um 09:02:54 Uhr
Goto Top
Guten Morgen,

Danke, ich werde das versuchen Heute nebenbei zu testen, ich melde mich mit den Ergebnissen.

Danke & Liebe Grüße
Mitglied: DeViL5
DeViL5 08.04.2020 um 09:32:09 Uhr
Goto Top
So,

ich habe es natürlich nicht lassen können und es gleich erledigt.
Habe einen betroffenen User in eine eigene OU gelegt und die Vererbung deaktiviert!

Hat auf anhieb funktioniert!

Beim zurückweisen in die alte OU hab ich wieder das kryptische Startmenü.

LG Greg
Mitglied: DerWoWusste
Lösung DerWoWusste 08.04.2020 aktualisiert um 09:45:31 Uhr
Goto Top
Ok, dann finde nun raus, welche GPO das ist, und zwar so:
nimm ihn wieder in die Test-OU und melde ihn neu an - es wird dann ja wieder funktionieren.

Nun verlinke die Hälfte der User-GPOs auf die Test-OU und melde ihn ab und wieder an ->geht es immer noch? Dann ist die Problem-GPO nicht unter den verlinkten. Nun verlinkst Du von der 2. Hälfte der GPOs wiederum die Hälfte und meldest Dich erneut an und so weiter, bis das Problem irgendwann auftritt. Dann weist Du, dass die Problem-GPO unter den zuletzt hinzugefügten ist und du kannst nun eine nach der anderen weider entfernen und jeweils testen, bis du die GPO gefunden hast.

Hast Du sie, schauen wir uns deren Einstellungen mal zusammen an.
Mitglied: DeViL5
DeViL5 08.04.2020 um 10:50:33 Uhr
Goto Top
Danke, hab jetzt nebenbei immer wieder Tests durchgeführt,
also ich habe die GPO nun gefunden,

ich hoffe es passt wenn ich Screenshots gemacht habe der Einstellungen?

LG Greg
gpo_01
gpo_02
gpo_03
Mitglied: DeViL5
DeViL5 08.04.2020 um 10:54:31 Uhr
Goto Top
Diese GPO wird "erzwungen" das bedeutet, dass sie ja trotz Deaktivierung der Vererbung angewendet wird.
Diese GPO liegt auf der Haupt OU und wird an alle unteren Abteilungen weitervererbt.

Das noch zur Info.
LG
Mitglied: DerWoWusste
DerWoWusste 08.04.2020 um 11:03:37 Uhr
Goto Top
Diese GPO wird "erzwungen" das bedeutet, dass sie ja trotz Deaktivierung der Vererbung angewendet wird.
Nein. Erzwungen bedeutet: "wenn eine andere GPO Einstellungen hat, die in dieser GPO auch drin sind, dann bevorzuge die erzwungene GPO". Es hat nichts zu tun mit Vererbung.

Jetzt Besprechung. Schau ich mir danach an.
Mitglied: DeViL5
DeViL5 08.04.2020 um 11:19:56 Uhr
Goto Top
Diese GPO wird "erzwungen" das bedeutet, dass sie ja trotz Deaktivierung der Vererbung angewendet wird.
Nein. Erzwungen bedeutet: "wenn eine andere GPO Einstellungen hat, die in dieser GPO auch drin sind, dann bevorzuge die erzwungene GPO". Es hat nichts zu tun mit Vererbung.
Wenn ich die Vererbung deaktiviere, ist das die einzige GPO die in der "Gruppenrichtlinienvererbung" bleibt mit "Rangfolge 1 (Erzwungen)"

Jetzt Besprechung. Schau ich mir danach an.
Super, Danke für die Unterstützung!
Mitglied: DerWoWusste
Lösung DerWoWusste 08.04.2020 um 11:47:43 Uhr
Goto Top
Nimm doch mal von Deinen Softwasre restriction policies die raus, die das Startmenü betreffen.
Mitglied: DeViL5
DeViL5 08.04.2020 um 15:36:56 Uhr
Goto Top
Hi,

Danke, ja das war auch mein Plan, habe diesen jetzt ebenfalls verfolgt, und siehe da, es funktioniert.
manchmal dauert es zwar aber mit Profil löschen klappt es dann auf Anhieb.

Vielen herzlichen Dank,
Liebe Grüße aus Wien und Gesund bleiben!!!
Mitglied: DerWoWusste
DerWoWusste 08.04.2020 um 15:38:20 Uhr
Goto Top
Prima.

Dito!
Mitglied: DerWoWusste
DerWoWusste 08.04.2020 um 15:39:02 Uhr
Goto Top
PS: jetzt überlegen wir uns noch einmal wie gut die Software restriction policies funktionieren, wenn man sie so überlisten kann...