Virtualisierung eines Servers

Mitglied: Lornsti

Lornsti (Level 1) - Jetzt verbinden

2017/04/28 um 14:45 Uhr, 1783 Aufrufe, 11 Kommentare

Hallo,
ich habe ein Problem mit der Virtualisierung eines Servers. Ich habe vom Server (2012 R2) mit Disk2vhd eine .vhdx Datei erstellt. Die Datei ansich wird in Ordnung sein, da ich per Doppelklick die vhdx als Laufwerk mounten kann und auch drauf zugreifen kann. Wenn ich die Datei dann allerdings in HYPER-V importiere und starten will, bootet Windows nicht. Es ist ausschließlich ein Cursor oben links in der Ecke und blinkt. Auch wenn ich eine ISO einbinde und Windows mit der ISO reparieren will passiert nichts.
Hat jemand eine Ahnung was der Fehler sein könnte?

Danke schon mal im Voraus und liebe Grüße
Mitglied: Pjordorf
2017/04/28, aktualisiert um 14:55 Uhr
Hallo,

Zitat von Lornsti:
Hat jemand eine Ahnung was der Fehler sein könnte?
Nur geraten:
Die versteckte Boot Partition (Volume) ist auch in deiner .VHDX?
Bootbar ist die auch?
Dein Hyper-V ist ein was? DOS 3.11?
Booten per IDE oder SCSI?
UEFI?
Secure Boot?
War vorher RAID und nun nicht ?
Alle benötigten Volumes erwischt?
All die sachen die eine Hardware auch haben können hat evtl deine verwendete hyper-V Version auch, sind halt nur andere Treiber.

Gruß,
Peter
Bitte warten ..
Mitglied: Vision2015
2017/04/28 um 15:03 Uhr
moin...

Auch wenn ich eine ISO einbinde und Windows mit der ISO reparieren will passiert nichts.

was hast du den für einen HyperV Server ?
bootet irgendeine ISO?
was für hardware hatte der Server2012R2 denn?

Frank
Bitte warten ..
Mitglied: Lornsti
2017/04/28 um 15:22 Uhr
Hi,
also auf dem Server laufen schon mehrere Server und die ISO ist die gleiche mit der ich das System auch installiert hatte. Der 2012R2 ist ein Fujitsu Esprimo mit 256GB Festplatte( also kein RAID). Und auch nach der Installation hab ich keine großen Veränderungen vorgenommen. Ich hab nur die IP geändert und den PC in die Domaine aufgenommen.
Meinst du die Version von meinem HyperV in das ich die vhdx einfügen will? das ist Version 6.3.9600
Bitte warten ..
Mitglied: Pjordorf
2017/04/28 um 16:21 Uhr
Hallo,

Zitat von Lornsti:
also auf dem Server
Auf welchen Server? Dein Blech welches du per Disk2VHD gewandelt haben willst oder eine VM oder dein Hypervisor Blech mit Server Version 2008 - 2008R2 - 2012 - 2012R2 - 2016?

laufen schon mehrere Server
Du meinst sicherlich mehrere VMs (Gäste), oder?

und die ISO ist die gleiche mit der ich das System auch installiert hatte.
Glaub ich nicht das du Blech mit einer ISO (allein) Installiert hast. Wie hat dein Blech denn die ISO gegessen?

Der 2012R2 ist ein Fujitsu Esprimo
Du meinst dein Server 2012R2 läuft auf Blech von Fujitsu...

mit 256GB Festplatte( also kein RAID)
Wieso bedeutet "mit 256GB Festplatte" denn nun die Erkenntniss das kein RAID vorhanden sei?

Und auch nach der Installation hab ich keine großen Veränderungen vorgenommen. Ich hab nur die IP geändert und den PC in die Domaine aufgenommen.
Von welchen PC ist denn jetzt die Rede? Du hast Bleche mit Os drauf, du hast mindesten ein Hyper-V server welches ein Host für Gäste darstellt und du hast VMs. Was also ist jetzt dein PC?

Meinst du die Version von meinem HyperV in das ich die vhdx einfügen will? das ist Version 6.3.9600
Eher ob es ein 2008 oder ein 2016 sei. Deine Antwort klingt eher nach "Wie gross bist du? und du antwortest "36 Tomaten"...

Gruß,
Peter
Bitte warten ..
Mitglied: Lornsti
2017/04/28, aktualisiert um 16:48 Uhr
Hi Peter,
also ich habe einen Esprimo mit Windows 2012R2. Eine Festplatte(256GB) kein RAID.
Dann habe ich einen HP DL160 Gen9 mit Windows 2012R2. Auf dem läuft mein HyperV. In dem HyperV sind bereits andere VMs die alle laufen.

Ich möchte nun den Esprimo in einen virtuellen PC umwandeln. Dazu habe ich mit Disk2vhd eine .vhdx Datei erstellt. Die Datei kann ich mounten und alles sehen.

Ich habe die .vhdx Datei nun in HyperV auf dem HP DL160 Gen9 importiert. Wenn ich die VM nun starten möchte, bekomme ich keine Fehlermeldung. Es passiert einfach nichts bis auf das Blinken des Cursors oben links.

Gruß,
Lornsti
Bitte warten ..
Mitglied: Pjordorf
2017/04/28 um 16:56 Uhr
Hallo,

Zitat von Lornsti:
also ich habe einen Esprimo mit Windows 2012R2. Eine Festplatte(256GB) kein RAID. Dann habe ich einen HP DL160 Gen9 mit Windows 2012R2. Auf dem läuft mein HyperV. In dem HyperV sind bereits andere VMs die alle laufen.
Das klärt dann dein Fuhrpark

Es passiert einfach nichts bis auf das Blinken des Cursors oben links.
Siehe https://www.administrator.de/content/detail.php?id=336426&nid=409676 ...

Gruß,
Peter
Bitte warten ..
Mitglied: Meierjo
2017/04/30 um 12:12 Uhr
Hallo

War denn auf dem Esprimo die Boot-Partition in derselben Partition, wie das OS?
Wenn nein, hast du wahrscheinlich die Boot-Partition nicht mitgeklont.

Ist denn die Partition im Hyper-V aktiv?
Kommst du mit (wenn du mit der ISO bootest) in die Reparatur-Optionen?
Wenn ja, dann geh dort mal in di Eingabe-Aufforderung und gib die folgenden Befehle ein:
bootrec /fixmbr
bootrec /fixboot
bootrec /rebuildbcd

Gruss
Bitte warten ..
Mitglied: Lornsti
2017/05/02 um 10:57 Uhr
Hi,
also ich denke inzwischen auch, dass die Boot-Partition nicht dabei ist. Ich habe jetzt noch einmal versucht die Festplatte zu klonen aber die Volume-Partition fehlt immernoch. Wenn ich aber nur die Volume-Partition beim klonen auswähle, funktionierrt es. Kann man die beiden Partitionen im nachhinein zusammenfügen?

Groß
Bitte warten ..
Mitglied: Meierjo
2017/05/02 um 11:59 Uhr
Hallo

Kannst du denn nicht beide Partitionen klonen?
Wenn der neue Server booten soll, sollten die Partitionen schon dem Quell-Server entsprechend, wird viel einfacher

Gruss
Bitte warten ..
Mitglied: Lornsti
2017/05/02 um 12:43 Uhr
Hi,
nee leider klont der die nicht mit :/ auch wenn ich es ausgewählt hatte wird die danach nicht gemountet.

Gruß
Bitte warten ..
Mitglied: Lornsti
2017/05/02 um 16:25 Uhr
Hi,
also ich habe mit der InstallationsDVD mal die Systemreparatur gestartet und habe da das Kommando Feld gestartet. Ich habe dort "Diskpart" und "List Disk" eingegeben.
Da steht eine Disk drin mit Status "Online" und "Gpt *"
dann habe ich "select Disk 0", "list partition".

Partition 1 Recovery 300 MB
  • Partition 2 System 100 MB
Partition 3 Reserved 128 MB
Partition 4 Primary 237 GB

bootrec /fixmbr ---> "The operation completed successfully."
bootrec /fixboot ---> "The operation completed successfully."
bootrec /rebuildbcd ---> "Total identified Windows installations: 1
[1] C:\Windows
add installation to boot list? Yes(Y/No(N)/ALL(A): A
The requested system device cannot be found."

Kann mir jemand mit den Informationen helfen?
Bitte warten ..
Heiß diskutierte Inhalte
Router & Routing
Cisco RIPv1 RIPv2
MrLabelFrageRouter & Routing25 Kommentare

Hallo Zusammen, ich muss nochmal auf eine schon behandelte Frage eingehen. Bitte jemand, der auch den Cisco Paket Tracer ...

Server-Hardware
Grobes Konzept Hyper-V Storage - Storage für Hyper-V
nachgefragtFrageServer-Hardware25 Kommentare

Hallo Administratoren. Um VHDX-Daten zentral zu halten freue ich mich auf Euren konstruktiven Input. Bisher liegen die VHDX-Daten jeweils ...

C und C++
(Cpp) Verständnisproblem: Nutzen des new-operators? (mit Beispiel)
gelöst SinixNDFrageC und C++16 Kommentare

Hallo liebe community! INTRO: Zunächsteinmal: Trotz mehrerer Stunden Recherche habe ich für meine Frage leider noch keine Antwort gefunden ...

Windows Server
Terminal Server Hyper-V Grafik performance
ReneM1983FrageWindows Server16 Kommentare

Moin Kollegen, ich habe da mal ein Problem, ein Kunde hat einen Terminal Server auf einem Hyper-V laufen, wo ...

Verschlüsselung & Zertifikate
Elektronische Unterschrift
PeterzFrageVerschlüsselung & Zertifikate14 Kommentare

Hallo zusammen, könnt ihr mir vielleicht ein paar Hinweise geben, wie ihr eine elektronische Unterschrift unter Dokumente und E-Mails ...

Server-Hardware
SFP(+) Schnittstellenkarte für Dell R230 mit OPNsense
MegaGigaFrageServer-Hardware12 Kommentare

Hallo Zusammen Bei uns wird es bald FTTH geben. Nun möchte ich direkt von der OTO an meine OPNsense ...

Ähnliche Inhalte
Vmware
Neuaufbau Virtualisierung
Mejestic12FrageVmware2 Kommentare

Hallo zusammen! Wir haben hier bei uns letztes Jahr eine relativ alte Virtualisierungs- Umgebung (3 Hyper-V Server mit lokaler ...

Virtualisierung
Welche Virtualisierung
mario89FrageVirtualisierung15 Kommentare

Hallo Leute, wollte hier nochmal um eure Unterstützung bitten. Hintergrund ist das ich bei mir zuhause aktuell einige Systeme ...

Netzwerke
DMZ aufbauen ESXi, Virtualisierung.
Tiggr1994FrageNetzwerke5 Kommentare

Hallo zusammen, Ich möchte auf einer 1 Maschine, 3 virtuelle Maschinen aufsetzen, und eine davon soll in eine DMZ. ...

Virtualisierung

PC Virtualisierung einer Prduktionsanlage

gelöst rudi66FrageVirtualisierung12 Kommentare

Hallo liebe IT-Freunde, der PC einer Produktoinsanlage mit WinXP ist ziemlich veraltet und soll ersetzt werden. Ein neuer PC ...

Windows Server

3D Virtualisierung mit RDP

NordicMikeFrageWindows Server15 Kommentare

Moin zusammen, ich habe schon einiges über RemoteFX und DDA im Netz gefunden aber so richtig eindeutig sind meine ...

Windows Server

SBS 2003 Virtualisierung Lizenz

Philbo69FrageWindows Server2 Kommentare

Hallo zusammen, ich habe mal eine Frage zur Virutalisierung eines SBS 2003. Vorhandenes System: - 1 Physikalischen Server mit ...

Berechtigungs- und IdentitätsmanagementBerechtigungs- und IdentitätsmanagementWebdienste und -serverWebdienste und -serverDatenbankenDatenbankenMonitoring & SupportMonitoring & SupportHybrid CloudHybrid CloudSmall Business ITSmall Business IT