Vlans mit Netgear Switches

Mitglied: petiteconne

petiteconne (Level 1) - Jetzt verbinden

29.08.2006, aktualisiert 01.09.2006, 8961 Aufrufe, 5 Kommentare

Hallo zusammen,
Unter http://shared-folder.com/vlans.jpg könnt ihr sehen was ich vorhabe.
Mein Problem ist, dass ich nciht weiß wie genau cih die beiden vlan-fähigen netgear switches konfigurieren muss,
damit der wlan router aus dem 2. stock die rote route geht, die clients aus dem 2. stock, aber direkt zum dhcp server 1 gehen.
Ich habe ausprobiert auf beiden switches 2 vlans einzurichten:
Netgear Switch 2:
- vlan1 : die normalen lan clients
- vlan2 : der port vom wlan router (192.168.40.2)

Netgear Switch 1:
- vlan1 : die normalen lan clients
- vlan2 : der port kabel das vom netgear switch 2 ins netgear switch 1 geht (lan clients und wlan router [192.168.40.2])

Der WLAN-Router muss über den Server 2 gehen, da die WLAN-Clients dort nach Login-Daten gefragt werden
und erst dann eine IP-Adresse erhalten sollen.

Ich bin leider Anfänger in Sachen VLAN und weiß nicht, was ich noch einstellen muss, damit das funktioniert!
Danke im Vorraus,
petite conne
Mitglied: 27119
27119 (Level 2)
29.08.2006 um 20:33 Uhr
Ich weiss nicht wie das bei netgear gelöst ist oder genannt wird.
Bei Cisco jedenfalls muessen die Switch Uplinks als Trunkports konfiguriert sein,
damit überhaupt Pakete mit verschiedenen VLAN-IDs über den uplink gehen.
Zwischen den VLANs muss dann geroutet werden, falls von VLaN1 Pakete ins VLAN2 kommen können sollen.

Clients in VLAN2 sollen also über den Server 192.168.40.1 IP-Adressen vom DHCP in VLAN1 bekommen? DHCP Discover Pakete von den Clients sind Broadcasts, und diese werden nicht in andere Subnetze gesendet (ausser man betreibt einen DHCP Relay Agent der die Broadcasts in IP verpackt).
Bitte warten ..
Mitglied: petiteconne
29.08.2006 um 20:47 Uhr
danke schonmal
also zwischen VLAN1 udn VLAN2 muss nichts gesendet werden.
und die clients von VLAN2 bekommen DHCP auch von der 192.168.40.1 und nicht vom VLAN1.
War vielleicht ein bisschen missverständlich.
Bitte warten ..
Mitglied: aqui
29.08.2006 um 21:08 Uhr
Die Lösung ist recht einfach:

Du definierst den Link zwischen den beiden NetGears als 802.1q (dot1q) Trunk (oder manche Hersteller bezeichnen das auch als TAGGED Link). Die Switches übertragen dann in einem speziellen .1q Header am Ethernet Frame die VLAN ID mit so das beide Switches die Frames wieder zuordnen können.
Leider schreibst du nicht welche NetGear Modelle du hast dann könnte man das mit dem Handbuch etwas genauer beschreiben...

Nachdem du die beiden Switch Verbindungsports als Trunkports (tagged) definiert hast, sind beide VLAN Segmente auf den Switches transparent vorhanden.
Nun musst du lediglich noch die Ports zuweisen welches im VLAN 1 und welcher im VLAN2 liegt. Achtung Endgeräte Ports sind immer untagged !

Es reicht dann z.B. den Hub nur mit einem Link an einen VLAN2 definierten Port am SW1 zu hängen. Eine parallele Verbindung zu SW2 ist dann überflüssig, denn das rennt ja über den dann tagged Port zwischen den Switches ! An SW2 müssen natürlich die Ports vom WLAN Router auch VLAN2 zugeordnet sein.

Gleiches Szenario für den Server: Für seine beiden LAN Karten reicht ein zugewiesener Port für VLAN1 und einer für VLAN2 an SW1 ! Den Hub kannst du eigentlich völlig "wegrationalisieren" !!!
Bitte warten ..
Mitglied: 34691
34691 (Level 1)
30.08.2006 um 15:53 Uhr
Hallo aqui,
erstmal danke für die gute Antwort, ich denke die wird weiterhelfen. Wenn du das noch anhand des Handbuchs beschreiben kannst, wäre das natürlich auch toll. Wichtig ist vielleicht noch, dass die Verbindung zwischen Switch 1 und 2 nur aus einem Kabel besteht. Die Modelle sind:

1. Etage: FS750T2 Smart Switch
2. Etage: FS726T Smart Switch

Die Ports sollen wie folgt aussehen:
Hub Port 1 <----> Netgear Switch 1 Port 1
Netgear Switch 1 Port 2 <----> Netgear Switch 2 Port 2
Netgear Switch 2 Port 1 <----> WLAN-Router Etage 2

Nocheinmal Danke im Vorraus
Alex
Bitte warten ..
Mitglied: aqui
01.09.2006 um 17:34 Uhr
Das ist recht einfach. Ich denke das die Bedienung bei beiden Switches gleich ist, so das ich mir mal das Handbuch lesen für den 2ten spare.....

Also der FS750T2 macht es laut Handbuch Seite 12 ff. (http://kbserver.netgear.com/pdf/fs750t2_user_manual.pdf) so
1.) VLANs anlegen Switch -> VLAN -> IEEE 802.1q tagged VLAN
2.) Ports dem VLAN zuordnen "Add a Port to a VLAN Group" (S.14)
WICHTIG ist hier das du auf dem Verbindungsport die Box mit dem "T" anklickst !!! Das bedeutet das der Link dann "tagged" ist also die VLAN Information (VLAN Header) mit übertragen wird.

Auf dem anderen Switch machst du das analog so das beide Switches die gleichen VLANs angelegt haben !!!
Denk dran das du den Verbindungsport zwischen beiden Switches in ALLE VLANs mit dem "T" (also tagged) reinnimmst, so das dort alle VLANs übertragen werden.
Alle anderen Ports für die Endgeräte bleiben UNTAGGED. Also hier bitte immer das "U" anklicken !
Das gilt auch für den Router und den HUB auf den entsprechenden Ports, da die natürlich keine tagged Frames verstehen. Router und HUB müssen dann in Ports mit der gleichen VLAN ID (Nr.) und dann eben mit dem "U" angeklickt. Ist dem so sollte ein Ping problemlos funktionieren.
Getagged (mit dem "T") sind dann nur lediglich jeweils die beiden Ports auf den Switches die die beiden NetGears verbinden. Das ist dann natürlich nur ein Kabel. Alle anderen evtl. parallelen Verbindungen kannst du getrost vergessen. Das rennt dann alles über deinen Verbindungslink.
Nicht vergessen alle nicht entsprechend konfigurierten Ports befinden sich immer im VLAN 1, was das default VLAN ist. Wenns also mal nicht klappen sollte mit der Verbindung immer erst checken ob die Ports auch richtig den entsprechenden VLANs zugeordnet sind !
Bitte warten ..
Heiß diskutierte Inhalte
Windows 10
Windows 10 Geschwindigkeitprobleme trotz viel mehr Gb Ram
Matthes88Vor 19 StundenFrageWindows 1036 Kommentare

Hallo ihr lieben aaaalso : Da mein neuer Arbeitsspeicher (32gb) von meiner alten Windows 7 version (max mit 8gb kompatibel) nicht angenommen wurde, habe ...

Off Topic
Realistische Gehaltsvorstellung für eine "IT-Allroundkraft"
gelöst JiggyLeeVor 14 StundenFrageOff Topic16 Kommentare

Hallo an alle, ich hege momentan den Wunsch mich von der alten verstaubten Behörden Bürokratie und langweiliger Aufgaben los zu lösen und in einem ...

Humor (lol)
Tipp: Dinge, die man besser nicht klaut
altmetallerVor 15 StundenTippHumor (lol)8 Kommentare

Hallo, so wurde meiner Hündin z.B. heute der (eingeschaltete) GPS-Tracker mit Mobilfunkanbindung quasi "direkt vom Halsband weggefunden". Akku hatte noch 60% :-P Und ich ...

Windows Userverwaltung
Account Aktivierung über VPN
Phill93Vor 1 TagFrageWindows Userverwaltung3 Kommentare

Hallo, ich muss mir für eine RDP Umgebung für einen Verein eine Lösung für die Account Aktivierung ausdenken. Meine Idee ist die folgende: 1. ...

Switche und Hubs
Suche Deutsche Sprachdatei für D-Link DGS-1210-24 D1 Switch
gelöst Oggy01Vor 1 TagFrageSwitche und Hubs8 Kommentare

Hallo, ich habe einen D-Link DGS-1210-24 Vers. D1 Switch bekommen und suche für diesen eine Deutsche Sprachdatei. Die Firmware ist auf dem aktuellen Stand ...

Video & Streaming
Videoaufnahme funktioniert nur bis zum ersten Reboot (0x80040217)
IllusionFACTORYVor 1 TagFrageVideo & Streaming10 Kommentare

Ich nehme über eine Video-Software von einem USB-Hardware-Encoder Video auf. Das funktioniert exakt bis zum ersten Reboot - danach bekomme ich beim Starten der ...

Windows Server
GPU Passthrough HYPER-V 2019
bintesVor 1 TagFrageWindows Server7 Kommentare

Hallo, ich habe ein ein Problem mit der Bereitstellung einer Grafikkarte an eine virtuelle Maschine. Hardware: - HPE ProLiant DL380 Gen9 V4 Rack Server ...

Windows Server
Windows Admin Center DC
maximidVor 1 TagFrageWindows Server3 Kommentare

Hallo, ich hätte mal eine Frage zu Windows Admin Center und zwar schaue ich es mir aktuell etwas an da mir die zentrale Verwaltung ...