pn-schrauber
Goto Top

Wechsel von GW zu Exchange kein externer Mail-Empfang

Hallo Gemeinde,

Ich habe mal wieder ein Problem bei der Umstellung von unserem Mailsystem.

Wir sind aktuell auf dem Stand, dass wir die Migration der Daten vom GroupWise ins Exchange mal im "großen" Stil durchgeführt haben, war Super, NICHT, aber dass ist egal.

Aktuell haben wir das Problem, dass die Leute bereits aus dem Outlook herraus Mails nach extern versenden können und diese auch beim Empfänger ankommen.

Jetzt haben wollten wir den SMTP-Relay auf der Firewall einfach vom GroupWise-Server auf den Exchange-Server schwenken, sprich einfach die SMTP-Route auf den anderen Server. Naja, klappt halt nicht.

Die Firewall meldet uns im Log immer ein

22.12.2022 08:04:23	postfix/smtpd	connect from mout.web.de[217.72.192.78]
22.12.2022 08:04:24	postfix/smtpd	connect from geheim.de[127.0.0.1]
22.12.2022 08:04:24	postfix/smtpd	NOQUEUE:client=mout.web.de[217.72.192.78]
22.12.2022 08:04:24	postfix/smtpd	00CEA78005F:client=geheim.de[127.0.0.1],orig_client=mout.web.de[217.72.192.78]
22.12.2022 08:04:24	postfix/smtpd	proxy-accept: END-OF-MESSAGE: 250 2.0.0 Ok: queued as 00CEA78005F;from=<Absender@web.de>to=<Empfänger@geheim.de>proto=ESMTPhelo=<mout.web.de>
22.12.2022 08:04:24	postfix/smtpd	disconnect from geheim.de[127.0.0.1]ehlo=1xforward=1mail=1rcpt=1data=1quit=1commands=6
22.12.2022 08:04:24	postfix/smtpd	disconnect from mout.web.de[217.72.192.78]ehlo=2starttls=1mail=1rcpt=1data=1quit=1commands=7
22.12.2022 08:04:54	postfix/relay/smtp	connect to [IP-ExchangeServer]:25: Connection timed out
22.12.2022 08:04:54	postfix/relay/smtp	00CEA78005F:to=<Empfänger@geheim.de>,relay=none,delay=30,delays=0.24/0/30/0,dsn=4.4.1,status=deferred(connect to [IP-ExchangeServer]:25: Connection timed out)
22.12.2022 08:08:21	postfix/relay/smtp	connect to [IP-ExchangeServer]:25: Connection timed out
22.12.2022 08:08:21	postfix/relay/smtp	7ED8F78004C:to=<Empfänger@geheim.de>,relay=none,delay=541,delays=511/0.01/30/0,dsn=4.4.1,status=deferred(connect to [IP-ExchangeServer]:25: Connection timed out)

Sobald ich das SMTP-Relay wieder auf den GroupWise-Server schwenke, läuft alles normal und die Mails kommen im GroupWise an.

Prinzipell kann der Exchange Mails Empfangen, in einem verherigen Schritt, haben wir alle Drucker, Scanner,.. für Berichte, Fehlermeldungen und Scan-to-Mail auf den Exchange-Server geschwenkt und das funktioniert ohne Probleme.

Ich vermute den Fehler an dem Empfangs-Conecctoren, dort habe ich nichts gemacht, die sind noch auf Standart, den vom Exchange gehen Mails raus und eingehende Mails kommen mit dem entsprechenden SMTP-Relay auch beim GroupWise an.

WO liegt mein Denkfehler oder was habe ich ggf. übersehen/vergessen?

Grüße
Lars

Content-Key: 5051400569

Url: https://administrator.de/contentid/5051400569

Printed on: July 22, 2024 at 10:07 o'clock

Member: SlainteMhath
SlainteMhath Dec 22, 2022 at 08:41:10 (UTC)
Goto Top
Moin,

vielleicht ein Firewall-Thema? Darf das Relay mit dem Exchg sprechen? Ggfs. muss auch die lokale FW am Exchange angepasst werden.

lg,
Slainte
Member: PN-Schrauber
PN-Schrauber Dec 22, 2022 at 09:25:49 (UTC)
Goto Top
Moin,

die Firewall Einstellungen passen, die haben wir mehrfach kontrolliert und wenn der Exchange was zu der FW, welche der SMTP-Relay nach und von extern ist, sendet, geht es auch raus. Einen Drop oder Block auf der FW haben wir auch nicht. Portregeln für GroupWise und Exchange sind identisch, alles über Port 25

Daher sind wir eher beim Exchanger, muss ich dem eventuell noch am Empfangsconnector sagen, das die Mails von Extern alle über die FW rein laufen? Bisher haben wir da wie gesagt nocht nichts geschraubt und uns gefreut, dass bisher zumindest intern alles läuft. Wir haben auch die Firewall auf dem Exchange bereits komplett abgeschalten, ohne Veränderung.
Member: SlainteMhath
SlainteMhath Dec 22, 2022 at 09:51:46 (UTC)
Goto Top
Der Exchange nimmt Mails an Port 25 an oder nicht - sofern seine Firewall korrekt konfiguriert/abgeschaltet ist.
Dabei nimmt der Exchange alle Domains an, für die er sich zuständig fühlt oder gibt dem Sende-MTA zumindest einen Fehlercode zurück.

Dein Timeout-Fehler deutet eher auf ein Netzwerk/Firewall-Problem hin. So Dinge wie Default-GW/Routing/Netzeinstellungen am Exchange sind alle korrekt?
Member: PN-Schrauber
PN-Schrauber Dec 22, 2022 at 12:40:17 (UTC)
Goto Top
Das mit dem Gateway, war die Lösung.

Der eigentliche Plan war, dem Exchange kein Gateway zu geben, um einen gewissen Schutz zu haben und ihn im Netzwerk zu verstecken.
Unser Denkfehler lag quasi im Mail-Transport. Wir sind davon ausgegengen, unsere FW nimmt die Mail an (casht sie zwischen) und leitet diese dann an den Exchanger weiter, doch anscheinden, ist sie nur der Türsteher und sagt dem Exchanger, da ist jemand für dich, hol mal ab.

Gibt es eine Möglichkeit es so zu bauen wie wir es gern hätten, also der exchange ohne aktive Verbindung zum Internet?

Updates gibt es vom WSUS.
Member: SlainteMhath
Solution SlainteMhath Dec 22, 2022 at 13:29:45 (UTC)
Goto Top
Gibt es eine Möglichkeit es so zu bauen wie wir es gern hätten, also der exchange ohne aktive Verbindung zum Internet?

Ja sicher. Dazu verbiegt man aber nicht das Default-Gateway, sondern verbietet an der Hardware-Firewall alle Verbindungen Exchange -> Internet.
Mails werden dann vom Exchange per Sende Connector an einen "Smarthost" gesendet.
Empfangen werden Mails von einem vorgeschalteten MTA (z.b. Postfix), der dann Mails für die eigenen Domains an den Exchange weitergibt.