searchbox
Goto Top

Windows 7 Client kann Domain nicht Hinzugefügt werden

Guten abend zusammen,

ich hatte hier schonmal ein problem mit einer Virtuellen Maschine en, die ich leider neu aufsetzen musste,

ich würde nun gern einen Windows 7 Client hinzufügen, jedoch kommt jedes mal eine Fehlermeldung....
hoffe mir kann jemand helfen....

Mfg
David.

Content-Key: 568032

Url: https://administrator.de/contentid/568032

Printed on: April 24, 2024 at 00:04 o'clock

Member: em-pie
em-pie Apr 27, 2020 at 18:09:03 (UTC)
Goto Top
Moin,

Anonymisierung bitte mal deinen Screenshot face-wink

Ansonsten:
Du hast keinen/ einen falschen DNS-Server in der Netzwerkkarte hinterlegt.

That's it

Trage einen richtigen DNS-Server ein und setze in den VM-Einstellungen den richtigen Netzwerktypen an.

Gruß
em-pie
Member: SearchBox
SearchBox Apr 27, 2020 at 18:14:27 (UTC)
Goto Top
Zitat von @em-pie:

Moin,
hey
Anonymisierung bitte mal deinen Screenshot face-wink
was meinst du ?
Ansonsten:
Du hast keinen/ einen falschen DNS-Server in der Netzwerkkarte hinterlegt.
ich habe den DNS meines servers genommen....
That's it

Trage einen richtigen DNS-Server ein und setze in den VM-Einstellungen den richtigen Netzwerktypen an.

Gruß
em-pie
Member: SearchBox
SearchBox Apr 27, 2020 at 18:15:29 (UTC)
Goto Top
ich habe als DNS beim Clienten die IP-Adresse, meines Servers genommen
Member: tomolpi
tomolpi Apr 27, 2020 updated at 18:31:37 (UTC)
Goto Top
Zitat von @SearchBox:

ich habe als DNS beim Clienten die IP-Adresse, meines Servers genommen
DNS auf dem Server (OS, usw. bitte noch sagen) funktioniert?
Versuch sonst mal, nur mit dem NetBios Namen beizutreten, wenn dein DHCP alle Infos vernünftig mitgibt, geht das auch.
Und noch bitte einen Screenshot von nslookup am Client posten...
Member: SearchBox
SearchBox Apr 27, 2020 at 18:42:58 (UTC)
Goto Top
Zitat von @tomolpi:

Zitat von @SearchBox:

ich habe als DNS beim Clienten die IP-Adresse, meines Servers genommen
DNS auf dem Server (OS, usw. bitte noch sagen) funktioniert?
Windows Server 2012 R2 Standard (180 Tage Testversion)
Member: SearchBox
SearchBox Apr 27, 2020, updated at Apr 21, 2022 at 13:42:38 (UTC)
Goto Top
nlslookup
Member: Archeon
Archeon Apr 28, 2020 at 05:06:08 (UTC)
Goto Top
Guten Morgen
Zitat von @SearchBox:

Zitat von @em-pie:

Moin,
hey
Anonymisierung bitte mal deinen Screenshot face-wink
was meinst du ?
In deinem Screenshot ist euer Firmenname zu sehen und das wirft kein gutes Licht auf die Firma.

Zitat von @SearchBox:
ich habe als DNS beim Clienten die IP-Adresse, meines Servers genommen
Hast du das da einfach händisch eingetragen oder wird das vom DHCP so verteilt? Hast du die DNS Rolle am DC auch konfiguriert?
Member: Meierjo
Meierjo Apr 28, 2020 at 05:33:54 (UTC)
Goto Top
Hallo

Poste doch mal ein Ergebnis von ipconfig /all vom Client.
Firewall am Client ausgeschaltet?

Gruss
Member: Tektronix
Tektronix Apr 28, 2020 at 05:49:35 (UTC)
Goto Top
Moin,
wieso sagst Du Dein DNS funktioniert, wenn da unknown als Servername steht?
Member: SlainteMhath
SlainteMhath Apr 28, 2020 at 06:24:20 (UTC)
Goto Top
Moin,

lass doch am Server mal ein dcdiag laufen und poste das zusammen mit ipconfig /all von DC und Client.

lg,
Slainte
Member: em-pie
em-pie Apr 28, 2020 at 07:53:10 (UTC)
Goto Top
Moin,

ich hatte hier schonmal ein problem mit einer Virtuellen maschien, die ich leider neu aufsetzen musste,
Mit welchem Hersteller/ Produkt wurde die VM virtualisiert?
  • Microsofts Hyper-V
  • VMWares ESXI/ VMWare Player?
  • Oracles VirtualBox
  • KVM
  • XenServer
  • ...

Ich vermute nämlich, dass die NIC in der VM nicht dahingehend eingestellt ist, dass der Netzwerktraffic den Host verlassen darf.
Um hier den richtigen Wortlaut zu verwenden, wäre es daher hilfreich, den Hypervisor zu kennen...


Bzgl. der Anonymisierung: @Archeon hat hier recht. Für eine IT-Recht-Firma kein gutes Zeichen, wenn die nicht mal in der Lage sind, Ihre Systeme zum laufen zu bekommen (ein Dienstleister wäre ja schon ausreichend. Der hat da Erfahrung mit, zumindest die guten face-wink)
Member: SearchBox
SearchBox Apr 28, 2020 at 13:01:33 (UTC)
Goto Top
Zitat von @Archeon:

In deinem Screenshot ist euer Firmenname zu sehen und das wirft kein gutes Licht auf die Firma.
Das ist nur ausgedacht, ich möchte mich gerne nöher mit Windows Server befassen, und hab das daher alles in einer Virtuellen Maschiene aufgesetzt.
Zitat von @SearchBox:
ich habe als DNS beim Clienten die IP-Adresse, meines Servers genommen
Hast du das da einfach händisch eingetragen oder wird das vom DHCP so verteilt? Hast du die DNS Rolle am DC auch konfiguriert?
Habe ich händisch eingetragen.

Hast du die DNS Rolle am DC auch konfiguriert?
wie ist das gemeint, kann ich dadurch einen Clienten einfacher eine IP zuweisen um ihn dann in meine Domain aufzunehmen ?
Member: SearchBox
SearchBox Apr 28, 2020 at 13:03:28 (UTC)
Goto Top
Zitat von @em-pie:

Mit welchem Hersteller/ Produkt wurde die VM virtualisiert?
  • Microsofts Hyper-V
  • VMWares ESXI/ VMWare Player?
  • Oracles VirtualBox
  • KVM
  • XenServer
  • ...
VMware Workstation

Ich vermute nämlich, dass die NIC in der VM nicht dahingehend eingestellt ist, dass der Netzwerktraffic den Host verlassen darf.
Um hier den richtigen Wortlaut zu verwenden, wäre es daher hilfreich, den Hypervisor zu kennen...
VMware Workstation wird benutzt.



Bzgl. der Anonymisierung: @Archeon hat hier recht. Für eine IT-Recht-Firma kein gutes Zeichen, wenn die nicht mal in der Lage sind, Ihre Systeme zum laufen zu bekommen (ein Dienstleister wäre ja schon ausreichend. Der hat da Erfahrung mit, zumindest die guten face-wink)
Member: SearchBox
SearchBox Apr 28, 2020 at 13:04:32 (UTC)
Goto Top
ich habe als DNS die IP-Adresse meines Servers genommen.

grüße
David
Member: Archeon
Archeon Apr 28, 2020 at 13:08:19 (UTC)
Goto Top
Zitat von @SearchBox:

ich habe als DNS die IP-Adresse meines Servers genommen.
Wenn der Server aber selbst nicht weiß, dass er DNS ist, weil da nichts konfiguriert ist, dann funktioniert das aber nicht.

Hast du die DNS Rolle am DC auch konfiguriert?
wie ist das gemeint, kann ich dadurch einen Clienten einfacher eine IP zuweisen um ihn dann in meine Domain aufzunehmen ?
Was hast du denn am Server bisher überhaupt konfiguriert? Besitzt der denn überhaupt die DHCP und DNS Rolle?
Member: Archeon
Archeon Apr 28, 2020 at 13:09:18 (UTC)
Goto Top
Jetzt mach doch endlich mal den Firmennamen unkenntlich!
Oder soll erst jemand bei euch anrufen und dir das am Telefon mitteilen?
Member: SearchBox
SearchBox Apr 28, 2020 updated at 13:20:18 (UTC)
Goto Top
Hab den Screenschot Rausgenomen, somit sieht man dies nicht mehr.
Member: SearchBox
SearchBox Apr 28, 2020 updated at 13:19:45 (UTC)
Goto Top
ja, der Server besitzt eine DNS rolle
Member: Archeon
Archeon Apr 28, 2020 at 13:22:12 (UTC)
Goto Top
Zitat von @SearchBox:
Hab den Screenschot Rausgenomen, somit sieht man dies nicht mehr.
Du solltest es doch nur unkenntlich mache und nicht entfernen.

Zitat von @SearchBox:
ja, der Server besitzt eine DNS rolle
Kannst du auch mal vollständige Antworten geben und auch auf andere Fragen eingehen?
Ein bisschen Mühe kannst du dir mit deinen Antworten schon geben, immerhin erbittest du ja hier Hilfe, sonst wird das wohl nichts werden.
Member: SearchBox
SearchBox Apr 28, 2020 at 13:25:57 (UTC)
Goto Top
Kannst du auch mal vollständige Antworten geben und auch auf andere Fragen eingehen?
Ein bisschen Mühe kannst du dir mit deinen Antworten schon geben, immerhin erbittest du ja hier Hilfe, sonst wird das wohl nichts werden.
In Odnung , ich werde mich bemühen... bin jedoch noch am lernen, und weiß nicht wirklich weiter.

Also ich hab die DNS-Rolle installiert, über den Server-Manager, jedoch hat der Server komischerweise kein Internet. ( Gelbes Dreieck unten am Internetsymbol)
Member: Archeon
Archeon Apr 28, 2020 at 13:29:04 (UTC)
Goto Top
Zitat von @SearchBox:
In Odnung , ich werde mich bemühen... bin jedoch noch am lernen, und weiß nicht wirklich weiter.
Ist ja nicht schlimm, aber dann sage ich es jetzt ein letztes mal, sonst bin ich hier raus, beantworte doch bitte die offenen Fragen.

Zitat von @SearchBox:
wie ist das gemeint, kann ich dadurch einen Clienten einfacher eine IP zuweisen um ihn dann in meine Domain aufzunehmen ?
Ja, nennt sich DHCP, hast du das konfiguriert oder wer macht das bei dir?
Member: SearchBox
SearchBox Apr 28, 2020 at 13:37:24 (UTC)
Goto Top
Ja, nennt sich DHCP, hast du das konfiguriert oder wer macht das bei dir?

nein DHCP ist nicht Installiert.
Zitat von @Archeon:

Zitat von @SearchBox:
Ist ja nicht schlimm, aber dann sage ich es jetzt ein letztes mal, sonst bin ich hier raus, beantworte doch bitte die offenen Fragen.
Ich habe doch jetzt alle Fragen beantwortet. face-smile

Zitat von @SearchBox:
Ja, nennt sich DHCP, hast du das konfiguriert oder wer macht das bei dir?
Nein DHCP ist noch nicht Installiert, bin grade dabei die Rolle auf meinem Server zu Installieren.
Member: SearchBox
SearchBox Apr 28, 2020 at 13:42:02 (UTC)
Goto Top
So, habe DHCP jetzt installiert. face-smile
Member: Archeon
Archeon Apr 28, 2020 at 13:50:52 (UTC)
Goto Top
Zitat von @SearchBox:
Ich habe doch jetzt alle Fragen beantwortet. face-smile
Es geht doch nicht nur um meine Fragen, so macht das hier echt keinen Spaß.

Zitat von @SearchBox:
So, habe DHCP jetzt installiert.
Und?! Muss man dir immer alles aus der Nase ziehen oder lieferst du auch mal ungefragt ein paar Fakten/Informationen?
Member: em-pie
em-pie Apr 28, 2020 at 13:51:27 (UTC)
Goto Top
Zitat von @SearchBox:

Zitat von @em-pie:

Mit welchem Hersteller/ Produkt wurde die VM virtualisiert?
  • Microsofts Hyper-V
  • VMWares ESXI/ VMWare Player?
  • Oracles VirtualBox
  • KVM
  • XenServer
  • ...
VMware Workstation

Ich vermute nämlich, dass die NIC in der VM nicht dahingehend eingestellt ist, dass der Netzwerktraffic den Host verlassen darf.
Um hier den richtigen Wortlaut zu verwenden, wäre es daher hilfreich, den Hypervisor zu kennen...
VMware Workstation wird benutzt.

Dann prüfe bitte mal, ob die Netzwerkkarte in den EInstellungen der VM auf Bridged stehen:
https://www.windowspro.de/andreas-kroschel/netzwerk-optionen-fuer-virtue ...


Und bevor du jetzt IRGENDWO irgendwelche ROllen installierst:
!STOP!
Mal eben ein AD nebst DNS und DHCP aufzusetzen erfordert ein wenig Planung und Wissen, wie die Systeme zusammenhängen..

Wer hat den Server denn bei euch initial installiert/ bereitgestellt?
Member: Archeon
Archeon Apr 28, 2020 at 13:55:53 (UTC)
Goto Top
Zitat von @em-pie:
Und bevor du jetzt IRGENDWO irgendwelche ROllen installierst:
!STOP!
Mal eben ein AD nebst DNS und DHCP aufzusetzen erfordert ein wenig Planung und Wissen, wie die Systeme zusammenhängen..
Ich glaube dafür ist es etwas zu spät face-big-smile
Wer hat den Server denn bei euch initial installiert/ bereitgestellt?
Vermutlich kennen wir beide die Antwort schon face-wink
Member: SearchBox
SearchBox Apr 28, 2020 at 13:58:25 (UTC)
Goto Top
Also, ich habe den server aufgesetzt auf meinem eigenen PC daheim, der server wird nicht Produtiv genutzt, oder gehört nicht irgeneiner Firma an... ich bin 20 Jahre, und möchte einfach nur etwas darüber lernen da es mein Hobby ist....
Member: Archeon
Archeon Apr 28, 2020 at 14:00:51 (UTC)
Goto Top
Das ist ja auch keinesfalls verwerflich, aber du musst uns schon Informationen geben, um dir helfen zu können face-wink

Ich bin jetzt erstmal unterwegs, gucke aber später wieder hier rein.
Member: SearchBox
SearchBox Apr 28, 2020 at 14:08:24 (UTC)
Goto Top
Super face-smile ich habe jetzt den server mal komplett neu aufgesetzt. face-smile

Hauptsächlich habe ich vor WSUS zu testen, um zu sehen wie man WSUS bedient, konfiguriert, und wie es grundsetzlich funktioniert.
Vom WSUS sollen versorgt werden:

1x der Eigentliche Server ( Windows Server 2012 R2 Standard x64 (180 Tage aktiviert)
1x Windows 7 Professional
1x Windows 8.1 Pro

nun meine Frage: wie soll ich am besten vorgehen ? habe jetzt erstmal alles Installiert. also alle 3 VM`s laufen jetzt. noch ist nix konfiguriert.

Danke für eure Hilfe!
Member: Dr.Bit
Dr.Bit Apr 29, 2020 updated at 08:14:37 (UTC)
Goto Top
Also, mal sehen ob ich das richtig verstanden habe: die drei Maschinen laufen virtuell auf Deinem Rechner zu Hause und Du willst einfach nur eine Testumgebung erstellen?

Dann muß zuerst Dein Server laufen und richtig konfiguriert sein. Mit den Clients brauchst Du da noch gar nicht anfangen. Auf dem Server muß mindestens der DNS Server konfiguriert sein und funktionieren, sowie die Domänencontroller Dienste. DHCP kannst Du machen, mußt Du aber nicht. Du kannst auch mit festen IP Adressen arbeiten. DHCP bietet sich, der Einfachheit halber, aber an.
Wenn der Server läuft, kannst Du anfagen die Clients hinzu zu fügen. Es müssen Windows Professional Versionen sein. Home wird nicht funktionieren. Windows 8 Pro - 10 Pro machen da keine Probleme. Bei Windows 7 Pro kommt es auf die Version an. Die ersten Win 7 Pro ISO´s hatten das Problem, das unter bestimmten Konstellationen die Integration in eine Domäne nicht funktionierte. Das Problem betraf alle Domänencontroller ab Server 2003. Hierzu habe ich damals, in der Kreidezeit, folgendes gefunden:

Windows 7: DNS-Problem beim Domänenbeitritt

Microsoft überrascht immer wieder: Bei uns läuft ein Windows 2008 Server als Domain Controller mit Active Directory.
In diese Domäne möchte ich einen Windows 7-Rechner aufnehmen. Alles Standard, alles kein Problem – sollte man meinen, bis diese Meldung erscheint:

“Fehler beim Versuch, den DNS-Namen eines Domänencontrollers in der Domäne … aufzulösen”

Nach langer Recherche im Netz stellt sich heraus, dass in der Registry des frischinstallierten Rechners zwei Schlüssel fehlen.
Windows Registry Editor Version 5.00
[HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\LanmanWorkstation\Parameters]
"DomainCompatibilityMode"=dword:00000001
"DNSNameResolutionRequired"=dword:00000000


Wenn Du die Werte in der Registry einträgst und neu startest funktioniert der Beitritt einwandfrei.

Ansonsten, wie hier schon erwähnt wurde, sollten die Netzwerkeinstellungen für die VM´s, die Du in VMware vornehmen kannst, schon korrekt sein.

Ich würde den Server mit zwei virtuellen Netzwerkkarten ausstatten, wobei eine Netzwerkkarte an Dein "echtes Hostnetz" angebunden ist und die Zweite in einem virtuellen Netzwerk für Deine Testumgebung liegt. In dieses virtuelle Netz würde ich dann auch die virtuellen Rechner einbinden. Dann kannst Du in Deiner virtuellen Umgebung schalten und walten wie Du willst und versaust Dir nicht Dein "echtes" Netz. Wichtig wäre hierbei dann noch, daß die Serverdienste nicht an die Netzwerkkarte die in dein Hostnetz zeigt angebunden sind.

Gruß
Stephan
Member: SearchBox
SearchBox Apr 29, 2020 at 12:35:39 (UTC)
Goto Top
Erstmal Vielen Dank für deine ausführliche Antwort.
Damit ich das richtig verstanden habe:

Zuerst den Windows Server Konfigurieren.

Ich verstehe das nur nicht so ganz mit der festen IP-Adresse kann ich eine Beliebige verwenden?

Oder woher weiß ich welche ich verwenden kann das ich Internetzugriff erhalte, und kein Gelbes Dreieck unten erscheint?
vmware netzeinstellungen
Member: Dr.Bit
Dr.Bit Apr 29, 2020 at 13:19:16 (UTC)
Goto Top
In Deinem Screenshot hast Du den Netzwerkadapter, den Du für den Zugriff auf Dein Hostnetzwerk benötigst ja schon richtig markiert. Den solltest Du verwenden um Zugriff auf´s Internet usw. zu bekommen. Allerdings nur mit dem Server (dazu am Ende mehr). Über Add.. kannst Du Dir jetzt noch eine weitere Netzwerkkarte erstellen. Der weist Du dann, auf der rechten Seite, über Custom, VMnet1 zu, das sollte Host-Only sein. Wenn das erledigt ist kannst Du in den Netzwerkeinstellungen des virtuellen Windows Servers die Netzwerkkarte, die gebridged ist, auf DHCP stellen. Die bekommt dann eine IP-Adresse von Deinem echten Host-Server/ Router und damit kommt Dein virtueller Server dann schon einmal ins Internet. Der zweiten Netzwerkkarte weist Du dann eine IP-Adresse verschieden von Deinem Hostnetzwerk zu. z.B. Hostnetzwerk bei einer Fritzbox ohne Server 192.168.178.0/24, virtuelles Netzwerk 192.168.1.0/24. Host- und virtuelles Netzwerk müssen verschieden sein. Deinen DNS und DHCP mußt Du nun an die Netzwerkkarte des virtuellen Netzwerks anbinden. ( Windowsseitig NICHT VMWareseitig). Zur Vereinfachung kannst Du in den Netzwerkeinstellungen deines virtuellen Servers einfach mal nachsehen, da sollten zwei Netzwerkkarten auftauchen und eine von den Beiden hat eine IP aus Deinem Hostnetz, sofern beide auf IP-Adresse automatisch beziehen stehen. Wenn nicht - ändern. Die läßt Du in Ruhe und nimmst die Andere für Dein virtuelles Netz. Dieser nun eine IP Adresse zuweisen und, wie gesagt, DNS und DHCP Server daran anbinden. Damit wäre Dein Server soweit vorbereitet, daß Du virtuelle Maschinen daran anbinden kannst.
Wenn Du nun die virtuellen Clienten anbinden willst, müssen diese auch mit ihren virtuellen Netzwerkkarten auf VMNet1 liegen, zu konfigurieren über die Virtual Machine Settings der jeweiligen virtuellen Maschine. In den Netzwerkeinstellungen der Windows Clients kannst Du nun feste IP-Adressen vergeben nach dem Beispiel 192.168.1.2 bis 192.168.1.253, oder im DHCP Server einen entsprechenden IP-Adressbereich vorgeben. Nicht wundern, die 192.168.1.1 würde ich für den Server reservieren, bzw. in dessen virtueller Netzwerkarte eintragen, und die 192.168.1.254 nehme ich immer für das Gateway (Firewall oder Router).
So, alle Netzwerkkarten fertig konfiguriert? Dann die Clients der Domäne hinzufügen und fertig.
Zu Beachten in diesem Szenario ist, das die Clienten nicht ins Internet kommen werden, da kein Router konfiguriert ist. Dieser müßte dann auch noch virtuallisiert werden, z.B. eine pfSense. Dann wird´s aber so langsam auch sportlich.

Viiiiiiiiel Spaß.

Gruß
Stephan
Member: SearchBox
SearchBox Apr 29, 2020 updated at 13:32:51 (UTC)
Goto Top
okay, ich bin etwas verwirrt...


Zitat von @Dr.Bit:

In Deinem Screenshot hast Du den Netzwerkadapter, den Du für den Zugriff auf Dein Hostnetzwerk benötigst ja schon richtig markiert. Den solltest Du verwenden um Zugriff auf´s Internet usw. zu bekommen. Allerdings nur mit dem Server (dazu am Ende mehr). Über Add.. kannst Du Dir jetzt noch eine weitere Netzwerkkarte erstellen. Der weist Du dann, auf der rechten Seite, über Custom, VMnet1 zu, das sollte Host-Only sein. Wenn das erledigt ist kannst Du in den Netzwerkeinstellungen des virtuellen Windows Servers die Netzwerkkarte, die gebridged ist, auf DHCP stellen. Die bekommt dann eine IP-Adresse von Deinem echten Host-Server/ Router und damit kommt Dein virtueller Server dann schon einmal ins Internet.

also das habe ich jetzt erledigt.

bedeutet das ich muss jetzt in die fritzbox von mir rein ? und da was ändern ?

und muss ich dem server keine Statische IP zuweisen ? weil davor hatte ich ihm eine statische zugwiesen, die auch im server manager angezeigt wurde.
Und jetzt steht da über DHCP zugewiesen...

Gruß
David
unbenannt
unbenannt2
Member: Dr.Bit
Dr.Bit Apr 29, 2020 updated at 14:08:54 (UTC)
Goto Top
Also: zwei Netzwerkkarten -> schonmal gut, eine auf bridged und eine auf VMNet1, auch gut. Im Windows Server auch zwei Netzwerkkarten, wieder gut. Eine von den beiden müßte jetzt eine IP Adresse von Deiner Fritzbox bekommen haben, aber nur eine. Der Anderen kannst Du jetzt eine IP Deiner Wahl, verschieden von dem IP-Adressbereich der Anderen zuweisen, also fest vergeben. z.B. 192.168.1.1.

Der Vorteil an diesem Szenario ist, dadurch daß die Clients nicht ins Internet kommen und Du ja den WSUS testen willst, kannst Du Dir auch sicher sein, daß die Updates der Clients nicht von irgendeinem MS Server kommen sondern von Deinem WSUS.

Edit: wie ich gerade sehe hat die Ethernet0 eine IP zugewiesen bekommen. Das bedeutet, daß der Server schon einmal ins Internet kommen müßte. Wahrscheinlich nicht über den IE, da der durch die Sicherheitseinstellungen erst einmal geblockt ist aber ein ping auf 8.8.8.8 sollte gehen.
Das bedeutet, daß Ethernet1 die Netzwerkkarte ist, die an VMNet1 gebunden ist. Dieser nun eine feste IP zuweisen.
Was mir noch aufgefallen ist: die Domäne SAMTHINK.local ist hoffentlich ausschließlich für Deine virtuelle Umgebung erstellt worden, ansonsten wird´s noch etwas komplizierter damit nachher alles sauber läuft.
Member: Dr.Bit
Dr.Bit Apr 29, 2020 at 14:05:12 (UTC)
Goto Top
Zitat von @SearchBox:

okay, ich bin etwas verwirrt...

Hab ich mir gedacht face-smile

also das habe ich jetzt erledigt.

Schön
bedeutet das ich muss jetzt in die fritzbox von mir rein ? und da was ändern ?

Auf keinen Fall
weil davor hatte ich ihm eine statische zugwiesen, die auch im server manager angezeigt wurde.
Deswegen das gelbe Ausrufezeichen
Und jetzt steht da über DHCP zugewiesen...
So soll es sein
Member: SearchBox
SearchBox Apr 29, 2020 at 14:07:57 (UTC)
Goto Top
Und was kommt dann bei: Bevorzugter DNS-Server rein ?

das muss doch auch konfiguriert werden oder nicht ? oder kann ich 8.8.8.8 als DNS nehmen, also von Google ?

also die IP-Adresse habe ich jetzt bei der VMNet1 karte eingetragen.
Member: SearchBox
SearchBox Apr 29, 2020 at 14:15:00 (UTC)
Goto Top
ahhhh okay jetzt hab ich es so einigermaßen verstanden ^^
Member: Dr.Bit
Dr.Bit Apr 29, 2020 at 14:18:04 (UTC)
Goto Top
Die lokale IP von Ethernet1 und nur die. Die Namesauflösung soll ja der DNS Server machen und der ist nunmal unter der IP von Ethernet1 erreichbar. Den DNS mußt Du natürlich, damit alles sauber läuft, auch noch endfertig durchkonfigurieren hierfür gibt´s im i-net haufenweise sehr gute Anleitungen, ebenso wie für die Konfiguration eines DHCP Servers. Ein Gateway solltest Du unter Ethernet1 nicht eintragen, hat ja keine Verbindung ins Internet und daher überflüssig. Falls Du hier ein falsches Gateway einträgst, kommt der Server vielleicht nicht mehr raus, weil er ja schon das Gateway von Deiner Fritte bekommen hat und dann nicht wüßte welches er nehmen soll. Also: auf Ehternet1 weglassen.
Member: Dr.Bit
Dr.Bit Apr 29, 2020 at 14:19:11 (UTC)
Goto Top
Zitat von @SearchBox:

ahhhh okay jetzt hab ich es so einigermaßen verstanden ^^
Ich harre der Dinge die da kommen.

Gruß
Stephan

AFK
Member: SearchBox
SearchBox Apr 29, 2020 at 14:24:48 (UTC)
Goto Top
Hier kommt jtz die IP-Adresse meines Servers rein ?
dns
Member: SearchBox
SearchBox Apr 29, 2020 at 14:54:35 (UTC)
Goto Top
Also ich habe den server nur neugestartet damit er updates Installieren kann....

jedoch ist jetzt das ausrufezeichen wieder da....
fehler
Member: SearchBox
SearchBox Apr 29, 2020 at 15:22:21 (UTC)
Goto Top
Zitat von @Dr.Bit:
Was mir noch aufgefallen ist: die Domäne SAMTHINK.local ist hoffentlich ausschließlich für Deine virtuelle Umgebung erstellt worden, ansonsten wird´s noch etwas komplizierter damit nachher alles sauber läuft.

Ja, die habe ich mir einfach nur ausgedacht ^^
Member: Dr.Bit
Dr.Bit Apr 29, 2020 updated at 18:07:59 (UTC)
Goto Top
welche IP Adresse hat er denn auf Ethernet0? Netzwerkumgebung-> rechte Maustaste auf Ethernet0-> Status-> Details-> IPv4-Adresse

Zum Konfigurieren des DNS hol Dir lieber eine Anleitung aus dem Netz, geht schneller.

Und wenn Du schon dabei bist: Im Servermanager die verstärkten Sicherheitskonfiguration für den IE Abschalten damit Du erst einmal weniger Probleme mit dem Internetzugriff hast. Später aber wieder einschalten und dann konfigurieren.
Member: SearchBox
SearchBox Apr 29, 2020 updated at 18:19:43 (UTC)
Goto Top
also auf der Netzwerkkarte ,,ethrnet0" habe ich jetzt internetzugriff, und bei Ethernet1 Steht begrenzt

kann ich irgendeine beliebige Anleitung nehmen, oder muss es eine für VMware sein ? kannst du da irgenwas empfehlen ?
Member: Dr.Bit
Dr.Bit Apr 29, 2020 at 19:13:26 (UTC)
Goto Top
Begrenzt ist in Ordnung, es ist ja kein gateway hinterlegt. Dennoch wäre ineressant, ob sich der IP Adressbereich von Ethernet0 von dem von Ethernet1 unterscheidet. Für Ethernet1 hast Du nämlich die Standard IP der FritzBox eingetragen, wenn Du die IP von Deiner Fritzbox nicht irgendwann mal geändert hast, ist das natürlich keine gute Idee.

Welche Anleitung Du nimmst ist in Deinem Fall wohl relativ egal, da Du ja offensichtlich noch nicht viel Ahnung hast. Daher wird Dir jede Anleitung wohl weiter helfen. Achten solltest Du darauf, das es eine für einen Windows Server DNS ist und nicht für einen Unix/Linux DNS oder Router/Firewall DNS. Und lies es erst komplett durch und versuche es zu verstehen. Dann nochmal durchlesen und dann erst probieren. Wenn Du etwas falsch konfigurierst kann Dir hier unter Umständen keiner wiklich weiter helfen, nicht weil wir keine Ahnung haben sondern Glaskugel und so.
Member: em-pie
em-pie Apr 29, 2020 updated at 19:26:16 (UTC)
Goto Top
Moin,

Tip:
verwende innerhalb des abgeschotteten Netzes das IP-Netz
10.20.30.0/24
/24 = SUbnetzmaske 255.255.255.0

Dann kannst du die Netze optisch direkt auseinander halten.

Ich gehe nämlich mal davon aus (wie @Dr.Bit auch), dass deine FritzBox derzeit noch immer die 192.168.178.1 hat.
Das führt dann an deinem virtuellen Server zu vielen Problemen...

Denn wohin soll er das Paket senden, wenn es für das Internet bestimmt ist:
Zur FritzBox oder zum anderen Netzwerk-Adapter (Ethernet1)?


Edit:
hier ein paar Tipps bzgl AD, DHCP, DNS & Co:


Gruß
Member: SearchBox
SearchBox Apr 29, 2020 at 19:29:39 (UTC)
Goto Top
In Ordnung, dann werde ich mich erstmal etwas einlesen, und dann wieder bie dir melden. wäre PN dann ggf. möglich ?
Member: SearchBox
SearchBox Apr 29, 2020 at 19:30:43 (UTC)
Goto Top
Danke dir für deine Hilfe! ich werde mich dann etwas einlesen, und mich dann wieder melden

warscheinlich dann morgen.
Member: Dr.Bit
Dr.Bit Apr 29, 2020 at 19:33:01 (UTC)
Goto Top
Zitat von @em-pie:

Moin,

Tip:
verwende innerhalb des abgeschotteten Netzes das IP-Netz
10.20.30.0/24
/24 = SUbnetzmaske 255.255.255.0

Na, dann wenigstens RFC 1918 konform und 10.20.30.0/8
/8 = Subnetzmaske 255.0.0.0. Wenn man schon irgendwas mit 16000 IP Adressen raushauen will. face-smile
Ich würde es zwar nicht so machen, aber übersichtlicher ist es schon.
Member: em-pie
em-pie Apr 29, 2020 at 19:48:07 (UTC)
Goto Top
Das ist schon richtig so, mit der /24
Lies dich mal in das Thema CIDR/ Subnetting ein, @Dr.Bit face-wink
Member: Dr.Bit
Dr.Bit Apr 30, 2020 updated at 05:49:27 (UTC)
Goto Top
Zitat von @em-pie:

Das ist schon richtig so, mit der /24
Lies dich mal in das Thema CIDR/ Subnetting ein, @Dr.Bit face-wink

Is mir schon klar. face-wink
Aber der TO bekommt ja schon die Konfiguration der Netzwerkkarten und das richtige Zuweisen der IP Adressen nicht alleine hin. Willst Du ihn dann auch noch mit Subnetting überfordern? Er scheint es ja nur als Hobby zu machen. Wenn er Subnetting auch noch verstehen soll, denke ich, wäre es etwas viel auf einmal. Mal abgesehen davon, das er wahrscheinlich gar nicht wußte, daß es sowas überhaupt gibt.
Er ist eben noch Anfänger.
Also Schritt für Schritt.
Member: tomolpi
tomolpi Apr 30, 2020 updated at 10:07:47 (UTC)
Goto Top
Moin zusammen,

es wundert mich ein bisschen, dass noch keiner das Openbook erwähnt hat face-wink deswegen @to: http://openbook.rheinwerk-verlag.de/windows_server_2012r2/ hier hast du viel zum Lesen.

Grüße

tomolpi
Member: Dr.Bit
Dr.Bit Apr 30, 2020 at 08:16:27 (UTC)
Goto Top
Zitat von @tomolpi:

Moin zusammen,

es wundert mich ein bisschen, dass noch keiner das Openbook erwähnt hat face-wink deswegen @to: http://openbook.rheinwerk-verlag.de/windows_server_2012r2/ hier hast du viel zum Lesen.

Guckst Du Post von em-pie vom 29.04.2020 um 21:26 Uhr
Member: tomolpi
tomolpi Apr 30, 2020 at 10:06:56 (UTC)
Goto Top
Zitat von @Dr.Bit:

Zitat von @tomolpi:

Moin zusammen,

es wundert mich ein bisschen, dass noch keiner das Openbook erwähnt hat face-wink deswegen @to: http://openbook.rheinwerk-verlag.de/windows_server_2012r2/ hier hast du viel zum Lesen.

Guckst Du Post von em-pie vom 29.04.2020 um 21:26 Uhr
Ahh, sorry, ich hab das Edit von ihm nicht gesehen. Mittlerweile ist das hier etwas verwirrend face-big-smile
Member: Dr.Bit
Dr.Bit Apr 30, 2020 at 10:12:03 (UTC)
Goto Top
Verwirrend? Ach, echt? face-smile
Member: Dr.Bit
Dr.Bit Apr 30, 2020 at 12:47:41 (UTC)
Goto Top
Wo ist eigentlich der TO?

Wahrscheinlich liest er sich gerde in DNS konfiguration ein oder ist schon verzweifelt aus dem Fenster gespungen. face-smile


Zitat von @SearchBox:

In Ordnung, dann werde ich mich erstmal etwas einlesen, und dann wieder bie dir melden. wäre PN dann ggf. möglich ?

PN finde ich immer schlecht, da wir hier ja alle aus den Fehlern und Problemen der Anderen lernen wollen. Außerdem kann es ja auch mal sein, daß die Hilfe, die angeboten wird, totaler Müll ist. Dann kann ein Anderer rettend eingreifen.
Member: SearchBox
SearchBox Apr 30, 2020 updated at 12:56:55 (UTC)
Goto Top
Ah, das hatte ich garnicht bedacht... aber ich bin euch wirklich dankbar das ihr mich unterstützen wollt. ich werde dann jetzt mal anfangen mich in das Thema DNS einzulesen.
Und bevor ich irgenwas einstelle, werd ich erstmal hier nachfragen. ;)
Member: Dr.Bit
Dr.Bit Apr 30, 2020 at 12:52:20 (UTC)
Goto Top
Klingt nach einem Plan.
Member: Archeon
Archeon Apr 30, 2020 at 13:02:03 (UTC)
Goto Top
Oh da ist ja seit gestern hier einiges passiert face-big-smile

Ich habe das nur mal überflogen, so wie es aussieht bist du ja jetzt in guten Händen gelandet face-wink
Member: SearchBox
SearchBox Apr 30, 2020 updated at 13:11:05 (UTC)
Goto Top
Hey face-smile jaaa, ich bin sooo froh, es funktioniert immer besser, bus jetzt habe ich mal den DNS-Sever installliert, und gestern als ich ich die VM runtergefahren habe, hat er mir 63 Updates installiert...
jetzt habe ich mich angelmeldet, jedoch habe ich jetzt kein Internetzugriff...

Ich versuche ihn mal neu zu starten.
Member: Dr.Bit
Dr.Bit Apr 30, 2020 at 13:14:07 (UTC)
Goto Top
Ok, also nochmal. Gib uns doch mal einen Screenshot von deiner Ethernet0 konfiguration. Also die Karte, die auf IP-Adresse automatisch beziehen stehen sollte.
Member: SearchBox
SearchBox Apr 30, 2020 at 13:21:34 (UTC)
Goto Top
BItte face-smile
ip-konfiguration
Member: Dr.Bit
Dr.Bit Apr 30, 2020 at 13:32:56 (UTC)
Goto Top
Schlecht. Der Server bekommt keine IP mehr von Deiner Fritzbox. Zur Info: wenn Du irgendwo mal eine IP siehst, die mit 169.254.... anfängt, hat die Netzwerkkarte keine Verbindung. Dies ist nämlich eine MS IP, die die MS Betriebsysteme automatisch vergeben, wenn kein Netzwerkkabel eingesteckt ist. In Deinem Fall besteht keine Verbindung zu der Netzwerkkarte, die in Deinem Rechner physikalisch verbaut ist. Schau mal in den Einstellungen von VMWare zu der virtuellen Maschine ob unter Network Adapter immer noch Briged drinsteht. Wenn nicht wieder auf briged ändern. Und die virtuelle Maschine neu starten.
Member: SearchBox
SearchBox Apr 30, 2020 at 13:38:53 (UTC)
Goto Top
Also in in den einstellungen ist noch alles wie davor....Briged steht drin
Member: em-pie
em-pie Apr 30, 2020 at 13:44:55 (UTC)
Goto Top
Gib der mal eine feste IP-Adresse.
Wenn deine FritzBox die 192.168.178.1 hat und bei dir die 192.168.178.2 noch frei ist, dann stelle die NIC am Server mal wie folgt ein:

IP-Adresse: 192.168.178.2
Netmask: 255.255.255.0
GW: 192.168.178.1
DNS: 192.168.178.1


Noch ein Tipp, wenn du später den DHCP-Server einrichtest: der DHCP-Server auf deinem virt. Server darf nur an das Interface ETHERNET1 gebunden sein, sonst hast du neben der Fritte auch noch den virtuellen Server als DHCP-Schleuder in deinem produktiven LAN...
Member: Dr.Bit
Dr.Bit Apr 30, 2020 at 13:46:33 (UTC)
Goto Top
Hmm. Merkwürdig.
Hast Du Deinen Rechner schon einmal neu gestartet?
Member: SearchBox
SearchBox Apr 30, 2020 at 13:47:38 (UTC)
Goto Top
also dies dann in der 2 netzwerkkarte eintragen ? anbei sende ich gleihc noch bilder
ip-konfiguration 2
Member: Dr.Bit
Dr.Bit Apr 30, 2020 updated at 14:15:39 (UTC)
Goto Top
Zitat von @em-pie:

Gib der mal eine feste IP-Adresse.
Wenn deine FritzBox die 192.168.178.1 hat

Tja, wenn wir das nur wüßten.

IP-Adresse: 192.168.178.2
Netmask: 255.255.255.0
GW: 192.168.178.1
DNS: 192.168.178.1

Das wird nichts bringen, wenn er vor den Updates eine IP bekommen hat und jetzt nicht mehr. Außerdem ist die 2 am Ende eine schlechte Idee. die wird dann wohl schon belegt sein.

Noch ein Tipp, wenn du später den DHCP-Server einrichtest: der DHCP-Server auf deinem virt. Server darf nur an das Interface ETHERNET1 gebunden sein, sonst hast du neben der Fritte auch noch den virtuellen Server als DHCP-Schleuder in deinem produktiven LAN...

Hatte ich schon in einem früheren Post geschrieben. Aber besser zweimal. face-smile
Member: SearchBox
SearchBox Apr 30, 2020 at 14:10:05 (UTC)
Goto Top
soll ich vielleicht die updates mal deinstallieren ?
Member: Dr.Bit
Dr.Bit Apr 30, 2020 updated at 14:16:17 (UTC)
Goto Top
Zitat von @SearchBox:

also dies dann in der 2 netzwerkkarte eintragen ? anbei sende ich gleihc noch bilder
Nein, er meint in die Erste. Also in Ethernet0. Aber wie ich schon sagte, das wird nichts bringen.
Mal abgesehen davon, das die 192.168.178.2 wahrscheinlich schon von Deinem PC oder Handy oder Tablet oder sonstwas belegt sein wird.
Da bekommst Du einenen IP-Adress Konflikt und dann geht auf beiden Geräten unter Umständen gar nichts mehr.
Member: Dr.Bit
Dr.Bit Apr 30, 2020 updated at 14:14:09 (UTC)
Goto Top
Das wird auch nichts bringen. Updates werden nach meiner Erfahrung nie so ganz deinstalliert. Irgenwas bleibt immer zurück.

Den Rechner schon neu gestartet? Also Deinen Host nicht nur die virtuelle Maschine.

Reboot tut immer gut .face-smile
Member: SearchBox
SearchBox Apr 30, 2020 at 14:15:22 (UTC)
Goto Top
nein das noch nicht, aber kann ich direkt mal machen.
werde mich dann wieder melden.
Member: SearchBox
SearchBox Apr 30, 2020 updated at 14:53:19 (UTC)
Goto Top
Warum auch immer...aber jetzt hab ich wieder internetzugang....

jedoch bekomme ich das mit dem DNS-Server ( Serverrolle ) nicht auf die reihe...ich weiß nicht wie ich anfangen soll....
Member: Dr.Bit
Dr.Bit Apr 30, 2020 at 15:32:39 (UTC)
Goto Top
Als erstes einmal, hast Du deinen PC neu gestartet? Wenn ja, dann poste doch mal ein Bild von deiner IP auf Ethernet0, damit wir uns ein Bild machen können wie denn Deine "echte" Netzwerkkonfiguration aussieht. So wie in Deinem Post von 15:21 Uhr. Davon ist nämlich abhängig, wie es weiter geht.
Member: SearchBox
SearchBox May 01, 2020 updated at 19:23:46 (UTC)
Goto Top
also von meinem Server?
Ja, habe meinen PC neu gestartet.
ethernet1
ethernet0
Member: em-pie
em-pie May 01, 2020 updated at 21:19:46 (UTC)
Goto Top
Du hast WIEDER beide NICs ins selbe Netz gesteckt.

Lies dir bitte noch einmal meinen obigen Post durch, in dem ich die 10.20.30.0/24 eingebracht habe.

Dein virtuelles Netz muss einen anderen IP-Kreis haben, als das Netz der FritzBox...
Member: SearchBox
SearchBox May 01, 2020 at 21:29:52 (UTC)
Goto Top
du hast NIC erwähnt.... ich weiß leider nicht was das bedeutet...
Member: tomolpi
tomolpi May 01, 2020 updated at 21:35:39 (UTC)
Goto Top
NIC ist eine Network Interface Card face-smile
Member: SearchBox
SearchBox May 01, 2020 at 21:40:43 (UTC)
Goto Top
achso, okay, und wie soll ich damit verfahren ?
Member: em-pie
em-pie May 01, 2020 at 21:57:37 (UTC)
Goto Top
Steht weiter oben....
Member: SearchBox
SearchBox May 01, 2020 at 22:02:14 (UTC)
Goto Top
Okay ich werd es mal versuchen face-smile
Member: Dr.Bit
Solution Dr.Bit May 02, 2020 at 06:56:26 (UTC)
Goto Top
Guten Morgen. Habt Ihr Nachts nix besseres zu tun? Keine Freundin? face-smile

Das habe ich mir schon gedacht das die Adressbereiche die Gleichen sind. Ich hätte erwartet, daß es inzwischen klar gewesen wäre, das die NIC´s unterschiedlich IP-Adressbereiche haben MÜSSEN!
Wie dem auch sei, nim für Ethernet1 irgendwas aus dem Bereich den em-pie vorgeschlagen hat. Dann erkennst Du nachher leichter, wo denn wahrscheinlich die Fehler bei der Anbindung der Clients liegen werden. Ich werde heute mal versuchen eine Zeichnung anzufertigen.
Member: Dr.Bit
Dr.Bit May 02, 2020 updated at 10:08:54 (UTC)
Goto Top
Hier mal ein Schaubild, wie es sein könnte.

virtualisierung

Die Verbindung zwischen Netzwerkkarte im PC und Bridged Adapter soll verdeutlichen, das die virtuelle Netzwerkkarte im Server 2012 R2 und die physikalische im PC die Gleichen sind und nur durch die Virtualisierungssoftware voneinander getrennt bzw. aneinander gekoppelt sind. Der virtuelle Switch hat keinerlei Verbindung zum Host-PC. Da die Virtuellen PC´s später logisch an diesen Switch angebunden werden sollen, haben diese dann auch KEINE Verbindung zum Host Netzwerk oder ins Internet.
Member: SearchBox
SearchBox May 02, 2020 at 22:48:38 (UTC)
Goto Top
Hey Dr.Bit!

Habe das heute bei jedem Clienten die IP über CMD ( ipconfig - > dann IP-Adresse, Gateway) auf Papier notiert.

Dann die notierten IP-Adressen auf statisch gesetzt, und bei bevorzugter DNS-Server die IP-Adresse meines Windows Servers eingetragen, Internet funktioniert somit jetzt bei jedem Client (Windows 7, Windows 8.1)
Dann habe ich die client's meiner Domain hinzugefügt. Hat auch funktioniert!

Ich bin zufrieden und Glücklich ­čśŐ

Ich danke euch allen für eure tatkräftige Unterstützung, und eure Geduld! Dankeeeee ­čĄŚ

Schöne Grüße, und bis zur nächsten Frage!
Member: Dr.Bit
Dr.Bit May 03, 2020 at 08:20:09 (UTC)
Goto Top
Moin,

das ist ja mal ein Trick. wenn Du alles so engerichtet hast, wie wir das hier vorgeschlagen haben, können Deine Clients gar nicht ins Internet kommen. Es besteht ja keine Verbindung dorthin, da in deiner virtualisierten Umgebung kein Router vorhanden ist. Ich denke mal, Du hast irgend etwas anders gemacht, als wir gesagt haben. Aber sei´s drum, wenn Du glücklich bist.

Gruß
Stephan
Member: em-pie
em-pie May 03, 2020 at 11:02:52 (UTC)
Goto Top
Das klingt in der Tat nicht so, wie wir es dir beschrieben haben.

Ich habe dir jetzt einmal ein Bild erstellt. Die ganzen IP-Adressen sollten theoretisch überall bestehen (abweichend ggf. die 192.168.178.101):

DHCP kann in den VMware Workstation-Einstellungen für "host-only" dektiviert werden, bzw. muss das sogar.
zeichnung1
Member: Dr.Bit
Dr.Bit May 03, 2020 at 11:20:30 (UTC)
Goto Top
Schönes Schaubild. Da kann ich mir noch was abgucken. face-smile

Ich würde allerdings den PC mit der VM Workstation und Ethernet0 Bridged auf dem Server auf DHCP stellen. Ich könnte mir vorstellen, daß er andernfalls sein Hostnetz lahmlegt.
Oder auf der Fritzbox den IP-Adressbereich, der verteilt werden kann, von 192.168.178.100 bis 192.168.178.250 beschränken.
Member: SearchBox
SearchBox May 04, 2020 at 20:33:18 (UTC)
Goto Top
werd mich mal dran versuchen. trozdem ein HERZLICHES DANKE!!!! an euch alle für die unterstützung face-smile

Bis zu nächsten Frage face-smile