Windows Server von interner Festplatte installieren

Mitglied: Crischi94

Crischi94 (Level 1) - Jetzt verbinden

21.03.2016 um 12:17 Uhr, 1288 Aufrufe, 10 Kommentare

Hallo liebe Community,

es ist an der Zeit, dass ich meinen alten Test-Server neu aufsetze. Ich habe den damals geschenkt bekommen mit laufendem System. Habe aber die Disks nicht dazu bekommen. (Ich habe noch eine Windows Server 2003 CD hier, dafür aber keinen Key; und die Support-Zeit läuft auch noch so super lange, deshalb möchte ich das gerne vermeiden. (Der Server kann nur 32 Bit, deshalb käme dann jetzt nur ein Windows Server 2008 (R1) in Frage, welches ich hier als DVD mit Key habe.))
Deshalb kann ich auch nur das nehmen, was ich habe. Der Server ist als Dell PowerEdge 2650 schon ein etwas älteres Modell. Deshalb hat er ein CD-Laufwerk und kein DVD-Laufwerk.
Und genau das stellt mein Problem dar. So kann ich das Betriebssystem nicht installieren. Von USB kann der Server leider auch nicht booten. PXE habe ich mal versucht, das Setup startet auch kurz. Aber dann bekomme ich die Meldung über fehlende Netzwerkkartentreiber im Image.
Deshalb hatte ich eine letzte Idee. Der HDD-Controller muss ja zwangsweise grundsätzlich interne Festplatten booten können. Wieso soll er also nicht ein Windows-Setup booten können?
Zu diesem Thema habe ich schon viel gegooglet, habe hier auch schon einige Stunden rum probiert. Was i ch genau gemacht habe:
Eine der Festplatten (Größe: 33,6GB; Partition mit 20GB) ist in FAT32 formatiert worden. Diese Partition ist als aktiv markiert worden und der Inhalt des ISO-Image ist auf die Festplatte kopiert worden. Ich habe nicht das ISO-Image an sich drauf kopiert. So oder so ähnlich wurde es auch in mind. 85% der Foren vorgeschlagen. Und der gleiche Weg funktioniert für USB-Sticks.
Festplatten werden in der Boot-Folge als letztes gestart. Aber die präparierte Festplatte unter den Festplatten als erstes.
Ein Boot sah dann folgendermaßen aus:
Der Server versuchte von CD zu booten, er hat eine gefunden, aber nicht gestartet, weil ich keine Taste gedrückt habe. Statt weiter zu machen, sagte er mir ich solle Medien entfernen und es erneut versuchen. Wenn ich eine Taste gedrückt habe, hat er es erneut versucht. Kam immer das Gleiche. Erst als ich die CD raus genommen habe, ging es weiter. Als nächstes standen die Netzwerkkarten an. Hier war es das Gleiche: nach erfolglosem Boot-Versuch sollte ich die Medien entfernen, um weiter zu machen. Da ich das aber nicht kann, habe ich den ganzen Server neu gestartet und alles aus dem Boot geschmissen, außer die Festplatten.
Jetzt bekomme ich direkt nach dem Start gesagt, dass ich irgendwelche Medien entfernen soll.
Aber wieso entfernen? Das habe ich noch nie vorher gesehen und das hat der Server auch erst gemacht, seitdem ich die Festplatte bootfähig gemacht habe und sie an die Spitze gesetzt habe. Setze ich die Festplatte mit dem alten System wieder an boot-Spitze, bootet der Server ganz normal seine Reihenfolge ab.
Ich möchte aber auch kein weiteres Geld mehr für irgendwelche Laufwerke oder so in der Server stecken, weil ich nicht weiß, ob mir der Server nicht morgen auseinander fliegt.

Würde jemandem spontan eine Möglichkeit einfallen, wie ich den Server dazu bringen kann das Windows-Setup von einer internen Festplatte zu booten, oder ein anderer Weg, wie ich mit gegebener Hardware mein Windows drauf installieren kann?

Ich danke im Voraus!

Mit freundlichen Grüßen
Crischi94
Mitglied: Lochkartenstanzer
21.03.2016 um 12:39 Uhr
Zitat von @Crischi94:

Würde jemandem spontan eine Möglichkeit einfallen, wie ich den Server dazu bringen kann das Windows-Setup von einer internen Festplatte zu booten, oder ein anderer Weg, wie ich mit gegebener Hardware mein Windows drauf installieren kann?


Moin,

Der Installer von Wndows 2008 Server, genauso wie auch der von Vista, mag es nicht, wenn man es vom selben Medium startet wie dasjenige, auf dem man es installieren will. Da wirst Du entweder kruzfristig ein DVD-Laufwerk einbauen müssen, oder mit Hilfe von dem PLOP Bootmanager, den Du von CD oder Diskette starten kannst von einem USB-Stick booten.

lks
Bitte warten ..
Mitglied: Crischi94
21.03.2016 um 12:44 Uhr
Hallo Lochkartenstanzer,

danke für Deine schnelle Antwort!

Es ist mir bewusst, dass ich das System nicht auf die gleiche Festplatte installieren kann, von der aus ich es installiere.
Der Server besitzt insgesamt 5 Festplatten. So kam ich erst auf die Idee. Auf einer der 5 Platten befindet sich dann das Setup und es soll das Windows dann auf eine der anderen 4 Platten installieren.
Geht das so nicht?
Habe ich hier noch einen anderen Denkfehler?

Mit freundlichem Gruß
Crischi94
Bitte warten ..
Mitglied: Lochkartenstanzer
LÖSUNG 21.03.2016 um 12:50 Uhr
Zitat von @Crischi94:

Geht das so nicht?

Nicht bei Windows 2008 Server oder Vista. da scheint der Installer eine Macke zu haben, wenn man den von einer internen Festplatte startet. Er findet danbn die Installationesdateien nicht. Du könntest natürlich testweise eine USB-Stick mit den Installationsdateien eingesteckt lassen, wenn Du von der internet Platte bootest. Auf manchen Systemen findet der Installer die Dateien dann.

Deswegen wäre mein Vorschlag, daß Du einfach mit Hilfe von PLOP direkt von USB bootest.

lks
Bitte warten ..
Mitglied: Crischi94
21.03.2016 um 14:50 Uhr
Vielen Dank!
Der BootLoader hat funktioniert. Das Setup hat von USB gestartet!

Jetzt bleibt mir nur das Problem, dass (warum auch immer) Laufwerkstreiber fehlen. Das Problem hatte ich noch nie vorher gehabt.
Und SO alte ist der Server ja nun auch wieder nicht. Ich weiß, dass dieses Modell definitiv schon den Server 2008 gerannt hat.

Aber ich schätze, dass das hier aussichtslos ist. Woher soll raus bekommen, was das für Raid-Controller ist (außer, dass er GLAUBE ICH von DEll ist)? So komme ich auch nicht an die notwendigen Treiber...

Mit freundlichen Grüßen
Crischi94
Bitte warten ..
Mitglied: 114757
114757 (Level 4)
LÖSUNG 21.03.2016, aktualisiert um 15:05 Uhr
Moin.
Zitat von @Crischi94:
Jetzt bleibt mir nur das Problem, dass (warum auch immer) Laufwerkstreiber fehlen. Das Problem hatte ich noch nie vorher gehabt.
Und SO alte ist der Server ja nun auch wieder nicht. Ich weiß, dass dieses Modell definitiv schon den Server 2008 gerannt hat.

Aber ich schätze, dass das hier aussichtslos ist. Woher soll raus bekommen, was das für Raid-Controller ist (außer, dass er GLAUBE ICH von DEll ist)? So komme ich auch nicht an die notwendigen Treiber...

Die Storport-Treiber für den Controller des PowerEdge 2650 erhältst du natürlich auf der Download-Seite für den Poweredge 2650:
http://www.dell.com/support/home/de/de/dedhs1/product-support/product/p ...

Laut Doku hat das Teil einen Embedded dual channel Ultra3 (U160) SCSI Controller.

Die Treiber packst du dir entpackt auf einen USB-Stick oder ein anderes Medium was du im Setup erreichen kannst und bindest sie im Windows-Setup entweder über die GUI ein, oder mit SHIFT-F10 und drvload treiberxyz.inf auf der Konsole des Windows PE.

Gruß jodel32
Bitte warten ..
Mitglied: Crischi94
21.03.2016 um 15:53 Uhr
Danke für deinen Hinweis jodel32!

Aber kann mich jetzt bitte mal jemand für blöd erklären?
Ich glaube ich schmeiße den Server einfach aus dem Fenster und hänge mein Studium an den Nagel.

Ich glaube ich bin einfach zu blind, um den richtigen Treiber in deinem Link zu finden (auf den ich zurzeit nicht mal mehr drauf komme, weil Dell ein Problem zu haben scheint).
Das einzige, was ich nach deinen Beschreibungen passend gefunden habe, ist eine Readme txt, in der ein Link zu finden ist, der mich nach Microsoft führt. Dort steht überall, dass das ein Hotfix für Windows Server 2003 und XP ist. Ich habe mir das einfach runtergeladen. Es ist aber nur eine exe-Datei, die ich auf einem laufenden Rechner installieren könnte, wenn 2003 oder XP drauf laufen würde.
Ich habe diese exe Datei einfach mal ganz frei mit WinRar geöffnet. Und es hat mir auch einige darin enthaltene Dateien angezeigt. Das sind aber _sfx_.dll; weitere _sfx_XXXX._p und _sfx_manifest_ Dateien. Die exe Datei an sich nahm der Server nicht. Auch wenn ich Dateien entpacke, werden diese nich akzeptiert.

Tut mir echt Leid, dass ich mich gerade so blöd anstelle, aber das ist absolutes Neuland für mich. ;)

Freundliche Grüße
Crischi94
Bitte warten ..
Mitglied: 114757
114757 (Level 4)
LÖSUNG 21.03.2016, aktualisiert um 16:18 Uhr
Nee, nimm mal die Adaptec und LSI-Logic Treiber, welchen du davon brauchst kann ich von hier aus nicht sagen ein kurzer Blick in die Kiste sollte aber schon reichen um den Adaptec oder LSI-Controller Chip zu identifizieren, ansonsten nimmst du eine LiveLinux-CD und liest die Hardwareinfos mit lspci aus.

Ansonsten nimm alle, entpacke sie und probiere sie alle im Setup durch.

Die EXEs kannst du meist entweder mit WinRAR entpacken oder ausführen, die extrahieren zu 99% die Treiber in ein Verzeichnis, da kopiert man sich die Files raus. Was du brauchst sind zumindest ein *.sys und ein *.inf File welches die Treiberinfos enthält.
Bitte warten ..
Mitglied: Lochkartenstanzer
21.03.2016, aktualisiert um 16:16 Uhr
Zitat von @Crischi94:

Aber kann mich jetzt bitte mal jemand für blöd erklären?

Wenn Du unbedingt drauf bestehst. :-) face-smile

Ich glaube ich schmeiße den Server einfach aus dem Fenster und hänge mein Studium an den Nagel.

Den Server aus dem Fenster werfen geht ja in Ordnugn aber deswegen gleich das Studium aufgeben? Es haben schon Dümmere Ihr Diplom bekommen, die gerade mal wußten, wie man einen Computer einschaltet.

Tut mir echt Leid, dass ich mich gerade so blöd anstelle, aber das ist absolutes Neuland für mich. ;)

Du brennst Dir am besten eine Knoppix CD oder machst eine Knoppix Stick und bootest davon.

Dann schaus Du mit lspci oder lshw nach, welche Hardware drinsteckt und suchst Dann bei DELL nach den Treibern.

lks
Bitte warten ..
Mitglied: Crischi94
21.03.2016 um 18:01 Uhr
Zitat von @Lochkartenstanzer:

Zitat von @Crischi94:

Aber kann mich jetzt bitte mal jemand für blöd erklären?

Wenn Du unbedingt drauf bestehst. :-) face-smile

Ich glaube ich schmeiße den Server einfach aus dem Fenster und hänge mein Studium an den Nagel.

Den Server aus dem Fenster werfen geht ja in Ordnugn aber deswegen gleich das Studium aufgeben? Es haben schon Dümmere Ihr Diplom bekommen, die gerade mal wußten, wie man einen Computer einschaltet.

Ich meine ja nur, weil ich zufällig an einem Informatk-Studium um mitlerweile 4ten Semester arbeite ;)
Für diese tolle Hilfe stelle ich euch ein Diplom aus (falls ihr nicht sogar schon eins habt)!

Am besten geht ihr beide mal kurz in den Garten, pflückt dort ein paar Blumen und legt die in meinem Namen vor eure Tür.
Wirklich vielen vielen Dank, ich habe es mit eurer extrem schnellen Hilfe endlich geschafft, der Server installiert sich gerade, bzw. ist gerade fertig geworden.
NATÜRLICH war genau der letzte Treiber von Dell der Richtige, wie immer ;)

Freundliche Grüße
Crischi94
Bitte warten ..
Mitglied: Lochkartenstanzer
21.03.2016 um 18:34 Uhr
Zitat von @Crischi94:

Für diese tolle Hilfe stelle ich euch ein Diplom aus (falls ihr nicht sogar schon eins habt)!

Habe schon eines. Ist sogar schon ziemlich alt. Lange vor der Zeit als man studiosi bolognese einführte und man noch ein ordenliches Studentenleben führte und nicht Studierender war.

lks
Bitte warten ..
Heiß diskutierte Inhalte
Sicherheit
Verpackter Laptop entwendet
r0x3llVor 1 TagFrageSicherheit11 Kommentare

Hallo. Mir wurde aus dem Büro ein noch verpackter Dell XPS Laptop mit einem Wert von ca 3.500€ gestohlen. Kann man da was orten? ...

Off Topic
Namenskonzept Kundengeräte
bitnarratorVor 1 TagFrageOff Topic5 Kommentare

Hallo, ich möchte gerne einmal die Diskussion anstoßen, weil ich eine hier in diese Richtung noch nichts gefunden habe. Es geht um die Bennenung ...

Netzwerkgrundlagen
Router für neues Heimnetzwerk - was will man 2021 haben?
billy01Vor 1 TagFrageNetzwerkgrundlagen7 Kommentare

Guten Abend zusammen, nachdem sich bei mir viel getan hat, stehe ich nun vor einem Umzug und dem Neuaufbau meines Heimnetzwerkes. Also weg von ...

LAN, WAN, Wireless
2x Fritzbox 7590 mit separatem DSL über WAN verbinden
gelöst FailixVor 22 StundenFrageLAN, WAN, Wireless19 Kommentare

Liebes Administrator Forum, Ich bin schon länger passiver Lese und habe mich jetzt entschlossen mit einer Frage den ersten Post hier zu schreiben. Über ...

Off Topic
Wie sieht eine korrekte IT-Organisation aus?
imebroVor 5 StundenFrageOff Topic17 Kommentare

Hallo, da unser IT-Verantwortlicher ja vor einem Jahr gehen musste, stelle ich mir die Frage, wie denn eine korrekte IT-Organisation überhaupt aussehen muss. Zur ...

LAN, WAN, Wireless
Cat 7 Patchkabel mit nur 11MBits im Download
gelöst RickHHVor 20 StundenFrageLAN, WAN, Wireless7 Kommentare

Moin zusammen, ich habe mir soeben ein paar Patchkabel (aus einem Cat 7 Kabel) fertig gemacht. Die Belegung ist: 1 weiß/grün 2 grün 3 weiß/orange 4 blau 5 weiß/blau ...

DNS
Network Scanner zeigt falschen Hostname an
gelöst vafk18Vor 22 StundenFrageDNS10 Kommentare

Ich habe in meinem Netzwerk 3 Fritzboxen im Betrieb. Die Fritzboxen haben in den Einstellungen als Namen "fb7270", "fb7369" und "fb7412". Jede Fritzbox hat ...

Windows 10
Windows 10 keine Eingabegeräte mehr erkannt - Anmelden nicht möglich
akira2012Vor 1 TagFrageWindows 107 Kommentare

Hallo Zusammen! Ich habe hier einen Windows 10 Rechner. Er bootet ganz normal aber nach dem hochfahren, werden die Eingabegeräte nicht mehr erkannt. Weder ...