Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

WOL geht nicht mit Broadcast-Adresse

Mitglied: sysad
Hallo,

normalerweise muss man als Ziel-IP für ein WOL-Aufwachpaket die Broadcastadresse angeben (x.x.x.255). Jetzt habe ich genau den Fall, dass es damit nicht geht. Habe einen Draytek 2700 der per DSL angesprochen wird und der einen W2003 Server wecken soll. Bei dieser Konfiguration funktioniert es, wenn ich Portforwarding von Port 9 auf die IP des Servers mache (mit Draytek kann ich das weil ARP-Tabelle gespeichert wird, Speedport z.B. kann das nicht).

Warum geht die x.x.x.10 aber nicht die x.x.x.255? Mache ich einen Denkfehler?

Danke für Tipps.

Content-Key: 101944

Url: https://administrator.de/contentid/101944

Ausgedruckt am: 24.07.2021 um 22:07 Uhr

Mitglied: aqui
aqui 16.11.2008 um 18:13:35 Uhr
Goto Top
Wenn du es wie hier beschrieben:

http://www.heise.de/netze/Wake-on-WAN--/artikel/89304/0

gemacht hast sollte es eigentlich auch mit der .255 funktionieren. Du solltest auf dem Server mal einen Sniffer wie MS-Netmonitor installieren und checken ob das Paket überhaupt kommt...

Im Layer 2 (Mac) muss als Zieladresse entweder die Mac der netzwerkkarte oder dir Ethernet-Broadcast-Adresse ff:ff:ff:ff:ff:ff drinstehen, damit die schlafende Karte darauf reagiert !
Mitglied: sysad
sysad 16.11.2008 um 19:04:46 Uhr
Goto Top
Zitat von @aqui:
Wenn du es wie hier beschrieben:

http://www.heise.de/netze/Wake-on-WAN--/artikel/89304/0

gemacht hast sollte es eigentlich auch mit der .255 funktionieren. Du
solltest auf dem Server mal einen Sniffer wie
[http://www.microsoft.com/downloads/details.aspx?familyid=f4db40af-1e08-4a21-a26b-ec2f4dc4190d&displaylang=en&tm
MS-Netmonitor] installieren und checken ob das Paket überhaupt
kommt...

Da es mit der .10 klappt kommt es wohl an. Im Prinzip ist es so gemacht wie in dem Artikel beschrieben. Da es funktioniert stimmt m.E. die Basiskonfiguration.


Im Layer 2 (Mac) muss als Zieladresse entweder die Mac der
netzwerkkarte oder dir Ethernet-Broadcast-Adresse ff:ff:ff:ff:ff:ff
drinstehen, damit die schlafende Karte darauf reagiert !


Geht leider nicht. Der Draytek ist übrigens ein sehr guter Tipp von Dir gewesen, danke! Ich werde die Kundenspeedports nach und nach durch Draytek ersetzen. Man ist mit SP zwar erst mal schneller, aber das Feintuning ist schlecht.
Mitglied: Crusher79
Crusher79 17.11.2008 um 09:56:21 Uhr
Goto Top
Hi,

Hab auch einen Vigor 2800. Schon ein nettes Teil. Zu deinen 27er: Geht ja um Broadcasting übers Internet wenn ich Dich richtig verstehe oder? Gibs da evtl. einen Broadcastfilter? Also das generell solche Pakete die über WAN kommen verworfen werden?

Meine Netgear, etc. machen dass ja auch. Selbst wenn ich bei meinen alten Netgear über telnet auf Broadcast weitergeleitet habe, kam das Magic Packet nicht an. NG lies nicht mal 255 Eingabe im Webinterface zu. Wurde als Fehler verworfen. Darum auch das Erzwingen via Telnet....

Geht denn WOL im LAN via Broadcast? Wenn ja, denke ich das dieser Pakettyp vom WAN aus geblockt wird.

In allen offiziellen Draytek Tuts wird übrigens mit IP-MAC Binding gearbeitet. Von Broadcast wird nix erwähnt.

http://www.draytek.co.uk/support/kb_vigor_wol.html


EDIT: Hab mal etwas weiter gegooglet. Es gibt ja 2x Arten von Portforwarding - wenn man das Ganze etwas aufgeweicht betrachtet!

Port Redirection und Open Ports
Ich weiss, ist nicht ganz daß selbe. Du hast ja nur von Port WEITERLEITUNG geschrieben. Habe eben gelesen, dass es wohl mit Redirection hinhaut - nicht mit Open Ports!

Probier bitte folgendes - ACHTUNG ich habe eine englische Oberfläche:
1. Port Redirection - Name eintragen
2. Protocol: UDP
3. WAN IP: All/ WAN IP Alias 2 << musst halt schauen, wo deine aktuelle IP drin steht
4. Public Port: 9
5. Private IP: 192.168.0.255 << ka ob die so ist. Hab selber hier ein Class-B Netz.
6. Private Port: 9
7. Active: Haken rein

Open Ports Weiterleitung bitte hierbei mal DEAKTIVIEREN.

So KÖNNTE es auch gehen. Probiers es doch mal.
mfg Crusher
Mitglied: aqui
aqui 17.11.2008 um 11:18:14 Uhr
Goto Top
Stimmt mit Redirection statt Forwarding könnte es klappen !

Zumal die Webseite in der ct Dokumentation auch ganz klar im Redirection Menü ist und nicht im Forwarding Menü. Siehe Seite-2 !

Da die das auch mit einem Draytek getestet haben und es klappte sollte das ja die Lösung sein ??!!

Sonst ggf. nochmal ein Firmwareupdate auf die allerneueste Version machen wenn du es nicht schon gemacht hast !
Mitglied: sysad
sysad 17.11.2008 um 13:51:41 Uhr
Goto Top
Danke.

Bei mir ist die Oberfläche deutsch (Gerät ist von TKR) und der Punkt dort heisst NAT-Portumleitungstabelle, und entspricht dem Bild im Heise-Artikel S.2

Vielleicht fällt uns ja noch was ein. Es geht erst mal, das ist ja auch schon was.
Mitglied: Crusher79
Crusher79 17.11.2008 um 13:55:34 Uhr
Goto Top
Hi,

hab leider auch etwas übersehen. In den Beitrag hat man wohl vorher eine VPN Verbindung aufgemacht. Ka was das mit WOL über WAN zu tuen haben soll. Denn Port Umleitung macht nur dann Sinn.

Aber lest bitte selber - ist ja kein geheime Quelle: WOL Forum

Ist ja mit DIE Seite wenns um WOL geht. Lest mal selber. Dachte hätte alles wesentliche erwischt. Steht auch die genaue Virgor 2700 Firmware mit drin. Damit scheints ja geklappt zu haben.

Model Name: Vigor2700 series
Firmware Version: 2.7.1.1_1311302
Build Date/Time: Jan 3 2007 14:10:20
ADSL Firmware Version: 1311302_B Annex B

Aktuell ist ja die engl. Version 2.8.2 Firmware. Hab auch bei T-Com DSL hier Vigor mit engl. Oberfläche. Sollte ja eh bei Annex B mit gängigen DSL Standards vereinbar sein. Alternativ gibs dort auch noch die Version 2.7.3.3 auf deutsch.

Nur wie.... oO

Kann nur mutmaßen, dass durch die VPN Verbindung die öffentliche IP der entfernten Stelle bekannt und somit evtl. Broadcast von dieser zugelassen wird. Normal hat ja das eine mit dem anderen nix zu tuen. Mir gehen auch die Ideen aus.
Mitglied: aqui
aqui 18.11.2008 um 13:29:37 Uhr
Goto Top
@Crusher79
Nein, der Heise Beitrag benutzt keine VPN Verbindung sondern mach das mit Port Translation aus dem Internet...ganz normal !
Mitglied: sysad
sysad 18.11.2008 um 21:59:27 Uhr
Goto Top
Zitat von @aqui:
Nein, der Heise Beitrag benutzt keine VPN Verbindung sondern mach
das mit Port Translation aus dem Internet...ganz normal !


So hatte ich das auch gemeint.
Mitglied: Crusher79
Crusher79 18.11.2008 um 22:29:05 Uhr
Goto Top
Hi,

öhm Leute ich doch auch... hmm, nein hab mich nur auf den Thread in den WOL Forum bezogen.

NICHT Heise.de SONDERN auf http://stephan.mestrona.net stand das so!

http://stephan.mestrona.net/wol/forum/viewtopic.php?t=572&highlight ...

Der Kerl dort schrieb ja:
Die derzeitige Einstellung am Router ist:
NAT -> 'Port Redirection' nach xxx.xxx.xxx.255
(NAT -> Open Ports -> UDP, Kanal und IP-Addresse eintragen ist disabeled - nicht 'enabeld' wie in meinem ersten Posting)

Zuerst öffne ich aber eine VPN-Verbindung zum Router -> so kann ich > leben


Deshalb hab ich das erwähnt. Klar sollte es auch ohne vorherige VPN Verbindung gehen. Aber wenn ich den Thread richtig gelesen habe, hat er es mit Port Redirection und Broadcast hin bekommen. Nur schreibt er ja nach vorheriger VPN Anbindung. Wie gesagt, halt ich auch für widersinnig.

@sysad: Hast du die Firmware mal aktualisiert?
Mitglied: aqui
aqui 18.11.2008 um 22:36:23 Uhr
Goto Top
Mit einem VPN ist das Unsinn, denn dann bin ich ja direkt im gleichen IP Netz wie die aufzuweckenden Geräte ohne die NAT Firewall dazwischen die ja das Problem macht.
Da benötigt man keinerlei Port Redirection oder Forwarding und der WOL Client funktioniert so ! Logisch ohne NAT !
Der Standppunkt wäre dann also technischer Unsinn in dem Mestrona Forum !
Mitglied: sysad
sysad 18.11.2008 um 23:23:48 Uhr
Goto Top
Zitat von @Crusher79:


@sysad: Hast du die Firmware mal aktualisiert?

Ich habe die m.W. neueste deutsche Version

Modellname : Vigor2700 series
Firmwareversion : 2.7.3.3_1311302
Erstellungsdatum : Nov 16 2007 09:40:07

Gibt's da was besseres?
Mitglied: Crusher79
Crusher79 19.11.2008 um 12:18:26 Uhr
Goto Top
Hab ich ja oben schon erwähnt. Gibt eine englische 2.8.2. Keine Ahnung ob die nun wirklich besser ist!

Mein 2800 funktioniert auch mit engl. Firmware + T-Com DSL ohne Probleme.
Heiß diskutierte Beiträge
question
RAM-Zugriff auf einem neuen High-Performance Server, teilweise um Welten langsamer als auf einer WorkstationMysticFoxDEVor 1 TagFrageBenchmarks45 Kommentare

Moin Zusammen, mir ist gestern beim Optimieren eines neuen Servers eine Sonderheit aufgefallen, die ich mir so beim besten Willen, momentan absolut nicht erklären kann. ...

general
Kosten nicht gerechtfertigt? Dienstleister stellt Kosten für "Troubleshooting" bei Neuanschaffung von HCI + CoreSwitchDirty2186Vor 1 TagAllgemeinZusammenarbeit17 Kommentare

Hallo Zusammen, ich interessiere mich für Eure Meinung zu dem Thema Leistungsnachweise von Systemhäusern und Dienstleistern und deren Berechnung von Leistungen. Da sich hier ja ...

question
Listet Microsoft Default ACLs von Windows?DerWoWussteVor 1 TagFrageSicherheit18 Kommentare

Moin Kollegen. Nach dem Sicherheits-GAU "Hivenightmare" stellt sich mir die Frage, wie ich in Zukunft sicherstellen kann, dass die ACLs der Systemdateien in Windows korrekt ...

question
Erfahrungen mit CodeTwo Exchange Migration von 2016-2019dlohnierVor 1 TagFrageExchange Server18 Kommentare

Hallo, ich möchte unseren Exchange Server 2016 der noch auf WIndows 2016 läuft auf einen Server 2019 mit Exchange 2019 migrieren. Habe das Tool "CodeTwo ...

question
Doppelte A-Records in DNSBPeterVor 1 TagFrageWindows Server10 Kommentare

Hallo, unsere Windows Notebooks registrieren sich im DNS mit ihrer Lan- und Wlan Adresse. D.h. es gibt 2 gleiche Namen mit 2 unterschiedlichen IP-Adressen. Wie ...

question
2U Home-Server Frage zur HardwaremossoxVor 21 StundenFrageServer-Hardware10 Kommentare

Hallo zusammen, ich habe in den letzten Jahren auf die Systeme von Synology gesetzt. Im Wesentlichen ging es immer nur um simple CIFS Dienste, nichts ...

question
Powershell Ordner löschen die älter als x Tage sindsascha46Vor 19 StundenFrageEntwicklung6 Kommentare

Hallo Ich würde gerne in einem Verzeichnis alle Ordner die älter als X Tage sind löschen. Aber irgendwie bekomme ich das nicht hin. Bisher habe ...

question
Antivirus auf Synology sinnvoll?CoreknabeVor 1 TagFrageSAN, NAS, DAS3 Kommentare

Moin, nachdem Antivirus Essentials auf unserem Synology-NAS wieder einmal lustige Kapriolen fabriziert (Installationsdatei für MS Office ist hochgefährlich), stelle ich mir die Frage, ob es ...