nixverstehen
Goto Top

Windows Backup - FilterManager Event 3

Hallo zusammen,

ich bin kein gelernter ITler und auch beruflich nicht in dem Feld tätig. Wir setzen in unserem Unternehmen einen Windows Server 2016 Essentials ein.
Wie in vielen KMUs ist die Kiste die übliche One-Man-Show als DC, DNS, DHCP, WSUS und Fileserver. Ich weiß, das ist suboptimal und wird bis Ende des Jahres auch geändert.

Als Backup laufen zwei externe USB-Platten (NAS-HDDs in Leergehäusen), auf die 2x täglich im Wechsel ein Backup erstellt wird.

In der Ereignisanzeige ist mir folgender Fehler aufgefallen, der immer mit ein paar Sekunden Versatz nach dem Start des Backup erscheint:

Event ID 3, Quelle: FilterManager
Der Filter-Manager konnte keine Verbindung mit dem Volume „\Device\HarddiskVolume87“ herstellen. Dieses Volume ist erst nach einem Neustart für die Filterung verfügbar. Der letzte Status war „0xC03A001C“.

Die Bezeichnung der Volumes variierte und auch die Anzahl der Fehler mit unterschiedlichen Volumes variierte je Backup. Nach einigem Suchen habe ich brauchbare Lösungen gefunden, die für sich alleine genommen aber nur teilweise wirkungsvoll waren. Das Problem sind wohl, wenn ich es richtig verstanden habe, nicht mehr vorhandene Volumes bzw. Schattenkopien, die man auch im
Gerätemanager ausgegraut sieht, wenn man sich ausgeblendete Geräte anzeigen läßt.

Der erste Ansatz kommt wie immer von MS: "You can savely ignore this error". Liebe Entwickler, warum schreibt ihr es denn dann in den Eventviewer?

Der zweite Ansatz brachte Besserung, aber es waren je Backup-Job immer noch genau zwei dieser Fehler in der Anzeige:

Filter Manager Event ID 3 Stop wsearch

Ich habe hier wie empfohlen, im Aufgabenplaner vor dem Backupjob zuerst "wsearch" beendet und nach dem Backup wieder gestartet.

Beim dritten Ansatz bin ich auf ein offensichtlich etwas älteres Tool namens "devnodeclean" gestoßen.

https://www.microsoft.com/en-us/download/details.aspx?id=42286

Das hat in Kombination zusammen mit Ansatz Nr. 2 das Problem gelöst und die Fehlermeldungen sind verschwunden. Ich lasse 15 Minuten vor jedem Backup über die
Aufgabenplanung mit dem Tool und Schalter /r diese Phantom-Volumes entfernen, stoppe zu Beginn des Backup-Jobs "wsearch" und starte "wsearch" nach dem Backup-Job wieder.
Mit "devnodeclean.exe /l" kann man sich auch die inaktiven Volumes nur anzeigen lassen. Das Tool braucht erhöhte Rechte.

Die Profis haben vermutlich andere und bessere Lösungen, aber mir hat's geholfen. Falls ich mir damit unwissentlich selbst einen Fallstrick für die Zukunft gedreht habe,
möge man mich bitte eines Besseren belehren.

Gruß NV

Content-Key: 430345

Url: https://administrator.de/contentid/430345

Printed on: April 18, 2024 at 00:04 o'clock