bibi52
Goto Top

DC1 2008R2 bootet ewig wenn DC2 nicht verfügbar

Hallo Leute,

habe folgendes Problem. Ich setze auf einem Hyper-V System einen frischen Server 2008R2 als Gast auf. Den mache ich zum ersten DC.
Auf dem Host läuft sonst nichts außer der Hyper-V Rolle
Soweit läuft alles super.

2. Schritt
Ich erstelle auf dem gleichen Host noch einen DC mit Server 2008R2.
Die VM kommt später auf einen anderen Host drauf!!
Der 2. DC ist in der gleichen Domäne, ist auch ein GC und macht auch DNS.
DNS ist AD integriert.

Problem ist jetzt, fahre ich beide Server runter und starte nur einen DC (egal welchen)
dann fährt der schon mal gut 10min lang hoch. Aber dann ist weder das AD aktiv
noch das DNS.

Wenn man dann noch einmal gut 10min wartet funktioniert auf einmal DNS und auch
das AD wieder ganz normal. Startet man den zweiten DC läuft dieser auch ganz normal
hoch und funktioniert sofort.

Woran kann das liegen? Sollte nicht ein DC auch nach einem Start sofort funktionieren?
Warum braucht der gut 20min bis wirklich alles einwandfrei funktioniert?

Hat hier jemand eine Erklärung?

Die IP Adressen sind auf beiden Servern über IPv4 fest eingetragen. Könnte es daran
liegen dass man noch die IPv6 Adressen konfigurieren muss?

Bin für jede Hilfe dankbar

Gruß
Christian

Content-Key: 183888

Url: https://administrator.de/contentid/183888

Printed on: July 24, 2024 at 21:07 o'clock

Member: Dani
Dani Apr 21, 2012 at 12:24:22 (UTC)
Goto Top
Moin,
kannst du hier nachlesen.
Du brauchst einen phy. DC. Ohne gehts nicht bzw. nur wenn du eine weitere und unabhängige Hyper-V Plattform hast.


Grüße,
Dani
Member: DerWoWusste
DerWoWusste Apr 21, 2012 at 12:33:13 (UTC)
Goto Top
Moin Dani.
Aus was von Deinem Verlinkten geht hervor
A) das es "ohne nicht geht"
B) seine Probleme von der Virtualisierung herrühren?
Das bezweifle ich mal ganz stark.

@bibi52: Gib mal an, wie Du die auf den DCs die DNS-Einträge gesetzt hast, sprich Ausgabe von ipconfig /all mit Erläuterung wer die IP-Adressen jeweils sind.
Member: bibi52
bibi52 Apr 21, 2012 at 12:35:22 (UTC)
Goto Top
Hallo Dani,
das ist mir durchaus bewust und habe ich ja auch oben beschrieben
nur hilft mir halt Deine Aussage überhaupt nicht.

Ich hatte bisher immer nur mit Netzwerken mit 1 DC zu tun.
Jetzt ist mir halt aufgefallen, siehe oben, dass ein einzelner DC
eeeewig lange bootet und betriebsbereit ist wenn der 2. DC z.B. ausgefallen ist.
Der 2. könnte ja in Deinem Beispiel der sein, der auf dem physikalischen Server läuft.

Egal ob ich den physiklaischen oder den virtuellen DC boote. Die brauchen gut 20min
bis alles läuft auf aktueller Hardware.

Vielleicht ist dieses Verhalten ja beim S2008R2 auch normal. Drum Frage ich ja hier auch.
Member: Dani
Dani Apr 21, 2012 at 12:40:50 (UTC)
Goto Top
Ich kenne das Problem seitens VMWare... fahre ich beide DCs herunter dauert der Start von ersten DC ebenfalls sehr lange. Darum haben wir physikalische DCs integriert.
Hyper-V ist allerdings nicht mein Steckenpferd. Ich dachte eben, dass das Problem abfärbt.


Grüße,
Dani
Member: bibi52
bibi52 Apr 21, 2012 at 12:48:18 (UTC)
Goto Top
Hallo DerWoWusste,

Ich habe die folgende Einträge:

IP Adressen:
DC1 = 192.168.10.100
DC2 = 192.168.10.101

DNS Einträge DC1
1.DNS = 192.168.10.101
2.DNS = 192.168.10.100

DNS Einträge DC2
1.DNS = 192.168.10.100
2.DNS = 192.168.10.101

Vielen Dank
Member: bibi52
bibi52 Apr 21, 2012 at 14:29:00 (UTC)
Goto Top
Hallo,

jetzt haben wir unser Szenario mal umgestellt und DC1 auf einer
physikalischen Maschine installiert und DC2 weiterhin als Hyper-V Gast
laufen lassen. Das Problem ist aber immer das gleiche. Egal welchen DC
man einzeln startet, es dauert weiterhin bis zu 10min bis der Anmeldeschirm kommt.

Einen Unterschied konnten wir allerdings feststellen.

Der phys. DC hat sofort nach dem Logon den DNS bereit unf funktioniert
während der DC in der VM das DNS noch nicht bereit hat. Das dauert dort auch
wieder einige Minuten oder man startet den DNS-Server einmal neu durch.
Dann ist auch hier das DNS betriebsbereit.

Somit vermute ich mal, dass das lange booten ein normaler Vorgang ist.
Member: DerWoWusste
DerWoWusste Apr 21, 2012 at 15:03:54 (UTC)
Goto Top
Ich schätze auch, dass es normal ist, wenn ich auch 10 min noch nie erlebt habe, eher 2 min.
Überleg Dir, dass ein DC immer schon beim Start versucht, seinen AD-Replikationspartner zu finden, ebenso der DNS-Dienst. Du kannst dies vermutlich auch anhand der Ereignisprotokolle nachvollziehen.
Member: rmarkus
rmarkus Apr 21, 2012 at 16:04:23 (UTC)
Goto Top
Zitat von @bibi52:
Hallo DerWoWusste,

Ich habe die folgende Einträge:

IP Adressen:
DC1 = 192.168.10.100
DC2 = 192.168.10.101

DNS Einträge DC1
1.DNS = 192.168.10.101
2.DNS = 192.168.10.100

DNS Einträge DC2
1.DNS = 192.168.10.100
2.DNS = 192.168.10.101

Vielen Dank

Hi,

ich würde den ersten DC so konfigurieren das er
mit dem DNS zunächst auf sich selbst zeigt, sprich:

DC 1
IP: 192.168.10.100
DNS1: 192.168.10.100
DNS2: 192.168.10.101

DC"
IP: 192.168.10.101
DNS1: 192.168.10.100
DNS2: 192.168.10.101

Wie soll auch sonst der erste DC den DNS vom anderen DC finden
wenn dieser noch garnicht gestartet ist bzw. hochgefahren.

Gruß

EDIT: Finde diesen Artikel sehr gut. Ich gehe davon aus das bei dir der letzte Punkt das Problem sein wird.
http://blog.dikmenoglu.de/Welcher+DNSServer+Sollte+Eingetragen+Werden.a ...