pasu69
Goto Top

Dentalsoftware - Leistungsabfall nach Migration auf 2012R2

Hallo zusammen,

ich habe hier ein Problem, an dem ich mir gerade die Zähne ausbeisse.

Der Kunde hat ein Zahnarztpraxis mit 1 Server und 6 Arbeitsplätzen.
Im Zuge der XP Migration auf Windows 7 wurde alle Hardware getauscht.
Als Server fungiert ein HP ML310e Gen8v2 mit Xeon, 16GB und einem RAID 1+0 aus
4 HP SATA 500GB HDDs mit 7200RPM, die am Smart Array P420i/1GB hängen.
Auf dem Blech läuft ESXI 5.5 (HP Image), der Server 2012r2 ist die einzige VM und
nutzt alle Kerne und den Speicher.
Soweit, so gut: Alles läuft schnell und so wie es sollte - außer der Dentalsoftware
"EVIDENT". Die basiert auf Firebird 2.01 (Update gibt es keines, es muss diese
Version sein. Der Aufruf von Patientendaten ging vorher (Server 2003/Clients XP)
sehr schnell (<1sek), jetzt dauert es, trotz neuer Hardware, mehr als 5 sek, bis
der Datensatz angezeigt wird.
Ich habe zu Testzwecken mal einen 2008R2 installiert (auf dem Host), mit dem
ist die Performance wieder so, wie sie sein sollte. Also muss irgendwas im 2012R2
die Software ausbremsen. Hat einer von euch eine Idee?

Danke!

Content-Key: 254048

Url: https://administrator.de/contentid/254048

Printed on: May 21, 2024 at 23:05 o'clock

Member: falscher-sperrstatus
falscher-sperrstatus Nov 06, 2014 at 11:57:10 (UTC)
Goto Top
Hallo,

was sagt denn der Hersteller?
Member: pasu69
pasu69 Nov 06, 2014 at 12:11:45 (UTC)
Goto Top
Zitat von @falscher-sperrstatus:

Hallo,

was sagt denn der Hersteller?

Nichts, was ich nicht schon vorher getestet habe. Die suchen den Fehler im Netzwerk, doch da ist er definitiv nicht.
Anderer Input war da leider nicht zu kriegen. Das Problem scheint auch kein Einzelfall zu sein, laut Aussage des
Arztes klagen einige Kollegen auch nach der Migration auf 2012R2 über miese Performance.

An Firebird liegt es auch nicht, eine andere Anwendung (dbswin) läuft auf dem Server und ist richtig schnell. Der
Unterschied zu EVIDENT ist allerdings, dass dbswin einen lokalen Client auf den Workstations installiert, während
die EVIDENT.exe direkt vom Server gestartet wird.
Member: falscher-sperrstatus
falscher-sperrstatus Nov 06, 2014 at 12:38:45 (UTC)
Goto Top
Ich weiss, ich kenne das "schöne" Programm.

An irgendwas muss es hapern. Hier ins "blaue" zu raten ist natürlich nicht zielführend, daher der Hinweis auf den Hersteller.
Member: Lochkartenstanzer
Lochkartenstanzer Nov 06, 2014 updated at 13:15:11 (UTC)
Goto Top
Zitat von @pasu69:

ich habe hier ein Problem, an dem ich mir gerade die Zähne ausbeisse.

Der Kunde hat ein Zahnarztpraxis ...

Da bist Du ja direkt an der quelle um da Abhilfe zu schaffen. face-smile


Ich habe zu Testzwecken mal einen 2008R2 installiert (auf dem Host), mit dem
ist die Performance wieder so, wie sie sein sollte.

Da würde ich einfach bis das Problem gelöst ist, auf 2008R2 downupgraden. Die Arbeitszeit mit Warten auf die Software dürfte wertvolelr sein, als das nach Lösung des Problem wieder in Angriff zu nehmen.

lks


PS: Hast Du 2012R2 auch mal direkt auf dem Blech probiert oder nur ind er VM?
Member: pasu69
pasu69 Nov 06, 2014 at 13:20:19 (UTC)
Goto Top
Ich habe den 2012R2 auch direkt auf dem Blech gehabt, das brachte aber keine wirkliche Verbesserung. Ich habe auch einen anderen Server getestet (DELL).
Das Problem versteckt sich irgendwo im 2012R2.
Member: Chonta
Chonta Nov 06, 2014 at 13:52:17 (UTC)
Goto Top
Hallo,

mitr ist so als hätte ich mal gelesen, das der 2012 bei einigen 32Bitanwendungen einen Leistungsabfall hat.
Finde ich abe rnicht mehr.
Zum ausführen der Software schonmal den kompatiblitätsmodus versucht?
Klingt blöd aber in seltenen Fällen hilft das sogar.

Gruß

Chonta
Member: Lochkartenstanzer
Lochkartenstanzer Nov 06, 2014 updated at 13:59:31 (UTC)
Goto Top
Zitat von @pasu69:

Das Problem versteckt sich irgendwo im 2012R2.

Deswegen würde ich da nciht zuviel Aufwand reinstecken. Das ist Aufgabe der Hersteller (MS und evident) das auszuklabüsern.

Ich würde einfach 2008R2 nehmen bis die das ausgekaspert haben.


lks

PS: Hast Du auch mal 2012 (ohne R2) probiert?
Member: keine-ahnung
keine-ahnung Nov 06, 2014 at 14:15:00 (UTC)
Goto Top
Hmmh,

ich mach das immer so: ich schaue beim Hersteller nach den Systemvoraussetzungen meiner Praxissoftware, bevor ich das Teil irgendwo aufbügele. Dann installiere ich ... Würdest Du das ebenfalls so handhaben, würdest Du bemerkt haben, das der Hersteller von W2012R2 nix, aber auch gar nix erzählt! Da das ja aber nur ein "Kunde" ist, kann man da auch mal spielen, wenn es Kohle bringt, Zeit=Geld, gelle?

BTW: Mir verschliesst sich irgendwie auch der Sinn, einen Host zu nutzen, auf welchem nur eine Gastmaschine läuft ...

LG, Thomas
Member: Lochkartenstanzer
Lochkartenstanzer Nov 06, 2014 at 14:22:10 (UTC)
Goto Top
Zitat von @keine-ahnung:

BTW: Mir verschliesst sich irgendwie auch der Sinn, einen Host zu nutzen, auf welchem nur eine Gastmaschine läuft ...

Der Vorteikl liegt oft darin, daß man die virtuelle Maschine oft einfacher auf einen neuen Host transplantieren kann als eine OS-Installation von einer Sorte Metall auf eine andere Sorte Metall. Da ergeben sich deutlich weniger Treiberprobleme.

Und man kann bei Bedarf einfach ein zweite maschine dazuklatschen oder für testwecke mit einer Kopie der VM arbeiten.

Es kann also gute Gründe dafür geben, aber man soltle sich halt üebr die Implikationen klar sein.

lks
Member: bastian42
bastian42 Nov 06, 2014 at 14:52:39 (UTC)
Goto Top
Hallo,

welche Virenlösung wird eingesetzt? Ich kenne das selbige Problem in Verbindung mit Symantec Produkten.

Gruß
Bastian
Member: keine-ahnung
keine-ahnung Nov 06, 2014 at 15:21:10 (UTC)
Goto Top
Moin nochmal,
Ich kenne das selbige Problem in Verbindung mit Symantec Produkten.
ich kenne das selbige Problem in Verbindung mit medatixx-Produkten face-wink. Sind auch noch nicht für R2 freigegeben, also lässt man besser die Patschehändchen davon. Ich hätte jetzt echt keinen Bock, jedesmal auf den refresh des Krankenblattes warten zu müssen ...

LG, Thomas
Member: pasu69
pasu69 Nov 06, 2014 at 18:56:32 (UTC)
Goto Top
Ich hatte mit EVIDENT vorher gesprochen und mir wurde telefonisch versichert, dass der 2012R2 freigegeben ist. Davon abgesehen ist der Kunde nicht nur ein Kunde, sondern auch ein Freund - Geld verdiene ich daran nicht wirklich. Und ich muss jetzt nicht wirklich auf die Vorteile der Virtualisierung eingehen, oder?
Member: pasu69
pasu69 Nov 06, 2014 at 18:57:58 (UTC)
Goto Top
Kompabilitätsmodus geht nicht, da die .exe direkt vom Server gestartet wird.
Member: pasu69
pasu69 Nov 06, 2014 at 18:59:27 (UTC)
Goto Top
Zitat von @bastian42:

Hallo,

welche Virenlösung wird eingesetzt? Ich kenne das selbige Problem in Verbindung mit Symantec Produkten.

Gruß
Bastian

Hallo Bastian,

es wird ein AVG Business eingesetzt. Der wurde allerdings erst später installiert, da waren die Probleme schon da.
Member: keine-ahnung
keine-ahnung Nov 06, 2014 updated at 20:02:42 (UTC)
Goto Top
Ich hatte mit EVIDENT vorher gesprochen und mir wurde telefonisch versichert, dass der 2012R2 freigegeben ist.
Mmmh, die publizierten Anforderungen stammen vom Oktober 2014 ...
Und ich muss jetzt nicht wirklich auf die Vorteile der Virtualisierung eingehen, oder?
Nee, musst Du nicht. Sonst würde ich auf die Nachteile eingehen müssen face-wink.

LG, Thomas

p.s.: Wenn Du selber mit einem 2008R2 quergetestet hast, dann scheint das Dentistengedöhns halt auf einem 2012R2 doch nicht richtig zu laufen ...
Member: pasu69
pasu69 Nov 06, 2014 at 21:15:49 (UTC)
Goto Top
p.s.: Wenn Du selber mit einem 2008R2 quergetestet hast, dann scheint das Dentistengedöhns halt auf einem 2012R2 doch nicht
richtig zu laufen ...

Ich habe es vollständigerweise auch auf einem 2012 ohne R2 getestet, mit denselben Ergebnissen wie auf dem R2.
Ich denke, wir gehen auf den 2008R2 und warten darauf, dass EVIDENT den Fehler findet.