niklasschaefer
Goto Top

Routing Problem mit TP-Link T1700G-28TQ

Hallo Admin-Kollegen,
ich habe aktuell mal wieder keine Ahnung was ich falsch mache.

Meine VM`s/ Server hängen aktuell in dem Netzwerk 192.168.2.0/24 mit den ganzen Rechnern/Clients/Drucker/Heim-Automation etc.
Da mir diese Struktur nicht gefällt habe ich mir gedacht ich lege auf meinem TP-Link Switch T1700G-28TQ ein neues 6 VLAN mit der ID 5 für meine Server soweit sogut.
Router ist ein Speedport W724V mit 192.168.2.0/24 aktiviertem DHCP/DNS

VLAN 5 angelegt und die Interfaces vom Server tagged hinzugefügt. Passt.

Nun habe ich gedacht lege ich eine Route in dem Switch an. Sollte ja laut Datasheet funktionieren das er routet. -> Macht er aber nicht.
routing

Ziel ist es von 192.168.2.0/24 -> 10.20.20.0/24 kommen und von 10.20.20.0/24 -> 192.168.2.0/24 zu kommen.
Dem Switch habe ich im VLAN5 eine IP-gegeben und ein Server hängt auch schon testweise im VLAN5 diese zwei können einwandfrei kommunizieren.

Was habe ich hier falsch gemacht?

Ich bedanke mich für eure Hilfe und wünsche euch ein schönes WE.

Gruß Niklas

Content-Key: 373667

Url: https://administrator.de/contentid/373667

Printed on: July 20, 2024 at 06:07 o'clock

Member: tikayevent
tikayevent May 11, 2018 at 17:17:51 (UTC)
Goto Top
Du darfst keine statische Route anlegen, da der Switch ja bereits weiß, welche Interfaces er hat. Du musst dem VLAN die IP-Adresse zuweisen und noch viel wichtiger, aber auch unmöglich: Du musst im Speedport eine statische Route eintragen, damit der weiß, wie er das neue IP-Netz erreichen kann.
Member: em-pie
em-pie May 11, 2018 at 18:31:15 (UTC)
Goto Top
Moin,

Was genau geht denn nicht?
Kannst du aus dem „alten“ Netz nicht auf einen (Windows-) Server im VLAN5 zugreifen? Falls dem so ist, prüfe auch die Firewall auf der Windows-Kiste, also ob die das neue/ alte UP-Netz auch zulässt


Gruß
es-pie
Member: aqui
aqui May 11, 2018 updated at 20:46:46 (UTC)
Goto Top
ein neues 6 VLAN mit der ID 5 für meine Server
Was soll das genau sein ?? Ein se(x)chs Vlan ?? face-smile
VLAN 5 angelegt und die Interfaces vom Server tagged hinzugefügt. Passt.
Wieso tagged man ein Server Interface ? Das ist doch Unsinn es sei denn der Server ist ein Hypervisor und hat einen internen vSwitch, der mehrere VLANs an die Außenwelt, sprich externen Switch, weitergibt.
Ohne VLANs und vSwitch tagged man doch nie einen Endgeräte Port für einen Server ?! Was sollte der Sinn von sowas sein ?
Router ist ein Speedport W724V mit 192.168.2.0/24 aktiviertem DHCP/DNS
Schrottrouter der kein statische Routimng supportet. Man ahnt schon was jetzt kommt... face-sad
Außerdem ist die .0 eine Angabe des netzwerkes aber NICHT der Router IP.
Nun habe ich gedacht lege ich eine Route in dem Switch an.
Wäre völliger Quatsch.
Das Einzige was der Switch braucht (er ist ja ein Layer 3 Switch) der zwischen den VLANs routet sind 2 einfache Dinge:
  • Eine IP Adresse auf dem Switch in jedem VLAN
  • Eine Default Route auf dem Switch auf den Speedport 192.168.2.1 (Jetzt mal geraten das der die Host Adresse .1 hat ?!)
Der Switch kann selber zwischen den beiden VLAN Netzen routen, denn er "kennt" ja diese beiden Netze. Logisch, denn sie sind ja direkt an ihm angeschlossen !
Alles was er nicht kennt routet er an die Speedport Gurke mit der Default Route.
Der Switch selber MUSS pro VLAN deshalb eine IP Adresse haben z.B.
VLAN 1 (Default) = 192.168.2.254 /24
VLAN 5 = 10.20.20.254 /24
Diese IP Adressen des Switches sind die Default Gateway IP Adressen der jeweiligen Endgeräte in den VLANs !
Hier siehst du auch schon deinen 2ten Kardinalsfehler, denn in VLAN 1 vergibt der SP die IPs und setzt sich selber als Gateway. Dazu MUSS er dann aber eine statische Route ins 10er Netz haben !!
Wie sollte er sonst wissen WO er Pakete hinschicken soll in das Netz. Ohne diese spezifische Route nutzt er seine Default Route zum Privider und sendet sie damit ins Nirwana.
(Privater RFC IP Netzwerk Traffic wird auf Providerseite sofort kommentarlos gelöscht)
Damit ist ein Routing schon mal grundsätzlich möglich zwischen den VLANs wenn man als Gateway IMMER die beiden Switch IP Adressen in den VLANs nutzt
Ein Ping Test oder Traceroute (tracert) zeigt dir das sofort.
Generell sollte man das Internet aber immer mit einem separaten VLAN von den beiden Produktivnetzen abtrennen wenn man schon den Luxus eines Layer 3 Switches hat wie du !

Du hast aber mit dem Speedport ein grundsätzliches Problem. Da der Speedport ein billiger Provider Schrottrouter ist supportet der als einer der wenigen Router keine statischen Routen.
Das ist aber zwingend, denn für die Rückroute ins VLAN 5 MUSST du einen statische Route auf dem Speedport eintragen:
Zielnetz: 10.20.20.0, Maske: 255.255.255.0, Gateway: 192.168.2.254
Nur so kann der Router den Rückweg ins VLAN 5 realisieren.
Ohne diese Route würden alle IP Pakete ins VLAN 5 fälschlicherweise zum Provider und damit ins Nirwana geroutet.
Fazit:
Generell wird deine Konfig durch den minder intelligenten Speedport so oder so scheitern.

Das gesamte Konstrukt wird übrigens in dem hiesigen Routing Tutorial en Detail beschrieben:
Routing von 2 und mehr IP Netzen mit Windows, Linux und Router
Das sollte eigentlich alle deine Fragen zu dem Thema beantworten.
Weitere Infos hat auch dieser Thread hier:
Verständnissproblem Routing mit SG300-28
Also einfach mal lesen und...verstehen !