mecie21313
Goto Top

Samba und WIn 7 - Deaktivieren von Roaming-Profilen

Sehr geehrte Community,

heute komme ich mal mit einem Problem, welches bei einem unserer Kunden auftaucht. Es betrifft dabei die Samba-Funktion: "Disabling Roaming Profile Support"

Dabei geht es darum einen Samba (3) Server mit open LDAP backend als Windows (7) Domaincontroller einzusetzten.

Als Basis diente folgende Anleitung:

http://www.howtoforge.com/centos-5.x-samba-domain-controller-with-ldap- ...


Die Anbindung von LDAP und Samba ist kein Problem.
Die Anbindung und Anmeldung an unsere Domäne klappt einwandfrei.

Ich kann einfach Nutzer einrichten, und Zugriff auf Filer, Unix und Windows (7) geht im
Netz mit dem Nutzernamen und Passwort.

Das LDAP backend verwaltet das problemslos...


Nun zum Problem:

Wir möchten allerdings explizit KEINE Roaming Profiles einsetzten, leider läst sich das nicht abschalten.
Wir haben schon verschiedene Varianten probiert, leider bisher nicht mit dem gewünschten Effekt, d.h. Windows7 greift weiterhin auf das Netzwerk zu und versucht dort profile abzulegen.

Besonderheit ist, dass der Samba server nur als Domaincontroller eingesetzten wird, der Filer ist ein open-e filer.


Vielleicht hat hier jemand einen Tipp?


Gruss
Mecie

Content-Key: 141565

Url: https://administrator.de/contentid/141565

Printed on: April 18, 2024 at 04:04 o'clock

Member: FISI-Azubi2010
FISI-Azubi2010 Apr 27, 2010 at 09:57:05 (UTC)
Goto Top
Hi Mecie,

hab da nen Beitrag in einem Forum gefunden vieleicht hilft dir der weiter.

http://www.linuxforen.de/forums/showthread.php?t=171166&highlight=l ...

Gruß FISI-AZUBI
Member: mecie21313
mecie21313 Apr 27, 2010 at 11:22:31 (UTC)
Goto Top
Hmm....

Das Hauptproblem bei diesem DeleteRoamingCache scheint zu sein, das die verschiedenen Hacks wohl unter Win7 nicht funktionieren.

Hat jemand andere Erfahrungen oder auch einen weiteren Hilfreichen Tipp??

Gruss
Mecie
Member: FISI-Azubi2010
FISI-Azubi2010 Apr 29, 2010 at 11:19:20 (UTC)
Goto Top
wie sieht denn deine Smb.conf aus? Der Link den du da gepostet hast bezieht sich ja eher auf das einrichten des LDAP-Backends.
Die Funktionen für die Roamingprofile sind aber Sambaeinstellungen. Vieleicht hast du ja noch irgenteine Funktion drin die der oben genannten Einstellung widerspricht.


Gruß FISI-AZUBI2010
Member: mecie21313
mecie21313 Apr 29, 2010 at 12:00:22 (UTC)
Goto Top
Hier die smb.conf (die rotmakierten smind schon die Stellen, die wir auch zusätzlich durch verschiedene Foren gefunden haben. Aber diese funktionieren auch nicht unter WinXP):

[root@dctsrv15 public]# testparm
Load smb config files from /etc/samba/smb.conf
Processing section "[homes]"
Processing section "[netlogon]"
Loaded services file OK.
Server role: ROLE_DOMAIN_PDC
Press enter to see a dump of your service definitions

[global]
dos charset = 850
unix charset = ISO8859-1
workgroup = DREAMCHIP
netbios name = DCTLDAP
server string = Samba Server Version %v
passdb backend = ldapsam:ldap://127.0.0.1/
passwd program = /usr/sbin/smbldap-passwd -u "%u"
passwd chat = "Changing *\nNew password*" %n\n "*Retype new password*" %n\n"
unix password sync = Yes
log level = 3
syslog = 3
log file = /var/log/samba/log.%U
max log size = 100000
time server = Yes
socket options = TCP_NODELAY SO_RCVBUF=8192 SO_SNDBUF=8192 SO_KEEPALIVE
delete user script = /usr/sbin/smbldap-userdel "%u"
add group script = /usr/sbin/smbldap-groupadd -p "%g"
add user to group script = /usr/sbin/smbldap-groupmod -m "%u" "%g"
delete user from group script = /usr/sbin/smbldap-groupmod -x "%u" "%g"
set primary group script = /usr/sbin/smbldap-usermod -g '%g' '%u'
add machine script = /usr/sbin/smbldap-useradd -t 0 -w "%u"
logon path =
logon home =

domain logons = Yes
os level = 65
preferred master = Yes
domain master = Yes
wins support = Yes
ldap admin dn = cn=manager,dc=dreamchip,dc=de
ldap group suffix = ou=Groups
ldap idmap suffix = ou=Idmap
ldap machine suffix = ou=Computers
ldap suffix = dc=dreamchip,dc=de
ldap ssl = no
ldap user suffix = ou=People
cups options = raw

[homes]
comment = Home Directories
valid users = DREAMCHIP\%S
read only = No
browseable = No

[netlogon]
comment = Network Logon Service
path = /home/netlogon
guest ok = Yes
Member: FISI-Azubi2010
FISI-Azubi2010 Apr 29, 2010 at 13:05:40 (UTC)
Goto Top
Puh nettes Knobelproblem

also deine Konfiguration sieht eigentlich ganz gut aus. Es gibt bei Windows 7 2 Gruppenrichtlinien die in Kombination serverseitige Profile deaktivieren sollen.

Computerconfiguration>Administrative Vorlagen > System> Benutzerprofile > Nur lokale Benutzerprofile zulassen und im selben tree noch die policy "Propagierung von Änderungen an servergespeicherten Profilen auf den Server verhindern"

Aber wahrscheinlich nutzt dir das nichts da du es wahrscheinlich zentral verwaltbar haben möchtest oder? (was ja auch das einzig sinnvolle ist)^^

Gruß FISI-AZUBI
Member: mecie21313
mecie21313 Apr 29, 2010 at 17:34:58 (UTC)
Goto Top
Hmm

Naja, so langsam bleibt wohl das die einzige Möglichkeit....

Oder hat jemand anderes ne Idee?