Telekom Companyflex FTTH mit pfSense

androxin
Goto Top
Hallo zusammen,

ich nutze seit Jahren erfolgreich eine pfSense mit zwei DSL Anschlüssen als virtuelle Maschine.
Nun kommt ein dritter Glasfaseranschluss dazu.
Es handelt sich um einen Companyflex Tarif von der Telekom.

Genutzt wird das Telekom "Glasfaser Modem 2" als Modem. Die pfSense, in der aktuellsten Version, soll die Einwahl übernehmen.

Ich habe alles gemäß dieses Tutorials eingerichtet: https://www.dnetz.de/cms/pfsense-pppoe-an-ftth-modem-glasfaseranschluss. ...
In Kurzform:
  • Geprüft, ob Glasfaser Modem 2 eine Verbindung hat (Grüne Ampel in der Weboberfläche des Modems)
  • Geprüft, ob pfSense eine Verbindung zum Modem hat (Testweise ein Gateway mit statischer IP erstellt. Ping auf 192.168.100.1 war erfolgreich)
  • VLAN Interface mit der VLAN ID 7 eingerichtet und mit dem korrekten Netzwerk-Interface verbunden
  • PPPoE Interface erstellt
  • Zugangsdaten gemäß des Telekom Schemas (Anschlusskennung + Zugangsnummer + 0001@t-online.de) und Kennwort eingegeben

Leider kann keine Verbindung aufgebaut werden.

Im Log gibt's folgende Meldung:

Selbes Spiel auch dann, wenn ich das PPPoE Interface direkt auf das Netzwerk-Interface lege. Ohne VLAN 7.

Kann man das Log noch irgendwie gesprächiger bekommen?
An welcher Stelle könnte der benannte Timeout entstehen? Wird das Modem ggf. nicht gefunden? Oder ist das ein Timeout bei der Einwahl?
Könnte es sein, dass dieses Zugangsdatenschema bei CompanyFlex ein anderes ist?

So viele Fragen. face-wink
Vielleicht hat jemand eine Idee?

Besten Dank und viele Grüße

Content-Key: 3247194086

Url: https://administrator.de/contentid/3247194086

Ausgedruckt am: 15.08.2022 um 17:08 Uhr

Mitglied: mossox
mossox 04.07.2022 um 07:59:34 Uhr
Goto Top
Guten Morgen,

hast du das VLAN7 dem physischen Port (igbx) als parent interface zugeordnet?
snipaste_2022-07-04_07-58-11
Mitglied: Androxin
Androxin 04.07.2022 um 08:20:06 Uhr
Goto Top
Zitat von @mossox:

Guten Morgen,

hast du das VLAN7 dem physischen Port (igbx) als parent interface zugeordnet?

Ja, genau so habe ich das gemacht.

Wobei mir unter der Dusche noch die Idee gekommen ist, dass sich das ggf. mit der restlichen VLAN Struktur behaken könnte.

Darum erkläre ich die noch mal eben:

Die (DSL) Modems stecken auf einem Switch. Jedes hat sein eigenes VLAN: 901, 902, 903.
Diese werden über einen Trunk an ein Hostsystem weitergereicht, auf dem u.a. die pfSense als VM läuft.
Die VM hat je Modem einen virtuellen Netzwerkadapter zugewiesen bekommen. (Das Hostsystem löst dabei das VLAN auf und reicht es als untagged an die VM weiter).
Dann gibt's noch einen weiteren virtuellen Netzwerkadapter, der als Trunk in die VM durchgereicht wird und über den der ganze interne LAN/VLAN Traffic läuft.

Dieses Konstrukt funktioniert eigentlich super. Ein Telekom DSL Modem (mit PPPoE Einwahl durch die pfSense) läuft so auch schon seit Jahren problemlos.
Mitglied: mossox
Lösung mossox 04.07.2022 aktualisiert um 08:33:04 Uhr
Goto Top
Sekunde...

Dein Glasfasermodem muss m.E. aber an einen tagged Port (V-Tag 7).
Mitglied: Androxin
Androxin 04.07.2022 um 08:56:39 Uhr
Goto Top
Zitat von @mossox:

Sekunde...

Dein Glasfasermodem muss m.E. aber an einen tagged Port (V-Tag 7).

Oh man. Du hast natürlich recht.

Ich habe das jetzt von der VLAN ID 903 auf 7 geändert und das VLAN kommt Tagged aus dem Switch Port raus.
Und siehe da: Es läuft.

Tausend Dank face-smile