Ubuntu 14.04 - ICMP Packet loss

Mitglied: Henere

Henere (Level 3) - Jetzt verbinden

28.03.2016, aktualisiert 15:44 Uhr, 1124 Aufrufe, 4 Kommentare

Hallo zusammen,

ich habe Probleme mit meinem Root-Server bei Netcup.de
Die Verbindung hakt immer wieder, selbst SSH kommt ins Stocken.

Nun soll ich ins Rettungssystem booten (ein kleines Linux) um auszuschliessen, dass meine Installation daran schuld ist.
Auf dem Server ist openssh, LAMP, Postfix TCPDUMP, MTR, ETHSTATUS installiert.

ein MTR vom root auf www.microsoft.com zeigt mir immer wieder packetloss schon zum ersten Hop hin.
Umgekehrt, von meinem PC aus, auch immer wieder packetloss zu 188.68.54.154
Auch von Kabel Deutschland aus immer wieder packet loss auf den Server. Liegt also nicht an meinem Anbieter (T-Offline)

Wenn ich mir nen TCPDUMP des ICMP Traffics ansehe, fallen mir auch immer wieder Lücken auf.

Da ich aktuell etliche User darauf habe, möchte ich gerne darauf verzichten den Server ins Rettungssystem zu booten.

Jemand ne Idee, was da meine Pakete verschlucken könnte ?
Oder wo ich ansetzen könnte ?
Traffic dümpelt unter 50kB/sek hin, ausgelastet ist die GBit/s Anbindung nicht.

Danke und Grüße, Henere
Mitglied: aqui
28.03.2016, aktualisiert um 17:24 Uhr
Jemand ne Idee, was da meine Pakete verschlucken könnte ?
Eine etwas naive Frage bei solch banaler Schilderung. Dein Korizont beschränkt sich ja rein auf dein Server System. Was mit dem Hoster Netzwerk an sich ist oder dessen Peering Anbing lässt du vollkommen außer Acht oder kommt in deinen Überlegungen ja gar nicht vor.
Was erwartest du also für eine zielführende Antwort auf deine Frage bei der Informationslage. Will man alle möglichen Optionen berücksichtigen ware das ein 2 Seiten Dokument hier.
Logisch das dir keiner sowas aufzählt, denn als Netzwerk weisst du das im Layer 2 genauso viele Problem wie im Layer 3 auftreten können, deine Server Probleme nochmal gar nicht angesprochen.

Gehe besser also strategisch vor und mache einen Traceroute auf das Ziel und checke wo die größte Verzögerung passiert. Dort ist meistens auch das Problem.
Pingplotter und ander Tools helfen ebenso. Dabei ist es wichtig das du abgehende ICMP Pakete am Client siehst und checkst ob die exakt am Server auftauchen.
Es geht doch zuallererst mal darum nachzuweisen das die Fehler in der Hoster Infrastruktur oder derer seiner ISP Peers liegen...oder auch nicht.
Ist es letzteres gehst du dann erst beim Server ins Eingemachte.
Bitte warten ..
Mitglied: Henere
28.03.2016 um 17:40 Uhr
Servus,

ja das ist mir schon klar. Ich meinte mit verschlucken, die lokale Seite.
MTR habe ich von beiden Seiten mehrfach angefertigt. (Server wie auch zu Hause).
Kann halt leider bei dem Hoster kein Fluke in die Leitung stecken, noch auf die Switche unterwegs zugreifen.
TCPDUMP / MTR ist so fast die einzige Möglichkeit die mir zur Verfügung steht. Wo die Pakete verschwinden kann ich damit aber auch nicht feststellen.

Mein MTR von zu Hause sieht aber komischerweise so aus: (keine Ahnung, warum die ersten Hops nicht antworten)


Ein traceroute von hier aus dann so:


Letzte Antwort vom Provider:


Wenn ich den Netzwerkkartentreiber tauschen müßte... dann hat doch der Hoster einen Fehler gemacht in der Bereitstellung seiner Pakete, oder ?
Es ging halt bis gestern vormittag ohne Probleme.

Grüße, Henere

Update: (beim Schreiben dieses Textes, neue Mail vom Provider:) face-smile


Na, schaun mer mal ...
Bitte warten ..
Mitglied: LordGurke
28.03.2016 um 17:49 Uhr
Ich kann den Packetloss von der Telekom aus nicht nachvollziehen:


Von Level3 auch nicht:



Für den Fall, dass das Problem nur zu bestimmten Zeiten auftritt:
  • Mache von immer den selben Quellen aus einen MTR zum Server und vergleiche die Latenzzeiten. Erhöhte Latenzzeiten (im Vergleich zum vorherigen MTR ohne Störung) weisen auf überlastete Strecken hin.
  • Versuche benachbarte IP-Adressen ebenfalls zu testen - wenn bei denen das selbe Problem auftritt, kannst du deinen Server definitiv als Ursache ausschließen.
  • Versuche den Zeitraum einzugrenzen und gib Netcup einen Hinweis, dass sie das mal prüfen sollen - eventuell ist das ein wiederkehrendes Phänomen, welches z.B. aufgrund von vielen parallelen Remote-Backups auftritt.
  • Falls das bis jetzt eine einzige Störung war: Es kann nunmal passieren, dass Probleme bei einzelnen Uplinks auftreten, die dann erstmal behoben werden müssen. Wenn das nicht wieder auftritt, hefte es ab unter "Internet ist nunmal so" ;-) face-wink
Bitte warten ..
Mitglied: Henere
28.03.2016 um 18:37 Uhr
Servus Lordgurke,

Wenn Du den MTR erst nach meinem post gemacht hast, da hatte der Provider ja irgendwas schon gedreht. Aktuell habe ich einen loss von unter 1%
3800 gesendet und "nur" 34 drops zum ersten Hop. Wobei mir das eigentlich schon zuviel ist. Wenn ich das bei mir zu Hause mache, habe ich 0,0 drops.

Naja, ich würde fast sage, der Drops ist erstmal gelutscht, mal schauen was die Zukunft so bringt. Werde das weiter im Auge behalten.

Danke euch und
Grüße, Henere
Bitte warten ..
Heiß diskutierte Inhalte
LAN, WAN, Wireless
Starlink im Unternehmen?
0xFFFFVor 15 StundenFrageLAN, WAN, Wireless37 Kommentare

Guten Morgen Admins, leider leiden wir darunter, dass wir uns hier in DE noch in einem Entwicklungsland was die Internetanbindung angeht, sehr. Nun kam ...

Off Topic
Klimaanlage im Serverraum
gelöst imebroVor 12 StundenFrageOff Topic19 Kommentare

Hallo, wir haben einen kleinen Serverraum (viell. 5 - 6 m²), in dem ein Serverschrank steht. Der Raum hat kein Fenster!!! Darin befinden sich ...

Microsoft
Datenkrake - Browser
DennisWeberVor 1 TagErfahrungsberichtMicrosoft11 Kommentare

Hallo zusammen, ich empfehle euch mal definitiv in "Temp" Verzeichnis eures Browsers zu schauen. Es war für mich erschreckend, wie viele wichtige Dokumente und ...

Netzwerkmanagement
Sicherheitsrisiken Synology DS Admin Konto
RitchtoolsVor 1 TagFrageNetzwerkmanagement6 Kommentare

Hallo Zusammen, ich habe die Pflege von einem Firmen NAS übernommen (Synology) es sind mehrere Rechner im Netzwerk die auf Daten zugreifen. Leider hat ...

Windows 10
Windows 10 hängt bei Neustart immer bei "Bitte warten" über Stunden
gelöst Odde23Vor 13 StundenFrageWindows 1023 Kommentare

Ich habe seit längerem, um genau zu sein seit gut einem Jahr, da wurde der Rechner gekauft, das Problem, dass der Rechner bei einem ...

Windows 10
Windows 10 System Recovery Ordner fast 60 GB - Wie löschen?
Looser27Vor 1 TagFrageWindows 106 Kommentare

Guten Morgen, bei einem unserer Clients funktioniert scheinbar das automatische Aufräumen nach Updates / Upgrades nicht. Wie kann ich dem Kollegen auf die Schnelle ...

Windows 10
Windows 10 verliert die Druckertreiber
KMP1988Vor 1 TagFrageWindows 1010 Kommentare

Servus zusammen, wir haben bei einem Kunden folgende Konstellation: - Server2019 (AD, DNS, DHCP) - Server2019 (Print-Server-Rolle) - W10-Clients Die Drucker werden übers Logon-Scirpt ...

DNS
Opendns.com - Kosten?
cordialVor 1 TagFrageDNS2 Kommentare

Moin, Ich möchte gerne den OpenDNS Dienst mal verstehen. Hab da schon länger einen Account mit Filterung. Die "Free" Edition bei OpenDNS ist doch ...