soccerdelux
Goto Top

Windows 10 Freigabe mit MAC

Hallo zusammen,

ich habe einen Windows 10 Rechner mit Windows Freigaben.

Auf diese Freigabe z.B. C:Share haben alle Benutzer zugriff.

Freigabename lautet:

\\Server\Freigabe\

Hat bis Dato auch alles wunderbar geklappt.

Nun habe ich seit 2 Tagen das Problem, das die Macs sich nicht mehr mit dem Server (Win10) verbinden wollen.

Erst wenn ich regedit öffne :

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters

und SMB2 den Wert von 0 auf 1 setze, geht es wieder.

Allerdings wird der Wert alle 3-10Minuten zurückgesetzt und ich weiss nicht warum.

Habe es auch über Powershell als Admin probiert:

Detect : Get-SmbServerConfiguration | Select EnableSMB2Protocol
Enable: Set-SmbServerConfiguration –EnableSMB2Protocol $true

Auch hier werden die Werte automatisch überschrieben.

Ideen Warum ?

Ich finde nichts wirklich bei google.de , das was ich finde ist, das Smb1 in den Featrues von Win10 aktiviert werden kann, auch schon getestet. Ob SMb1 aktiv oder nicht - macht hier kein Unterschied.


Auch konnte ich früher von den "Freigegebenen Ordner" eine Verknüpfung über den Desktop anlegen.

Hier kommt Fehler -8060 -

Hiermit kann ich zur Not Leben, allerdings das der Wert von SMb2 überschrieben wird alle paar Minuten nicht.

Mac Betriebssystem: macOS High Sierra Version 10.1.3.6

Danke

Content-Key: 463386

Url: https://administrator.de/contentid/463386

Printed on: July 23, 2024 at 00:07 o'clock

Member: sabines
sabines Jun 18, 2019 updated at 11:41:56 (UTC)
Goto Top
Moin,

mit den Einstellungen wird SMBv2 aktiviert und deaktiviert, schau mal nach, ob in den Aufgaben (oder per GPO) etwas diesen Wert regelmäßig überschreibt (und warum).

Oder stell bei den Macs SMBv3 aktiv, wahrscheinlich ist das durch irgendein Update ausgestellt worden.

Gruss
Member: Soccerdelux
Soccerdelux Jun 18, 2019 at 11:47:16 (UTC)
Goto Top
Moin,

Danke für dein schnelle Feedback.

Hast du nen Tipp wo ich das finden kann in der GPO ?

Weil eigentlich sollte keine Gpo aktiv sein, da die Windows 10 Maschine alleine im Netzwerk steht.

In der Aufgabenplanung von Windows 10 ist nur drin, das er Nachts um 3:00Uhr nach Update suchen soll.

Danke für deine Hilfe.

LG
Member: Soccerdelux
Soccerdelux Jun 18, 2019 at 11:48:27 (UTC)
Goto Top
Mit den Macs auf SMBv3 aktiv setzen teste ich mal ! Melde mich dazu. Danke
Member: Soccerdelux
Soccerdelux Jun 18, 2019 at 14:23:06 (UTC)
Goto Top
Hi,

ich komme zu keiner Lösung.

Habe jetzt nochmal Versucht Smb1 auf dem Server (windows10) zu aktivieren.

Habe dann einen Windows 10 Client genommen und nachdem ich unter Features auch Smb1 Client aktivieret habe, komme ich auf den Sever drauf.

Bis dahin ist wohl alles gut. Also scheint der Server nicht auf smb2 und 3 zu reagieren ? Was ja auch erstmal so ok wäre.

Allerdings bleiben die Probleme bestehen, ich muss immer wieder in der registry den Wert von 0 auf 1 ändern - damit alles Funktioniert.

Kann ich den Mac dazu zwingen das er Smb1 nutzen soll ?

Ansonsten könnte ich höchsten noch ein Script schreiben, was den Wert jede Minute von 0 auf 1 überschreibt ?
Member: LeeX01
LeeX01 Jun 18, 2019 at 15:10:56 (UTC)
Goto Top
Wieso aktivierst du auch noch das unsichere SMB1 wenn es mit SMB2 funktioniert und nur noch geklärt werden muss warum sich das disabled?

Richtlinien sind immer aktiv und wenns bloß die lokalen sind.
Member: aqui
aqui Jun 18, 2019 updated at 15:39:48 (UTC)
Goto Top
Mac OS macht aber schon seit langem per default SMBv2 und SMBv3. Es ist also ziemlich sinnfrei (und auch gefährlich) da in die Steinzeit zurückzugehen und SMBv1 zu erzwingen !
https://support.apple.com/de-de/HT205926
Member: Soccerdelux
Soccerdelux Jun 18, 2019 at 16:15:27 (UTC)
Goto Top
Bin gerne für weitere Tipps bereit, irgendwie muss ich es zum laufen bringen.. auch wenn es erstmal gebastelt ist.

Daher dachte ich über Smb1 - was aber auch wieder an dem Wert der registry scheitert.

Also script schreiben was alle 2 Minuten ausgeführt wird und den Eintrag unter:

Computer\HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters
Smb2 auf Wert 1 setzt.

Oder habt ihr noch einen Tipp bezüglich der lokale Gpo ? Ich habe gerade mal überflogen, aber bis auf z.B. Kennwortrichtlinie habe ich nicht viel gesehen.

Wo könnte das sonst stehen ?

Danke schön !
Member: StefanKittel
StefanKittel Jun 18, 2019 updated at 18:07:44 (UTC)
Goto Top
Zitat von @LeeX01:
Wieso aktivierst du auch noch das unsichere SMB1 wenn es mit SMB2 funktioniert und nur noch geklärt werden muss warum sich das disabled?

Zitat von @aqui:
Mac OS macht aber schon seit langem per default SMBv2 und SMBv3. Es ist also ziemlich sinnfrei (und auch gefährlich) da in die Steinzeit zurückzugehen und SMBv1 zu erzwingen !
https://support.apple.com/de-de/HT205926

Hallo,

ich darf kurz auf die Informationen eines der größten Anbieter von Abrechnungssoftware für Zahnärzte in Deutschland verweisen.

"Um Probleme beim File-Locking auszuschalten, MÜSSEN folgende 2 Registry-Einträge gesetzt werden"
Server
EnableOplocks = 0
SMB2 = 0

Client
Windows-Taste –nach Systemsteuerung suchen und öffnen–Programmeund Features –Windows-Features aktivieren oder deaktivieren–„... SMB1.0 ...“ aktivieren

Immerhin muss man nicht mehr UAC deaktivieren und lokale Administratorrechte haben.
Ach nee face-smile Man hat ja noch eine Röntgensoftware via VDDS angebunden. Also doch lokale Adminrechte und UAC ausschalten face-smile

Kurzer hinweis der Fairness: Alle anderen mir bekannten Anbieter sind auch nicht besser und VDDS bringt alle ins Sicherheitsgrab
Member: Visucius
Visucius Jun 18, 2019 updated at 18:10:31 (UTC)
Goto Top
Meinem Gefühl nach, gehst Du "falsch" herum an das Problem. Nicht das SMB3 vom Windows ist das Problem, sondern die SMB-Thematik am Mac ist "tricky". Da findet sich massig Material im Netz. Und grundsätzlich ist SMB auf MacSeite die aktuell und zukunftig präferierte Lösung, weil AFP "ausläuft".

An sich geht es aber - bei mir ist sogar schon TimeMachine drüber gelaufen.

Oder löse Dich von SMB komplett und gehe über "Windows Sharing MacOS". Da findest Du leichter Lösungen.

Wenn gar nix hilft: https://communities.apple.com/de/welcome
(die sind recht flott)
Member: Soccerdelux
Soccerdelux Jun 19, 2019 at 14:30:58 (UTC)
Goto Top
Hallo zusammen,

so heute nochmal ganz von vorne das Projekt angegangen.

erstmal die SMb1 auf dem Sever wieder deaktiviert.

Dann anhand MS Artikel Smb2 aktiviert über Powershell.

Artikel

Erkennen:


Get-SmbServerConfiguration | Select EnableSMB2Protocol

dann auf true gesetzt:

Aktivieren:

Set-SmbServerConfiguration -EnableSMB2Protocol $true

Und siehe da alle Mac's konnten sich sofort verbinden.

Dann teilte mit ein Windows User mit das er nicht mehr auf die Windows Maschine kommt.

Dort habe ich dann Smb1 Client deinstalliert / neugestartet / und danach die Netzlaufwerke neu eingerichtet.

Alles ohne Probleme face-smile

dann dachte ich ok - es klappt alles wieder und nach ca. 10 Minuten wieder der Wert den ich oben auf True gesetzt habe, wieder von alleine auf false..

Die Windows 10 Clients konnten trotzdem noch auf die Netzlaufwerke zugreifen.

Die Macs allerdings nicht, Strg + K mit server verbinden - geht wieder nicht. Liegen noch Verknüpfungen auf die unterordner der Freigabe auf dem Mac Desktop - lässen diese sich auch öffnen. Ohne erneut mit dem Server zu verbinden.

Nach einem Neustart der Macs, geht beides nicht mehr - dann muss ich den Wert in Windows 10 erst wieder auf true setzen und dann geht es wieder.

Was mich halt verwundert ist, das ich bei manchen MAcs eine Verknpüfung anlegen funktioniert und beim nächsten wieder Fehler -8060-

Immerhin können wir teilweise wieder arbeiten, mal schauen ob es am Montag funktioniert oder nicht.

Das mal zum Statusupdate für euch.

Tja ich glaube echt ich schreib ein Script oder Powershell der den Wert auf 1 bzw. true setzt...

Da ich mittlerweile nicht mehr weiss, was ich sonst machen könnte. Smb1 ist auf jedenfall aus face-smile

Erfolg 1 - Check face-wink

schönen Feiertag !
Member: Soccerdelux
Soccerdelux Jun 24, 2019 at 13:39:16 (UTC)
Goto Top
Hi,

ein User hier im Forum konnte mir weiterhelfen: Colinardo

Viele Dank nochmal dafür !

Lösung