Windows 2008R2 SMB - Windows 10

Mitglied: schakaL-

schakaL- (Level 1) - Jetzt verbinden

27.07.2018 um 16:35 Uhr, 6579 Aufrufe, 4 Kommentare, 1 Danke

Hallo miteinander,

ich habe ein Problem mit dem Zugriff von Windows 10 auf einen Windows Server 2008R2 via Namen/IP, also "\\NAME". Meine Vermutung liegt beim SMB, das hier etwas falsch eingestellt ist:

Windows 10 Rechner, aktueller Build, in einer Domäne. Möchte zugreifen auf den File-Server und dessen Freigaben. Hier kommt aber nur die Info, dass der Zugriff nicht möglich ist. Mit den alten PCs unter Windows 7 funktioniert es. Genauso funktioniert der Ping. Zugriff auf einen zweiten Windows Server 2008R2 funktioniert auch. Ich habe es dann hinbekommen, dass ich zugreifen kann, mit folgendem Befehl unter Windows 10:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/nsi
sc.exe config mrxsmb20 start= disabled

Deaktiveren von SMB2. Danach habe ich Zugriff auf dem Server, aber keine Möglichkeit mehr, auf einen anderen Windows 10 Rechner per "\\Name" oder "\\IP", Ping funktioniert (leider dank UPS-Software notwendig). Wenn ich dann wieder mrxsmb20 auf auto mache, funktioniert eben der Zugriff auf die Windows 10 Rechner wieder, aber nicht mehr auf diesen einen Windows Server 2008R2.

Registry bzw. SMB2 von Windows Server 2008R2 habe ich geprüft, dies läuft, auch schon die Tips aus dem Internet bzgl. Registry-Einträge erledigt (How to detect, enable and disable SMBv1, SMBv2, and SMBv3 in Windows and Windows Server). Zudem eben auch per Befehl den SMB nochmal aktiviert, also diesen hier:

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb20 start= auto

Dienste laufen alle, sfc sagt auch alles in Ordnung.

Vielleicht hat hier noch jemand einen Tipp, was ich prüfen könnte... bevor ich die Reinstallation in Angriff nehmen würde.

Gruß
Sascha
Mitglied: DerWoWusste
27.07.2018 um 17:01 Uhr
Hi.

Wie immer: versuche das Problem weitestgehend zu isolieren. Deinstalliere evtl. vorhandene Softwarefirewalls und starte neu.
Update deine Systeme und NIC-Treiber
Repariere zunächst die Clientinstallation, dann, falls noch nicht besser, den Server, wenn Du damit Erfahrung hast (inplace-Upgrade).
Bitte warten ..
Mitglied: BlakeDarko
27.07.2018 um 17:08 Uhr
Auf der Windows 10 Maschine -> Features Hinzufügen und Entfernen -> SMB 1.0 aktivieren für Client und Server. Seit 1803 ist diese Option deaktivert und macht Probleme.
unbenannt - Klicke auf das Bild, um es zu vergrößern
Bitte warten ..
Mitglied: vBurak
27.07.2018 um 23:16 Uhr
Ab Windows 10 Version 1803 wird SMB1 / CIFS standardmäßig deaktiviert. Dies ist auch besser so, weil SMB1 ein veraltetes und unsicheres Protokoll ist und durch SMB2 und SMB3 abgelöst wurde.

Bei SMB gibt es Server und Client und dein Server 2008R2 wird wohl SMB2 als Server deaktiviert haben.

Hier wird alles erläutert:
https://support.microsoft.com/de-de/help/2696547/how-to-detect-enable-an ...

Zum Aktivieren von SMB2 auf Server 2008R2 musst du

Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB2 -Type DWORD -Value 1 –Force

sowie

sc.exe config lanmanworkstation depend= bowser/mrxsmb10/mrxsmb20/nsi
sc.exe config mrxsmb20 start= auto

in der PowerShell ausführen.


Wenn der Zugriff dann von allen Maschinen funktioniert, würde ich empfehlen, SMB1 auf allen Geräten zu deaktivieren. Dazu

Set-ItemProperty -Path "HKLM:\SYSTEM\CurrentControlSet\Services\LanmanServer\Parameters" SMB1 -Type DWORD -Value 0 –Force

sowie

sc.exe config lanmanworkstation depend= bowser/mrxsmb20/nsi
sc.exe config mrxsmb10 start= disabled

auf allen Windows 7 und Server 2008R2 Geräten ausführen.

Gruß
Burak
Bitte warten ..
Mitglied: schakaL-
30.07.2018 um 08:17 Uhr
Zuerst einmal vielen Dank für die Hilfe.

Das mit Windows 10 ist bekannt und wurde auch aktiviert. Das SMB1 eigentlich abzuschalten ist, ist mir auch bekannt... nur eben bekommt man nur so aktuell Zugriff auf diesen Server.

Der Registry-Eintrag bzgl. SMB2 wurde schon gesetzt, genauso der sc-Befehl (aber im CMD als Administrator, zeigte jeweils "Erfolgreich"). Natürlich auch danach Neustart des Servers erledigt.

SMB1 kann ich mal deaktivieren und prüfen, ob dann überhaupt noch jemand Zugriff hat, dies habe ich noch nicht getestet - nur das aktivieren von SMB2... dazu werde ich im Laufe der Woche kommen.
Bitte warten ..
Heiß diskutierte Inhalte
Netzwerkprotokolle
DHCP-Server vom ausgeschalteten PC?
pow3rlock3Vor 1 TagFrageNetzwerkprotokolle47 Kommentare

Guten Tag in die Runde, kurz zu mir: IT-Administrator und seit über 20 Jahren im PC-Bereich unterwegs. habe zu Hause jetzt ein Problem: grober ...

Server
Argumente für Serverumstellung
Stivi1989Vor 1 TagFrageServer15 Kommentare

Hallo zusammen, ich benötige einmal unterstützung eine Serverumstellung zu begründen. Problem ist wie folgt: Ein Unternehmen setzt aktuell noch einen SBS2011 ein. Da dieses ...

Microsoft
Software zur Archivierung von Rechnungen
gelöst MazenauerVor 1 TagFrageMicrosoft12 Kommentare

Guten Tag zusammen Leider habe ich keine passende Rubrik gefunden, deshalb probiere ich es hier. Als ich letzthin die ersten bezahlten Rechnungen des Jahres ...

Server-Hardware
Intel(R) 82576 Gigabit-Netzwerkarte macht nur 10MBit
fdk007Vor 1 TagFrageServer-Hardware18 Kommentare

Hallo Leute, das Problem bleibt, (s. Bild): Egal welcher Treiber…die Intel Karten machen 10 Mbit. Egal was ich einstelle. Die 3. Netzwerkarte des Cisco ...

LAN, WAN, Wireless
Fritzbox mit Switch verbinden und Vlan einrichten
Forrest57Vor 23 StundenFrageLAN, WAN, Wireless35 Kommentare

Hallo zusammen. Möchte meine Geräte über VLAN trennen. Anhand der Zeichung sieht man wie das Netz aufgebaut sein soll es ist ein 24 Port ...

Windows Server
Änderung des Standard-Browsers Server 2019
EmptymanVor 1 TagFrageWindows Server3 Kommentare

Hallo liebe Gemeinde. Ich schlage mich mit einem kleinen Problem rum, dessen Lösung ich aber leider nicht auf die Schliche komme. Auf meiner Terminalserver-Umgebung, ...

Netzwerkmanagement
TIA568A oder B - Leistungsunterschiede oder egal?
gelöst alboshiroVor 20 StundenFrageNetzwerkmanagement15 Kommentare

Hallo Zusammen, ich bin aktuell im Hausbau und habe in jedem Zimmer ein RJ45 CAT7 Ethernetkabel für jeden Raum verlegt. Jetzt müsste ich die ...

Firewall
PfSense direkt an Glasfasermodem der Telekom über PPPoE
gelöst snah0815Vor 16 StundenFrageFirewall23 Kommentare

Hallo Zusammen, nachdem ich die pfSense nun eine Zeit lang in einer Kaskade mit einer Fritzbox 7590 betrieben habe, möchte ich nun gerne die ...