Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Zwei Netze mit Router verbinden

Mitglied: Rattenfaenger

Rattenfaenger (Level 1) - Jetzt verbinden

07.02.2005, aktualisiert 10.02.2005, 17758 Aufrufe, 6 Kommentare

Ein freundliches Hallo von einem Neuen. Habe mir schon viele Anregungen aus Eurem
Forum geholt. Danke dafür und hier zu meinem Problem:

Habe ein zweites Netz über einen zweiten Router ins WWW gebracht, der zweite Router
verfügt über eine Fileserver (2xUSB) und eine Printserver.

Internetverbindung funktioniert auch in beiden Netzen, nur ich kann nicht
untereinander arbeiten.
Vom zweiten Netz kann ich alle Rechner sehen (aus dem ersten und zweiten Netz) aber im ersten nicht ansprechen (auch keinen Ping).
Vom ersten Netz kann ich nur die Rechner des ersten Netzes sehen (keinen Ping ins zweite Netz).

erster Router
INTERNET über SMC7004VBR
Cable/DSL: CONNECTED
WAN IP: XXX.XXX.XXX.XXX.
Subnet Mask: 255.255.255.0
Gateway: XXX.XXX.XXX.XXX
Primary DNS: XXX.XXX.XXX.XXX
Secondary DNS: XXX.XXX.XXX.XXX

GATEWAY
IP Address: 10.0.0.99
Subnet Mask: 255.255.255.0
DHCP Server: Disabled
Firewall: Enabled
UPnP: Disabled

INFORMATION
Numbers of DHCP Clients: 0
Runtime Code Version:
1.232 (May 11 2004 16:09:13)
Boot Code Version: V1.05
LAN MAC Address:
00-04-E2-79-3C-B0
WAN MAC Address:
00-04-E2-79-3C-B1
Hardware Version: R01

_____________________________________

zweiter Router
Netpassage NP26G
System Up Time : 0 Days 21:05:32
BIOS/Loader Version : 2.0 (build 0023)
Firmware Version : 1.28 (build 1118)
Network Address Translation : Enable
Wireless:
WLAN name (ESSID): compex
Operating frequency : 2.4220G
Operating Channel : 3
Security mode : None
LAN Port:
IP Address : 192.168.168.1
Network Mask : 255.255.255.0
DHCP Server : Enable
WAN Port:
Hardware Address : 00-80-48-2c-d4-cd
WAN Type : Static
IP Address : 10.0.0.101
Network Mask : 255.255.255.0
Default Gateway : 10.0.0.99

Bei einer Adressvergabe im gleichen Adressbereich,
Erstes 10.0.0.99 bis 10.0.0.199 Subnet 255.255.255.0 (feste IP)
Zweites 10.0.0.200 bis 10.0.0.254 Subnet 255.255.255.0 (DHCP, Bereich gesetzt)
habe ich keine Internetverbindung im zweiten Netz und es steigt immer der Router aus.

Leider habe ich Probleme mit den Begriffen NAT ,DNS Redirection und Dynamic DNS oder Routing Table, Port, bzw IP- Forward. Vieleicht fehlt hier die entsprechende Einstellung.
Bin für jeden Tip dankbar.
Mitglied: stg78
08.02.2005 um 09:01 Uhr
Ist ein wenig schwer das nur mit den Angaben aus den Routern heraus zu lösen.
So wie ich das bis jetzt sehe sind die Routen falsch gesetzt.

Das default Gateway des ersten Routers muss die IP des Wanports sein der mit dem Internet verbunden ist. Wenn ich das oben richtig deute ist das jetzt nicht der Fall.
Der zweite Router bekommt die IP des Lanports des ersten Routers.
Da ich nicht weiß wie hier genau die Topologie des Netzwerkes ist basiert meine Vermutung des Problems auf folgendem.

Der erste Router kennt seinen Bereich des Netzwerkes und die Rechner die darin vorkommen. Außerdem weis er das er eine Verbindung in Richtung Internet hat.
Der zweite Router kennt die Rechner in seinem Subnetz und weis das er ein anderes Subnetz neben sich hat wo er die Rechner allerdings nicht kennt. Wenn man nun aus dem zweiten Netz einen Rechner aus dem ersten versucht zu ereichen dann kommt das Anfrage Paket am Router an der feststellt das der gewünschte Rechner nicht in seinem Subnetz existiert und reicht das Paket weiter an das erste Subnetz und lässt den ersten Router sich drum kümmern ob der gewünschte Rechner in seinem Subnetz existiert. Da ich vermute das die default Gateways falsch sind kommt keine Antwort zurück zum zweiten Router.

Meine Annahme des Netzwerkes:

Subnetz2 ->Router2 -> Subnetz1 ->Router1 -> Internet

Wenn das erste Subnetz z.B. 192.168.0.xx hat und der Router1 selber die Lanaddresse 192.168.0.1 hat dann ist das default Gateway des zweiten Routers 192.168.0.1 also die Addresse des ersten Routers.

Kann sein das ich da jetzt falsch liege aber die Informationen zu dem hier vorhandenen Netz sind ein wenig dürftig.

MfG

stg78
Bitte warten ..
Mitglied: Rattenfaenger
08.02.2005 um 10:38 Uhr
SMC7004 ist erste Router an DSL:
WAN IP und DNS vom Provider,
Gateway ist gleich die im Lan-Setup vergebene IP 10.0.0.99
(DHCP deaktiviert).


NP26G ist zweiter Router:
WAN Static Setup
IP Adress :10.0.0.101
Mask : 255.255.255.0
Gateway :10.0.0.99

LAN Setup:
IP Address: 192.168.168.1
Network Mask: 255.255.255.0
DHCP Start IP Address: 192.168.168. 100
DHCP End IP Address: 192.168.168. 254
DHCP Gateway IP Address: 192.168.168. -leer-
Always use these DNS servers Enable
Primary DNS IP Address: 10.0.0.99
Secondary DNS IP Address:
DHCP Server: Enable

UP´s, hier fehlt im Lan-Setup die DHCP Gateway IP Address, bzw ist nicht vollständig.....

..... mit 192.168.168.1 ändert sich aber auch nichts.

Muß noch nachtragen, Ping vom zweiten Netzwerk (NP26G) an Adresse 10.0.0.99 und 10.0.0.101 geht. Auch Ping an Rechner im ersten Netz funktionieren. Kann den Rechner aber nicht ansprechen, (nicht im NetzwerK gefunden). Sehe den Rechner auch nur unter Benachbarte Computer wenn er als letzter eingeschaltet wird, bzw die Netzanmeldung erfolgt nach dem der Rechner im zweiten schon gebootet hat.
Bitte warten ..
Mitglied: id.scary
08.02.2005 um 16:18 Uhr
Poste hier mal deine Routing tabelle vom beiden Router.

btw. DHCP Gateway IP Address auf 0.0.0.0 setzen.
Bitte warten ..
Mitglied: Rattenfaenger
08.02.2005 um 16:59 Uhr
Beim SMC2004 (erster Router am WWW)
kann ich keine DHCP Gateway IP Address eingeben, die ist identisch mit der IP des vergebenen Adressbereich.
DHCP ist deaktiviert. Routing tabelle habe ich dort auch nicht, habe folgende Optionen:
Address Mapping kann ich einer "Global ID" (is transformed as multiple virtual IPs) eine Route von IP nach IP
(nur interne Adressen) zuweisen. Aktuell nicht aktiv, keine Einträge.
Virtual Server kann ich einer "Private ID" einen Private Port und einen Public Port zuweisen. Aktuell nicht aktiv,
keine Einträge.
Und unter Spezial Aplikationen kann ich "Range of the Trigger Ports" konfigurieren.


Beim NP26G (zweiter Router im Netz)
war die ganze Zeit DHCP Gateway IP Address auf 0 ,
Die Routing tabelle sieht folgend aus:
Destination Network Mask Gateway
10.0.0.101 255.255.255.255 10.0.0.99
192.168.168.101 255.255.255.255 *
10.0.0.99 255.255.255.255 10.0.0.101
10.0.0.0 255.255.255.0 *
127.0.0.0 255.255.255.0 *
192.168.168.0 255.255.255.0 *
0.0.0.0 0.0.0.0 10.0.0.99

Diese Einträge davon habe ich selber gamacht, hat aber nichts gebracht.
10.0.0.99 255.255.255.255 10.0.0.101
10.0.0.101 255.255.255.255 10.0.0.99
Ich möchte die beiden Router auch nicht untereinander austauschen um die Routingtabelle nutzen zu können, ich brauch die USB-Anschlüße für Printserver und Fileserver im Subnetz (ist ortsgebunden).
Bitte warten ..
Mitglied: id.scary
09.02.2005 um 03:28 Uhr
..blabla schnipschnap...

Destination Network Mask Gateway
10.0.0.101 255.255.255.255 10.0.0.99
???
192.168.168.101 255.255.255.255 *
???
10.0.0.99 255.255.255.255 10.0.0.101
???
10.0.0.0 255.255.255.0 *
127.0.0.0 255.255.255.0 *
192.168.168.0 255.255.255.0 *
???
0.0.0.0 0.0.0.0 10.0.0.99

Diese Einträge davon habe ich selber
gamacht, hat aber nichts gebracht.
10.0.0.99 255.255.255.255 10.0.0.101
10.0.0.101 255.255.255.255 10.0.0.99
was sollen die einträge bewirken?

Es ist mir schleierhaft wie dein Router die Arbeit verrichtet...
Der 2. Router soll doch alle Anfragen, die nicht für 2. Netzwerk bestimmt sind an 1. router weiterleiten. Oder habe ich da was missverstanden?
Demnach sollte:
destination netmask gateway
0.0.0.0 0.0.0.0 10.0.0.99 (i-net anfragen)
192.168.168.0 255.255.255.0 192.168.168.1 (2. Netzwerk)
10.0.0.0 255.255.255.0 10.0.0.99 (1. Netzwerk)
192.168.168.1 255.255.255.255 127.0.0.1 (Loopback)
10.0.0.101 255.255.255.255 127.0.0.1 (Loopback)

die anderen Einträge sind entweder unnötig oder gar schlicht falsch.

Da zu dem 1. Router keine Routing tabelle vorliegt,
kann ich nur vorschlagen was drin sein sollte.

0.0.0.0 0.0.0.0 ext.ip für i-net
10.0.0.0 255.255.255.0 10.0.0.99 für LAN1
192.168.168.0 255.255.255.0 10.0.0.101 für LAN2
...und loopback...
Bitte warten ..
Mitglied: Rattenfaenger
10.02.2005 um 17:06 Uhr
Erst einmal an id.scary: "Vielen Dank für deine Mühe".
Du hast sicher recht das hier der "loopback" fehlt, vor allem beim ersten Router. Die Eintragungen beim zweiten, dem NP26G, die mit einem * ergänzt sind, sind Vorgaben die sich im Setup nicht ändern lassen. Ich habe aber die Möglichkeit die beiden Router über den WAN-Port zu verbinden verworfen, und ihn statt dessen über LAN-Port zu LAN-Port als Switch mit File- und Printserver in nur einem Netz intrigiert. Ein wichtiger Grund ist auch das über den WAN-Port nur 10Mbps laufen.
Jetzt ist am ersten Router DHCP dissable. Hier bekommen alle Rechner und auch der zweite Router bekommen eine feste IP. Am zweiten Router ist DHCP im Adressbereich *-200 bis *-254 enable. Hierbei mußte ich auch dem offenen WAN-Port eine feste IP zuweisen weil sonst die File- und Printserver nicht laufen. So läuft es und ich kann am zweite Ruoter auch diverse Rechner zu Service-Zwecken anscließen. Die Sicherheitseinstellungen im ersten Netz und W-Lan in Verbindung mit einem V-Scanner reichen auch aus um mich ausreichend zu schützen.
Hab jetz noch ein Prob mit den Berechtigungen auf dem Printserver (Samba), gehört aber nicht hier rein.
Mit Grüßen aus HM,
Rattenfaenger.
Bitte warten ..
Ähnliche Inhalte
Firewall

Zwei Netz über VPN an Fritzbox anbinden

Frage von Otto1699Firewall3 Kommentare

Hallo, ich habe zwei IP-Netze (Telefon und LAN) in pfsense und möchte diese beiden Netze über VPN einem anderen ...

DSL, VDSL

Zwei Wohnhäuser via WAN im gleichen Netz?!!

gelöst Frage von VivaBavariaDSL, VDSL21 Kommentare

Liebe Community, folgende Situation: Zwei Einfamilienhäuser, ca. 500m voneinander entfernt, befinden sich plötzlich im gleichen Netz?? D.h. beide Parteien ...

TK-Netze & Geräte

Verbind 2 Hauser mit Kupfer und einen Netzwerkisolator

Frage von Hampi7273TK-Netze & Geräte3 Kommentare

Ich hab gelesn das in der Medizin Technik oft mit Netzwerkisolator gebaut wird. Netzwerkisolatoren bilden innerhalb einer kupfergeführten Ethernet-Datenleitung ...

Vmware

VMware Workstation zwei Virtuelle Betriebssysteme im eigenen Netz verbinden

gelöst Frage von matze2090Vmware5 Kommentare

Hallo, ich möchte zwei Virtuelle Betriebssysteme so einrichten das sie miteinander Kommunizieren können. Auf der einen läuft Linux und ...

Neue Wissensbeiträge
Sicherheit

Citrix ADC, Gateway u. SD-Wan: Schwachstellen patchen

Information von kgborn vor 1 TagSicherheit

Keine Ahnung, wie viele Admins von Citrix-Applicances hier unterwegs sind und ob die Versorgung mit Advisories klappt. Aber im ...

Off Topic

Im Tel Raum von Hamburg (040) sind mal wieder viele Indische Microsoft Anrufer unterwegs

Information von TomTomBon vor 2 TagenOff Topic6 Kommentare

Moin Moin, Die sind so schlecht das sogar meine Frau sofort die erkannt hat was die sind. Und Ihr ...

Router & Routing

FritzOS 7.20 kommt auch auf Deine Fritze (wahrscheinlich)

Information von Visucius vor 2 TagenRouter & Routing16 Kommentare

Nachdem ich hier die Hassliebe zu den kleinen Kistchen kenne, sollten wir das nicht zu breit ausdehnen. Ein paar ...

Netzwerke

PfSense VPN mit L2TP (IPsec) Protokoll für mobile Nutzer

Anleitung von aqui vor 3 TagenNetzwerke

Allgemeine Einleitung Das folgende VPN Tutorial ist eine Ergänzung zum bestehenden VPN_Client_Tutorial. Es beschreibt ebenfalls die VPN Anbindung von ...

Heiß diskutierte Inhalte
Grafikkarten & Monitore
Auflösungsprobleme Windows 10 über Displayport
Frage von VollmilchheiniGrafikkarten & Monitore35 Kommentare

Hallo zusammen, ich habe folgendes Problem. An eine HP Z2 Tower G4 Workstation ist ein Monitor über DP angeschlossen. ...

Server
Firmennetzwerk und legales Filesharing: Konzept zur Absicherung gegen illegales Filesharing
gelöst Frage von kundenbeschwerdeServer15 Kommentare

Guten Tag, ich heiße Hans und habe von meinem Unternehmen die Aufgabe übertragen bekommen, ein Konzept zur Abwehr vom ...

Windows Server
Server 2012R2 Probleme mit Internet
Frage von NordsterneWindows Server13 Kommentare

Hallo zusammen, ich habe folgendes Problem: Server 2012R2 verbunden über Netzwerkkabel. Die IP ist statisch eingestellt. Gateway ist die ...

Windows Netzwerk
Probleme beim Routing zwischen VLAN-Netzen durch Windows Firewall
Frage von ByteCraftWindows Netzwerk13 Kommentare

Hallo zusammen, ich sitze nun schon den zweiten Tag an meinem Problem. Die Situation ist wie folgt: Ich habe ...