menace
Goto Top

DHCP Problem bei Reservierung im deaktivierten Bereich

Hallo,

ich habe einen 2012 Server, auf dem die DHCP-Rolle konfiguriert ist.
Aktuell gibt es einen Konfigurierten Bereich 192.168.1.0, welcher an die Clients verteilt wird. Funktioniert auch alles soweit ohne Probleme. Die DHCP-Leases der Clients sind alle reserviert, jeder Client erhält also immer die selbe IP vom DHCP-Server.

Demnächst soll das LAN auf ein anderes IP-Netz 172.20.0.0 umgestellt werden. Ich habe hierfür schon einen entsprechenden IP-Bereich auf dem DHCP Server konfiguriert.
Um das Ganze vor der Umstellung einmal zu testen, habe ich nun den aktiven DHCP Bereich deaktiviert und den neuen aktiviert.
Wenn ich nun einen Client starte erhält dieser aber leider keine IP aus dem neuen DHCP-Bereich vom Server.

Kann das damit zusammen hängen, dass der Client bzw. die MAC auf dem DHCP Server noch eine "aktive" Reservierung im alten bzw. aktuell deaktivierten DHCP Bereich hat?!


Besten Dank für Eure Hilfe!

Content-Key: 303044

Url: https://administrator.de/contentid/303044

Ausgedruckt am: 03.10.2022 um 14:10 Uhr

Mitglied: emeriks
Lösung emeriks 27.04.2016 aktualisiert um 21:30:16 Uhr
Goto Top
Hi,
nein, das wird damit zusammenhängen, dass der DHCP-Server sicherlich eine IP-Adresse aus 192.168.1.0 hat. Wenn ja, dann kann er dem Client keine IP aus 172.20.0.0 geben, weil die Anforderung von einer Schnittstelle aus dem 192'-Netz aufgenommen wurde. Wenn Du das also testen willst, dann muss der DHCP-Server an eine Netzkarte gebunden sein, welche an erster Stelle eine Adresse aus dem 172'-Netz hat. Oder Du testest das in einem anderen Segment und stellst dort einen DHCP-Helper mit einer Adresse aus dem 172' bereit, welcher die Anfragen an den DHCP-Server im 192' weiterleitet.

Einfacher wäre es aber, dem DHCP-Server an der NIC, an welcher er gebunden ist, zusätzlich eine 172' Adresse zu geben. Dann fasst Du die beiden Bereiche zu einer Bereíchsgruppierung (Super Scope) zusammen und deaktivierst im Produktionfall den 172' Bereich und im Testfall aktivierst Du ihn und schliest im 192 Bereich den kompletten Bereich aus. Nicht den 192' Bereich deaktivieren.
Zur Umstellung lässt Du es dann wie im Testfall laufen. Für alle Clients Reservierungen im 172' erstellen und im 192' löschen. Dann warten, bis sich alle Clients ne neue Lease aus dem 172' geholt haben. Dann die 172'-Adresse des DHCP-Servers an erster Stelle schieben und dann kannst Du den 192' Bereich löschen.

E.
Mitglied: menace
menace 27.04.2016 um 21:38:18 Uhr
Goto Top
danke für den Hinweis, genau das ist dann wohl das Problem!