visucius
Goto Top

Einbruch Netzwerkperformance an einem Client

Hallo in die Runde,

ich sitze gerade seit 2 Stunden an einem kleinen Problem und komme gerade nicht so richtig weiter.

Folgende Situation:
a) Unraid Linux Client mit Dual-LAN
b) Mikrotik CRS326
c) Dual-Port-Bonding 802.3ad, vLAN
d) iPerf-Server auf Linux-Client
e) Alle Updates - auch in den letzten Tagen - beidseitig eingespielt
f) Eine Festplatte im Unraid defekt

Vorfall:
Seit Mitte letzter Woche gabs Beschwerden, dass andere Clients, auf die dort gehostete DB extrem "hängen"

Folgendes habe ich gemacht:
I) Alles neu gestartet
II) Allgemeine Netzwerk-Performance über 3 andere Clients getestet (iperf3, 850-950 Mbit/s Up/Down, UDP, TCP, sogar über vLAN hinweg)
III) Bonding des besagten Clients geprüft mit einem überraschenden Fehler bei den Bondingprotokolle (802.3ad contra activebackup)
IV) Bonding "gefixt"
V) Bonding aufgelöst
VI) Einzelports an Router und Switch gewechselt/getestet
VII) Ganz anderen Port am Router genutzt
VIII) Netzwerkkabel getauscht, Client auch direkt an CRS angeschlossen
IX) Festplatten (Lesetest ohne Fehler)

Folgendes Problem:
Die iPerf-Performance ist in allen(!) Fällen vom Server zum Client (down) bei rund 900 Mbit/s (TCP). Die Upload-Performance (Client2Server) dagegen lag anfangs bei 2-3(!) Mbit/s, zwischenzeitlich um die 20 Mbit/s und teilweise sogar um rund 100 Mbit/s. Aber irgendwo hakts noch?! MW. läuft iPerf im RAM (32GB), was die Festplatte eigentlich ausschließt. Der Fehler ist wie gesagt auch maximal 1,5 Wochen alt, weil er während meines Urlaubs gemeldet wurde. Ausgehandelt werden an den Ports 1 Gbit/s.

# oct/20/2022 21:25:59 by RouterOS 7.6
# software id = 5DQL-79U4
#
# model = CRS326-24G-2S+
/interface bridge
add admin-mac=08:55:31:5E:00:7F auto-mac=no ingress-filtering=no name=bridge vlan-filtering=yes
/interface ethernet
s
set [ find default-name=ether15 ] name=eth15b_33
set [ find default-name=ether16 ] name=eth16b_33
set [ find default-name=ether23 ] name=eth23_33
set [ find default-name=ether24 ] name=eth24_wifi-trunk
set [ find default-name=sfp-sfpplus1 ] disabled=yes
set [ find default-name=sfp-sfpplus2 ] disabled=yes
/interface vlan
add interface=bridge name=vlan33 vlan-id=33
/interface bonding
add disabled=yes mode=802.3ad name=bond15+16 slaves=eth15b_33,eth16b_33
/interface ethernet switch
set 0 l3-hw-offloading=yes name=switch
/interface ethernet switch port
set 0 l3-hw-offloading=no
set 1 l3-hw-offloading=no
set 3 l3-hw-offloading=no
set 14 l3-hw-offloading=no
set 15 l3-hw-offloading=no
/port
set 0 name=serial0
/routing table
add disabled=no fib name=to_WAN1
add disabled=no fib name=to_WAN2
/interface bridge port
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged ingress-filtering=no interface=eth23_99 pvid=33
add bridge=bridge hw=no ingress-filtering=no interface=eth24_wifi-trunk
add bridge=bridge ingress-filtering=no interface=sfp-sfpplus1
add bridge=bridge ingress-filtering=no interface=sfp-sfpplus2
add bridge=bridge frame-types=admit-only-untagged-and-priority-tagged interface=bond15+16 pvid=33
/ip neighbor discovery-settings
set discover-interface-list=none
/ipv6 settings
set disable-ipv6=yes
/interface bridge vlan
add bridge=bridge tagged=bridge,eth24_wifi-trunk vlan-ids=33
/ip address
add address=10.98.1.1/26 interface=vlan1 network=10.98.1.0
add address=10.98.11.1/26 interface=vlan11 network=10.98.11.0
add address=10.98.22.1/26 interface=vlan22 network=10.98.22.0
add address=10.98.33.1/26 interface=vlan33 network=10.98.33.0
add address=10.98.44.1/26 interface=vlan44 network=10.98.44.0
add address=10.98.99.1/26 interface=vlan99 network=10.98.99.0
/ip cloud
set ddns-enabled=yes
/ip cloud advanced
set use-local-address=yes
/ip dns
set allow-remote-requests=yes cache-size=4096KiB
/ip service
set telnet disabled=yes
set ftp disabled=yes
set www address=10.98.1.0/26,10.98.33.0/26,10.98.99.0/26,10.98.200.0/26,192.168.196.0/24,192.168.66.0/26
set ssh disabled=yes
set api disabled=yes
set winbox address=10.98.1.0/26,10.98.33.0/26,10.98.99.0/26,10.98.200.0/26,192.168.196.0/24,192.168.66.0/26
/ip ssh
set strong-crypto=yes
/ip traffic-flow
set interfaces=WAN1_Cable
/system clock
set time-zone-name=Europe/Berlin
/system ntp client
set enabled=yes
/system ntp server
set broadcast=yes broadcast-addresses=10.98.1.1 enabled=yes
/system ntp client servers
add address=0.de.pool.ntp.org
add address=3.de.pool.ntp.org
/tool mac-server
set allowed-interface-list=Mgmt
/tool mac-server mac-winbox
set allowed-interface-list=LAN

Content-Key: 4348030145

Url: https://administrator.de/contentid/4348030145

Printed on: March 1, 2024 at 01:03 o'clock

Member: aqui
aqui Oct 21, 2022 at 08:11:57 (UTC)
Goto Top
Leider fehlt die .ad Bonding Konfig des Clients auf den getestet wurde. face-sad
Hast du mal einen der 3 iperf3 non Bonding Testkandidaten die 850-950 Mbit/s Up/Down schaffen auf einen der Bonding Member Ports gesteckt?
Der Port wird ja dann trotzdem aktiv auch wenn kein .ad Client dran ist und bietet dann die Option festzustellen ob die Bonding Konfig an sich das Problem darstellt.
Wenn du dann oben auch 850-950 Mbit/s Up/Down an einem LAG Memberport des Switches erzielst kannst du den Switch und sein Bonding dann von vorn herein ausschliessen. Dann ist es eher das .ad Setup auf dem Client.
Member: Visucius
Visucius Oct 21, 2022 updated at 13:45:13 (UTC)
Goto Top
Leider fehlt die .ad Bonding Konfig des Clients auf den getestet wurde. face-sad
Ehrlich gesagt war das bonding im oben eingestellten Setup eh schon deaktiviert und der problematische Client lief am kurzfristig von vLAN99 auf vLAN33 umgelabelten Ethernetport 23 des CRS.

auf einen der Bonding Member Ports gesteckt
Eben auch nicht, weil die Probleme auch ohne Bonding Bestand hatten

Dann ist es eher das .ad Setup auf dem Client.
Jo, mit einer Nacht Abstand liegt das eigentlcih auf der Hand.

Jetzt bestelle ich erstmal die Ersatz-Platte - auch wenn es daran eigentlich ja nicht liegen kann. Dann gehe ich eh noch ein paar mal an die Maschine. Auch dort gabs nämlich ein relativ großes Update. Ich resette dort die Netzwerk-Config und mache das ganze nochmal frisch.

Danke und WE-Grüße in den hohen Norden face-wink
Member: aqui
aqui Oct 21, 2022 updated at 13:56:38 (UTC)
Goto Top
weil die Probleme auch ohne Bonding Bestand hatten
Sorry, das war dann aber verwirrend von dir geschildert weil du oben genau das Gegenteil beschrieben hattest.
"Allgemeine Netzwerk-Performance über 3 andere Clients getestet (iperf3, 850-950 Mbit/s Up/Down, UDP, TCP, sogar über vLAN hinweg"
und mache das ganze nochmal frisch.
Viel Erfolg!
Member: micneu
micneu Oct 23, 2022 at 18:38:23 (UTC)
Goto Top
@Visucius,
was ist ein:
a) Unraid Linux Client mit Dual-LAN
Unraid ist doch ein NAS (oder Ähnlich) kann man es als Arbeitsplatz Rechner nutzen (Client)?
Member: Visucius
Visucius Oct 23, 2022 updated at 19:39:26 (UTC)
Goto Top
Nen PC mit 2xLAN und 2xssd, nem Linux-Basesystem und mehreren VMs und Docker-Instanzen drauf. Arbeitet im Prinzip wie nen Raid4, bei mir aber wegen der (nur) 2 Platten eher wie ein Raid 1.

Ja, man könnte Grafik, USB, usw an eine VM durchreichen und dann „direkt“ dran sitzen, ist aber hier nicht der Fall.