spartacus
Goto Top

Mikrotik cAP AC WLAN Aussetzer bei VPN

Hallo zusammen,
ich habe ein seltsames Phänomen und benötige Hilfe bei der Eindämmung des Problems.

Umgebung:
1 x RB4011 mit OS 6.47.8
4 x cAP AC über capsman gemanaged

Die cAPS sind so konfiguriert, dass sie sowohl im 2.4GHz und im 5GHz Netz funken; 2.4 GHz ist auf Auto Channel eingestellt. Im 5GHz Band, wird auf unterschiedlichen Bändern gefunkt.
band

AP3 hängt im Flur und AP4 im Wohnzimmer, ca. 5m auseinander.

Wenn ich mit meinem Dienst PC im VPN-Netz der Firma hänge und jemand die Tür vom Flur zum Wohnzimmer öffnet, wird die VPN Streck getrennt. Das heisst, hier scheint der Rechner den AP vom Wohnzimmer zum Flur zu wechseln und dabei bricht das VPN zusammen. Das Wechseln des APs ist ja ok, aber warum bricht dann der Tunnel zusammen? Darf das so sein? Ist das ein normales Verhalten oder ein Bug in der Konfiguration?
Wenn ich AP4 vom Netz nehme, habe ich keine Problem, aber den AP4 brauche ich zwingend für den Außenbereich, das schafft der AP3 nicht!

Danke und Gruß,
Spartacus

Content-Key: 664920

Url: https://administrator.de/contentid/664920

Printed on: February 27, 2024 at 23:02 o'clock

Member: aqui
Solution aqui Mar 19, 2021 updated at 21:24:37 (UTC)
Goto Top
aber warum bricht dann der Tunnel zusammen?
Ohne Nennung des verwendeten VPN Protokolls bleibt uns am Freitag mal wieder mal nur die Kristallkugel. face-sad
Nicht alle VPN Protokolle sind Unterbrechungs tolerant.
Nebenebi: Hat es einen Grund warum du dein 5 Ghz Band auf 20 Mhz statt der .11ac üblichen 40 Mhz kastrierst ? Guckst du auch hier.
Member: Spartacus
Spartacus Mar 19, 2021 at 21:18:08 (UTC)
Goto Top
Moin aqui,
sorry, das hatte ich vergessen! Ich nutze FortiClient. Bei meiner Frau ist das auch so, kann ich aber erst am Montag gucken, was sie nutzt.

Keine Ahnung, warum ich das auf 20MHz kastriert habe. Das hatte einen Grund, muss ich noch mal nachlesen....

Spartacus
Member: aqui
aqui Mar 19, 2021, updated at Mar 20, 2021 at 06:54:29 (UTC)
Goto Top
Ich nutze FortiClient.
Frage: Welches Auto fährst du denn ??
Antwort: Die Lackfarbe ist blau !
Soviel zur Frage nach dem VPN Protokoll...aber heute ist ja auch Freitag. face-big-smile

Auto Channel ist generell keine gute Idee. Es gibt keinen Hersteller bei dem das sauber funktioniert. Du solltest besser mit einem freien WLAN Scanner wie z.B. DIESEM die RSSID Feldstärke am Ort der Clients messen. Diese sollte keinesfalls unter -70dbm sinken.
Auch ob du eine Überlappungs freie Frequenz Zuordnung der APs nach dem 1, 6 11er Prinzip hast mit mindestens 4 kanaligem Abstand. Das gilt auch für Nachbar WLANs ! Guckst du dazu auch HIER.
Es ist ja offensichtlich das du dort eine schlechte bis sehr schlechte Ausleuchtung hast oder entsprechende Störungen im WLAN wenn schon das Bewegen einer Tür ein sofortiges Client Roaming auf einen anderen AP auslöst. Das ist das Grundübel deines VPN Problems !
Mitglied: 147669
147669 Mar 20, 2021 updated at 09:42:46 (UTC)
Goto Top
Nimm einfach Wireguard, das schert sich nicht um solche Verbindungsunterbrechungen , das wurde explizit für das reibungslose Handover von unterschiedlichsten Übertragungsmedien entwickelt ­čśë.
Ansonsten wie schon gesagt wurde, kein Autokanal sondern Kanal fest zuordnen und alle APs überlappungsfrei voneinander den Kanal zuordnen und bei Bedarf auch die Leistung reduzieren, gerade wenn man mit mehreren APs arbeitet und diese ziemlich nah beieinander liegen sollte man es penibel ausmessen sind komt es bei Mikrotik zu einem ständigen Springen der Clients zwischen den APs.
Member: Spartacus
Spartacus Mar 24, 2021 at 21:12:41 (UTC)
Goto Top
Moin zusammen,
ganz lieben Dank für Eure Unterstützung. Ich habe es aktuell sehr easy gelöst und einfach auf einen der beiden cAPs ein WLAN mit eigener SSID konfiguriert. Jetzt können die Clients nicht mehr wechseln....

Die 40MHz Bandbreite werde ich mal einstellen. Ich habe auch eine Access-Regel im capsman, der mir Clients trennt, wenn diese eine zu schlechte Verbindung zum AP haben.
access

Wie ich die langsamen Datenraten bei dem capsman aus dem Beaconing nehme, weiss ich noch nicht. Ich nehme mal an, man muss im Reiter Rates die BasisRate auf 12Mbit stellen.

bild

Nur wie bindet man das Profil an die einzelnen CAPs?

Spartacus
Member: aqui
aqui Mar 25, 2021 at 08:54:36 (UTC)
Goto Top
Ich nehme mal an, man muss im Reiter Rates die BasisRate auf 12Mbit stellen.
Richtig !
Basic Rate nur Haken bei 12 und 24 Mbit.
Nur wie bindet man das Profil an die einzelnen CAPs?
Das machst du im CapsMan Basis Profil, dann wir d es automatisch auf alle Caps Interfaces angewendet.
Member: Spartacus
Spartacus Mar 25, 2021 at 19:12:57 (UTC)
Goto Top
Moin zusammen,
ich habe feststellen können, dass es trotz der separaten SSID an nur einem cAP zu Abbrüchen bei VPN kommt. Das Handover der cAPs kann es jetzt nicht mehr sein! Es muss an etwas Anderem liegen....wer hat noch eine idee, bzw einen Ansatzpunkt?

Zu den Frequenzen im 5GHz Band.
Ich habe 5 cAPs. Da ist es nicht möglich 4-5 Kanäle Abstand zu halten, oder wie meinst Du das?

Aktuell sind sie so konfiguriert:

1. 5280, 40MHz turbo, a/n/ac Ce
2. 5500, 40MHz turbo, a/n/ac Ce
3. 5180, 40MHz turbo, a/n/ac Ce
4. 5600, 40MHz turbo, a/n/ac Ce
5. 5680, 40MHz turbo, a/n/ac Ce

Wenn ich es richtig verstehe, dann sind die Kanäle wie folgt definiert:
channel
5180MHz+4x40MHz=5340MHz und damit bin ich schon über die 5280MHz, also Kanal 52. Oder wie wird das gerechnet?

Spartacus
Member: aqui
aqui Mar 25, 2021 updated at 21:37:14 (UTC)
Goto Top
Hier findest du es verständlich grafisch dargestellt über die 5 GHz UNII Netze:
https://wlanport.de/information/wlanwiki/5ghz-kanaele-fuer-wlan-in-deuts ...
Z.B. Kanal 38, 46, 54, 62 im unteren Band.
Member: Spartacus
Spartacus Mar 26, 2021 updated at 19:12:14 (UTC)
Goto Top
Hi aqui,
ok.
Da hatte ich Dich falsch verstanden. Jeder cAP sollte mind. 6-8 Kanäle Abstand haben, heißt konkret:
cAP1           cAP2           cAP3
Kanal 38 + 8 = Kanal 46 + 8 = Kanal 54.......

Dann passt das ja bei mir!
Spartacus
Member: aqui
aqui Mar 26, 2021 at 19:13:21 (UTC)
Goto Top
­čĹŹ
Member: Spartacus
Spartacus Mar 28, 2021 updated at 13:11:53 (UTC)
Goto Top
Hi aqui,
also irgendetwas stimmt mit der 40MHz Bandbreite noch nicht. Und ich hab gard keine Idee, was das klemmt. Das Capsman Interface zeigt mir jetzt bei den 5GHz Kanälen immer
"no supported Channel" an. Ich vermute, dass ich die Zuordnung von Kanal und Frequenz falsch gemacht habe, aber ich finde hier keine geeignete Frequenz zu Kanalzuordnung für für 40MHz Bandbreite. Die 20MHz sehen ja so aus.

channel

Kann mir mal jemand auf die Sprüge helfen, wie ich einen vollständige Liste für 40Mhz Bandbreite erstellen kann? Also die Frequenzen für die Kanäle 38, 46, 54, 62, 102, 110, 118, 126, 134.....oder wenigstens die Basisfrequenz für Kanal 38

Spartacus
Member: aqui
aqui Mar 28, 2021 at 13:54:00 (UTC)
Goto Top
zeigt mir jetzt bei den 5GHz Kanälen immer "no supported Channel" an
Das liegt daran das du den .11a Standard aktiviert hast, der kann das nicht.
Du darfst nur .11ac oder .11n einstellen, dann klappt das auch. face-wink
Member: Spartacus
Spartacus Mar 28, 2021 updated at 14:41:49 (UTC)
Goto Top
Hi aqui,
das hatte ich schon probiert, das ist es aber nicht! Läuft immer noch nicht! Weder mit "n" noch mit "ac".

channel

band

Spartacus
Mitglied: 147669
147669 Mar 28, 2021 updated at 15:52:45 (UTC)
Goto Top
Du musst die Kanalbreite auf 20MHz lassen und dann unten unter Extension-Channel 1 Erweiterungskanal wählen bspw.
Ce
Das C steht für Control Channel und die 'e' s für die Erweiterungskanäle.
Control Channel + 1 Erweiterungskanal = 2*20MHz = 40MHz Gesamtbreite
Bei Ceee und 20MHz Breite sind es 80MHz Gesamtbreite.
Je nachdem wo die 'e' stehen werden Kanäle unter oder über dem Control Channel belegt.
Nun gecheckt?
Member: Spartacus
Spartacus Mar 28, 2021 updated at 15:04:11 (UTC)
Goto Top
Hi SchmitzKatz,
ok. dann war das also von Anfang an korrekt bei mir, mit den 20MHz und dem Ce face-smile
Danke Dir,
Spartacus

band
Member: Spartacus
Spartacus Mar 30, 2021 at 17:46:57 (UTC)
Goto Top
Hallo,
ja, danke der Nachfrage! Das war von Anfang an korrekt bei mir konfiguriert. Die Verwirrung kam durch einen Tipp, das Ganze doch auf 40MHz zu stellen...

Alles Gut!
Spartacus
Member: aqui
aqui Mar 31, 2021 at 09:46:15 (UTC)
Goto Top
Und .ac solltest du in jedem Falle im 5 GHz Band aktivieren !
Mitglied: 148121
148121 Mar 31, 2021 updated at 10:14:42 (UTC)
Goto Top
Zitat von @Spartacus:
Kann mir mal jemand auf die Sprüge helfen, wie ich einen vollständige Liste für 40Mhz Bandbreite erstellen kann? Also die Frequenzen für die Kanäle 38, 46, 54, 62, 102, 110, 118, 126, 134.....oder wenigstens die Basisfrequenz für Kanal 38
Ich bin mal so frei, für 2G und 5G alle Kanäle mit 20,40,80,160MHz für die capsman channellist zum copy n' pasten mit comment ob indoor only oder dfs für Germany/Europa, für alle die die Wikipedia nicht lesen können face-wink
/caps-man channel 

# 2G channels

add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2412 name=2G_CHAN_1
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2417 name=2G_CHAN_2
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2422 name=2G_CHAN_3
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2427 name=2G_CHAN_4
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2432 name=2G_CHAN_5
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2437 name=2G_CHAN_6
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2442 name=2G_CHAN_7
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2447 name=2G_CHAN_8
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2452 name=2G_CHAN_9
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2457 name=2G_CHAN_10
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2462 name=2G_CHAN_11
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2467 name=2G_CHAN_12
add band=2ghz-g/n extension-channel=disabled control-channel-width=20mhz frequency=2472 name=2G_CHAN_13

# 2G 40MHz channels

add band=2ghz-g/n extension-channel=Ce control-channel-width=20mhz frequency=2422 name=2G_CHAN_3_40MHz_2422_2462

# 5G 20MHz channels 36, 40, 44, 48, 52, 56, 60, 64, 100, 104, 108, 112, 116, 120, 124, 128, 132, 136, 140

add band=5ghz-a/n/ac comment=INDOOR control-channel-width=20mhz frequency=5170 name=5G_CHAN_36_5170_5190
add band=5ghz-a/n/ac comment=INDOOR control-channel-width=20mhz frequency=5190 name=5G_CHAN_40_5190_5210
add band=5ghz-a/n/ac comment=INDOOR control-channel-width=20mhz frequency=5210 name=5G_CHAN_44_5210_5230
add band=5ghz-a/n/ac comment=INDOOR control-channel-width=20mhz frequency=5230 name=5G_CHAN_48_5230_5250
add band=5ghz-a/n/ac comment=INDOOR,DFS control-channel-width=20mhz frequency=5250 name=5G_CHAN_52_5250_5270
add band=5ghz-a/n/ac comment=INDOOR,DFS control-channel-width=20mhz frequency=5270 name=5G_CHAN_56_5270_5290
add band=5ghz-a/n/ac comment=INDOOR,DFS control-channel-width=20mhz frequency=5290 name=5G_CHAN_60_5290_5310
add band=5ghz-a/n/ac comment=INDOOR,DFS control-channel-width=20mhz frequency=5310 name=5G_CHAN_64_5310_5330
add band=5ghz-a/n/ac comment=INDOOR,DFS control-channel-width=20mhz frequency=5330 name=5G_CHAN_68_5330_5350
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5470 name=5G_CHAN_96_5470_5490
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5490 name=5G_CHAN_100_5490_5510
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5510 name=5G_CHAN_104_5510_5530
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5530 name=5G_CHAN_108_5530_5550
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5550 name=5G_CHAN_112_5550_5570
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5570 name=5G_CHAN_116_5570_5590
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5590 name=5G_CHAN_120_5590_5610
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5610 name=5G_CHAN_124_5610_5630
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5630 name=5G_CHAN_128_5630_5650
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5650 name=5G_CHAN_132_5650_5670
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5670 name=5G_CHAN_136_5670_5690
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz frequency=5690 name=5G_CHAN_140_5690_5710

# 5G 40MHz channels 38, 46, 54, 62, 102, 110, 118, 126, 134

add band=5ghz-a/n/ac comment=INDOOR control-channel-width=20mhz extension-channel=Ce frequency=5170 name=5G_CHAN_38_40MHz_5170_5210
add band=5ghz-a/n/ac comment=INDOOR control-channel-width=20mhz extension-channel=Ce frequency=5210 name=5G_CHAN_46_40MHz_5210_5250
add band=5ghz-a/n/ac comment=INDOOR,DFS control-channel-width=20mhz extension-channel=Ce frequency=5250 name=5G_CHAN_54_40MHz_5250_5290
add band=5ghz-a/n/ac comment=INDOOR,DFS control-channel-width=20mhz extension-channel=Ce frequency=5290 name=5G_CHAN_62_40MHz_5290_5330
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz extension-channel=Ce frequency=5490 name=5G_CHAN_102_40MHz_5490_5530
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz extension-channel=Ce frequency=5530 name=5G_CHAN_110_40MHz_5530_5570
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz extension-channel=Ce frequency=5570 name=5G_CHAN_118_40MHz_5570_5610
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz extension-channel=Ce frequency=5610 name=5G_CHAN_126_40MHz_5610_5650
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz extension-channel=Ce frequency=5650 name=5G_CHAN_134_40MHz_5650_5690

# 5G 80MHz channels 42, 58, 106, 122

add band=5ghz-a/n/ac comment=INDOOR control-channel-width=20mhz extension-channel=Ceee frequency=5170 name=5G_CHAN_42_80MHz_5170_5250
add band=5ghz-a/n/ac comment=INDOOR,DFS control-channel-width=20mhz extension-channel=Ceee frequency=5250 name=5G_CHAN_58_80MHz_5250_5330
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz extension-channel=Ceee frequency=5490 name=5G_CHAN_106_80MHz_5490_5570
add band=5ghz-a/n/ac comment=DFS control-channel-width=20mhz extension-channel=Ceee frequency=5570 name=5G_CHAN_122_80MHz_5570_5650

# 5G 160Mhz channels 50, 114

add band=5ghz-a/n/ac comment=INDOOR,DFS control-channel-width=40mhz-turbo extension-channel=Ceee frequency=5170 name=5G_CHAN_50_160MHz_5170_5330
add band=5ghz-a/n/ac comment=DFS control-channel-width=40mhz-turbo extension-channel=Ceee frequency=5490 name=5G_CHAN_114_160MHz_5490_5650
Gruß w.
Member: aqui
aqui Mar 31, 2021 at 10:16:07 (UTC)
Goto Top
wlan-5ghz-kanaele-deutschland
Member: Spartacus
Spartacus Mar 31, 2021 at 10:35:13 (UTC)
Goto Top
habe jetzt alles auf "onlyn" gestellt.
Spartacus
Member: aqui
aqui Mar 31, 2021 at 10:44:30 (UTC)
Goto Top
ac only im 5 Ghz kitzelt noch mehr raus !