Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

gelöst Netzwerkgeschwindigkeit vom Server zum Client zu langsam

Mitglied: bluebird2000

bluebird2000 (Level 1) - Jetzt verbinden

08.01.2011 um 17:21 Uhr, 10121 Aufrufe, 7 Kommentare

Hallo...

ich habe seit nicht genau feststellbarer Zeit das Problem, dass die Geschwindigkeit bei Datenübertragungen vom Server zu allen Clients nur noch ungefähr der hälfte entspricht
wie von den Clients auf die Serverlaufwerke.

Zum Server ca. 60-70Mb/s
Vom Server ca. 30Mb/s

Zum System:

Server: Windows SBS 2003 R2 (selbst gebaut)
Realtek RTL8169 Gigabit für LAN-Verbindung des Server

Switch: Netgear GS108T

Client: z.B. ASUS P5Q-WS Onboard

Bitte sagen wenn noch Informationen fehlen wo relevant sind.

Gruß
Andreas
Mitglied: aqui
08.01.2011 um 17:36 Uhr
Realtek NICs sind generell eine sehr schlechte Wahl für Server, da ein Großteil des Ethernet Packet Handlings mit der Rechner CPU abgehandelt werden. (Deshalb sind diese Karten so billig und werden bevorzugt von Mainboard herstellern im Massenmarkt für Desktop Mainboards verwendet !)
Von solchen Netzwerk Karten darfst du also so oder so schon mal per se keine "Gigabit" Wunder erwarten, da sie nur einen Bruchteil davon schaffen !!
Besser sind NICs mit Intel, Broadcom oder Marvell Chipsätzen oder auch Chipsatz integrierte NICs die das Paket Handling lokal in Hardware machen.

Desweiteren solltest du um strategisch vorzugehen um den Fehler einzukreisen als allererstes einmal eine reine Netzwerk Analyse fahren mit einem kleinen Tool wie NetIO
http://www.nwlab.net/art/netio/netio.html
oder jPerf:
http://www.nwlab.net/know-how/JPerf/
Damit kannst du dann generell erstmal ohne Einfluss eines Protokolls wie SMB/CIFS etc. die nackte Netzwerk Performance messen !
Damit hast du dann erstmal einen Masstab was physisch über dein Netzwerk (Switch, Karten, etc.) überhaupt möglich ist.
Der Rest ist dann abhängig von Server Hardware wie Plattencontroller, Platten, NIC, verwendetes Protokoll usw. usw.
Bitte warten ..
Mitglied: bluebird2000
08.01.2011 um 17:46 Uhr
Okay...Danke!

Werde das mal testen mit einem der Programme.

Mit 60-70 Mb war ich sehr zufrieden eigentlich!
Nur jetzt eben nicht mehr in beide Richtungen

Es handelt sich hier um ein Heimnetzwerk mit Cat.5e Kabeln (350MHz)

Habe mal mit den Jumbo-Frames Einstellungen rumgespielt.

Was bedeutet "Verschiebungs-TCP_GroßeSendung" in Erweitert der Realtek-Karte?
Bitte warten ..
Mitglied: bluebird2000
08.01.2011 um 18:29 Uhr
Hallo nochmal "aqui"

Das kam beim ersten Test raus

TCP connection established.
Packet size 1k bytes: 22475 KByte/s Tx, 24085 KByte/s Rx.
Packet size 2k bytes: 34303 KByte/s Tx, 26399 KByte/s Rx.
Packet size 4k bytes: 54119 KByte/s Tx, 27019 KByte/s Rx.
Packet size 8k bytes: 62158 KByte/s Tx, 26914 KByte/s Rx.
Packet size 16k bytes: 76982 KByte/s Tx, 27065 KByte/s Rx.
Packet size 32k bytes: 23942 KByte/s Tx, 27335 KByte/s Rx.
Done.

Es sagt mir ja genau das wie es auch ist...
Aber warum Rx so wenig ist...???
Bitte warten ..
Mitglied: aqui
08.01.2011 um 22:21 Uhr
30 Mbyte = 240 Mbit/s ist für ein Gigabit Netzwerk (1000 Mbit/s) entschieden zuwenig !!
Der 16k Wert mit 77 Mbyte = 616 Mbit/s ist da schon etwas realistischer.

Der Trend das es mies funktioniert bei kleinen Paketen und besser bei größeren deutet typisch auf einen Billigswitch hin.Deren CPU Performance ist meist Müll im kleineren Paketbereich. Windows Dateitransfers mit SMB/CIFS nutzen zudem ineffizient nur solche kleinen Pakete, deshalb auch deine miese Performance !
Die Asymetrie in den RX und TX Werten ist auch bedenklich ??
Hast du für die Realtek Karte die originalen und aktuellsten Treiber vom Chipsatzhersteller verwendet ??
http://www.realtek.com.tw/downloads/downloadsView.aspx?Langid=1&PNi ...
Das solltest du zwingend tun, bzw. updaten ist das nicht der Fall.
Dasgleiche gilt für den Client und dessen NIC Chipsatz !

Du solltest zudem zwingend einen Vergleichstest mit exakt demselben Setup machen diesmal aber OHNE Switch indem du den Client und den Server direkt mit einem Crossover Ethernet Kabel verbindest. Nur um sicherzugehen das der Switch nicht der böse Buhmann
ist !
Wie sind bei diesem Test die Werte ??
Nutzt du als Clients Winblows XP ??
Wenn ja hast du dort die TCP Windowsize angepasst ?? Die ist eingestellt für ISDN 64kB Transfers im Default !
http://www.heise.de/netze/artikel/TCP-IP-Tuning-221778.html

Wie bereits gesagt Client to Server Back to Back Testwerte wären interessant !!
Bitte warten ..
Mitglied: bluebird2000
09.01.2011 um 01:14 Uhr
@ aqui

So habe jetzt mal neuere Treiber auf beiden Seiten draufmachen können (beides Realtek); sowie Jumbo Frames deaktiviert auf Karten und Switch
und momentan schaut es so aus:

TCP connection established.
Packet size 1k bytes: 26153 KByte/s Tx, 44280 KByte/s Rx.
Packet size 2k bytes: 43692 KByte/s Tx, 50642 KByte/s Rx.
Packet size 4k bytes: 60337 KByte/s Tx, 55724 KByte/s Rx.
Packet size 8k bytes: 78320 KByte/s Tx, 56973 KByte/s Rx.
Packet size 16k bytes: 80273 KByte/s Tx, 57707 KByte/s Rx.
Packet size 32k bytes: 58782 KByte/s Tx, 59004 KByte/s Rx.
Done.

Das mit dem Switch werde ich noch testen... (Aber werde mir kaum einen besseren wie meinen NETGEAR GS108T leisten können)
Dachte eigentlich dass der für Hobby-Netzwerk ganz Gut ist!
Bitte warten ..
Mitglied: bluebird2000
09.01.2011 um 01:35 Uhr
Das Ergebnis mit NETio ohne den Switch(Cross-Kupplung dazwischen):

TCP connection established.
Packet size 1k bytes: 27651 KByte/s Tx, 34102 KByte/s Rx.
Packet size 2k bytes: 46325 KByte/s Tx, 40534 KByte/s Rx.
Packet size 4k bytes: 74119 KByte/s Tx, 52484 KByte/s Rx.
Packet size 8k bytes: 43857 KByte/s Tx, 57345 KByte/s Rx.
Packet size 16k bytes: 53760 KByte/s Tx, 60793 KByte/s Rx.
Packet size 32k bytes: 74461 KByte/s Tx, 63838 KByte/s Rx.
Done.

...was mich allerdings etwas verwundert!

Ach so! Client`s ist Win7 U 64/32er
Bitte warten ..
Mitglied: bluebird2000
09.01.2011 um 14:37 Uhr
Das bekomme ich hin wenn alles wie Exchange-Outlook; RDP; Kaspersky zu AdminKit nicht an ist:

TCP connection established.
Packet size 1k bytes: 36851 KByte/s Tx, 50804 KByte/s Rx.
Packet size 2k bytes: 59260 KByte/s Tx, 59067 KByte/s Rx.
Packet size 4k bytes: 72731 KByte/s Tx, 69914 KByte/s Rx.
Packet size 8k bytes: 79257 KByte/s Tx, 71147 KByte/s Rx.
Packet size 16k bytes: 86040 KByte/s Tx, 72699 KByte/s Rx.
Packet size 32k bytes: 86796 KByte/s Tx, 73929 KByte/s Rx.
Done.


Denke mal das geht für eine Realtek-Verbindung mit Netgear GS108T Verbindung!?

Bringen die INTEL-NIC`s da noch einiges bzw. ist PCI-X 133 besser als z. B. PCIe 1x oder 4x
Bitte warten ..
Ähnliche Inhalte
Windows 7
Client-PCs starten langsam
gelöst Frage von JensDNDWindows 712 Kommentare

Hallo Admins, hab leider in der Suche nichts richtiges dazu gefunden. Einige PCs im Netzwerk starten sehr langsam (ca. ...

Netzwerke

PfSense Netzwerkgeschwindigkeit von Interface zu Interface

Frage von christianWNetzwerke2 Kommentare

Hallo zusammen, ich habe mit der pfSense aktuelles Release (Hardware Apu1C) folgendes Problem. Wenn ich auf Rechner die an ...

Windows Netzwerk

Kopiervorgang von Share zu Client langsam

gelöst Frage von ahussainWindows Netzwerk4 Kommentare

Hallo, ich habe schon X Beiträge zu dieser Frage gelesen, aber nichts hat bisher geholfen. Problem: der Kopiervorgang von ...

Windows Netzwerk

Netzwerkgeschwindigkeit bricht bei Domänenan- und abmeldung zusammen

gelöst Frage von hermesWindows Netzwerk10 Kommentare

Hallo Leidensgenossen, erstmal wünsche ich Euch allen einen guten Start in das neue Jahr ! Seit einigen Wochen kämpfe ...

Neue Wissensbeiträge
Sicherheit
Alexa un Co. TU-Darmstadt entwickelt Anti-Spy Tool
Information von the-buccaneer vor 12 StundenSicherheit3 Kommentare

Moinsen! HR-Info hatte heute ein Feature in dem das "LeakyPick" der TH-Darmstadt vorgestellt wurde. Das Tool existiert bisher nur ...

Linux Tools
Rsync datenvolumen reduzieren mit -fuzzy
Anleitung von NetzwerkDude vor 3 TagenLinux Tools

Moin, aus der Kategorie "Häufig übersehene Parameter": Meistens benutzt kaum jemand den fuzzy Parameter von rsync, und er taucht ...

Sicherheit

Citrix ADC, Gateway u. SD-Wan: Schwachstellen patchen

Information von kgborn vor 5 TagenSicherheit

Keine Ahnung, wie viele Admins von Citrix-Applicances hier unterwegs sind und ob die Versorgung mit Advisories klappt. Aber im ...

Off Topic

Im Tel Raum von Hamburg (040) sind mal wieder viele Indische Microsoft Anrufer unterwegs

Information von TomTomBon vor 6 TagenOff Topic16 Kommentare

Moin Moin, Die sind so schlecht das sogar meine Frau sofort die erkannt hat was die sind. Und Ihr ...

Heiß diskutierte Inhalte
Windows 10
OneDrive: GUI lädt, move nicht
Frage von holliknolliWindows 1028 Kommentare

Hallo liebe alle, befindet sich jemand aus dem Kreise der MS-Developer, speziell Onedrive unter den Teilnehmern hier? Frage: warum ...

Festplatten, SSD, Raid
Backup einer an die FRITZBox angeschlossenen Festplatte
Frage von DJ-KeyFestplatten, SSD, Raid19 Kommentare

Habe eine Frstplatte, die mehrere Partitionen beherbergt. Die Festplatte die an der FRITZ!Box als NAS dient ist schon älter ...

Router & Routing
Fritzbox Feste IP-Adresse Zugang
gelöst Frage von TobiTobiRouter & Routing19 Kommentare

Guten Tag liebes Forum, Ich habe ein Problem wo ich nicht weiterkomme! Situation: Netzwerk: DSL-Modem(daytrec)-OPNSense-Netzwerk Habe aktuell mein Anschluss ...

Exchange Server
Exchange CAL Lizenzen?
gelöst Frage von KleinProfiExchange Server16 Kommentare

Hallo Jungs, wir sind in der Firma 10 Mann, haben aber auf dem Exchange 15 Postfächer bzw. 15 User ...