Routing zwischen 2 Netzwerken mit Routing und Ras W2k8R2 und einem Internet Router

Mitglied: vip3234

vip3234 (Level 1) - Jetzt verbinden

26.07.2011, aktualisiert 18.10.2012, 7081 Aufrufe, 5 Kommentare, 1 Danke

Folgende Konfiguration liegt vor:

______________________________________________________________
- Server 1 ist DC

Server 1 physikalische NIC: (Sicheres Intranet)
IP: 10.10.10.2
Sub: 255.255.255.0
GW: -
DNS: 127.0.0.1

Server 1 virtueller NIC: (Virtuelles Lan zwischen 2 virtualisierten Servern)
IP. 10.100.100.2
Sub: 255.255.255.0
GW: -
DNS: 10.0.0.1

Server 1 führt den Dienst Routing & Ras aus mit folgenden statischen Routen:
Ziel: 10.0.0.0
Sub: 255.255.255.0
GW: 10.100.100.3

Ziel: 0.0.0.0
Sub: 0.0.0.0
GW: 10.0.0.1


______________________________________________________________
Server 2 physikalische NIC: (Unsicheres Netz z.B. Wlan)
IP: 10.0.0.3
Sub: 255.255.255.0
GW: 10.0.0.1
DNS: 10.0.0.1

Server 2 virtueller NIC: (Virtuelles Netz zwischen 2 virtualisierten Servern)
IP. 10.100.100.3
Sub: 255.255.255.0
GW: -
DNS: 10.100.100.2

Server 2 führt auch den Dienst Routing & Ras aus mit folgenden statischen Routen:
Ziel: 10.10.10.0
Sub: 255.255.255.0
GW: 10.100.100.2

Ziel: 0.0.0.0
Sub: 0.0.0.0
GW: 10.0.0.1


______________________________________________________________
Internet Router:
IP: 10.0.0.1
Sub: 255.255.255.0

Er verfügt über 2 statische routen:
Ziel: 10.10.10.0
Sub: 255.255.255.0
GW: 10.0.0.3

Ziel: 10.100.100.0
Sub: 255.255.255.0
GW: 10.0.0.3



______________________________________________________________

Rechner aus dem Intranet (10.10.10.x) und aus dem virtuellen Netz (10.100.100.x) können Rechner aus dem WLAN (10.0.0.x) anpingen und auch erreichen. Und auch umgekehrt.
Allerdings haben die Rechner aus dem 10.10.10.x Netz und der Server1 keinen Zugang zum Internet Router. Die IP 10.0.0.1 ist anpingbar und die Domains z.B. google.de werden aufgelöst jedoch kommt denn "Zielhost nicht erreichbar".

Was muss ich ändern, damit Rechner aus dem Netz 10.10.10.x Zugang zum Internet erlangen ?

Vielen Dank für eure Hilfe.

Gruß,
Waigel



124015ed1ed80df9ba48bd41d1ce0815 - Klicke auf das Bild, um es zu vergrößern
Mitglied: aqui
26.07.2011, aktualisiert 18.10.2012
Vielleicht hilft dir das für die Grundlagen:
https://www.administrator.de/wissen/routing-mit-2-netzwerkkarten-unter-w ...
Vermutlich hast du am Router vergessen die statischen Routen für die Subnetze im Internet Router einzutragen oder sie nicht aktiv oder du hast irgendwo NAT/ICS aktiviert dann sind die Routen eh überflüssig ?!
Oder sofern du NAT/ICS irgendwo machst kann das wie gesagt entfallen aber ob du NAT/ICS machst wird aus deiner Beschreibung leider nicht ersichtlich !
Man müsste an Server 1 auch keine statische Route eintragen. Ein default Gateway Eintrag auf die 10.100.0.1 würde auch reichen, da ja so oder so alles an den Server 2 gesendet werden muss. Eine singuläre statische Route macht da wenig Sinn. (ist aber nicht falsch)

Server 1 virtueller NIC: (Virtuelles Lan zwischen 2 virtualisierten Servern)
IP. 10.100.100.2
Sub: 255.255.255.0
GW: 10.100.100.3
DNS: 10.0.0.1

Hilfreich wären mal die Traceroute und/oder Pathping Outputs aus dem 10.10.0.0er Netz auf die Router IP und/oder eine nackte Internet IP.
Bitte warten ..
Mitglied: vip3234
26.07.2011 um 19:02 Uhr
NAT/ICS wird nicht verwendet.

d.h. an Server 1 keine statischen Routen verwenden, nur einfaches Lan Routing.

Server 1 virtueller NIC: (Virtuelles Lan zwischen 2 virtualisierten Servern)
IP. 10.100.100.2
Sub: 255.255.255.0
GW: 10.100.100.3
DNS: 10.0.0.1

Server 1 physikalische NIC: (Sicheres Intranet)
IP: 10.10.10.2
Sub: 255.255.255.0
GW: -
DNS: 127.0.0.1


und für Clients im 10.10.10.er Netz dann

IP: 10.10.10.x
Sub: 255.255.255.0
GW: 10.10.10.2
DNS 10.10.10.2


Damit sollten dann Client und auch Anfragen von Server 1 immer zu Server 2 weitergeleitet werden und ggf. dann auch über den Internet Router ins Internet. (Nachdem Server 2 die per Routing Table weiß dass er Antworten an die 10.10.10.er Netze über die 10.100.100.2 weiterleiten muss)

Richtig so ?
Bitte warten ..
Mitglied: aqui
26.07.2011 um 23:23 Uhr
Ja, richtig so ! Server 2 muss aber zwingend eine statische Route haben, sonst würde er ja alles durch seinen default Gate Eintrag an den Internet Router schicken auch die Pakete fürs 10.10.0.10 /24 Netz, was natürlich nicht sein darf sonst gehen diese Pakete ins Nirwana.
route add 10.10.0.0 mask 255.255.255.0 10.100.100.2 -p Hast du ja schon richtig gemacht.
Mit route print kanst du die korrekten Routing Tabellen in den Servern überprüfen.
der Internet Router selber muss 2 statische Routen haben:
Zielnetz : 10.10.10.0 Maske: 255.255.255.0 Gateway 10.0.0.3
Gleiches mit dem 10.100.100 /24 Netz.
Dann wäre alles korrekt.
Traceroute und Pathping aus dem 10.10.10.0 /24 Netz sollten dann den korrekten Routing Pfad zeigen.
Bitte warten ..
Mitglied: vip3234
27.07.2011 um 12:58 Uhr
Danke dir !

Interessanterweise hatte ich das gestern schon einmal so eingerichtet INKL. den statischen Routen auf dem Internet Router. Hat aber nicht funktioniert.

Heute wollte ich nochmal ganz frisch anfangen und habe die NICs im Gerätemanager von Server 1 deinstalliert, neugestartet und alles neu eingerichtet.
Siehe da, es funktioniert.

Danke nochmal aqui für die Hilfe.
Bitte warten ..
Mitglied: aqui
27.07.2011 um 13:46 Uhr
Alles wird gut .... :-) face-smile
Bitte warten ..
Heiß diskutierte Inhalte
Zusammenarbeit
Klimaschutz
NebellichtVor 1 TagTippZusammenarbeit56 Kommentare

Hallo friends, (friends in Anlehnung an die vielen Fs in dem englischen von FFF: fridays for future. Übrigens am 19.03.2021 gibts wieder einen globalen ...

Hyper-V
ESXi free oder Windows Hyper-V Server 2019
lukas0209Vor 1 TagAllgemeinHyper-V20 Kommentare

Hallo, ich brauche ca. 2 oder 3 Windows 10 virtualisiert um Dinge zu testen. Ist es dafür sinnvoller ein Windows Hyper-V Server 2019 (kostenlos) ...

Microsoft Office
Microsoft365 und Outlook verbinden
ratzekahl1Vor 1 TagFrageMicrosoft Office31 Kommentare

Guten Morgen zusammen, ich habe einige Probleme / Fragen. Ich habe Office 365 auf den ersten Rechnern installiert. Admin angelegt, Benutzer usw. Da ich ...

Off Topic
Nach 700 Tagen adwcleaner
altmetallerVor 1 TagAllgemeinOff Topic8 Kommentare

Hallo, ich habe in meinem Netzwerk diverse Maßnahmen, um nicht nur Angriffe, sondern auch - sagen wir mal - unerwünschte Datenabflüsse und Tracking zu ...

Server-Hardware
Was bedeuten die Abkürzungen beim HPE-Server wie z.B. NC, Mod-X?
gelöst kaineanungVor 1 TagFrageServer-Hardware19 Kommentare

Hallo Leute, ich habe ein HPE-Serverangebot vorliegen bei dem ich an 1-2 Positionen nicht weiß was diese überhaupt bedeuten. Suche ich im Internet danach ...

Netzwerkgrundlagen
DS-Lite Verständnisfrage Wireguard
gelöst fnbaluVor 1 TagFrageNetzwerkgrundlagen19 Kommentare

Hallo zusammen, bisher läuft bei mir alles klassisch. pfSense mit DDNS und ich verbinde mich mit OpenVPN in das Heimnetz und erspare mir so ...

Exchange Server
0-day Exploit Chain für Exchange Server - Patches verfügbar
kgbornVor 1 TagInformationExchange Server6 Kommentare

Zur Info: Microsoft warnt vor einer Exploit-Chain, bei der vier 0-day-Schwachstellen für gezielte Angriffe auf Exchange per Outlook Web App kombiniert werden (eine chines. ...

Microsoft Office
Jubiläen in Outlook 2016 korrekt eintragen
imebroVor 1 TagFrageMicrosoft Office16 Kommentare

Hallo an Alle. Wir haben nur einen recht kleinen Mitarbeiterkreis. Da in der Vergangenheit schon mehrfach versäumt wurde, Kolleg/-innen zu Betriebs-Jubiläen zu gratulieren, würde ...