getuemii
Goto Top

USB Diskettenlaufwerk mit ASR Wiederherstellung

Hallo @all,

ich habe mir in den Kopf gesetzt, endlich mal aus den beiden 500er SATA-Platten in meinem Rechner ein RAID1 zu bauen. Also ein ASR-Backup gemacht und die Daten gesichert. Dann das SATA-RAID gebaut, den OEM-Treiber für das SATA-RAID geholt und mit auf die ASR-Diskette gepackt.

Nach dem Start des Setup erst F6 (für den neuen Treiber) und dann F2 (für die Systemwiederherstellung) gedrückt. Treiber wird abgefragt und von der Diskette geladen. Danach wird der Monitor schwarz (IMHO wird die Kontrolle an der Stelle vom Setup übernommen).

Wenn nun der Monitor wieder auf den blauen Setuphintergrund zurückgeht, werde ich mit der folgenden Info begrüßt:
"Setup kann nicht fortgesetzt werden. Es konnte kein Diskettenlaufwerk gefunden werden. Drücken Sie F3, um Setup zu beenden."

Muß ich jetzt echt im "Hardwarelager" ein internes Diskettenlaufwerk suchen und es temporär in die Kiste mimen? Oder hat jemand eine zündende Idee?

Kopfschüttelnd, geTuemII

Content-Key: 86266

Url: https://administrator.de/contentid/86266

Printed on: April 25, 2024 at 11:04 o'clock

Member: LordGurke
LordGurke Apr 23, 2008 at 21:49:28 (UTC)
Goto Top
Zwei Ideeen sogar:

- Lässt sich im BIOS eventuell explizit einstellen, dass USB-Speicher auch ohne Betriebssystem (nennt sich je nach Hersteller USB-Thumb-Driver oder USB-Disk-Support usw...) erkannt werden?

- Erstelle dir mit nLite eine personalisierte Setup-CD und binde einfach die Treiber bereits dort ein, dann brauchts keine Diskette mehr.
Member: geTuemII
geTuemII Apr 23, 2008 at 21:55:25 (UTC)
Goto Top
Zwei Ideeen sogar:
Das ist ja heldenhaft face-smile

- Lässt sich im BIOS eventuell explizit einstellen, dass USB-Speicher auch
ohne Betriebssystem (nennt sich je nach Hersteller USB-Thumb-Driver oder
USB-Disk-Support usw...) erkannt werden?
Da sehe ich morgen mal nach, das könnte was sein.

- Erstelle dir mit nLite eine personalisierte Setup-CD und binde einfach
die Treiber bereits dort ein, dann brauchts keine Diskette mehr.
Ich bin ja immer für nLite zu haben, aber in diesem Fall bringt das nichts. ASR besteht stoisch auf der Diskette. In diesem Punkt ist MS wiedermal seiner Zeit weit voraus. face-wink

geTuemII
Mitglied: 54487
54487 Apr 23, 2008 at 22:36:07 (UTC)
Goto Top
Nlite ist m. E. so lange nicht empfehlenswert, wie der Entwickler zwingend dieses dämliche .NET voraussetzt.

Eine Alternative, die genauso empfehlenswert ist und ohne auskommt, ist
http://winfuture.de/xpisobuilder

Da das Setup von W2k/XP zwingend ein Diskettenlaufwerk erwartet (wahrscheinlich werden die Funkionen über die Diskettenports angesprochen), könnte ich mir vorstellen, dass mit USB nichts funktionieren wird.
Mitglied: 60730
60730 Apr 24, 2008 at 14:39:39 (UTC)
Goto Top
Da das Setup von W2k/XP zwingend ein Diskettenlaufwerk erwartet (wahrscheinlich
werden die Funkionen über die Diskettenports angesprochen), könnte ich
mir vorstellen, dass mit USB nichts funktionieren wird.

Fast richtig - das dumme an der Sache ist wirklich - es kommt auf das Floppylaufwerk, bzw. den Apater auf USB an - ob es geht oder nicht.

"Lustigerweise" hab ich für diese Zwecke eine Apple USB Floppy (eingebaut ist ein Samsung Laufwerk), das mich bisher in diesem Zusammenhang immer gerettet hat.

Auch wenn ein HP USB Laufwerk am HP Server nicht erkannt wurde, das Apple wird immer erkannt.
(beim starten wird zwar immer der Bootblock gesucht {Motor springt an} -das wars dann aber auch )

Probier daher mal ein anderes Laufwerk - am besten von Samsung.
Member: geTuemII
geTuemII Apr 24, 2008 at 15:57:48 (UTC)
Goto Top
Ich habe mich für die Variante "Hardwarelager" entschieden.

Aber evtl. kann mir doch noch jemand erklären, warum der RAID-Treiber von der Diskette geladen wird und selbiges im weiteren Verlauf des Textsetups nicht mehr erkannt wird. Der RAID-Treiber ändert doch nichts an USB oder Diskettenlaufwerk?!

geTuemII
Mitglied: 60730
60730 Apr 24, 2008 at 16:04:14 (UTC)
Goto Top
Hi geTuemII,

also ich kanns dir auch nicht sagen, warum es so ist.

Vermuten tue ich folgendes:

Beim ersten einlesen des Laufwerkes (da funktionierts noch) wird das Bios "gefragt"
Danach läuft ja der ganze Treiber Schmonz von Wind00f und der erkennt wohl "irgendwas" hängt an USB aber nicht mehr das Laufwerk, das "dahinter" ist.

Wie gesagt, ich bin da auch schon wie Rumpelstilzchen um den (die) Server gehoppelt, bis ich mal das Apple Laufwerk (ursprünglich) zum Spass angeschlossen habe.
Mitglied: 54487
54487 Apr 24, 2008 at 18:46:18 (UTC)
Goto Top
Aber evtl. kann mir doch noch jemand erklären, warum der RAID-Treiber von der
Diskette geladen wird und selbiges im weiteren Verlauf des Textsetups nicht mehr
erkannt wird.

Da oben steht zwar
Treiber wird abgefragt und von der Diskette geladen.
bloß ob nur auf der Diskette gesucht wurde, ob die Diskette vielleicht fehlerhaft, der richtige Treiber drauf war und auch wirklich geladen wurde, geht aus dieser Bemerkung nicht hervor, das ist lediglich eine - zumindest von mir - nicht überprüfbare Behauptung. face-wink
Außerdem steht dort noch was von Systemwiederherstellung, die dazwischengefunkt hat.
Woraus schließt du belegbar, dass der richtige Treiber auch wirklich geladen wurde?
Member: geTuemII
geTuemII Apr 24, 2008 at 19:16:10 (UTC)
Goto Top
bloß ob nur auf der Diskette gesucht wurde, ob die Diskette vielleicht fehlerhaft,
der richtige Treiber drauf war und auch wirklich geladen wurde, geht aus dieser
Bemerkung nicht hervor, das ist lediglich eine - zumindest von mir - nicht
überprüfbare Behauptung. face-wink
Du glaubst mir aber auch gar nichts face-wink

Woraus schließt du belegbar, dass der richtige Treiber auch wirklich geladen wurde?

  • Wenn keine Diskette im Laufwerk lag (normaler Start des Setups , auch ohne ASR-F2-Drückerei), wurden keine Festplatten erkannt.
  • Setup hat auf die Diskette hörbar zugegriffen, danach waren die Platten im normalen Setup verfügbar.
  • Nachdem ich ein altes internes DiskettenLW aus dem "Hardwarelager" gefischt und an den Rechner gemimt hatte, lief sowohl das RAID als auch das ASR.
Ist das Beleg genug? face-smile

Scheint sich also um ein Windows-Feature zu handeln. Offenbar funktionieren USB-DiskettenLW zwar, solange die Kontrolle beim BIOS liegt, sobald aber Windows übernimmt, werden nur noch bestimmte Typen unterstützt. Mir ist dazu auch ein KB-Artikel über den Weg gelaufen, den ich aber wieder verbuddelt habe.

geTuemII
Mitglied: 54487
54487 Apr 24, 2008 at 19:34:49 (UTC)
Goto Top
Das mag sein, was mich stutzig gemacht hatte, war die Systemwiederherstellung, die nach der Treiberinstallation gelaufen war. Wenn dabei Hardwareeinstellungen erneuert wurden, könnten dir die passenden Treiber wieder gefehlt haben.
Und ja, USB während des und nach dem Setup wird von Windows etwas merkwürdig behandelt. Das ist auch einer der Gründe, warum Booten von USB selten funktioniert und von MS nicht unterstützt wird. face-wink

Der Artikel trifft zwar nicht den Kern, ist aber vielleicht doch was für deine Sammlung. ;)
http://www.microsoft.com/whdc/archive/usb-boot.mspx