swisstom
Goto Top

Windows 10 Display-Sprache mit GPO setzen

Moinmoin

Ich habe folgendes Problem:

Wir sind dabei, in unserer Domäne die PCs von W7 auf Win10 upzugraden.
Dis klappt soweit ganz gut.

Nach dem Upgrade sind unter "Systemsteuerung/Sprache" folgende Sprachen in dieser Reihenfolge installiert: Deutsch (Deutschland), Deutsch (Schweiz), Französisch (Schweiz).
Bei uns müsste jedoch Deutsch (Schweiz) zu oberst stehen und die anderen Sprachen werden nicht benötigt.

Dies spielt u.a. eine Rolle bei der Anmeldung (mit Sonderzeichen im Passwort), wie auch (wie wir soeben feststellen mussten) bei Berechnung-Makros im Office z.B. für Kosten.

Per GPP setze ich folgende Einstellungen:
HKEY_CURRENT_USER\Keyboard Layout\Preload REG_SZ 00000807
HKEY_LOCAL_MACHINE\SYSTEM\Keyboard Layout\Preload REG_SZ 00000807

Dies ändert allerdings nichts an der Display-Sprache bzw. Reihenfolgen.

Gibt es per GPO eine Möglichkeit, nicht benötigte Sprachen gleich zu entfernen oder die Reihenfolge anzupassen?
Oder wie löst ihr dieses Problem?

Besten Dank für die Hilfe

Gruss Swisstom

Content-Key: 304985

Url: https://administrator.de/contentid/304985

Printed on: May 24, 2024 at 10:05 o'clock

Mitglied: 129413
129413 May 20, 2016 updated at 08:28:58 (UTC)
Goto Top
Findest du hier:
Computerkonfiguration\Richtlinien\Administrative Vorlagen\System\Systemsteuerung\Regions- und Sprachoptionen
  1. Von Windows für alle angemeldeten Benutzer verwendete Benutzeroberflächensprache einschränken
  2. Außerkraftsetzen der Benutzeroberflächensprache des Benutzers durch die des Systems erzwingen

Es sei aber vermerkt das es eine Oberflächensprache Deutsch(Schweiz) nicht gibt. Die Anzeigesprache ist hier primär "Deutsch". Das (Schweiz) ist nur für die Eingabemethode als Tastaturlayout. Wenn du das also ändern willst musst du also nicht die Display-Sprache ändern sondern das Tastaturlayout für Systemkonten, denn am Anmeldebildschirm wird die "Systemeinstellung" verwendet.

Die Einstellungen lassen sich so auf den Welcome-Screen kopieren:
http://superuser.com/questions/706207/win7-keyboard-layout-change-from- ...
Geht abweichend so auch unter Windows 10 !

Gruß skybird
Member: swisstom
swisstom May 20, 2016 at 09:06:33 (UTC)
Goto Top
Hallo Skybird

Das haben wir soeben ausprobiert.

Aber da beim Login die Reihenfolge mit Deutsch (Deutschland) beginnt, schreibt er dort statt $ das Zeichen #.
Es müsste also bereits vor dem Login auf Deutsch (Schweiz) gesetzt werden...

Gruss Swisstom
Mitglied: 129413
129413 May 20, 2016 updated at 10:00:17 (UTC)
Goto Top
http://www.powershellmagazine.com/2014/03/24/set-keyboard-layouts-avail ...

Die "Preload"-Settings hier festlegen:

HKEY_USERS\.DEFAULT\KeyboardLayout\Preload
HKEY_USERS\S-1-5-18\KeyboardLayout\Preload
HKEY_USERS\S-1-5-19\KeyboardLayout\Preload

Oder wie oben die gewünschten Einstellungen über den Dialog auf die Systemkonten kopieren
Member: swisstom
swisstom Aug 10, 2016 at 05:59:14 (UTC)
Goto Top
Hallo

Etwas spät...
...aber hier noch die Lösung, welche wir nun anwenden:

https://msdn.microsoft.com/en-us/goglobal/bb964650

Über eine GPO rufen wir beim Login ein Script-File auf, welches dann das entsprechende XML-File anwendet.

<gs:GlobalizationServices xmlns:gs="urn:longhornGlobalizationUnattend"> 
    <!--User List-->
    <gs:UserList>
        <gs:User UserID="Current" CopySettingsToSystemAcct="true" CopySettingsToDefaultUserAcct="true" />  
    </gs:UserList>

    <!--Display Language--> 
    <gs:MUILanguagePreferences> 
        <gs:MUILanguage Value="de-DE" />  
        <gs:MUIFallback Value="en-US" />  
    </gs:MUILanguagePreferences> 

    <!--User Locale-->
    <gs:UserLocale> 
        <gs:Locale Name="de-CH" SetAsCurrent="true" ResetAllSettings="false"/> 
    </gs:UserLocale>

    <!--input preferences--> 
    <gs:InputPreferences> 

        <!--de-CH--> 
        <gs:InputLanguageID Action="add" ID="0807:00000807" Default="true"/>  

        <!--en-US--> 
        <gs:InputLanguageID Action="remove" ID="0409:00000409"/>  

        <!--de-DE--> 
        <gs:InputLanguageID Action="remove" ID="0407:00000407"/>  

        <!--fr-CH-->
        <gs:InputLanguageID Action="remove" ID="100c:0000100c"/>  
    </gs:InputPreferences> 

    <!--location--> 
    <gs:LocationPreferences> 
        <gs:GeoID Value="223"/>  
    </gs:LocationPreferences>
</gs:GlobalizationServices>  


So können wir dann die gewünschte Sprache als Standard setzen.

Danke trotzdem für die Mithilfe.

Beste Grüsse
Swisstom
Member: manuwj
manuwj Dec 07, 2016 at 10:08:23 (UTC)
Goto Top
Stehe vor der gleichen Herausforderung.

Ich habe zwar den Artikel von Microsoft gelesen, doch verstehe ich nicht ganz, WIE genau ich jetzt das erstellte XML per GPO laden/verteilen soll.

Könntest du mir das nochmals erklären?

Vielen Dank. Manuwj
Member: swisstom
swisstom Dec 09, 2016 at 11:44:18 (UTC)
Goto Top
Hallo Manuwj

Sorry, für die späte Antwort. Ich musste noch Geschenke für Weihnachten einkaufen... face-smile

1. Also, das XML habe ich auf in folgendem Pfad "\\unserServer\netlogon" abgelegt (auch "\\unsereDomain\netlogon" würde passen).

2. In gleichem Pfad habe ich eine Batch-Datei (Language-Settings_Win10.bat) abgelegt, mit folgendem Inhalt:
control intl.cpl,, /f:"\\unserServer\netlogon\language.xml"  

3. Nun muss der Batch mit Anmeldeskript in einer GPO auf die OU, welche eure User beinhaltet, angewendet werden:

1

2

Computer neu starten und Anmelden, dann müsste die Sprache entsprechend dem XML eingestellt sein.

Viel Glück

Gruss Swisstom
Member: manuwj
manuwj Dec 14, 2016 at 06:56:31 (UTC)
Goto Top
Vielen vielen herzlichen Dank. Funktioniert bestens face-smile
Gruss, Manuwj