Zeitstempel mit Robocopy kopieren

hokaido
Goto Top
Hallo,

ich spiegel ein lokales Laufwerk per Robocopy auf ein webdav Laufwerk:
Robocopy "Y:\Wissen" "U:\Wissen" /MIR /MT:3 /LOG+:"Y:\Wissen.log" /TEE

Leider werden mir dabei die Dateiattribute nicht mitkopiert. Ich hätte gerne die Erstellungsdaten so, wie auf dem Quelllaufwerk. Andernfalls kopiert Robocopy bei jedem Durchlauf wieder alle Dateien, da die Zeitstempel nciht passen.

Geht das mit dem Befehl?

Danke & Grüße

Stefan

Content-Key: 584999

Url: https://administrator.de/contentid/584999

Ausgedruckt am: 19.08.2022 um 12:08 Uhr

Mitglied: em-pie
em-pie 04.07.2020 um 16:14:33 Uhr
Goto Top
Moin,

bau mal den Parameter /COPYALL mit ein

Gruß
em-pie
Mitglied: Penny.Cilin
Penny.Cilin 04.07.2020 um 16:40:33 Uhr
Goto Top
Zitat von @em-pie:

Moin,

bau mal den Parameter /COPYALL mit ein
Öhm, dann muss er Robocopy aber im elevated prompt (erweiterten Rechten) starten. Sprich die Eingabeaufforderung (CLI ==> Command line interface) als Administrator starten.

Gruß
em-pie

Gruss Penny.
Mitglied: em-pie
em-pie 04.07.2020 um 16:55:32 Uhr
Goto Top
Zitat von @Penny.Cilin:

Zitat von @em-pie:

Moin,

bau mal den Parameter /COPYALL mit ein
Öhm, dann muss er Robocopy aber im elevated prompt (erweiterten Rechten) starten. Sprich die Eingabeaufforderung (CLI ==> Command line interface) als Administrator starten.
Jo, aber er sprach ja nicht davon, dass er das Script Interaktiv laufen lässt. Ich ging von einem geplanten Task via passenden Rechten aus...

Ansonsten den Parameter /COPY:S verwenden, wenn es NUR um Zeitstempel geht
Mitglied: hokaido
hokaido 04.07.2020 aktualisiert um 22:05:45 Uhr
Goto Top
Ich löse den Auftrag manuell via Batch Datei aus.
Wenn ich wie vorgeschlagen /COPY:S hinzüfüge, erhalte ich diese Fehlermeldung:

Robocopy "Y:\Wissen" "U:\Wissen" /MIR /COPY:S /MT:3 /LOG+:"Y:\Wissen.log" /TEE

HINWEIS: Sicherheit kann nicht kopiert werden. Quelle unterstützt möglicherweise keine persistenten ACLs.

HINWEIS: Sicherheit kann nicht kopiert werden. Ziel unterstützt möglicherweise keine persistenten ACLs.
Mitglied: emeriks
emeriks 06.07.2020 um 09:32:37 Uhr
Goto Top
Hi,
Zitat von @Penny.Cilin:
Öhm, dann muss er Robocopy aber im elevated prompt (erweiterten Rechten) starten.
Nein, muss nicht.
Nur, wenn Schalter /B angegeben wird oder wenn der Benutzer seine Rechte zum Lesen (Quelle) und/oder Schreiben (Ziel) der ACL über eine der über UAC geschützten Gruppen erlangt.

E.
Mitglied: hokaido
hokaido 06.07.2020 um 10:56:46 Uhr
Goto Top
Also /COPY:S oder /COPYALL funktionieren nicht, s.o.

Gibt vll. andere Möglichkeiten, evtl. Freeware Sync Tools, z.B. Synbackfree?
Mitglied: emeriks
emeriks 06.07.2020 um 11:40:42 Uhr
Goto Top
Worum geht es jetzt eigentlich? Um Zeitstempel oder Attribute?
Für Zeitstempel gibt es noch den Schalter /FFT
Mitglied: hokaido
hokaido 06.07.2020 um 12:04:42 Uhr
Goto Top
Zeitstempel
Mitglied: Dilbert-MD
Dilbert-MD 06.07.2020 um 16:13:34 Uhr
Goto Top
Hallo,

es gibt noch den Schalter /dcopy:T für die Zeitstempel (erweitert /dcopy:DAT)

Möglicherweise liegt es auch daran, dass der root-Ordner nicht richtig kopiert wird dann Zeitstempel verloren gehen können.
Was passiert, wenn Du statt /MIT den Schalter /e benutzt beim ersten mal Kopieren?

Gruß
Mitglied: hokaido
hokaido 08.07.2020 um 23:15:26 Uhr
Goto Top
Ich nutze nirgendwo /MIT....
Mitglied: hokaido
hokaido 26.08.2020 aktualisiert um 21:57:39 Uhr
Goto Top
Leider ist das Problem immer noch gelöst. Hat jemand noch eine Idee?

Alternative Lösungen gehen natürlich auch. Muss kein Robocopy sein.
Mitglied: em-pie
em-pie 26.08.2020 um 22:07:02 Uhr
Goto Top
Moin,

welche ROBOCOPY-Version nutzt du eigentlich?

die ersten Versionen hatten da ein Problem mit dem übernehmen von Zeitstempeln von Ordnern...
Mitglied: hokaido
hokaido 26.08.2020 aktualisiert um 22:10:56 Uhr
Goto Top
Na die in der aktuellsten Win10 Version
Anmerkung: Bei lokalen Laufwerken klappt es, es liegt an der Kombi Webdav