Werte in der Registry werden nicht angewendet

marcys
Goto Top
Hallo,

ich habe ein Problem mit der Registry.

Und zwar setze ich die Werte für den Proxy nicht über den Internetexplorer - Extras-Internetoptionen-Verbindungen -LAN Einstellungen sondern über den Registryeintrag

HKEY_Current_User\Software\Microsoft\Windows\CurrentVersion\Internet Settinngs

Hier die Eingräe:

Proxyserver: 123.123.123.123:8080
ProxyEnable: 1
ProxyOverride:

Insbesondere habe ich Probleme mit dem ProxyOverride. Dort trage ich die Adressen ein, die lokal vom Proxyserver umgegangen werden sollen. Wenn dort eine Adresse steht, ist auch im IE der Haken bei "Proxyserver für lokale Adressen umgehen" drin. Ist der Registry Eintrag leer. Ist auch der entsprechende Haken weg.

Doch trotz Eintrag in der Registry der Adresse unter ProxyOverride erscheint der Haken im IE nicht. Und ich weiß nicht woran es liegt. Die Einträge: Proxyserver und ProxyEnable funktionieren. D. h. wenn ich dort etwas ändere, sind die Änderungen auch in im IE sichtbar.

Komischerweise ist es nicht an allen Clients.

Gruß
Martin

Content-Key: 281707

Url: https://administrator.de/contentid/281707

Ausgedruckt am: 28.05.2022 um 17:05 Uhr

Mitglied: Pjordorf
Lösung Pjordorf 01.09.2015 aktualisiert um 15:04:50 Uhr
Goto Top
Hallo,

Zitat von @Marcys:
Doch trotz Eintrag in der Registry der Adresse unter ProxyOverride erscheint der Haken im IE nicht.
Oben hast du aber gerade etwas anderes behauptet. Was denn nun?
Welche OSe sind involviert?
Welche Browser Versionen sind involviert?

Komischerweise ist es nicht an allen Clients.
Was unterscheidet die Clients voneinander?
GPOs?

Gruß,
Peter
Mitglied: fdiv-bug
fdiv-bug 01.09.2015 aktualisiert um 15:16:31 Uhr
Goto Top
ich habe mir ein BAT-script gebastelt, welches den aktuell gewünschten proxy für mich einstellt:


(die BAT muss als Admin ausgeführt werden)

funktioniert auch, allerdings muss bei proxy-änderung mit dem script, bei laufendem IE, der IE anschließend einmal neu gestartet werden (stört mich aber nicht).

für einen proxy via "Script für automatische Konfiguration" habe ich ein etwas anderes script...
Mitglied: Marcys
Marcys 01.09.2015 um 15:15:52 Uhr
Goto Top
Zitat von @Pjordorf:

Hallo,

> Zitat von @Marcys:
> Doch trotz Eintrag in der Registry der Adresse unter ProxyOverride erscheint der Haken im IE nicht.
Oben hast du aber gerade etwas anderes behauptet. Was denn nun?
Welche OSe sind involviert?
Welche Browser Versionen sind involviert?


Oben habe ich beschrieben, wie das Verhalten des Registryeintrages sein sollte.


Des Weiteren haben beide IE11, Win 7 und die gleichen GPO's
Mitglied: Marcys
Marcys 01.09.2015 um 15:28:03 Uhr
Goto Top
Hallo,

also ich habe die Lösung.

In dem Eintrag Proxyoverride habe ich zuvor

meinserver.prt.com

eintetragen.

nun habe ich
<local>;meinserver.prt.com

eingetragen und jetzt klappt. es.