lochkartenstanzer
Goto Top

Windows 10 (1709) Tastur und Maus wieder einschalten?

Moin,

Ich habe von einem Kunden einen Win10-Rechner bekommen, bei dem weder Tastatur noch Maus geht. Die Hardware funktioniert einwandfrei, sowohl im BIOS als auch mit Live-Systemen (ubuntu, knoppix, windows-togo, WinPE, etc). Sobald Windows startet, sieht man, daß die Maus und die Tastatur "ausgeschaltet" werden. Wenn man die USB-Teile umstöpselt, oder andere dazustöpselt, erkennt man, das die Hardware-Erkennung ordentlich funktioniert. Aber sobald die Treiber installiert sind, werden die Eingabegeräte wieder deaktiviert. Im abgesicherten Modus passiert übrigens dasselbe.

Natürlich ist es in so einer Situation etwas schwierig, Einstellungen an Windows vorzunehmen.

Hat jemand irgendeinen Tipp für mich, wie ich Windows 10 dazu bringen kann, die Treiber rauszuwerfen und frisch von Windows-Update zu holen? ich stehe momentan auf dem Schlauch.

lks

Content-Key: 365211

Url: https://administrator.de/contentid/365211

Printed on: February 25, 2024 at 05:02 o'clock

Mitglied: 135333
135333 Feb 19, 2018 updated at 10:29:50 (UTC)
Goto Top
Hi.
Prüf mal ob es Skripte/Tasktrigger gibt die mit devcon die eingestöpselte Hardware prüfen. Da wird gerne mit gebastelt wenn bestimmte USB-Hardware nicht verwendet werden soll (DLP/Sicherheit/etc.). Wenn man da die falschen Klassen (HID) oder HardwareIDs hinterlegt sperrt man sich schnell seine Eingabegeräte aus.
So was bieten auch viele Security-Suites an, dort also auch mal nachhaken/deaktivieren/deinstallieren.

Gruß Snap
Member: Looser27
Looser27 Feb 19, 2018 at 10:32:13 (UTC)
Goto Top
Moin,

ist irgendeine AV-Software drauf, die USB-Ports sperrt? Einen PS/2 Anschluß hat das Teil wahrscheinlich nicht mehr....?
Hast Du mal versucht im Bios den USB-Controller zu deaktivieren? Anschließend booten. Dann nochmal ins Bios und wieder aktivieren?
Vielleicht kann man evtl. Software-Lösungen so "aushebeln".

Gruß

Looser
Member: Looser27
Looser27 Feb 19, 2018 at 10:33:01 (UTC)
Goto Top
Edit: Vielleicht kommst Du per Remote auf den PC?
Member: Lochkartenstanzer
Lochkartenstanzer Feb 19, 2018 at 10:37:48 (UTC)
Goto Top
Zitat von @135333:

Hi.
Prüf mal ob es Skripte/Tasktrigger gibt die mit devcon die eingestöpselte Hardware prüfen. Da wird gerne mit gebastelt wenn bestimmte USB-Hardware nicht verwendet werden soll (DLP/Sicherheit/etc.).

Glaub ich eher nciht. Das ist ein Privat-Kunde, d-h ein älterer herr, de die Kiste als "Schreibmaschine" nutzt. da wären solche Sachen kaum zu erwarten.

lks
Mitglied: 135333
135333 Feb 19, 2018 updated at 10:40:06 (UTC)
Goto Top
Auf "Ungeziefer" hast du schon offline geprüft?
Member: Lochkartenstanzer
Lochkartenstanzer Feb 19, 2018 at 10:39:36 (UTC)
Goto Top
Zitat von @Looser27:

Moin,

ist irgendeine AV-Software drauf, die USB-Ports sperrt?

Scheint nur defender drauf zu sein.
Einen PS/2 Anschluß hat das Teil wahrscheinlich nicht mehr....?

Nö.

Hast Du mal versucht im Bios den USB-Controller zu deaktivieren? Anschließend booten. Dann nochmal ins Bios und wieder aktivieren?
Vielleicht kann man evtl. Software-Lösungen so "aushebeln".

Ich hatt enoch nicht viel zeit das eingehender zu analysieren. Bin momentan am ideen sammeln, wie man an die Kiste kommen könnte.

lks
Member: Lochkartenstanzer
Lochkartenstanzer Feb 19, 2018 at 10:40:18 (UTC)
Goto Top
Zitat von @Looser27:

Edit: Vielleicht kommst Du per Remote auf den PC?

Das wäre ja zu einfach. face-smile

Nee, ist ein Home-PC, nichts mit remote draufschalten.

lks
Member: Lochkartenstanzer
Lochkartenstanzer Feb 19, 2018 at 10:40:55 (UTC)
Goto Top
Zitat von @135333:

Auf "Ungeziefer" hast du schon offline geprüft?

Der scan mit desinfect läuft noch, sieht aber nciht so aus, als ob da was wäre,.

lks
Member: Kraemer
Kraemer Feb 19, 2018 at 10:44:16 (UTC)
Goto Top
Moin lks,

wenn du weißt welche Treiber für die Geräte verantwortlich sind, kannst du diese in der recovery-console deaktivieren (LISTSVC , DISABLE)

Gruß

PS: Klingt nach Logitech!?
Member: Looser27
Looser27 Feb 19, 2018 at 10:47:58 (UTC)
Goto Top
Glaub ich eher nciht. Das ist ein Privat-Kunde, d-h ein älterer herr, de die Kiste als "Schreibmaschine" nutzt. da wären solche Sachen kaum zu erwarten.

DAS sind die schlimmsten User. Aus Erfahrung weiß ich, dass die ohne Sinn und Verstand alles installieren, was nicht bei 3 auf den Bäumen ist.
Daher ist die Idee mit einer verseuchten Kiste gar nicht so verkehrt......
Member: em-pie
em-pie Feb 19, 2018 at 11:57:20 (UTC)
Goto Top
Moin,

per LiveLinux die TeamViewer QS in das Autostartverzeichnis kopieren und beim STart dann am Bildschirm ID und PWD ablesen....

Das wäre jetzt so das schnellste, was mir einfällt...

Gruß
em-pie
Member: slauf82
slauf82 Feb 19, 2018 at 12:25:50 (UTC)
Goto Top
Nimm irgendwelche anderen Geräte, die funktionieren und dann kannst Du im Geräte-Manager die falschen Geräte löschen ! Beim Löschen wirst Du dann gefragt, ob Du die Treiber mitlöschen willst, dort sagst Du einfach ja !
Member: Archeon
Archeon Feb 19, 2018 updated at 12:28:18 (UTC)
Goto Top
Mahlzeit,

du könntest noch mit einem Offline Registry Editor folgende Schlüssel prüfen:
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Kbdclass
HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Mouclass
HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\usbhub
Hier jeweils den Wert von "Start" überprüfen, steht der Wert auf "0" oder "4" werden die Eingabegeräte bzw. USB Schnittstellen deaktiviert.

Gruß
Member: Looser27
Looser27 Feb 19, 2018 at 12:26:43 (UTC)
Goto Top
Zitat von @slauf82:

Nimm irgendwelche anderen Geräte, die funktionieren und dann kannst Du im Geräte-Manager die falschen Geräte löschen ! Beim Löschen wirst Du dann gefragt, ob Du die Treiber mitlöschen willst, dort sagst Du einfach ja !

Das funktioniert aber nur, wenn überhaupt eine Tastatur / Maus funktioniert. Tut es aber scheinbar nicht.
Member: chgorges
chgorges Feb 19, 2018 at 12:43:32 (UTC)
Goto Top
Im BIOS gibts je nach Modell auch noch ein paar USB-Optionen, XHCI-Handsoff oder änhliches, da kann man auch sein Glück versuchen, weil diese Symptome bis nach zu Windows 7 zurück reichen.
Member: Zumfra
Zumfra Feb 19, 2018 at 15:42:42 (UTC)
Goto Top
Hi! Nach dem Motto weniger ist mehr, hast du beide raus genommen, neugestartet und dann reingesteckt?
Klingt witzig aber ist mir letztens passiert.
Eine Kundin, rief an: Bildschirm ganz schwarz, Maus noch zu bewegen aber ohne Funktion.
Ich habe mir einen Wolf gesucht bis ich auf einmal einen anderen USB Steckplatz probieren wollte, habe die Maus raus gesteckt und Ta Daaaa!
Bildschirm ging an, und alles war wieder Ok!
Manchmal sind die einfache Wege die wirksamsten!
Member: Lochkartenstanzer
Lochkartenstanzer Feb 19, 2018 at 17:53:24 (UTC)
Goto Top
Moin,

war unterwegs beim (anderen) Kunden und konnte eswegen nicht zeitnah antworten. Deswegen jetz teine Sammeantwort:

Hab die Kiste gerade mal angeworfen, Als erstes rennt da ein schottischer Affe, spric McAfee los. Danach kommen irgend wann Blubberblasen als Bildschirmschoner und man sieht ncihts mehr. Und grad fällt mir auf, daß der Virenscan, den ich heute morgen gestartet habe nicht mehr läuft. das köntne aber auch am desingfect liegen. Die letzte Version ist da manchmal zickig.

zum Thema "funktionierende" Geräte anstecken hatte ich ja schon etwas gesagt: Es geht nciht! Die geräte selbst funktionierenja.

Auch das Anstecken nach dem Einschalten und hochfahren habe ich schon probiert. Dasselbe Ergebnis.

Die Anregung mit dem TV-QS werde ich ausprobieren. Ich hatte mri selbiges schon mit einem VNC-Server überlegt und woltle heute Abend in Ruhe danach schauen.


Als nächstes kommen erstmal die BIOS und Registry-Einstellungen dran. Mal schauen, ob sich da etwas finden läßt.

Auf jeden Fall mal herzlichen Dank für die Anregungen.

lks
Member: Lochkartenstanzer
Lochkartenstanzer Feb 19, 2018 at 18:59:25 (UTC)
Goto Top
Zitat von @slauf82:

Nimm irgendwelche anderen Geräte, die funktionieren und dann kannst Du im Geräte-Manager die falschen Geräte löschen ! Beim Löschen wirst Du dann gefragt, ob Du die Treiber mitlöschen willst, dort sagst Du einfach ja !

Bub, lies Dir meine Frage mal genauer durch und versuch sie zu verstehen. face-smile

lks

PS: Nach einen halben dutzend verschiedener Tastaturen und Mäuse die alle dasselbe "Fehlerbild" haben sieht das nach einem grundsätzlichen Problem mit Input-devices von Windows aus.
Member: Looser27
Looser27 Feb 19, 2018 at 19:25:24 (UTC)
Goto Top
...oder einem defekten Chipsatz auf dem Mainboard. Dann sind die USB Ports tot.
Member: Lochkartenstanzer
Lochkartenstanzer Feb 19, 2018 updated at 19:30:27 (UTC)
Goto Top
Zitat von @Looser27:

...oder einem defekten Chipsatz auf dem Mainboard. Dann sind die USB Ports tot.

Sagt mal Leute, lest Ihr nicht was ich schreibe oder versteht ihr das nicht? Oder habe ich es so formuliert, daß es keiner kapiert? Alles funktioniert einwandfrei, solange man im BIOS ist oder ein Live-System bootet. Es ist nur dieses MistWindows das herumspinnt.

lks

PS: TeamviewerQS startet nicht. (oder nicht schnell genug bevor der Bildschirmschoner kommt).
Member: Looser27
Looser27 Feb 19, 2018 at 19:30:25 (UTC)
Goto Top
Treiber vom Chipsatz kaputt gegangen beim Upgrade?
Member: Lochkartenstanzer
Lochkartenstanzer Feb 19, 2018 at 19:31:32 (UTC)
Goto Top
Zitat von @Looser27:

Treiber vom Chipsatz kaputt gegangen beim Upgrade?

Keine Ahnung, Ich mache gerade ein Backup, um die Kiste frisch zu installieren. Alles andere wird für den Kunden zu teuer.

lks
Member: Archeon
Archeon Feb 19, 2018 at 19:32:07 (UTC)
Goto Top
Wenn du die Sachen mit der Registry probierst, kannst du den Bildschirmschoner doch auch gleich darüber deaktivieren.

HKEY_CURRENT_USER\ Software\ Policies\ Microsoft\ Windows\ Control Panel\ Desktop
"ScreenSaveActive" als Datentyp REG_SZ und der Wert 0 sollte den deaktivieren.
Member: Looser27
Looser27 Feb 19, 2018 at 19:32:36 (UTC)
Goto Top
Zitat von @Lochkartenstanzer:

Zitat von @Looser27:

...oder einem defekten Chipsatz auf dem Mainboard. Dann sind die USB Ports tot.

Sagt mal Leute, lest Ihr nicht was ich schreibe oder versteht ihr das nicht? Oder habe ich es so formuliert, daß es keiner kapiert? Alles funktioniert einwandfrei, solange man im BIOS ist oder ein Live-System bootet. Es ist nur dieses MistWindows das herumspinnt.

lks

PS: TeamviewerQS startet nicht. (oder nicht schnell genug bevor der Bildschirmschoner kommt).

Den kannst Du doch offline in der Registrierung abdrehen.
Member: Lochkartenstanzer
Lochkartenstanzer Feb 19, 2018 updated at 19:53:13 (UTC)
Goto Top
Zitat von @Archeon:

> HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Kbdclass
> HKEY_LOCAL_MACHINE\System\CurrentControlSet\Services\Mouclass
> HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\usbhub
> 
Hier jeweils den Wert von "Start" überprüfen, steht der Wert auf "0" oder "4" werden die Eingabegeräte bzw. USB Schnittstellen deaktiviert.

Sind alle auf Start=3, also m grünen Bereich.

lks

PS: Der schlüssel heißt mouclass (case-sensitive).
Member: Archeon
Archeon Feb 19, 2018 at 20:24:27 (UTC)
Goto Top
Huch mein Fehler, aber bist ja trotzdem fündig geworden, auch wenn es leider nicht geklappt hat.
Member: gartenlaube
gartenlaube Feb 20, 2018 at 13:46:11 (UTC)
Goto Top
sieht ein bißchen aus, als hättest du den tablet-modus aktiviert.
Member: Archeon
Archeon Feb 20, 2018 at 14:01:21 (UTC)
Goto Top
Der deaktiviert aber nicht die Tastatur.
Member: Meierjo
Meierjo Feb 21, 2018 at 12:38:46 (UTC)
Goto Top
Hallo

Auch wenn du diese Idee vielleicht auch schon hattest:
Kann es sein, dass das Update KB 4074588 die USB-Anschlüsse deaktiviert hat?
https://www.askwoody.com/forums/topic/report-of-the-win10-1709-cumulativ ...

Kommst du in die Wiederherstellungskonsole, um die hier beschriebene Methode 4 auszuprobieren?

Gruss
Member: Lochkartenstanzer
Lochkartenstanzer Feb 21, 2018 at 15:00:18 (UTC)
Goto Top
Zitat von @Meierjo:

Auch wenn du diese Idee vielleicht auch schon hattest:
Kann es sein, dass das Update KB 4074588 die USB-Anschlüsse deaktiviert hat?

Ich hatte zwar die Idee, daß irgendein Update die USB-devices gekillt hat, aber keine Gelegenheit, das auch noch zu testen. Aus Kostengründen (für den Kunden) war es einfacher einfach die Kiste frisch zu installieren, als weiterzuprobieren. Ich habe aber eine Backup gezogen, so daß ich in einer ruhigenMinute ausprobieren werden, ob das dir ursache war. Da ich das nur aus Neugierde machen werde und dem Kuden nicht in rechnung stellen werde, probiere ich das in einer ruhigeren Minute aus.

https://www.askwoody.com/forums/topic/report-of-the-win10-1709-cumulativ ...

Kommst du in die Wiederherstellungskonsole, um die hier beschriebene Methode 4 auszuprobieren?

Ich kam zwar in die Wiederherstellugnskonsole, aber hatte keine Gelegenheit das auszuprobieren.


lks
Member: Lochkartenstanzer
Lochkartenstanzer Feb 21, 2018 updated at 16:52:31 (UTC)
Goto Top
Zitat von @Lochkartenstanzer:

https://www.askwoody.com/forums/topic/report-of-the-win10-1709-cumulativ ...

Kommst du in die Wiederherstellungskonsole, um die hier beschriebene Methode 4 auszuprobieren?

Ich kam zwar in die Wiederherstellugnskonsole, aber hatte keine Gelegenheit das auszuprobieren.


Nachtrag:

Übrigens funktioniert "dism /online ..." nicht mit Windps PE wie in dem obigen Link aufgeführt. Es müsste dism /image:c:\ ... heißen.

lks

PS. ich habe es noch nicht probiert.
Member: the-buccaneer
the-buccaneer Feb 28, 2018 at 23:00:03 (UTC)
Goto Top
Hi LKS!

Mein aufrichtiges Mitgefühl! und Glückwunsch für die rechtzeitige Entscheidung face-wink

Warum hast du aber nicht versucht einen Wiederherstellungspunkt zu nehmen? Das geht doch fix.
Das Netz berichtet von positiven Erfahrungen:
https://social.technet.microsoft.com/Forums/windows/en-US/2d5b8bde-cc21- ...

Offizielles Schuldeingeständnis und Lösung:
https://support.microsoft.com/en-us/help/4091240/usb-devices-may-stop-wo ...

Selbst das bisschen Software, das Privatkunden so haben und das Rücksichern der Dateien ist doch auch wieder ein ewiger Zeitfresser...

Ich warte aber auf den Tag, an dem der verzweifelte Kunde anruft und sagt, dass ein "In-Drive-Update" seines Autos Touchscreen, Lenkung und Bremse deaktiviert hat und zwar der Autopilot noch fährt, er aber zum letzten funktionierenden Fahrziel in 500 km Entfernung chauffiert wird. Ich rate ihm, zu fahren, bis der Akku leer ist, oder 3x bei voller Fahrt den Notstop zu drücken und wieder zu starten und höre noch, wie der 80-Tonnen LKW von hinten automatisch hupend hineincrasht, weil das selbe Update dessen Abstandsensor deaktiviert hat. face-wink
Hoffentlich sind wir dann in Rente!

OT aber das musste raus. face-wink

Buc
Member: Lochkartenstanzer
Lochkartenstanzer Mar 01, 2018 updated at 05:12:10 (UTC)
Goto Top
Zitat von @the-buccaneer:

Warum hast du aber nicht versucht einen Wiederherstellungspunkt zu nehmen? Das geht doch fix.

Moin,

Win10 macht per Default keine Wiederherstellungspunkte mehr.

Zumindest war keines vorhanden. Sonst hätte ich mir Zeit und dem Kunden Geld sparen können.

lks

PS: dism, wusa & Co. aus dem Recovery-Environment heraus haben auch nicht geholfen. Kamen irgendwelche Fehlermeldungen, die besagten, daß ich das Update nicht loswerden kann.