swisstom
Goto Top

Windows Server 2008 R2 findet keine Updates seit Januar 2018

Guten Tag

Ich habe hier einen virtuellen Windows 2008 R2 Server.

Leider findet er seit diesem Jahr nur noch die "Windows Malicious Software Removal Tool" Updates, ansonsten aber nichts.
Die Security Monthly Quality Rollup-Updates werden z.B. bei diesem Server seit Januar nicht angeboten, bei anderen Servern mit der gleichen Windows Version jedoch schon...

Ich habe schon den ganzen Ordner "Software Distribution" gelöscht, leider vergeblich...
Da er die "Removal Tool"-Updates findet, funktioniert der Update-Dienst ja grundsätzlich...

Hat jemand eine Idee, an was dies liegen könnte?

Besten Dank
Swisstom

Content-Key: 368206

Url: https://administrator.de/contentid/368206

Printed on: May 24, 2024 at 10:05 o'clock

Member: sabines
sabines Mar 15, 2018 at 11:15:45 (UTC)
Goto Top
Moin,

installiere als erstes die beiden aktuellen Updates vom März manuell, damit das Ding erst mal gesichert ist.
Die KBs findest Du wenn Du bei den anderen Servern im Updateverlauf nachschaust.

Dann mal bitte mehr Input, WSUS vorhanden, welcher etc?

Gruss
Member: swisstom
swisstom Mar 15, 2018 at 11:20:34 (UTC)
Goto Top
Zitat von @sabines:
Dann mal bitte mehr Input, WSUS vorhanden, welcher etc?

Hi
Er ist selbst der WSUS-Server... und das funktioniert auch.
Seine Updates holt er jedoch direkt bei Microsoft bzw. sollte er...
Member: sabines
sabines Mar 15, 2018 at 11:23:12 (UTC)
Goto Top
Auch nicht nach einem Neustart?
Member: Pjordorf
Pjordorf Mar 15, 2018 at 11:26:16 (UTC)
Goto Top
Hallo,

Zitat von @swisstom:
Seine Updates holt er jedoch direkt bei Microsoft bzw. sollte er...
Nicht bei Aldi? face-smile
Member: swisstom
swisstom Mar 15, 2018 at 11:27:46 (UTC)
Goto Top
Zitat von @sabines:
Auch nicht nach einem Neustart?
Leider Nein...
Member: swisstom
swisstom Mar 15, 2018 at 11:28:45 (UTC)
Goto Top
Zitat von @Pjordorf:

Hallo,

Zitat von @swisstom:
Seine Updates holt er jedoch direkt bei Microsoft bzw. sollte er...
Nicht bei Aldi? face-smile

Wer weiss face-smile
Wollte damit nur sagen, dass er diese nicht von einem WSUS bezieht.
Member: DerWoWusste
DerWoWusste Mar 15, 2018 updated at 11:53:33 (UTC)
Goto Top
Liegt oft daran, dass die Registryeinträge nicht gesetzt sind, die AV-Kompatibilität signalisieren sollen:
Windows Registry Editor Version 5.00

[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\QualityCompat]
"cadca5fe-87d3-4b96-b7fb-a231484277cc"=dword:00000000  
Wenn nicht vorhanden, kommen keine neuen Patches rein.

Die Werte werden nicht gesetzt, wenn
A AV vorhanden aber inkompatibel oder nicht aktualisiert
B AV nicht vorhanden
C AV vorhanden aber deaktiviert
Member: swisstom
swisstom Mar 15, 2018 at 11:59:43 (UTC)
Goto Top
Hy

Zitat von @DerWoWusste:

Liegt oft daran, dass die Registryeinträge nicht gesetzt sind, die AV-Kompatibilität signalisieren sollen:
Windows Registry Editor Version 5.00
> 
> [HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\QualityCompat]
> "cadca5fe-87d3-4b96-b7fb-a231484277cc"=dword:00000000  
Wenn nicht vorhanden, kommen keine neuen Patches rein.

Dieser Schlüssel ist bei dem betroffenen Server jedoch gesetzt...
Member: DerWoWusste
DerWoWusste Mar 15, 2018 at 12:11:05 (UTC)
Goto Top
Ok, dann wäre eine Reparaturinstallation fällig, danach wird das Updating wieder funktionieren.
Member: n.o.b.o.d.y
n.o.b.o.d.y Mar 15, 2018 at 12:22:59 (UTC)
Goto Top
check mal:

- ist noch genug Platz auf der C: Platte frei?
- Was sagt das Windowsupdate-log?
- oder das Eventlog?
Member: swisstom
swisstom Mar 15, 2018 at 12:44:46 (UTC)
Goto Top
Zitat von @n.o.b.o.d.y:
check mal:

- ist noch genug Platz auf der C: Platte frei?
- Was sagt das Windowsupdate-log?
- oder das Eventlog?

Auf dem C: sind noch 28GB frei...
Im Windowsupdate-log habe ich folgendes gefunden:
2018-03-15	13:34:50:634	 388	b80	Handler	FATAL: UH: 0x80070490: EvaluateApplicability failed in CCbs::EvaluateApplicability
2018-03-15	13:34:51:087	 388	b80	Agent	WARNING: Failed to evaluate Installed rule, updateId = {8D75381D-A3D2-452F-A13E-67FF59E2081B}.101, hr = 80070490
2018-03-15	13:35:06:697	 388	b80	Handler	FATAL: UH: 0x80070490: EvaluateApplicability failed in CCbs::EvaluateApplicability

Nun habe ich mal noch "sfc /scannow" laufen gelassen, jedoch hat auch dies nichts gebracht.

Im Eventlog habe ich auch nichts auffälliges entdeckt.
Member: Looser27
Looser27 Mar 15, 2018 at 12:58:07 (UTC)
Goto Top
Wenn der Registry Eintrag stimmt, leg mal ne neue GPO für den WSUS an und ordne die nur dem Server zu.
In den Update Einstellungen nur die Option 3-Herunterladen, manuell installieren einstellen. Sonst alles leer lassen.
Vielleicht ist ein Fehler in der GPO.....?
Member: swisstom
swisstom Mar 15, 2018 at 13:38:30 (UTC)
Goto Top
Zitat von @Looser27:

Wenn der Registry Eintrag stimmt, leg mal ne neue GPO für den WSUS an und ordne die nur dem Server zu.
In den Update Einstellungen nur die Option 3-Herunterladen, manuell installieren einstellen. Sonst alles leer lassen.
Vielleicht ist ein Fehler in der GPO.....?

Der Server bezieht die Updates nicht von einem WSUS, sondern vom direkt Internet.
Folglich ist hierfür auch keine GPO vorhanden.

Grüsse
Swisstom
Member: Looser27
Looser27 Mar 15, 2018 at 13:46:03 (UTC)
Goto Top
Dann änder das doch mal ab. face-wink
Member: swisstom
swisstom Mar 15, 2018 at 13:50:09 (UTC)
Goto Top
Zitat von @Looser27:

Dann änder das doch mal ab. face-wink

Könnte ich, wenn ich möchte face-smile
Es muss aber auch ohne WSUS funktionieren.
Member: Looser27
Looser27 Mar 15, 2018 at 15:03:13 (UTC)
Goto Top
Wenn du keine Lösungen versuchen willst, solltest Du zurück in Dein stilles Kämmerlein gehen und alleine weiter probieren.
Member: swisstom
swisstom Mar 16, 2018 at 07:06:20 (UTC)
Goto Top
Zitat von @Looser27:
Wenn du keine Lösungen versuchen willst, solltest Du zurück in Dein stilles Kämmerlein gehen und alleine weiter probieren.

Deine Antwort hilft mir natürlich ungemein bei meinem Problemfall...

Ich habe sicher nicht gesagt, dass ich keine Lösung versuchen will!
Aber meine Frage bezieht sich nicht auf mögliche Lösungen für Updates, sondern nach der Ursache des beschriebenen Problems.

Nun, unsere Server sind nicht für Updates mit einem WSUS konfiguriert, nur Clients und das funktioniert auch.
Er findet auch alle Updates bis und mit Dezember 2017, auch wenn ich diese vorher deinstalliere.
Updates ab Januar 2018 findet er keine, ausser das Update wie oben bereits erwähnt.
Würde ich diesen nun für WSUS konfigurieren, dann wüsste ich trotzdem nicht wo das Problem hier liegt.

Danke trozdem!
Member: sabines
sabines Mar 16, 2018 at 07:15:20 (UTC)
Goto Top
Zitat von @swisstom:
Würde ich diesen nun für WSUS konfigurieren, dann wüsste ich trotzdem nicht wo das Problem hier liegt.

Vielleicht solltest Du hier umdenken und eher lösungorientiert arbeiten.
Was nutzt Dir die Fehlerursache, wenn die Kiste monatelang ungepatch bleibt?

Die Update Einstellungen in der Registry hast Du schon quergeprüft?
Member: swisstom
swisstom Mar 16, 2018 at 07:21:02 (UTC)
Goto Top
Zitat von @sabines:
Die Update Einstellungen in der Registry hast Du schon quergeprüft?

Falls du diesen Schlüssel meinst:
"HKEY_LOCAL_MACHINE \ SOFTWARE \ Microsoft \ Windows \ CurrentVersion \ QualityCompat" Wert = "cadca5fe-87d3-4b96-b7fb-a231484277cc" Typ = "REG_DWORD"

Data = "0x00000000"

Der ist vorhanden...
Member: DerWoWusste
DerWoWusste Mar 16, 2018 at 07:44:20 (UTC)
Goto Top
Mach eine Reparaturinstallation über Nacht (inplace-Upgrade) - kostet dich ein Lächeln und danach läuft es wieder.
Member: swisstom
swisstom Mar 16, 2018 at 15:16:12 (UTC)
Goto Top
Zitat von @DerWoWusste:
Mach eine Reparaturinstallation über Nacht (inplace-Upgrade) - kostet dich ein Lächeln

Oder kostet mich "das Lächeln" wenn dann die anderen Anwendungen nicht mehr funktionieren...
Werde dies eher als letzte Option durchführen.
Member: Pjordorf
Pjordorf Mar 16, 2018 at 21:02:51 (UTC)
Goto Top
Hallo,

Zitat von @swisstom:
Werde dies eher als letzte Option durchführen.
Nun, das ist ja auch deine Entscheidung, nur um dir wirklich und zielgerichtet helfen zu können haben wir eher viel zu wenig Infos. https://serverfault.com/questions/101685/windows-updates-fails-server-20 ...
https://blogs.msdn.microsoft.com/andrekl/2008/09/29/how-to-overcome-erro ...
https://blogs.technet.microsoft.com/asiasupp/2011/06/19/the-error-0x8007 ...
https://support.microsoft.com/de-de/help/958044/windows-update-error-0x8 ...
https://social.technet.microsoft.com/Forums/lync/en-US/f4928c0e-6c03-4f1 ...

Und was spricht dagegen eine Datensicherung zu machen und den vorgeschlagenen weg von @DerWoWusste: zu gehen. Notfalls die Datensicherung einfach zurückspielen wobei einfach auch ganz schön komplex werden kann. Ausser das es eine VM mit Server 2008 R2 und installiertem WSUS ist, wissen wir ja nichtsface-sad

https://www.google.de/search?q=server+2008+update+error+0x80070490

Gruß,
Peter
Member: swisstom
swisstom Mar 20, 2018 at 07:54:53 (UTC)
Goto Top
Zitat von @Pjordorf:
Nun, das ist ja auch deine Entscheidung, nur um dir wirklich und zielgerichtet helfen zu können haben wir eher viel zu wenig Infos.
Ich habe als erstes einfach mal die Infos geben, welche mir als wichtig erschienen.

0x80070490
Weiss jetzt nicht, wie du auf diesen Error-Code kommst. Mein Problem ist ja, dass ich gar nicht erst einen Fehler erhalte...

Und was spricht dagegen eine Datensicherung zu machen und den vorgeschlagenen weg von @DerWoWusste: zu gehen. Notfalls die Datensicherung einfach zurückspielen wobei einfach auch ganz schön komplex werden kann. Ausser das es eine VM mit Server 2008 R2 und installiertem WSUS ist, wissen wir ja nichtsface-sad
Weil das meines Erachtens nicht gleich der erste Lösungsweg ist, welchen man gehen sollte.

Grüsse
Swisstom
Member: swisstom
swisstom Mar 20, 2018 at 08:00:42 (UTC)
Goto Top
Problem gelöst!

Wir sind wohl nicht die einzigen, welche von diesem Problem betroffen waren.

https://social.technet.microsoft.com/Forums/windowsserver/en-US/3033757e ...

Die Lösung findet sich im letzten Beitrag.
Auch wir hatten vor zwei Jahren mal Symantec Endpoint installiert. Und da waren wohl noch Überbleibsel vorhanden, welche auf die Update-Suche seit Januar Fehler verursachte .
Das Symantec Cleanwipe Tool hat nun diese Reste entfernt und der Server findet nun wieder seine Updates face-smile

Besten Dank für die Mithilfe.

Beste Grüsse
Swisstom
Member: Pjordorf
Pjordorf Mar 20, 2018 updated at 17:46:56 (UTC)
Goto Top
Hallo,

Zitat von @swisstom:
Problem gelöst!
Sehr schön.

Auch wir hatten vor zwei Jahren mal Symantec Endpoint installiert.
Was wir hier aber weder wussten noch vonb dir gesagt wurde face-sad

Weiss jetzt nicht, wie du auf diesen Error-Code kommst.
Na, durch deine uns zufliessende Information. Du solltest vielleicht in Zukunft mal lesen was du hier rein stellst.
2018-03-15	13:34:50:634	 388	b80	Handler	FATAL: UH: 0x80070490: EvaluateApplicability failed in CCbs::EvaluateApplicability
> 2018-03-15	13:34:51:087	 388	b80	Agent	WARNING: Failed to evaluate Installed rule, updateId = {8D75381D-A3D2-452F-A13E-67FF59E2081B}.101, hr = 80070490
> 2018-03-15	13:35:06:697	 388	b80	Handler	FATAL: UH: 0x80070490: EvaluateApplicability failed in CCbs::EvaluateApplicability
von hier Windows Server 2008 R2 findet keine Updates seit Januar 2018

Weil das meines Erachtens nicht gleich der erste Lösungsweg ist, welchen man gehen sollte.
Also wartest du erstmal 10 Lösungswege ab und nimmst aber grundsätzlichen nicht den ersten. Bedeutet der erste Lösungsweg ist also immer ein falscher und daher ignorierst du diesen face-sad

Aber jetzt läuft es ja wieder. face-smile

Gruß,
Peter
Member: swisstom
swisstom Mar 20, 2018 at 19:04:53 (UTC)
Goto Top
Auch wir hatten vor zwei Jahren mal Symantec Endpoint installiert.
Was wir hier aber weder wussten noch vonb dir gesagt wurde face-sad

Die "Deinstallation" von Symantec Endpoint lag ja bereits 2 Jahre zurück, also ganz sicher nicht an das Erste was man denkt, da es ja bis und mit Dezember 2017 auch funktioniert hat!

Weiss jetzt nicht, wie du auf diesen Error-Code kommst.
Na, durch deine uns zufliessende Information. Du solltest vielleicht in Zukunft mal lesen was du hier rein stellst.
2018-03-15	13:34:50:634	 388	b80	Handler	FATAL: UH: 0x80070490: EvaluateApplicability failed in CCbs::EvaluateApplicability
>> 2018-03-15	13:34:51:087	 388	b80	Agent	WARNING: Failed to evaluate Installed rule, updateId = {8D75381D-A3D2-452F-A13E-67FF59E2081B}.101, hr = 80070490
>> 2018-03-15	13:35:06:697	 388	b80	Handler	FATAL: UH: 0x80070490: EvaluateApplicability failed in CCbs::EvaluateApplicability

Stimmt, mein Fehler. Der Error-Code steht im Log. Bei der Windows-Updatesuche erscheint jedoch kein Fehler, so wie ich es auch geschrieben habe.

Weil das meines Erachtens nicht gleich der erste Lösungsweg ist, welchen man gehen sollte.
Also wartest du erstmal 10 Lösungswege ab und nimmst aber grundsätzlichen nicht den ersten. Bedeutet der erste Lösungsweg ist also immer ein falscher und daher ignorierst du diesen face-sad

Nein, vielleicht solltest du ja auch mal besser lesen! Du hast ja selbst geschrieben, dass das zurückspielen der Datensicherung auch komplex werden kann. Außerdem wäre der Fehler, wie wir nun wissen, auch nach dem zurückspielen des Backups weiterhin vorhanden gewesen...

Ich denke, bevor man gleich ein Inplace-Upgrade durchführt oder eine Wiederherstellung vom Backup ausführt, darf man sich doch auch mal an ein Forum wenden um zu sehen, ob das Problem bereits jemandem bekannt ist.
Für dies ist das Forum doch auch da, dachte ich jedenfalls...

Beste Grüsse
Swisstom