Zugriff auf NAS über TP-Link und Fritz!Box

maverick90
Goto Top
Hallo zusammen,

mein Internetanschluss wird erst Ende August fertiggestellt.
Daher musste ich mir eine günstige Übergangslösung basteln, um Internet zu haben und von extern auf mein NAS zugreifen zu können.
Internet funktioniert, aber der Zugriff auf mein NAS noch nicht, vielleicht kann mir jemand helfen?

Mobiler Router (TP-Link M7200, 192.168.0.1)
>>WLAN>> Router (Fritz!Box 7490, 192.168.0.101 & 192.168.9.1)
>>LAN>> NAS (Synology, 192.168.9.3)

Die Fritz!Box nutzt das WLAN des TP-Links als Gateway.
Folgende Portfreigaben sind auf beiden Geräten eingetragen:

Mobiler Router
Name: Synology
External Port: 443
Internal IP: 192.168.0.101
Internal Port: 443
Protocol: TCP

Router
Name: Synology
External Port: 443
Internal IP: 192.168.9.3
Internal Port: 301
Protocol: TCP

Der Port für den Webzugriff auf dem NAS ist 301.

Content-Key: 3228460005

Url: https://administrator.de/contentid/3228460005

Ausgedruckt am: 15.08.2022 um 18:08 Uhr

Mitglied: aqui
aqui 01.07.2022 aktualisiert um 12:41:17 Uhr
Goto Top
Als erstes ist dein Routing falsch. Die FritzBox kann niemals 2 IP Netze im WLAN routen. Dazu ist sie technisch nicht in der Lage.
Das WLAN IP Netz der FritzBox ist immer identisch zu ihrem LAN Netz und die FB supportet keine weiteren IP Netze. Ein Routing auf den LTE Router ist also technisch unmöglich wenn der nicht im gleichen IP Netz liegt wie die FritzBox.
Deine Angaben dazu oben sind etwas wirr und unverständlich denn mit der IP Adressierung ist das technisch so nicht machbar.
Grundlagen zum Routing von 2 solchen IP Netzen findest du hier:
https://administrator.de/tutorial/routing-von-2-und-mehr-ip-netzen-mit-w ...

Der 2te wichtige Punkt:
Für so einen remoten Zugriff über ein Mobilfunknetz ist es zwingend erforderlich das der LTE Router einen Mobilfunk APN nutzt der ihm öffentlich erreichbare IPv4 Adressen am LTE Port (Internet Port) zur Verfügung stellt. Leider machst du dazu keinerlei Angaben. face-sad
Das ist bei den meisten Billigtarifen aber nicht mehr der Fall weil öffentliche v4 IPs bei der Mehrzahl der Billigprovider wegen der IPv4 Knappheit nur noch den teureren Business Tarifen vorbehalten sind.
Diese Provider machen dann CGN (Carrier Grade NAT, Address Translation) und nutzen im Mobilfunknetz private RFC 1918 oder RFC 6598 IP Adressen.
Mit denen ist dann ein remoter Zugriff per Port Forwarding technisch ausgeschlossen weil du den Provider internen NAT Prozess nicht überwinden kannst. Der LTE Router bleibt in solchen Mobilfunknetzen also unereichbar von außen.

Es wäre also sehr sinnvoll gewesen ZUERST einmal nachzusehen WELCHE Art von IP Adresse du auf dem LTE Port des Routers bekommen hast (Router Dashboard). Leider fehlt diese Angabe. face-sad
Ist das einer der o.a. IP Adressen, dann ist eine Lösung unmöglich und die Erreichbarkeit von remote ausgeschlossen. Zumindestens nicht mit Bordmitteln und IPv4.

Was aber immer geht ist ein Zugriff über IPv6, denn diese Mobilnetze vergeben immer erreichbare IPv6 Adressen. Damit klappt es also mit Bordmitteln immer.

Du kannst es auch über ein VPN lösen wenn andere Familienmitglieder etc. noch öffentliche IPs bekommen an ihrem Router und der VPN fähig ist (FritzBox etc.) oder mit einem gemieteten vHost. Siehe dazu auch HIER.
Mitglied: Maverick90
Maverick90 01.07.2022 um 13:00:16 Uhr
Goto Top
Die 192.168.0.101 wird auf der Fritz!Box als öffentliche IP-Adresse angezeigt.
Diese bekommt die Fritz!Box vom TP-Link zugewiesen.
fritz - Ö-ip

Auf dem Dashboard des TP-Link werden IPv4- und IPv6-Adressen angezeigt.
tp-link - Ö-ip
Mitglied: aqui
aqui 01.07.2022 aktualisiert um 14:00:59 Uhr
Goto Top
Die 192.168.0.101 wird auf der Fritz!Box als öffentliche IP-Adresse angezeigt.
Ist das der LTE Port ? Dann sind alle weiteren Bemühungen mit IPv4 sinnlos, denn das ist ja einen RFC 1918 IP die im Internet nicht geroutet wird.
Einsteigen von außen tust du aber doch mit dem LTE Router, oder ? Leider kann man nicht erkennen ob der eine öffentliche v4IP dort hat oder eine RFC 1918 IP
https://de.wikipedia.org/wiki/Private_IP-Adresse
Du machst wieder einmal keinerlei Angaben dazu. face-sad
Man kann nur rudimentär erkennen das es etwas mit 1...ist. 18. usw wäre öffentlich, ist aber geraten.

Du hast aber auch eine öffentliche IPv6 Adresse bekommen 2a01:... Mit der wird dann der Zugriff auf das NAS klappen.
Mit IPv4 würde es nur klappen wenn die LTE Router Adresse im Mobilfunknetz eine öffentliche IP ist. Dazu lieferst du ja leider wiederholt keine Information. face-sad
Hilfreich wäre auch eine kleine Skizze WIE FritzBox und LTE Router verbunden sind!! Was geht und was nicht bzw. an statischen Routen erforderlich ist siehst du ja selber am obigen Routing Tutorial. Wenn man es denn mal liest...
Mitglied: Maverick90
Maverick90 01.07.2022 um 15:49:20 Uhr
Goto Top
Anbei die Skizze, ich hoffe das beantwortet deine Fragen?
skizze mit infos
Mitglied: aqui
Lösung aqui 01.07.2022 aktualisiert um 16:40:08 Uhr
Goto Top
Du siehst das Drama ja selber mit der 10er Adresse im LTE!!
Damit bist du dann zumindestens was IPv4 betrifft chancenlos. Das Warum ist dir ja oben beschrieben worden. Falscher LTE Vertrag der mit CGN arbeitet und eine Realisierung damit unter IPv4 unmöglich macht. Du musst also dein Provider kontaktieren und um Umstellung bitten.
Ansonsten ist dein bester Freund mit Bordmitteln dann IPv6. Damit wird es dann problemlos klappen. face-wink

Case closed
https://administrator.de/faq/32
Mitglied: Maverick90
Maverick90 01.07.2022 aktualisiert um 16:44:43 Uhr
Goto Top
Wie würde denn eine Lösung mit IPv6 aussehen?

Unter https://www.wieistmeineip.de bekomme ich aber eine IPv4-Adresse angezeigt:
80.187.121.254
Unter IPv6 steht dort: Nicht vorhanden
Mitglied: em-pie
Lösung em-pie 01.07.2022 aktualisiert um 22:32:39 Uhr
Goto Top
Moin,

Mal ne blöde Frage:
Warum kommt der tp-Link überhaupt zum Einsatz?
Warum keinen LTE-Stick direkt an die Fritte hängen?
Das würde zwar das CGN- Problem u.U. Nicht lösen, ABER die konfig und das (Doppel?)-NAT bzw. Bei CGN TripleNAT wäre nicht da.
https://avm.de/service/wissensdatenbank/dok/FRITZ-Box-7490/76_FRITZ-Box- ...

Du müsstest nur den passenden Stick ermitteln…

Edit: die von dir ermittelte IP ist quasi der Break-Out bei der Telekom:
https://ipinfo.io/AS3320/80.187.0.0/16-80.187.120.0/23
Alles was dahinter kommt, also dein WAN am LTE-Router ist für Seiten wie „wieistmeineip“ unsichtbar… es wird ja genattet

Gruß
em-pie
Mitglied: aqui
aqui 02.07.2022 aktualisiert um 09:10:53 Uhr
Goto Top
Wie würde denn eine Lösung mit IPv6 aussehen?
Du müsstest das dir via v6 zugewiesene IPv6 Netz im lokalen LAN aktivieren. Damit hast du dann ein erreichbares, öffentliches v6 Netz das von allen externen Netzen problemlos erreichbar ist.
Idealerweise nimmt man dazu dann einen LTE Stick an der FB wie der Kollege @em-pie oben schon richtig sagt.
Zur "wieistmeinip..." Anzeige hat der Kollege ja ebenso schon alles gesagt. Vermutlich ist das die Anzeige eines Clients am lokalen FritzBox Netz der dann auch via FritzBox geroutet wird.
Du machst ja leider (mal wieder) keinerlei Angaben WO sich dieser Client befindet und über WELCHEN Router (FB oder LTE?) er ins Internet geht.
Zumindesten ein Blick aufs Dashboard der FritzBox wäre sinnvoll gewesen ob diese ggf. die 80.187.121.254 als IP am WAN Port hält. Den CGN Teil hat Kollege @em-pie schon kommentiert.
Letztlich also wieder einmal sinnfreie Kristallkugelei weil wiederholt relevante Angaben schlicht fehlen. face-sad
Mitglied: Maverick90
Maverick90 03.07.2022 um 23:18:00 Uhr
Goto Top
Zitat von @em-pie:
Warum kommt der tp-Link überhaupt zum Einsatz?
Hatte ich noch zu Hause, da Übergangslösung, sollte es günstig sein.

Zitat von @aqui:
Du machst ja leider (mal wieder) keinerlei Angaben WO sich dieser Client befindet und über WELCHEN Router (FB oder LTE?) er ins Internet geht.
Zumindesten ein Blick aufs Dashboard der FritzBox wäre sinnvoll gewesen ob diese ggf. die 80.187.121.254 als IP am WAN Port hält. Den CGN Teil hat Kollege @em-pie schon kommentiert.
Alle Clients verbinden sich natürlich nur mit der Fritz!Box.
Die Fritz!Box bekommt immer die 192.168.0.101 als öffentliche IP angezeigt.

Ich habe es nun geschafft, dass ich eine IPv4 (37.80.103.213) am mobilen Router erhalte.
Habe den APN anders definiert.
Der externe Zugriff (z.B. über mein Handy über LTE) funktioniert nun.
Allerdings im LAN über Domain noch nicht, per IP klappt es.
Hat dazu jemand eine Idee?
Mitglied: aqui
aqui 04.07.2022 aktualisiert um 10:13:58 Uhr
Goto Top
Allerdings im LAN über Domain noch nicht
Wie ist das zu verstehen?? Du willst aus dem lokalen LAN mit einer DynDNS Adresse auf den eigenen externen WAN Port des Routers zugreifen?
Wenn ja, dann geht das vermutlich nicht weil dein Router scheinbar (geraten, weil mal wieder keine Info!) kein NAT Hairpinning supportet.
Mitglied: Maverick90
Maverick90 04.07.2022 um 11:08:52 Uhr
Goto Top
Zitat von @aqui:
Wie ist das zu verstehen?? Du willst aus dem lokalen LAN mit einer DynDNS Adresse auf den eigenen externen WAN Port des Routers zugreifen?
Wenn ja, dann geht das vermutlich nicht weil dein Router scheinbar (geraten, weil mal wieder keine Info!) kein NAT Hairpinning supportet.

Ich habe eine Domain bei Strato, dort ist über einen CNAME-Record eine DynDNS-Adresse von Feste-IP hinterlegt, welche sich über die Fritz!Box die öffentliche IP besorgt.
Korrekt und ich möchte aus meinem lokalen LAN über die Domain auf mein NAS zugreifen, welches auch im lokalen LAN steht.
Ob der mobile Router Hairpinning supportet, kann ich leider aus der Produktbeschreibung nicht erkennen:
https://www.tp-link.com/de/home-networking/mifi/m7200/#specifications
Mitglied: aqui
Lösung aqui 04.07.2022 aktualisiert um 11:42:12 Uhr
Goto Top
Wird vermutlich so sein das er das nicht kann bzw. supportet. Das ist bei 90% dieser Consumer Router der Fall.
Sofern der also im Router Setup keine Option hat das sog. NAT Reflection/NAT Hairpinning zu aktivieren bzw. deaktivieren wirst du das nicht hinbekommen. Die Grundproblematik ist z.B. hier beschrieben.
Mitglied: Maverick90
Maverick90 04.07.2022 um 11:51:28 Uhr
Goto Top
Damit kann ich leben, die Übergangslösung ist hoffentlich nur für max. 2 Monate, danke für eure Hilfe!
Mitglied: aqui
aqui 04.07.2022 um 12:04:06 Uhr
Goto Top
Immer gerne! face-smile

Bitte dann auch nicht vergessen deinen Thread hier als erledigt zu markieren!