porfavor
Goto Top

Apache nur von Hostrechner aus erreichbar

Hallo,

ich habe ein Problem mit meinem Apache auf Windows Server 2008 R2.

Ich kann ihn auf dem Host über
http://localhost
sowie
http://192.168.0.195 (interne IP)
erreichen.
Jedoch kann ich das vom Client aus nicht. Sprich wenn ich http://192.168.0.195 aufrufe, bringt er einen Seiten-Ladefehler.

Die Firewall hatte ich ausgeschaltet. Woran kann das liegen?

Content-Key: 138405

Url: https://administrator.de/contentid/138405

Printed on: April 21, 2024 at 17:04 o'clock

Mitglied: 60730
60730 Mar 16, 2010 at 18:51:20 (UTC)
Goto Top
moin,

in der .htaccess steht allow 127.0.0.1 und Deny from * ?
Und das ist der Grund, afaik macht das aber nur ein Xampp, kein echter Apache.
Member: kingkong
kingkong Mar 16, 2010 at 20:25:47 (UTC)
Goto Top
XAMPP ist soweit ich weiß offen wie ein Scheunentor. Solche Regeln muss man händisch erstellen. Erst vor einigen Tagen habe ich mit das aktuelle XAMPP heruntergeladen und es war noch immer so - dazu auch "Die Philosphie" auf http://www.apachefriends.org/de/xampp.html

Deine Serverfirewall ist auch entsprechend konfiguriert? Und der IIS ist ausgeschaltet?
Member: Porfavor
Porfavor Mar 17, 2010 at 21:01:08 (UTC)
Goto Top
Ich habe aber kein XAMPP, sondern Apache als Standalone^^

Aber ich werde das mal überprüfen. Jedoch sollte ich vom Host dann auch nur per localhost im Browser zugreifen können.
Member: kingkong
kingkong Mar 17, 2010 at 21:19:31 (UTC)
Goto Top
Da wäre ich mir nicht so sicher. Ich könnte mir vorstellen, dass bei einem Zugriff auf die eigene IP diese in die localhost übersetzt wird. In jedem Fall solltest Du auch mal deine httpd.conf überprüfen. Wenn dort Override nicht zugelassen ist, dann ändern eventuelle Einträge oder Nicht-Einträge in der .htaccess für ein bestimmtes Verzeichnis nichts.
Member: Porfavor
Porfavor Mar 19, 2010 at 18:15:10 (UTC)
Goto Top
Also, in der httpd.conf stehf folgendes:

<Directory />
Options FollowSymLinks
AllowOverride None
Order deny,allow
Deny from all
</Directory>

Demnach schließe ich, dass Override nicht zugelassen ist. .htaccess scheint es keine zu geben, Jedenfalls zeigt es keine an.
Bringt es etwas, wenn ich Angaben hier ändere? "Deny from all" bezieht sich auf was?
Member: kingkong
kingkong Mar 19, 2010 at 19:48:17 (UTC)
Goto Top
Wenn ich mich recht entsinne bedeutet das, dass der Zugriff von allen IP-Adressen abgelehnt wird... http://aktuell.de.selfhtml.org/artikel/server/apacheconf/ sollte Dir helfen...
Member: Porfavor
Porfavor Mar 21, 2010 at 19:46:54 (UTC)
Goto Top
Sorry, ich habe den Fehler gefunden. Ich hatte versehentlich mein Virenprogramm ausgeschaltet, aber nicht die Windows-Firewall. Die war doch das Problem.
Habe nun eine neue Regel mit Port 80 zulassen erstellt und siehe da: es geht!

Danke für eure Mühen!