samrein
Goto Top

Exchange Sendeconnector

Moinsen zusammen,

mal wieder was schönes...

Exchange Server 2016

hier möchte ich mehrere Sendeconnector definieren die über 2 verschiedene Smarthosts Ihre Mails ausliefern.

Bei der Stammdomäne xxxy@test.de habe ich in der Bereichsdefinition derzeit ein *.

Folglich liefert er auch alle Mails über diesen Connector aus. Zum testen möchte ich aber Mails einer anderen Domäne an einen anderen Sendeconnector schicken.

Wenn ich nun *.xxxy@test.de für alle Subdomänen oder xxxy@test.de nur für die entsprechende Domäne einstelle, bleiben die Mails im Exchange hängen.
Für die Änderung am Sendeconnector bedarf es keinen Neustart eine Dienstes oder dergleichen.

In dem Fall erhalte ich aber die Fehlermeldung:

Ein entsprechender Connector zum Weiterleiten des externen Empfängers kann nicht gefunden werden;16;<No Matching Connector>;0

Jetzt bleibt natürlich die spannende Frage warum er keinen Connector findet...

Grüße
Stefan

Content-Key: 623439

Url: https://administrator.de/contentid/623439

Printed on: July 12, 2024 at 16:07 o'clock

Member: falscher-sperrstatus
falscher-sperrstatus Nov 18, 2020 at 11:17:44 (UTC)
Goto Top
Hallo Sam,

Wenn ich nun *.xxxy@test.de für alle Subdomänen oder xxxy@test.de nur für die entsprechende Domäne einstelle, bleiben die Mails im Exchange hängen.

Wenn du die Subdomains einschliessen willst muss es auch eher ein

@*.xxx.domain.de sein. - So generell.

Allgemein hilft es sich an die MS Leitlinie zu halten

https://docs.microsoft.com/en-us/exchange/mail-flow-best-practices/manag ...

Das sollte auch für Exchange ab min 2013 gelten

Grüße,

Christian
certifiedit.net
Member: samrein
samrein Nov 18, 2020 updated at 11:24:16 (UTC)
Goto Top
Hallo Chrisitan,

bei Microsoft ist vom @ nicht die Rede...funktionierte bei mir aber auch nicht, den kann ich nichtmal speichern

docs.microsoft.com/en-us/exchange/mail-flow/connectors/send-connectors?view=exchserver-2019
sc
Member: falscher-sperrstatus
falscher-sperrstatus Nov 18, 2020 at 11:37:39 (UTC)
Goto Top
Hi,

korrekt, war nur exemplarisch auf deine Beispiele.

für Subdomains nimmst du *.xxx.domain.xx - bzw den "Subdomain $true" Schalter, siehe Link.

Damit sollte es tun.

Grüße
Member: LeeX01
LeeX01 Nov 18, 2020 at 17:21:47 (UTC)
Goto Top
Servus,

ein @ hat auch in einer Domain Definition nichts verloren. Glaube dein Denkansatz ist da falsch, der will nicht wissen für welche email-adressen der Connector ist sondern für welche Domain. Das eine Bedingt dann natürlich das andere.

Grüße
Member: samrein
samrein Nov 19, 2020 at 14:55:58 (UTC)
Goto Top
Hi Lee,

danke, ich hatte das mit

*.test.de
test.de

versucht, allerdings bekomm ich weiterhin die Meldung das es keinen Sendeconnector gäbe.
Es funktionert nur ein allgemeines *

Ich muss da mal weiter forschen...

Danke

Grüße
Stefan
Member: LeeX01
Solution LeeX01 Nov 19, 2020 at 17:53:48 (UTC)
Goto Top
Zitat von @samrein:

Hi Lee,

danke, ich hatte das mit

*.test.de
test.de

versucht, allerdings bekomm ich weiterhin die Meldung das es keinen Sendeconnector gäbe.
Es funktionert nur ein allgemeines *

Ich muss da mal weiter forschen...

Danke

Grüße
Stefan

das muss gehen mit test.de. was sagt der Befehl?

get-sendconnector | select *
Member: samrein
samrein Nov 20, 2020 at 08:02:17 (UTC)
Goto Top
Hi Lee,
Du hast mich auf den richtigen Weg gebracht, dank Dir.

Scheinbar scheint ein anderer Sendeconnector dazwischen zu funken. Ich hätte mal direkt über die Console den Connector abfragen sollen. face-sad
Ich werde die jetzt nach und nach wieder aktivieren bis ich den gefunden habe, der dazwischen funkt.

Grüße
Stefan
Member: samrein
samrein Nov 20, 2020 at 08:07:05 (UTC)
Goto Top
zu früh gefreut.

der erste mit * Wildcard, der funktioniert, der zweit leider nicht

RunspaceId                   : aad27f8a-c3d6-41d2-9e44-8d78e668efdc
DNSRoutingEnabled            : False
TlsDomain                    :
TlsAuthLevel                 :
ErrorPolicies                : Default
SmartHosts                   : {[192.168.9.5]}
Port                         : 25
ConnectionInactivityTimeOut  : 00:10:00
ForceHELO                    : False
FrontendProxyEnabled         : False
IgnoreSTARTTLS               : False
CloudServicesMailEnabled     : False
Fqdn                         : mail.xxx.de
TlsCertificateName           :
RequireTLS                   : False
RequireOorg                  : False
Enabled                      : True
ProtocolLoggingLevel         : None
SmartHostAuthMechanism       : None
AuthenticationCredential     :
UseExternalDNSServersEnabled : True
DomainSecureEnabled          : False
SourceIPAddress              : 0.0.0.0
SmtpMaxMessagesPerConnection : 20
ConnectorType                : Default
SmartHostsString             : [192.168.9.5]
CertificateSubject           :
Region                       : NotSpecified
AddressSpaces                : {SMTP:*;1}
ConnectedDomains             : {}
IsScopedConnector            : True
IsSmtpConnector              : True
Comment                      :
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {EX2016}
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : EX2016
MaxMessageSize               : 68.36 MB (71,680,000 bytes)
AdminDisplayName             :
ExchangeVersion              : 0.1 (8.0.535.0)
Name                         : Mailgateway
DistinguishedName            : CN=Mailgateway,CN=Connections,CN=Exchange Routing Group (DWBGZMFD01QNBJR),CN=Routing Groups,CN=Exchange Administrative Group
                               (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=BWH GmbH,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=xxx,DC=de
Identity                     : Mailgateway
Guid                         : e23de3f6-b412-49fa-bf25-f0bec8c51116
ObjectCategory               : xxx.de/Configuration/Schema/ms-Exch-Routing-SMTP-Connector
ObjectClass                  : {top, msExchConnector, mailGateway, msExchRoutingSMTPConnector}
WhenChanged                  : 18.11.2020 12:10:33
WhenCreated                  : 16.03.2010 15:54:46
WhenChangedUTC               : 18.11.2020 11:10:33
WhenCreatedUTC               : 16.03.2010 14:54:46
OrganizationId               :
Id                           : Mailgateway
OriginatingServer            : bwh03.xxx.de
IsValid                      : True
ObjectState                  : Unchanged


RunspaceId                   : aad27f8a-c3d6-41d2-9e44-8d78e668efdc
DNSRoutingEnabled            : False
TlsDomain                    :
TlsAuthLevel                 :
ErrorPolicies                : Default
SmartHosts                   : {[192.168.9.5]}
Port                         : 25
ConnectionInactivityTimeOut  : 00:10:00
ForceHELO                    : False
FrontendProxyEnabled         : False
IgnoreSTARTTLS               : False
CloudServicesMailEnabled     : False
Fqdn                         : mail.xxx.de
TlsCertificateName           :
RequireTLS                   : False
RequireOorg                  : False
Enabled                      : True
ProtocolLoggingLevel         : None
SmartHostAuthMechanism       : None
AuthenticationCredential     :
UseExternalDNSServersEnabled : True
DomainSecureEnabled          : False
SourceIPAddress              : 0.0.0.0
SmtpMaxMessagesPerConnection : 20
ConnectorType                : Default
SmartHostsString             : [192.168.9.5]
CertificateSubject           :
Region                       : NotSpecified
AddressSpaces                : {SMTP:*.xxx.de;1, SMTP:*.yyy.media;1}
ConnectedDomains             : {}
IsScopedConnector            : True
IsSmtpConnector              : True
Comment                      :
SourceRoutingGroup           : Exchange Routing Group (DWBGZMFD01QNBJR)
SourceTransportServers       : {EX2016}
HomeMTA                      : Microsoft MTA
HomeMtaServerId              : EX2016
MaxMessageSize               : 68.36 MB (71,680,000 bytes)
AdminDisplayName             :
ExchangeVersion              : 0.1 (8.0.535.0)
Name                         : Mailgateway
DistinguishedName            : CN=Mailgateway,CN=Connections,CN=Exchange Routing Group (DWBGZMFD01QNBJR),CN=Routing Groups,CN=Exchange Administrative Group
                               (FYDIBOHF23SPDLT),CN=Administrative Groups,CN=XXX GmbH,CN=Microsoft Exchange,CN=Services,CN=Configuration,DC=xxx,DC=de
Identity                     : Mailgateway
Guid                         : e23de3f6-b412-49fa-bf25-f0bec8c51116
ObjectCategory               : xxx.de/Configuration/Schema/ms-Exch-Routing-SMTP-Connector
ObjectClass                  : {top, msExchConnector, mailGateway, msExchRoutingSMTPConnector}
WhenChanged                  : 20.11.2020 08:55:08
WhenCreated                  : 16.03.2010 15:54:46
WhenChangedUTC               : 20.11.2020 07:55:08
WhenCreatedUTC               : 16.03.2010 14:54:46
OrganizationId               :
Id                           : Mailgateway
OriginatingServer            : XXX03.xxx.de
IsValid                      : True
ObjectState                  : Unchanged
Member: LeeX01
LeeX01 Nov 20, 2020 at 17:57:27 (UTC)
Goto Top
Dann solltest du aber auch zwei unterschiedliche Smarthosts angeben, jetzt gerade benutzen beide 192.168.9.5:25 was den zweiten unnötig macht.

Hast du noch mehr Sendeconnectoren?

Nimm mal noch den Firmennamen aus dem DN und OriginatingServer des zweiten Commectors.
Member: samrein
samrein Nov 20, 2020 at 18:20:22 (UTC)
Goto Top
Das hast du falsch verstanden. Es handelt sich jeweils um den gleichen connector, einmal als wildcard, und einmal mit der gewünschten Domäne. Sobald ich eine Dömäne eintrage sagt mir der Exchange das er keinen passenden connector finden kann. Alle anderen sendeconnectoren habe ich zum Testen deaktiviert.

Grüße
Stefan