Dieser Beitrag ist schon älter. Bitte vergewissern Sie sich, dass die Rahmenbedingungen oder der enthaltene Lösungsvorschlag noch dem aktuellen Stand der Technik entspricht.

Kann man einen Server zur Performacesteigerung mit 2 Netzwerkkarten parallel an einem Switch betreiben? Wenn ja mit welcher Konfiguration ?

Mitglied: herber-herber

Wir haben seit kurzem ein NAS was über zwei 1GB NIC´s im Modus Loadoptimierung an den Switch angeschlossen ist.
Dies wirft bei mir (als Nichthardwarespezi) die Frage auf, ob ich evtl. auch den 2ten bisher ungenutzten NIC des Server für so etwas mit nutzen kann?

Wenn dies geht, mit welche Konfiguration muss ich den 2ten NIC zur Performancesteigerung an den Switch anschließen?

Server:
SBS 2003 mit allen SP´s
Konfig NIC1
IP.192.168.1.11
Gatewaye.192.168.1.254
DNS1:192.168.1.11
DNS2:192.168.1.254

Clients:
XP pro. inkl. aller SP´s


Vielen Dank im voraus!

Content-Key: 113735

Url: https://administrator.de/contentid/113735

Ausgedruckt am: 23.10.2021 um 08:10 Uhr

Mitglied: aqui
aqui 13.04.2009, aktualisiert am 18.10.2012 um 18:37:58 Uhr
Goto Top
Ja, generell klappt das vollkommen problemlos !!! Bei Microsoft Servern (oder PCs generell) nennt man diese IEEE 802.3ad Link Aggregation Teaming !!

Bei Intel Chip basierenden Treibern ist das z.B. die bekannte Intel Pro Suite und bei den ebenfalls sehr populären Marvel Chipsätzen auf Mainbords sind das diese Treiber die ein Teaming supporten:
http://www.marvell.com/drivers/driverDisplay.do?driverId=199
Broadcomm Chipsätze in HP Servern z.B.
http://www.broadcom.com/support/ethernet_nic/downloaddrivers.php
Haben eine Management Suite (BACS) die man mit den Treibern downloaden kann und die ein Adapter Teaming supportet.

3Com und andere NIC Hersteller haben entsprechende Treiber in ihren Download Bereichen im Web !

Diese beiden Threads hier:

https://www.administrator.de/forum/motherboard-mit-2-onboard-lan-anschl% ...
und
https://www.administrator.de/forum/traffic-am-server-auf-2-nics-verteile ...

sollten zudem alle deine Fragen zu diesem Thema beantworten !!

Was das Thema Konfiguration anbetrifft ist das mehr oder weniger Hersteller spezifisch. Bei Winblows Servern heist so ein Link Aggregation Teaming und der NIC Kartentreiber muss das supporten, was aber die meisten High End Karten heutzutage problemlos machen.

Auf der Switch Seite ist das auch sehr unterschiedlich und hängt von der Command Line Syntax ab. Hier mal 3 Beispiele (2 GiG Trunk) als Vergleichsübersicht mit einer Cisco Switch Konfig, einer Foundry Switch Konfig sowie einer HP Switch Umgebung:

Cisco Konfiguration:

interface Port-channel35
description 2 GiG Trunk zum Server
no ip address
switchport
switchport access vlan 10
switchport mode access
!
interface GigabitEthernet1/1
description Erster 1 GiG Link
no ip address
switchport
switchport access vlan 10
switchport mode access
channel-protocol lacp
channel-group 35 mode active
!
interface GigabitEthernet1/14
description Zweiter GiG Link
no ip address
switchport
switchport access vlan 10
switchport mode access
channel-protocol lacp
channel-group 35 mode active


Foundry Konfiguration:

interface ethernet 1/1
port-name Erster GiG Link
link-aggregate configure key 10000
link-aggregate active
!
interface ethernet 1/2
port-name Zweiter GiG Link
link-aggregate configure key 10000
link-aggregate active

HP Konfiguration:

Bei HP Switches ist generell LACP im passive Modus auf allen Ports im Default aktiviert. Ob das nun sinnvoll ist oder nicht ist sicher diskussionswürdig aber nicht Thema dieses Threads.
Der HP Switch kann also sofort Links bündeln sofern die andere Seite (Server oder Switch) im LACP active Modus ist.
Den HP Switch kann man pro Port auch in den Active Modus setzen mit:
.
(config) # int eth 1 to 2
(eth-1-2) # lacp active
(eth-1-2) # write mem
Danach kann man sich wie bei den o.a. Switches auch mit
(eth-1-2) # show lacp
Den Trunking /Teaming Status ansehen !

Bei anderen Herstellern hast du halt andere Kommandos. Welche das sind steht im Handbuch unter Link Aggregation !!
Mitglied: aqui
aqui 19.04.2009 um 20:01:57 Uhr
Goto Top
Wenns das jetzt war bitte dann
https://www.administrator.de/index.php?faq=32
nicht vergessen !!
Heiß diskutierte Beiträge
question
Einfache Software für MitarbeiterinformationichbinwerichbinVor 1 TagFrageZusammenarbeit9 Kommentare

Guten Morgen Ich lese hier schon seit Jahren und bräuchte jetzt mal einen Hinweis. Ich weiss nicht ob Fragen nach Software beantwortet werden (Werbung?) aber ...

question
Gefahren durch Nutzung von EOL Smartphones (end of life support)nachgefragtVor 21 StundenFrageSicherheit15 Kommentare

Hallo Administratoren, weil Freitag ist erlaube ich mir die Frage (brainstorming): Welche Gefahren hinsichtlich IT-Sicherheit und Datenschutz seht ihr bei der Nutzung von (eol) Smartphones, ...

question
Netzwerk Neuaufbau - DHCP - VLANs gelöst SommelierVor 1 TagFrageWindows Server17 Kommentare

Hallo zusammen! Wir ziehen gerade unser Netzwerk neu auf, und ich wollte mir bei euch Rat einholen. Wir wollen verschiedene VLANs anlegen: Printer (172.16.20.0/24) Windowsumgebung ...

question
Netzwerkplan u. Kabelbelegung zeichnen? gelöst McLionVor 20 StundenFrageNetzwerke11 Kommentare

Hallo zusammen, ich suche irgendein Tool (am besten Open Source) um Netzwerkpläne zu zeichnen. Diese gibt es zwar wie Sand am Meer, aber mir geht's ...

question
Nebenstellenkreis von 2stellig auf 3stellig - was geschieht mit den bisherigen Rufnummerndeparture69Vor 1 TagFrageTK-Netze & Geräte13 Kommentare

Hallo. Bei uns besteht für 2022 die Anforderung, deutlich mehr Bürotelefone in Einsatz zu bringen. Die Anzahl der Nebenstellen ist vertragsseitig derzeit aber auf 100 ...

question
Standort vs. Standort gelöst erikroVor 1 TagFrageWindows Server8 Kommentare

Moin, Hintergrund der Frage ist, dass ich für ein PS-Skript auf dem RDS wissen muss, wo der Client steht. Ich hatte zuerst die Idee, das ...

question
HA Konstrukt für Firmennetzwerk mit mehreren WAN VerbindungenITAllrounderVor 1 TagFrageLAN, WAN, Wireless19 Kommentare

Guten Morgen zusammen, ich stehe gerade vor der Überlegung unser Firmen Netzwerk etwas umzustrukturieren. Aktuell primäres Problem: Wir haben theoretisch 2x Sophos XG310 (nur 1x ...

question
Mitarbeiter Onboarding Trainings Program on Premise gelöst MineralwasserVor 1 TagFrageSonstige Systeme3 Kommentare

Guten Nachmittag Kennt jemand ein gutes Programm das als Web-Service läuft, jedoch am besten nicht in der Cloud um die Mitarbeiter zu schulen. Also wenn ...