meltinsands
Goto Top

NAS nur nach Router-Reboot erreichbar

Hallo zusammen,

Ich nutze eine NAS als Backup im Client LAN für meine lokale NAS.

Hintergrund:
Ich habe vor kurzem von OpenVPN (IPv4) auf Wireguard (IPv4 und IPv6) umgesattelt und dabei Server und Client (beides RaspberryPi) komplett neu aufgesetzt. Danach habe ich folgendes Problem festgestellt.

Setup:
- Wireguard Site-to-Site VPN
- Firewall auf beiden Systemen nftables
- NAS DS220j - ver. 7.2.
- Router FRITZ!Box 7530 - ver. 7.57
- Im Client-LAN ist per nftables eingerichtet, dass ich nur Zugriff auf Router und NAS habe. Umgekehrt ist es genauso.

Problem:
- Ich komme nicht auf die NAS im Client LAN, der Router im Client LAN ist erreichbar.
- Ich kann die NAS per IPv6 anpingen aber nicht per IPv4.

Workaround:
- Ich muss den Router im Client LAN neu starten. Nach dem Reboot ist die NAS erreichbar.

Lösungsansätze:
- Ich hatte mich auch schon per Remotesitzung auf einen Laptop im Site-to-Site LAN angemeldet und auch dort war erst nach einem Reboot die NAS zu sehen.

Ich bin daher sicher, das Problem ist bei NAS und Router zu finden und es hat nichts mit meiner VPN Konfiguration zu tun.

Leider sehe ich keine Fehler...sonst würde ich ja nicht schreiben. Aber auffällig ist, dass im Infocenter der NAS die 2001er IPv6 3x identisch zu finden ist. In meiner lokalen NAS ist die globale IPv6 nur 1x enthalten.

Was passiert beim Reboot, dass das Problem temporär löst, aber sobald man die NAS rebootet, ist sie nicht im LAN erreichbar?

Content-Key: 33324509818

Url: https://administrator.de/contentid/33324509818

Printed on: February 25, 2024 at 11:02 o'clock

Member: kreuzberger
kreuzberger Nov 14, 2023 at 16:31:40 (UTC)
Goto Top
Nabend @meltinsands

ggf. solltest du dem SYNOLOGY eine feste IP4 Adresse geben und diese in deinem lokalen DNS fest eintragen.

Kreuzberger
Member: lucas1243
lucas1243 Nov 14, 2023 at 16:42:00 (UTC)
Goto Top
Vielleicht ne doppelte IP im LAN?
Member: meltinsands
meltinsands Nov 14, 2023 updated at 16:53:14 (UTC)
Goto Top
@kreuzberger Die DS hat eine feste IP, der DNS ist die Fritzbox. Der DNS ist bei der DS nicht manuell eingetragen, hatte aber auch schon manuell die Fritzbox hinterlegt, aber hat nichts geändert.

@lucas1243 Daran hatte ich auch schon gedacht. Habe in der Fritzbox die DHCP auf einen neuen Bereich gelegt und ich sehe kein Gerät mit der selben IP im Heimnetz.

Ich finde den funktionierenden IPv6 Ping komisch und die doppelten Einträge der globalen IPv6. Irgendwas stimmt doch nicht face-wink Schade, dass man im Browser nicht über die IPv6 auf die DS Oberfläche zugreifen kann.
Member: lucas1243
lucas1243 Nov 14, 2023 at 16:52:35 (UTC)
Goto Top
Ansonsten vielleicht ein Gerät welches versucht sich mit falschen Zugangsdaten am NAS anzumelden, wodurch die NAS Firewall greift?

Würde mal in den Logs vom NAS schauen.
Member: meltinsands
meltinsands Nov 14, 2023 updated at 19:38:14 (UTC)
Goto Top
Nach dem reboot kommen
[LAN 1] link down
[LAN 1] link up
[LAN 1] link down
[LAN 1] link up

Das taucht erstmalig ab dem Update auf DSM 7.2-64570 Update 3 nach einem Reboot auf.

Habe mittlerweile auf DSM 7.2-69057 Update 1 gewechselt...keine Änderung.

Habe in der Fritzbox das Gerät aus den festen IP Adressen rausgeworfen und im Heimnetz komplett zurück gesetzt, sodass es wie ein Neugerät nach dem Reboot behandelt wird.
Member: meltinsands
meltinsands Nov 14, 2023 updated at 20:05:52 (UTC)
Goto Top
Ich habe IPv6 in der NAS deaktiviert und nun bleibt sie auch nach einem Reboot im Netzwerk erreichbar.

Ist zwar eigentlich nicht die Lösung....aber ich weiß auch nicht, wo hier der Konflikt ist und warum sie nicht per IPv4 erreichbar ist, wenn IPv6 ein Problem hat. Ich habe wohl IPv6 nach/kurz vor dem Update aktiviert.
Member: kreuzberger
kreuzberger Nov 14, 2023 at 22:40:08 (UTC)
Goto Top
Nabend @meltinsands

es macht Sinn die feste IP4 des SYNO im DNS der Fritzbox als Reservierung bzw. A Record einzutragen.

Kreuzberger
Member: aqui
aqui Nov 15, 2023 updated at 07:50:06 (UTC)
Goto Top
wenn IPv6 ein Problem hat.
IPv6 hat wohl eher kein Problem sondern deine Router Konfig. Ohne das du aber deine IPv6 Adressierung hier näher erläuterst werden wohl auch wir nur kristallkugeln können... face-sad
Nebenbei: Das GUI des NAS' lässt sich auch problemlos per IPv6 im Browser erreichen. face-wink
Member: meltinsands
meltinsands Nov 15, 2023, updated at Nov 16, 2023 at 20:47:21 (UTC)
Goto Top
@kreuzberger: Die DS ist mit einer festen IP in der Fritzbox hinterlegt. Das meinst du doch?

@aqui: Stimmt, IPv6 hat höchstens das Problem, dass es noch immer nicht vernünftig implementiert ist.
Dann will ich mal etwas Licht in die Glaskugel bringen:
  • Fritzbox ist der Internet Router
  • Router Advertisement im LAN aktiv + ULA immer zuweisen aktiv + ULA Präfix manuell festlegen
  • Fritzbox stellt den Standard-Internetzugang zur Verfügung + Präferenz des Router Advertisements ist mittel
  • DNSv6-Server auch über Router Advertisement bekanntgeben + Lokaler DNSv6 Server ist die Fritzbox IP
  • DHCPv6 Server in der Fritzbox für das Heimnetz aktiv + Nur DNS Server zuweisen
  • DNSv6 Server ist vom Internetanbieter zugewiesener DNSv6 Server
Member: aqui
aqui Nov 16, 2023 at 12:24:35 (UTC)
Goto Top
IPv6 hat höchstens das Problem, dass es noch immer nicht vernünftig implementiert ist.
Sorry, solche Aussage ist barer Unsinn heutzutage. Da solltest du noch einmal in dich gehen bevor du so etwas in einem Admin Forum postest. face-sad
Member: meltinsands
meltinsands Nov 16, 2023 at 12:48:24 (UTC)
Goto Top
Auch Sorry, aber es gibt genügend Software und Dienste, wo das Thema IPv6 absolut stiefmütterlich behandelt wird.
Member: meltinsands
Solution meltinsands Nov 16, 2023 at 20:49:16 (UTC)
Goto Top
@kreuzberger: IPv4 habe ich nun auch in der NAS manuell hinterlegt. Hat das Problem gelöst. Hattest du noch einen anderen Ansatz oder meintest du das?
Member: kreuzberger
Solution kreuzberger Nov 16, 2023 at 20:56:44 (UTC)
Goto Top
Hurra, @meltinsands, wenn es nun geht, is doch supa.

Die IP4 Adresse des SYNO sollte fest im NAS eingetragen sein, damit sie nicht mal so mal so lautet. Diese IP4 sollte identisch reserviert im DHCP sein.
Darüber hinaus sollte diese IP4 noch im DNS als A-Record stehen.

https://www.ionos.de/digitalguide/hosting/hosting-technik/a-record/

Krezberger