ex0r2k16
Goto Top

Windows 10 Suche defekt?

Hallo!

Einem Kollegen und mir ist folgendes Phänomen bei Win 10 - 1909 aufgefallen. Die Suche ist plötzlich aus dem nichts defekt.

Der besagte Freund ist in keiner Domäne und sprach mich darauf an. Kurz darauf kam ein Anruf von einem meiner User mit exakt dem gleichen Problem.

Man erhält einfach nur ein leeres Bild zurück.

Welche Verschwörung steckt dahinter? Und nun mal alle fleissig selbst testen :D
2020-02-05 13_55_57-

Content-Key: 543937

Url: https://administrator.de/contentid/543937

Printed on: May 22, 2024 at 15:05 o'clock

Member: falscher-sperrstatus
falscher-sperrstatus Feb 05, 2020 at 13:00:26 (UTC)
Goto Top
Moin,

aktuelles Update eingespielt?

VG
Member: Ex0r2k16
Ex0r2k16 Feb 05, 2020 at 13:07:37 (UTC)
Goto Top
Jein. Ich habe meine festen Patchdays (WSUS). Dieser ist schon ein paar Tage her. Der besagte Freund hat keinen WSUS und patched das Ding privat.

Einzige Gemeinsamheit: Alles Lenovo Laptops (T460p-T480-T490).
Member: falscher-sperrstatus
falscher-sperrstatus Feb 05, 2020 at 13:08:57 (UTC)
Goto Top
Nach Neustart immer noch so?
Member: 7Gizmo7
7Gizmo7 Feb 05, 2020 at 13:12:00 (UTC)
Goto Top
Hi,

Bei einem neuen Konto das selbe Problem?
Member: Ex0r2k16
Ex0r2k16 Feb 05, 2020 at 13:14:50 (UTC)
Goto Top
Zitat von @falscher-sperrstatus:

Nach Neustart immer noch so?

korrekt
Member: ForgottenRealm
ForgottenRealm Feb 05, 2020 updated at 13:20:18 (UTC)
Goto Top
Moin,

bei mir ist es auf mehreren PCs in der Firma ebenfalls so. Einer davon hat seit 2 Wochen keine Updates mehr gesehen, wurde heute zum ersten Mal eingeschaltet.

Interessanterweise funktioniert auch die Suche nach Dateien oder Inhalten im Explorer nicht, nach Eingabe passiert einfach nichts.

Auf zwei privat PCs geht alles.

Firma zwei PCs mit WSUS, keine Updates bekommen da auf 14 Tage gestellt, zwei VM Ware PCs ohne WSUS, ebenfalls Suche defekt.
Member: falscher-sperrstatus
falscher-sperrstatus Feb 05, 2020 at 13:20:55 (UTC)
Goto Top
Da schraubt doch wieder jemand an dem Cloud-Mist von Cortana rum bei Microsoft …

gehe ich auch von aus. Ggf. weil die Kommunikationseinstellungen auf minimum gesetzt wurden, wie siehst du das Exor?
Member: Ex0r2k16
Ex0r2k16 Feb 05, 2020 at 13:25:38 (UTC)
Goto Top
das denke ich auch. Ich bin noch bei der Analyse und warte weitere Meldung ab, aber das Thema könnte mir (oder uns) um die Ohren fliegen.

@ForgottenRealm: Hast du Win10 Pro oder Entperise bei den betroffenen Clients im Einsatz?

Ein neuer User half übrigens auch nicht. Der Bug ist systemweit. Egal ob lokales oder Domain Konto.
Member: ForgottenRealm
ForgottenRealm Feb 05, 2020 updated at 13:26:31 (UTC)
Goto Top
Eine der VMs steht auf Microsofts "wir wollen alles wissen" Einstellungen, also nichts deaktiviert. Dort geht's ebenfalls nicht.

Edit: Win 10 Pro
Member: Ex0r2k16
Ex0r2k16 Feb 05, 2020 at 13:29:17 (UTC)
Goto Top
hier auch Win 10 Pro...
Member: MarcAdams
MarcAdams Feb 05, 2020 at 13:30:59 (UTC)
Goto Top
Hallo zusammen,

wir haben im Unternehmen auch aktuell das Problem.
Es ist Windows 10 Pro 1909 Build 18363.628.

Alle Windows Update sind installiert.

Falls jemand eine Lösung hat gerne melden face-smile

Gruß
Marc
Member: Ex0r2k16
Ex0r2k16 Feb 05, 2020 updated at 13:32:22 (UTC)
Goto Top
Was ist denn hiermit?

https://www.windowslatest.com/2020/02/05/its-not-just-you-windows-10-sea ...

/Edit: Kann aktuell nicht neustarten. Daher kann ich das nicht verifizieren.
Member: MarcAdams
MarcAdams Feb 05, 2020 at 13:38:21 (UTC)
Goto Top
Brachte bei uns leider keine Verbesserung face-sad
Member: Ex0r2k16
Ex0r2k16 Feb 05, 2020 updated at 13:42:51 (UTC)
Goto Top
Ich hab den nächsten Rechner mit dem Symptom. Na Prost Mahlzeit...
/Edit: +2
Member: ForgottenRealm
ForgottenRealm Feb 05, 2020 updated at 13:42:38 (UTC)
Goto Top
@Ex0r2k16, auf meinem PC geht's nach deinem Link wieder, die Suche läuft, findet aber dank BingSearchEnabled=0 keine Bing Suchergebnisse, was mich zudem sehr Glücklich macht.

Werds mal auf den anderen PCs testen.
Member: akira2012
akira2012 Feb 05, 2020 at 13:49:09 (UTC)
Goto Top
Wir reden hier von der Datei und Ordner Suche und nicht von der "Ich gebe mal alles was Du hier eingibst ungefragt ins Internet weiter"-Suche? Muss ich zu Hause mal testen. Läuft denn der Such-Dienst?
Member: SeaStorm
SeaStorm Feb 05, 2020 at 13:53:59 (UTC)
Goto Top
Hi


das ist die Bing Suche. Die ist kaputt.

Einfach folgende registry einträge setzen und dann die searchui.exe abschiessen

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Search]
"BingSearchEnabled"=dword:00000000  
"CortanaConsent"=dword:00000000  
Member: ForgottenRealm
ForgottenRealm Feb 05, 2020 at 13:54:02 (UTC)
Goto Top
Kaputt war/ist die Suche über das Startmenü + "Drucker", "Word" … eingeben, als auch die Suche nach Dateien oder Dateiinhalten direkt im Explorer Fenster oben rechts.

Wie es scheint, sind nicht einzelne PCs betroffen, sondern entweder alle PCs im Netzwerk, die an einer Internetleitung hängen, oder eben keiner.

Bei 4 Kunden habe ich keine Probleme, je etwa 5-50 PCs, bei 2 Kunden geht's nicht.

Wir sind bei der Telekom, die zwei Kunden bei denen es geht meines Wissens nach auch. Andere sind bei EWE/Vodafone, da geht's.
Member: leon123
leon123 Feb 05, 2020 updated at 13:55:34 (UTC)
Goto Top
Bei uns ist das Problem auch bei vielen PCs egal ob in der Domäne oder nicht.


Ich hab gerade an einem anderen PC getestet, das erste mal suchen hat geklappt, beim zweiten mal ging sie dann nicht mehr.

Das mit der Registry hat bei mir nicht funktioniert.

Ohne diese Suche kann heute leider niemand mehr arbeiten...


Mich würde interessieren was da los ist...


Das Problem ist aber erst seit gut 1-2 h.
Member: Ex0r2k16
Ex0r2k16 Feb 05, 2020 at 13:56:34 (UTC)
Goto Top
Der Suchdienst läuft. Ja wir reden von dieser Cortana Suche. Die lokale Dateissuche ist aber ebenfalls betroffen!
Member: Ex0r2k16
Ex0r2k16 Feb 05, 2020 at 13:57:35 (UTC)
Goto Top
Zitat von @leon123:

Ich hab gerade an einem anderen PC getestet, das erste mal suchen hat geklappt, beim zweiten mal ging sie dann nicht mehr.


Genau das kann ich bestätigen. Nach 5min warten klappte es nicht mehr. Ich klapper jetzt nochmal die Rechner ab, die ich eben getestet habe.
Member: dertowa
dertowa Feb 05, 2020 at 13:59:13 (UTC)
Goto Top
Nicht zwingend, wir haben per GPO Cortana deaktiviert, trotzdem:
Windows 10 suche geht nicht mehr
Member: Ex0r2k16
Ex0r2k16 Feb 05, 2020 at 14:01:46 (UTC)
Goto Top
So ich kann es erstmal bestätigen. Bei einem weiteren Client, der eben noch ging, klappt die Suche nicht mehr. Anschluss ist ebenfalls Telekom. Ja geil.
Member: ForgottenRealm
ForgottenRealm Feb 05, 2020 at 14:06:25 (UTC)
Goto Top
Bei Vodafone gibt's inzwischen auch Probleme, bei mir zuhause ging es vor einer halben Stunde noch, jetzt nicht mehr.
Nach dem Registry-Fix geht's wieder.
Mitglied: 142232
142232 Feb 05, 2020 updated at 15:10:38 (UTC)
Goto Top
Zitat von @SeaStorm:

Hi


das ist die Bing Suche. Die ist kaputt.

Einfach folgende registry einträge setzen und dann die searchui.exe abschiessen

Windows Registry Editor Version 5.00
> 
> [HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Search]
> "BingSearchEnabled"=dword:00000000  
> "CortanaConsent"=dword:00000000  

Jepp so isses... Bing "Bling Bling" is im A.... Sehe ich hier auch im Debugger wenn ich mich an den searchui Prozess klemme, astreine Buffer Overflows, mal sehen was sich damit so alles anfangen lässt face-wink, zero day i'm coming.
Member: Ex0r2k16
Ex0r2k16 Feb 05, 2020 at 15:20:29 (UTC)
Goto Top
Ich finde bei mir keine searchui.exe. Unter welcher Prozessgruppe soll die sein?

In meiner Registry sind die Werte bereits genau so gesetzt.
Mitglied: 142232
Solution 142232 Feb 05, 2020 updated at 15:48:42 (UTC)
Goto Top
Zitat von @Ex0r2k16:

Ich finde bei mir keine searchui.exe. Unter welcher Prozessgruppe soll die sein?
Auf den Detailreiter wechseln und search eintippeln ...
Kannst stattdessen natürlich auch neu starten

screenshot

Oder gleich schnell das hier in die Powershell abgefeuert
# startmenu empty fix
New-ItemProperty 'HKCU:\SOFTWARE\Microsoft\Windows\CurrentVersion\Search' -Name BingSearchEnabled -Value 0 -PropertyType DWORD -Force -verbose | out-null  
New-ItemProperty 'HKCU:\SOFTWARE\Microsoft\Windows\CurrentVersion\Search' -Name CortanaConsent -Value 0 -PropertyType DWORD -Force -verbose | out-null  
gps searchui | kill -force -Verbose
Feddisch.
Member: Henere
Henere Feb 05, 2020 at 15:38:51 (UTC)
Goto Top
Member: Ex0r2k16
Ex0r2k16 Feb 05, 2020 at 15:58:53 (UTC)
Goto Top
Vielen Dank! Der Powershell Befehl funtzt. Die Registrierungsgeschichten haben bei mir irgendwie nicht gezogen. Dann rolle ich das Ding moin mal aus,
Member: ArnoNymous
ArnoNymous Feb 05, 2020 at 19:29:32 (UTC)
Goto Top
Vielen Dank!
Das hat mich ja heute beinahe verrückt gemacht.
Member: UweGri
UweGri Feb 05, 2020 updated at 22:02:00 (UTC)
Goto Top
Ich würde nix ändern. Denn A ist das Problem bekannt B geht es bei mach Leuten (hier z.B.) und C kommt kommende Woche wieder Flicken …

zweifel ich echt am Systemdesign.

Bei W10? Jetzt erst? Ups ….

Ich mag zwar Dr. W nicht … aber

https://www.drwindows.de/news/schoene-neue-online-welt-ausfall-der-windo ...
Member: Alchimedes
Alchimedes Feb 05, 2020 at 23:04:35 (UTC)
Goto Top
Sorry Leute,

aber in der Registry rumhacken um ein beschissenes Update zu fixen ?
Wenn ich schon lese bing ... cortana ... ich koennt kotzen.

Die updates aus Redmond werden einfach nicht richtig getestet, dauernd wird nur verschlimmbessert.
Ich lehne das administrieren von dem Windowsdreck einfach ab.

Nun haben die Microsoft-Server offenbar einen kleinen Schluckauf – und der führt dazu, dass die Suche in Windows 10 vollständig außer Funktion ist

Die Win-Admins tun mir leid , da stehen jetzt alle mit Fackeln und Forken vor der Tür nur wegen dieser Nichtigkeit... Oder kann Keiner(r) deswegen mehr arbeiten ?

Aber das nächste Update kommt bestimmt.....


Gruß Alchimedes
Member: ArnoNymous
ArnoNymous Feb 06, 2020 at 07:47:22 (UTC)
Goto Top
"In der Registry rumhacken" hat mir gefallen. Was genau soll das Problem daran sein?
Member: Ex0r2k16
Ex0r2k16 Feb 06, 2020 at 07:57:51 (UTC)
Goto Top
Das klingt von ihm etwas hart formuliert, ja - aber im Grunde genommen hat er Recht. So etwas darf einfach nicht passieren. Zumal ja auch eine Standard Offline Suche dadurch abgeschossen wurde. Was machen denn jetzt die ganzen Heimanwender mit Win10 Pro? Die haben zum Teil noch nie etwas von ner Registry gehört. Für die ist das nicht nur "rumhacken" sondern ganz einfach Zauberei.
Member: ArnoNymous
ArnoNymous Feb 06, 2020 at 08:26:57 (UTC)
Goto Top
Das eine hat mit dem anderen nichts zu tun.
Natürlichdarf sowas nicht passieren - und ja, das passiert bei MS doch relativ oft.
Trotzdem sind wir hier noch immer in einem Admin-Forum.
Member: dertowa
dertowa Feb 06, 2020 at 08:28:24 (UTC)
Goto Top
Zitat von @UweGri:
zweifel ich echt am Systemdesign.
Bei W10? Jetzt erst? Ups ….

So wie das Startmenü gestrickt ist, würde ich mal vermuten es ist noch niemandem bei Microsoft bewusst aufgefallen,
dass dann auch lokal nicht mehr gesucht werden kann. :D
Nach der Erfahrung gestern habe ich aber auch dazugelernt und die Bing-Suche bleibt aus.

Wenn sowas nach einem offensichtlichen Update eintritt oder mit einer entsprechenden Meldung nicht mehr funktioniert
ist das die eine Sache, den Benutzer oder den Admin aber so dermaßen im Regen stehen zu lassen ist mies.
Member: MysticFoxDE
MysticFoxDE Feb 08, 2020 at 09:24:23 (UTC)
Goto Top
Moin Zusammen,

anscheinend hat noch niemand das wahre Problem hinter dem Problem realisiert. 😨😱
Jeder der dieses Problem in einem Firmennetzwerk erlebt hat, sollte das Folgende besonders genau durchlesen!!!

Die Windows Suche übermittelt in der Standardeinstellung jeglichen Suchbegriff an Microsoft/Bing, auch dann, wenn ihr nur nach lokalen Inhalten suchen wolltet. Insbesondere bei den internen Suchanfragen können die Suchbegriffe auch personenbezogene Daten enthalten.
Die Übermittlung von personenbezogenen Daten an dritte ohne die Erlaubnis des "Besitzers" ist jedoch laut EU-DSGVO untersagt und kann zu schweren Strafen führen!

Eigentlich macht hier Microsoft einen riesen Fehler, da per Standard die Übermittlung sämtlicher Suchanfragen per opt-out zugelassen ist, jedoch weis ich aus Erfahrung, dass sich an diesem Missstand, seitens Microsoft nicht so schnell etwas ändern wird.

Deshalb ist jedem Admin und auch User an dieser Stelle angeraten, selbst die Sache in die Hand zu nehmen und dieses gesetzeswidrige Verhalten schnellstmöglich abzustellen.

Besonders einfach und sicher geht es in Unternehmen bei denen die Domänencontroller bereits auf Server 2019 basieren.
Auf den DC gehen, Gruppenrichtlinienverwaltung aufrufen und die Default Domain Policy folgend bearbeiten.
Computerkonfiguration --> Richtlinien --> Administrative Vorlagen --> Windows-Komponenten --> Suche

no_cortona


Mit freundlichen Grüssen aus BaWü

Alex
Member: dertowa
dertowa Feb 09, 2020 at 11:39:59 (UTC)
Goto Top
Zitat von @MysticFoxDE:
Besonders einfach und sicher geht es in Unternehmen bei denen die Domänencontroller bereits auf Server 2019 basieren.
Auf den DC gehen, Gruppenrichtlinienverwaltung aufrufen und die Default Domain Policy folgend bearbeiten.
Computerkonfiguration --> Richtlinien --> Administrative Vorlagen --> Windows-Komponenten --> Suche

Alex

Hallo Alex,

wieso bedarf es dazu eines DCs der Version 2019?
Die Optionen waren bei uns gesetzt, trotzdem waren wir vom Problem des Bingausfalls betroffen.
Member: MysticFoxDE
MysticFoxDE Feb 09, 2020 at 14:44:54 (UTC)
Goto Top
Moin,

wieso bedarf es dazu eines DCs der Version 2019?

Weil hier die entsprechenden Templates schon von Haus aus dabei sind, bei einem 2016er DC mit Standardtemplates habe ich diese Einstellungen nicht setzen können, da diese nicht vorhanden waren. Mit aktualisierten ADMX geht es natürlich auch auf einem 2016er.

Die Optionen waren bei uns gesetzt, trotzdem waren wir vom Problem des Bingausfalls betroffen.

Tja, hier scheint sich wohl der nächste Bug anzukündigen. 🤢
Die oben erwähnen Einstellungen werden so wie es aussieht nicht von den Rechner übernommen. 🤮

Ich habe mittlerweile eine eigenständige GPO Namens "NO CORTANA" mit den oben beschriebenen Einstellungen erstellt und diese ganz oben
an die Domäne gehängt. Authentifizierte Benutzer und Domänencomputer dürfen lesen und ausführen.

Die Richtlinie wird laut "Gruppenrichtlinienergebnisse" und gpresult auch angewandt, nur landen die Einstellungen nicht auf dem Client.
Einfach auf dem Client zu prüfen --> "Editor für lokale Gruppenrichtlinien".

no_cortona_no_work

Jetzt heisst es, raus zu finden, warum es so ist ... nu Microsoft, nu pagadi ... 😡🤬👿

Grüsse aus BaWü

Alex
Member: dertowa
dertowa Feb 09, 2020 at 17:09:03 (UTC)
Goto Top
Zitat von @MysticFoxDE:
Mit aktualisierten ADMX geht es natürlich auch auf einem 2016er.
Da geht es sogar mit DC 2012...

Tja, hier scheint sich wohl der nächste Bug anzukündigen. 🤢
Die oben erwähnen Einstellungen werden so wie es aussieht nicht von den Rechner übernommen. 🤮
Mag daran liegen, dass einige Einstellungen derweil Enterprise-only sind und von den Pro-Versionen nicht berücksichtigt werden, also kein Bug.
Member: MysticFoxDE
MysticFoxDE Feb 09, 2020 at 19:44:01 (UTC)
Goto Top
Da geht es sogar mit DC 2012...

Jup, da hast du vollkommen recht.

Mag daran liegen, dass einige Einstellungen derweil Enterprise-only sind und von den Pro-Versionen nicht berücksichtigt werden, also kein Bug.

Das glaube ich weniger, dann würde ich die Optionen auf einem Win 10 PRO unter lokalen Gruppenrichtlinien auch nicht sehen, aber die sind da.
Wenn ich die Optionen von Hand lokal setzte (lokaler Gruppenrichtlinieneditor) dann funktionieren diese auch bestens.
Über GPOs geht aber gar nichts.

Laut rsop.msc (Client) müssten die entsprechenden Einstellungen auch gesetzt werden ...
rsop

Aber nichts geschieht ... 😤

Prüf mal bei dir auf einem Client der das Fehlerbild aufweist ob er die GPOs bei dir auch annimmt. ???
Der Fehler bei der Suche tritt nämlich nur auf, wenn die Cortana/Bing Suche auf den Clients aktiviert ist. 😉

Gruss Alex
Member: MysticFoxDE
MysticFoxDE Feb 09, 2020 updated at 20:30:12 (UTC)
Goto Top
Moin Zusammen,

juhu, das GPO Problem (Richtlinie wird nicht übernommen) ist nun auch gelöst.
Ich habe die Optionen nun wie folgt per GPO und Registry-Key gesetzt …

no_cortona_reg

HKLM\SOFTWARE\Policies\Microsoft\Windows\Windows Search

AllowCortana --> REG_DWORD --> 00000000
AllowCloudSearch --> REG_DWORD --> 00000000
AllowSearchToUseLocation --> REG_DWORD --> 00000000
ConnectedSearchUseWeb --> REG_DWORD --> 00000000
DisableWebSearch --> REG_DWORD --> 00000001

Und schon funktioniert es so wie es sein sollte und auch ohne aktuelle ADMX einsetzbar. 😀

@ Microsoft 😝

Grüsse aus BaWü

Alex
Member: falscher-sperrstatus
falscher-sperrstatus Feb 09, 2020 at 20:47:38 (UTC)
Goto Top
Dann liegt es wohl an der fehlenden Enterprise Version...
Member: MysticFoxDE
MysticFoxDE Feb 09, 2020 updated at 21:25:37 (UTC)
Goto Top
Dann liegt es wohl an der fehlenden Enterprise Version...

Nein, das tut es nicht.
Von den fünf Optionen ist lediglich nur eine, nur bei der Enterprise konfigurierbar und zwar die "Websuche nicht Zulassen", die anderen müssten auch bei der PRO gehen, zumindest habe ich bisher nichts gefunden was dem widerspricht.

Siehe auch ...

https://docs.microsoft.com/de-de/windows/client-management/group-policie ...

https://www.windowspro.de/wolfgang-sommergut/cortana-web-suche-deaktivie ...

cortana_dis

Gruss Alex
Member: dertowa
dertowa Feb 10, 2020 updated at 08:41:25 (UTC)
Goto Top
Zitat von @MysticFoxDE:
cortana_dis

Gruss Alex
Das ist auch heute noch so, ansonsten wäre der Eintrag
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Search]
"CortanaConsent"=dword:00000000

wohl bei den Clients nicht 0. ;)

Um den hier besprochenen Bing-Suche-Bug zu bereinigen reichte es durchaus:
[HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Search]
"BingSearchEnabled"=dword:00000000

Diesen hast du nun bei deinen ganzen Regkeys nicht gesetzt, ich bezweifle daher, dass
deine Regkeys die Lösung für das hier besprochene Problem gewesen wäre.
Member: MysticFoxDE
MysticFoxDE Feb 10, 2020 updated at 10:28:09 (UTC)
Goto Top
Moin,

Diesen hast du nun bei deinen ganzen Regkeys nicht gesetzt, ich bezweifle daher, dass
deine Regkeys die Lösung für das hier besprochene Problem gewesen wäre.

die oberen Keys funktionieren, habe es soeben bei einem Kunden der das Problem auch hatte reingeklopft,
Rechner durchgestartet und schon wars beseitigt.

Die von dir erwähnten Keys sind dennoch sehr interessant, danke für den Tip, das ist mir durchgerutscht.

War aber auch nicht von Anfang an bei Win 10 so, den Mist mit dem HKCU Part hat MS erst ab 1803 eingebaut, siehe ...

https://www.heise.de/newsticker/meldung/Windows-10-Version-1803-Microsof ...

So, nun schnell die GPO um die beiden Werte erweitern ...

Computer Part wie gehabt.
no_cortona_reg

noch den Benutzer Part.
no_cortona_v2

Grüsse aus BaWü

Alex