Top-Themen

Aktuelle Themen (A bis Z)

Administrator.de FeedbackApache ServerAppleAssemblerAudioAusbildungAuslandBackupBasicBatch & ShellBenchmarksBibliotheken & ToolkitsBlogsCloud-DiensteClusterCMSCPU, RAM, MainboardsCSSC und C++DatenbankenDatenschutzDebianDigitiales FernsehenDNSDrucker und ScannerDSL, VDSLE-BooksE-BusinessE-MailEntwicklungErkennung und -AbwehrExchange ServerFestplatten, SSD, RaidFirewallFlatratesGoogle AndroidGrafikGrafikkarten & MonitoreGroupwareHardwareHosting & HousingHTMLHumor (lol)Hyper-VIconsIDE & EditorenInformationsdiensteInstallationInstant MessagingInternetInternet DomäneniOSISDN & AnaloganschlüsseiTunesJavaJavaScriptKiXtartKVMLAN, WAN, WirelessLinuxLinux DesktopLinux NetzwerkLinux ToolsLinux UserverwaltungLizenzierungMac OS XMicrosoftMicrosoft OfficeMikroTik RouterOSMonitoringMultimediaMultimedia & ZubehörNetzwerkeNetzwerkgrundlagenNetzwerkmanagementNetzwerkprotokolleNotebook & ZubehörNovell NetwareOff TopicOpenOffice, LibreOfficeOutlook & MailPapierkorbPascal und DelphiPeripheriegerätePerlPHPPythonRechtliche FragenRedHat, CentOS, FedoraRouter & RoutingSambaSAN, NAS, DASSchriftartenSchulung & TrainingSEOServerServer-HardwareSicherheitSicherheits-ToolsSicherheitsgrundlagenSolarisSonstige SystemeSoziale NetzwerkeSpeicherkartenStudentenjobs & PraktikumSuche ProjektpartnerSuseSwitche und HubsTipps & TricksTK-Netze & GeräteUbuntuUMTS, EDGE & GPRSUtilitiesVB for ApplicationsVerschlüsselung & ZertifikateVideo & StreamingViren und TrojanerVirtualisierungVisual StudioVmwareVoice over IPWünsch Dir wasWebbrowserWebentwicklungWeiterbildungWindows 7Windows 8Windows 10Windows InstallationWindows MobileWindows NetzwerkWindows ServerWindows SystemdateienWindows ToolsWindows UpdateWindows UserverwaltungWindows VistaWindows XPXenserverXMLZusammenarbeit

Cisco, Mikrotik, pfSense VPN Standort Vernetzung mit dynamischem Routing

Mitglied: aqui

aqui (Level 5) - Jetzt verbinden

21.01.2019, aktualisiert 18.07.2020, 6349 Aufrufe, 5 Kommentare, 10 Danke


Allgemeine Einleitung

Das nachfolgende Tutorial ist eine Fortführung der hier bei Administrator.de schon bestehenden VPN Tutorials. Es beschreibt eine heterogene VPN Standort Vernetzung auf Basis von IPsec zwischen Cisco Routern und Mikrotik Routern. Es deckt damit ein Szenario ab bei dem ggf. in der Zentrale ein leistungsfähiger VPN Router (Cisco) zum Einsatz kommt, in den Außenstandorten aber z.B. aus Budget Gründen preiswerte Mikrotik Router.
Der Clou dieses Designs ist eine sicher verschlüsselte VPN Verbindung (IPsec im Transport Mode) über die eine GRE Tunnel Verbindung gelegt ist.
Die Verwendung von separaten GRE Tunneln bzw. Tunnel Interfaces im Vergleich zum direkten IPsec im Tunneling Mode ermöglicht den Einsatz von dynamischen Routing Protokollen wie RIPv2 oder OSPF.
Durch den vollständigen Entfall der manuellen Konfiguration statischer Routen, bei Verwendung eines dynamischen Routing Protokolls, ergibt sich eine erhebliche Vereinfachung und Fehlersicherheit im Routing.
Bei einer Vielzahl von Außenstellen stellt das eine erhebliche Erleichterung der Installation und des Managements dieser remoten Netze dar.
Ferner sind damit einfache automatische Leitungs Backup Szenarien realisierbar ohne jede manuelle Intervention um z.B. gesonderte Außenstellen über eine zweite Leitung oder direkten Backup auf eine andere Außenstelle abzusichern.
Gerade in VPN Standort Designs mit erhöhten Anforderungen wie remoter VoIP Telefonie usw. ergeben sich durch automatisches Backup und dynamisches Rerouting eine erheblich größere Betriebssicherheit.
Ebenso ist Multicast Routing (Audio- und Video Streaming) mit PIM über so ein Tunnel VPN Design in alle Standorte routebar.
Ziel ist es bei privaten oder Firmen VPNs im klein- und mittelständischen Umfeld bei Standort Vernetzungen ohne großes Probieren schnell zu einer funktionierenden und betriebssicheren Lösung zu kommen.
Die hier vorgestellten Beispiele und Screenshots können direkt auf bestehende Projekte übertragen werden, bei entsprechender Anpassung der IP Adressierung auf die eigenen Belange.
Die Beispiele können ebenfalls dazu dienen, solche VPN Designs auch in reinen Cisco oder reinen Mikrotik Umgebungen zu realisieren, da die grundlegenden Konfigurations Schritte identisch sind. Ebenso ist die Wahl des dynamischen Routing Protokolls frei. Wer OSPF bevorzugt kann dies natürlich statt des hier vorgestellten RIPv2 verwenden. RIPv2 wurde hier wegen der Einfachheit der Konfiguration gewählt. Zudem ist RIPv2 oft Feature Grundbestandteil auch einfacher Layer 3 (Routing) Switches und dedizierter Router.

In den weiterführenden Links am Ende des Tutorials findet man zusätzliche Informationen zu den Themen VPN und Routing.
Die Konfig ist einfach und auch von Laien umsetzbar. Ein klein wenig Basiswissen zum Thema IPsec VPNs generell und Cisco Command Line Interface bzw. Mikrotiks grafischer WinBox Konfig kann aber, wie immer, nicht schaden und hilft beim Verständnis !

GRE Testumgebung

Das Internet wird hier durch separate 10er IP Netze mit DHCP Adressvergabe simuliert. Alle VPN Router arbeiten mit ihrem WAN / Internet Port per NAT (Netzwerk Adress Translation) und einer aktiven Firewall untereinander auf diesem IP Netz. Somit genau wie im Internet bzw. über den Provider unter realen Bedingungen.
Die VPN Verschlüsselung nutzt nur das aktuelle und derzeit sichere AES in einer 256Bit Variante.
Eigene IP Adressierung und ggf. WAN Port Konfigs wie xDSL müssen entsprechend angepasst werden.
Das VPN Design sieht so aus:

gre-test-basis - Klicke auf das Bild, um es zu vergrößern

Dieses Design behandelt im ersten Schritt die Grundkonfiguration beider Komponenten. Die IP Adressierung hier im Tutorial:
Internet Adresse Cisco = 10.99.1.198
Internet Adresse Mikrotik = 10.1.1.150
GRE Tunnel Netz = 172.31.31.8 /30 (Cisco=172.31.31.9, Mikrotik=172.31.31.10)
Lokale LANs gemäß o.a. Abbildung.

Das Tunnel Netz ist ein Punkt zu Punkt Netz. Deshalb kommen hier immer /30er Netze (30er Prefix = 255.255.255.252 Subnetzmaske) mit 2 nutzbaren Hostadressen zum Einsatz.
Im zweiten Schritt des Tutorials wird ein zweiter Mikrotik Standort eingebunden und die Cisco sowie die Mikrotik Seite mit weiteren lokalen VLAN IP Netzen erweitert, um ein mehr Realitäts bezogenes Setup zu zeigen. Dazu später mehr...
Los gehts....

Cisco Router Setup (GRE)

Das Tutorial geht bewusst nicht mehr im Detail auf ein Standard Internet Setup ein was den Rahmen dieses Tutorial sprengen würde. Aus Gründen der Übersicht wird dies vorausgesetzt bzw. kann vom hiesigen Cisco_Grundlagen_Tutorial einfach übernommen werden. Es gilt für alle Cisco IOS basierten Modelle.
Es wird hier lediglich die VPN und GRE Tunnel Konfiguration in Verbindung mit einer Zone Based Firewall beschrieben die zur Konfiguration nötig sind.

(Alle hier rot markierten Konfig Parameter betreffen das erweiterte Design in Kapitel 6 für mehrere Standorte und zusätzliche lokale (V)LANs. Diese zusätzlichen lokalen LAN Netzwerke können in einem einfachen Design mit 2 Standorten und je einem einzigen lokalen LAN gem. der Zeichnung von oben natürlich weggelassen werden.
Kommentare zur Cisco Konfiguration in schwarz.)

!
hostname cisco_router
!
aaa new-model
!
aaa authentication login default local
aaa authorization network default local
!
clock timezone CET 1 0
==> Uhrzeit auf Europa / Sommerzeit setzen
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
ip dhcp binding cleanup interval 30
ip dhcp excluded-address 192.168.77.1 192.168.77.100
==> DHCP IP Adresspool .101 bis .149
ip dhcp excluded-address 192.168.77.150 192.168.77.254
!
ip dhcp pool LAN
==> DHCP Server für lokales LAN
network 192.168.77.0 255.255.255.0
dns-server 192.168.7.254
domain-name cisco.home.arpa
default-router 192.168.77.1
!
ip domain lookup source-interface Ethernet1
ip domain name cisco.home.arpa
ip name-server <DNS IP-Adresse>
ip inspect log drop-pkt
==> Logging der von der Firewall geblockten Pakete
!
class-map type inspect match-any internet-allowed
==> Festlegen der vom Internet erlaubten Pakete durch die Firewall
description Zugriff vom Internet erlauben
match access-group name WAN_IN
class-map type inspect match-any lan-allowed
==> Festlegen der vom LAN erlaubten Pakete durch die Firewall
description Lokale LAN Protokolle ins Internet erlauben
match protocol dns
match protocol http
match protocol https
match protocol imaps
match protocol smtp extended
match protocol sip-tls
match protocol rtsp
match protocol ssh
match protocol ntp
match protocol tcp
match protocol udp
match protocol icmp
!
policy-map type inspect lan-allowed-policy
==> Firewall Policy Lokales LAN zu Internet
description LAN zu Internet Policy
class type inspect lan-allowed
inspect
class class-default
drop
policy-map type inspect internet-allowed-policy
==> Firewall Policy Internet zu Router
description Internet zu Router Policy
class type inspect internet-allowed
pass
class class-default
drop
!
zone security lan
zone security wan
zone-pair security lan-wan source lan destination wan
description Firewall LAN-Internet
service-policy type inspect lan-allowed-policy
zone-pair security wan-self source wan destination self
description Firewall Internet-Router
service-policy type inspect internet-allowed-policy
!
crypto keyring MTVPN
pre-shared-key address 10.1.1.150 key test123

pre-shared-key address 10.99.1.149 key geheim123
==> Zweiter VPN Router (Siehe: Kapitel 6)
!
crypto isakmp policy 10
==> Festlegen der IPsec Schlüsselparameter
encr aes 256
hash sha256
authentication pre-share
group 14
!
crypto isakmp profile Mikrotik-1
==> Verbindungsparameter Mikrotik-1
description IPsec Mikrotik-1
keyring MTVPN
match identity address 10.99.1.149 255.255.255.255

crypto isakmp profile Mikrotik-2
==> Verbindungsparameter Mikrotik-2 (Siehe: Kapitel 6)
description IPsec Mikrotik-2
keyring MTVPN
match identity address 10.1.1.150 255.255.255.255

!
crypto ipsec transform-set mikrotik esp-aes 256 esp-sha256-hmac
mode transport
==> Transport Mode da Tunnel durch GRE realisiert !
!

crypto map mikrotik 10 ipsec-isakmp
==> Router Mikrotik-2 (Siehe: Kapitel 6)
description IPsec Mikrotik-2
set peer 10.1.1.150
set transform-set mikrotik
set isakmp-profile Mikrotik-2
match address 107
==> Alles was diese ACL definiert wird IPsec verschlüsselt
crypto map mikrotik 15 ipsec-isakmp
description IPsec Mikrotik-1
set peer 10.99.1.149
set transform-set mikrotik
set isakmp-profile Mikrotik-1
match address 108
!
interface Tunnel0
==> GRE Tunnel Interface
description GRE zu Mikrotik-2
ip address 172.31.31.9 255.255.255.252
ip mtu 1400
zone-member security lan
tunnel source 10.99.1.198
tunnel destination 10.1.1.150
tunnel path-mtu-discovery
!

interface Tunnel1
description GRE zu Mikrotik-1
ip address 172.31.31.1 255.255.255.252
ip mtu 1400
zone-member security lan
tunnel source 10.99.1.198
tunnel destination 10.99.1.149
tunnel path-mtu-discovery

!
interface Vlan1
description Lokales LAN
ip address 192.168.77.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
zone-member security lan
!

interface Vlan10
description Lokales VLAN-10
ip address 192.168.177.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
zone-member security lan

!
interface Ethernet 1
description Internet / WAN Verbindung
ip address 10.99.1.198 255.255.255.0
no ip redirects
no ip unreachables
ip nat outside
zone-member security wan
crypto map mikrotik
!
router rip
==> Dynamisches RIP Routing mit Version 2 ! aktivieren
version 2
passive-interface default
no passive-interface Tunnel0

no passive-interface Tunnel1

network 172.31.0.0
==> Netzwerke in klassischer Notation A,B,C angeben
network 192.168.77.0

network 192.168.177.0

no auto-summary
==> WICHTIG ! Aktiviert CIDR Masken
!
ip route 0.0.0.0 0.0.0.0 10.99.1.254
==> Default Route Internet
!
ip dns server
==> Cisco ist hier DNS Proxy. (Entfällt bei lokalem DNS Server !)
ip nat inside source list 101 interface Ethernet 1 overload
!
ip access-list extended WAN_IN
permit icmp any any echo-reply
permit icmp any any packet-too-big
permit icmp any any time-exceeded
permit udp any eq bootps any
permit udp any any eq isakmp
permit udp any any eq non500-isakmp
permit esp any any
permit gre any any
permit udp any eq domain any
permit tcp any eq domain any
permit udp any eq ntp any
!
access-list 101 deny ip 192.168.77.0 0.0.0.255 172.16.0.0 0.15.255.255
==> VPN Traffic in lokale private IP Netze vom NAT ausgenommen (Tunnel)
access-list 101 deny ip 192.168.77.0 0.0.0.255 192.168.0.0 0.0.255.255

access-list 101 deny ip 192.168.177.0 0.0.0.255 172.16.0.0 0.15.255.255
==> VLAN-10 VPN Traffic dto. vom NAT ausgenommen (Tunnel)
access-list 101 deny ip 192.168.177.0 0.0.0.255 192.168.0.0 0.0.255.255

access-list 101 permit ip 192.168.77.0 0.0.0.255 any
Alles andere per NAT ins Internet
access-list 101 permit ip 192.168.177.0 0.0.0.255 any
Dto. für VLAN-10
access-list 107 permit gre host 10.99.1.198 host 10.1.1.150
==> GRE Traffic (IP 47) zu Mikrotik-2 IPsec verschlüsselt ##
access-list 108 permit gre host 10.99.1.198 host 10.99.1.149
==> GRE Traffic (IP 47) zu Mikrotik-1 IPsec verschlüsselt ##
!
ntp server ntps1-0.cs.tu-berlin.de source Ethernet 1
==> Router Uhrzeit einstellen per NTP (Referenz TU Berlin)
!
end


Mikrotik RouterOS Setup

Default Konfiguration

Der Mikrotik Router kann für eine Grundkonfiguration im Default Setup verbleiben. Im Mikrotik Default Setup ist der Port ether 1 ein Internet Port (WAN) mit Firewall und NAT (IP Adress Translation) und arbeitet als DHCP Client. Er erhält also automatisch eine IP Adresse wenn man ihn mit diesem Port in ein bestehendes Netzwerk mit DHCP Adressvergabe steckt.
Dadurch, das in der Default Konfig eine sichere Firewall am ether1 Port arbeitet, geht man hier auch sicherheitstechnisch absolut auf Nummer sicher was den Schutz von außen anbetrifft !
Man kann den Mikrotik im Menüpunkt "System -> Reset Configuration" und Haken bei "Default Configuration" und "No Backup" mit einem Werksreset mit dieser Default Konfiguration versehen.

Default Konfiguration
tgre1 - Klicke auf das Bild, um es zu vergrößern

Interface und IP Adress Konfiguration

Im ersten Schritt richtet man dazu unter Interfaces - GRE ein Tunnel Interface ein.

Tunnel Interface einrichten und der "LAN" Interface Liste hinzufügen:
tgre2 - Klicke auf das Bild, um es zu vergrößernlanlist - Klicke auf das Bild, um es zu vergrößern


IP Adressen auf allen Interfaces konfigurieren:
tgre3 - Klicke auf das Bild, um es zu vergrößern

IPsec Schlüsselparameter setzen

Der Mikrotik bietet die Option ein separates IPsec Policy Profil für die Phase 1 und 2 zu setzen. Wer möchte kann das natürlich machen.
Einfacher und übersichtlicher ist es aber die schon bestehenden Default Profile im Mikrotik von Altlasten (3DES und SHA1) zu befreien und die modernere und sichere AES Verschlüsselung zu setzen. Damit können die Default Profile dann einfach beibehalten werden.

IPsec Peer Profil (Phase 1) einstellen
tgre4 - Klicke auf das Bild, um es zu vergrößern

IPsec Policy Profil (Phase 2) einstellen
tgre5 - Klicke auf das Bild, um es zu vergrößern

IPsec Peer auf den Cisco einrichten
tgre6 - Klicke auf das Bild, um es zu vergrößern
(Für Mikrotik-2 aus Kapitel 6 entsprechend das Passwort: geheim123 )

IPsec Peer Policies einstellen
tgre7 - Klicke auf das Bild, um es zu vergrößern
(IP Peer Adressen auf dem zweiten Router (Mikrotik-2, Kapitel 6) entsprechend anpassen !)

Wenn hier in der Phase 2 der Status auf "Established" geht, ist die IPsec Verbindung OK und der Tunnel aktiv. Der Cisco Router zeigt dann im Gegenzug mit show crypto isakmp sa den QM_IDLE Status an.

Dynamisches Routing mit RIPv2 Protokoll aktivieren

Generell kann hier jedes beliebige, dynamische Routing Protokoll verwendet werden. Ein Distance Vector Protokoll wie OSPF ist hier also durchaus auch eine Option sofern dies gefordert ist.
Das Tutorial beschreibt hier der Einfachheit halber ein einfaches Next Hop Protokoll wie das bekannte RIP (Routing Information Protocol) in der Version 2.
RIP ist auch in KMU Modellen von L3 Switches und Routern sowie in so gut wie allen Firewalls sehr weit verfügbar. OSPF eher mehr im High End Bereich. (Bei entsprechendem Interesse (PM) kann das Tutorial um ein OSPF Kapitel erweitert werden.)
Ganz wichtig ist das unbedingt und zwingend die Version 2 von RIP aktiviert wird !!!
Nur RIPv2 kann mit CIDR_Subnetzmasken Subnetzen umgehen, also mit variablen Subnetz Masken. Diese modernen und heutzutage allseits verwendeten CIDR Masken ersetzen endgültig die alte und 1993 abgeschaffte Einteilung in feste Netzwerk Klassen.

RIPv2 auf dem Mikrotik aktivieren und lokale IP Netze eintragen:
tgre8 - Klicke auf das Bild, um es zu vergrößern
Der Parameter "Passive" auf dem LAN Interface bedeutet das der Router hier keine RIPv2 Updates sendet und damit im LAN keine Routing Daten weitergibt. Soll er ja auch nur im WAN (VPN) machen !
Wer hier im LAN weitere RIPv2 Router betreibt, aktiviert hier natürlich KEINEN Passive Modus !
Zusätzlich ist es möglich die RIPv2 Routing Updates mit einem Passwort zu versehen um nicht authorisierte Router im Netz daran zu hindern Fake (Falsche) Routing Updates zu senden um so den Datenverkehr zu manipulieren.
Routing Updates werden dann nur mit Gegenstellen akzeptiert die gleiche Passwörter haben. Ein Sicherheits Feature.

Kontrolle der Routing Tabelle und IP Verbindung
tgre10 - Klicke auf das Bild, um es zu vergrößern
(DAC = Connected IP Netze, DAr = via RIPv2 dynamisch gelernt
Distance : 0=Lokal, 1=Statisch, 120=gelernt mit RIPv2)

Routing Tabellen Check auf dem Cisco Router:
120/1 zeigt auch hier die per RIPv2 ("R") vom Mikrotik gelernten Netze.
Ein Ping vom einen lokalen LAN in das remote lokale LAN verifiziert jetzt die korrekte Funktion der VPN Standort Vernetzung.

Sicher ?: Vertrauen ist gut, Kontrolle ist besser !...

Sind keine Konfigurationsfehler gemacht worden ? Sind die Daten wirklich sicher und verschlüsselt ?
Latente Zweifel bleiben (fast) immer wenn man sich den Datenverkehr der Standorte nicht explizit ansieht.
Eine kurze Kontrolle ob die VPN Daten wirklich sicher verschlüsselt über öffentliche Netze (Internet) gehen ist also nie falsch und schafft Vertrauen in diese Lösung ! Der Cisco Router zeigt die Sicherheit an:
Und auch der Mikrotik in seinem Log...:

lanlist3 - Klicke auf das Bild, um es zu vergrößern

Letzte Gewissheit das die Daten sicher sind schafft aber wie üblich ein Wireshark Sniffer Trace:

lanlist2 - Klicke auf das Bild, um es zu vergrößern
Das ESP Paket transportiert die verschlüsselten Daten zwischen den 2 Standorten !
Works as designed...! 👍

Erweiterte Standort Konfiguration mit mehreren lokalen VLANs

Ein mehr Praxis orientiertes VPN Standort Design ist eines, welches auch mehrere lokale (V)LANs berücksichtigt, denn die Mehrheit der KMU Netze sind heutzutage segmentiert. Größere sowieso. Dies muss schon aufgrund der Einführung von VoIP so sein um Voice Daten von produktiven Netzen fernzuhalten.
Das Beispiel beschreibt 3 Standorte und kann beliebig auf weitere Standorte erweitert werden. Die Konfigurationsschritte sind dazu immer gleich.

gre-test - Klicke auf das Bild, um es zu vergrößern

Die für den Cisco Router zu erweiternden Konfigurations Kommandos für einen zweiten Standort und ein weiteres lokales LAN (VLAN 10) findet man oben rot markiert.
Für die VLAN Grundkonfiguration der Mikrotiks findet man hier im Forum ein eigens, ausführliches VLAN_Tutorial !
Es müssen lediglich der RIP Routing Prozess aktiviert werden und die zusätzlichen lokalen IP Netze und Interfaces dort im RIP Routing eingetragen werden.


Virtuelle Tunnel Interfaces VTI statt GRE Tunnel verwenden

Eine Alternative zur oben gezeigten traditionellen Verwendung von GRE Tunneln mit dynamischem Routing stellt der modernere Ansatz mit VTI Tunneln dar. Aktuelle IPsec Implementationen supporten in der Regel auch VTI Interfaces. Damit ist eine IPsec LAN zu LAN Verbindung mit dynamischen Routing Protokollen und z.B. parallelem Multicast Routing erheblich einfacher zu konfigurieren. VTI Interfaces verhalten sich, wie oben schon bei den GRE Tunneln gesehen, wie ganz normale Netzwerk Interfaces.
Das hiesige Demo Setup nutzt die gleiche Internet Test Infrastruktur wie oben. Als dynamisches Routing Protokoll kommt hier das modernere OSPF statt RIPv2 zum Einsatz um beide Konfig Optionen zu zeigen.
In der pfSense muss dafür das Routing Package Quagga-OSPF oder alternativ das FRR Package installiert werden. Hier im Beispiel wurde FRR verwendet. Letztlich ist es egal denn die Konfigs der beiden Packete ist fast identisch.
Bei Mikrotik ist der VTI Support derzeit noch ein Request für künftige Firmware und deshalb in dieser Variante aktuell außen vor da nicht supportet zur Zeit.
An der Cisco Konfig bleibt die Grundkonfiguration mit IPs, Zone based Firewall usw. bestehen, deshalb werden der Übersicht halber nur die geänderten IPsec Konfigurationen hier aufgeführt.
Los gehts...

VTI Testumgebung

vti-vpn - Klicke auf das Bild, um es zu vergrößern

Cisco Router Setup (VTI)

Cisco Router 1 (R1):
!
crypto keyring ROUTER1
pre-shared-key address 0.0.0.0 0.0.0.0 key geheim123
pre-shared-key hostname CiscoR2 key geheim1234
!
crypto isakmp policy 5
encr aes 256
hash sha256
authentication pre-share
group 14
!
crypto isakmp policy 10
encr aes
authentication pre-share
group 2
!
crypto isakmp profile DVTI
description Dynamic VPN Tunnel
keyring ROUTER1
match identity address 0.0.0.0
virtual-template 3
crypto isakmp profile CISCO_R2
description Dynamic VPN Tunnel Cisco R2
keyring ROUTER1
self-identity user-fqdn CiscoR1
match identity user-fqdn CiscoR2
virtual-template 2
!
crypto ipsec transform-set VTISET esp-aes esp-sha-hmac
mode tunnel
!
crypto ipsec profile CISCO_R2
set transform-set VTISET
set isakmp-profile CISCO_R2
!
crypto ipsec profile DVTI
set transform-set VTISET
set isakmp-profile DVTI
!
interface Loopback1
ip address 172.27.27.1 255.255.255.255
!
interface Virtual-Template2 type tunnel
description Tunnel Interface Cisco-R2
ip unnumbered Loopback1
ip ospf network point-to-point
tunnel source 10.1.1.222
tunnel mode ipsec ipv4
tunnel destination dynamic
tunnel protection ipsec profile CISCO_R2
!
interface Virtual-Template3 type tunnel
description Dynamic VTI Tunnel
ip unnumbered Loopback1
ip mtu 1400
<== (muss für pfSense auf 1400 gesetzt sein sonst OSPF Link MTU Mismatch !)
ip ospf network point-to-point
tunnel source 10.1.1.222
tunnel mode ipsec ipv4
tunnel destination dynamic
tunnel protection ipsec profile DVTI
!
interface Vlan1
description Local LAN
ip address 172.27.1.254 255.255.255.0
ip nat inside
!
interface <WAN>
description Internet Port
ip address 10.1.1.222 255.255.255.0
ip nat outside
!
router ospf 1
router-id 172.27.27.1
passive-interface default
no passive-interface Virtual-Template2
no passive-interface Virtual-Template3
network 172.27.1.0 0.0.0.255 area 0
network 172.27.27.1 0.0.0.0 area 0
!
end


Cisco Router 2 (R2):
!
crypto keyring ROUTER2
pre-shared-key hostname CiscoR1 key geheim1234
!
crypto isakmp policy 5
encr aes 256
hash sha256
authentication pre-share
group 14
!
crypto isakmp policy 10
encr aes
authentication pre-share
group 2
!
crypto isakmp profile ROUTER1
description IPsec Tunnel Router-1
keyring ROUTER2
self-identity user-fqdn CiscoR2
match identity user-fqdn CiscoR1
!
crypto ipsec transform-set VTISET esp-aes esp-sha-hmac
mode tunnel
!
crypto ipsec profile ROUTER1
set transform-set VTISET
set isakmp-profile ROUTER1
!
!
interface Loopback1
ip address 172.27.27.5 255.255.255.255
!
interface Tunnel1
description VPN Tunnel Router-1
ip unnumbered Loopback1
tunnel source <WAN Interface>
tunnel mode ipsec ipv4
tunnel destination 10.1.1.222
tunnel protection ipsec profile ROUTER1
!
interface <WAN>
description Internet Port
ip address <Dynamic>
ip nat outside
!
interface Vlan1
description Local LAN
ip address 172.27.2.254 255.255.255.0
ip nat inside
!
router ospf 1
router-id 172.27.27.5
passive-interface default
no passive-interface Tunnel1
no passive-interface Vlan1
network 172.27.2.0 0.0.0.255 area 0
network 172.27.27.5 0.0.0.0 area 0
!
end


pfSense Setup (VTI)

Die pfSense hat ein ganz normales Standard Setup auf das hier im Tutorial nicht weiter eingegangen wird. Grundkonfigurationen zur pfSense findet man in den u.a. weiterführenden Links.
Lediglich am dritten OPT Port sind über einen VLAN Switch 3 Vlans 1, 10 und 20 angebunden um die OSPF Routing Tabelle etwas zu "füllen".
Über das IPsec VPN richtet man einen normalen Lan zu LAN Tunnel mit Phase 1 und Phase 2 an:
Phase 1:
vti-p1-1 - Klicke auf das Bild, um es zu vergrößern
vti-p1-2 - Klicke auf das Bild, um es zu vergrößern

Phase 2:
ACHTUNG: Das Besondere ist hier der Phase 2 Mode, der auf (Routed) VTI gesetzt werden muss !
vti-p2-1 - Klicke auf das Bild, um es zu vergrößern
vti-p2-2 - Klicke auf das Bild, um es zu vergrößern

Hat man alles richtig gemacht sieht es in der IPsec Übersicht so aus:
vti-phases - Klicke auf das Bild, um es zu vergrößern

Stimmen alle Einstellungen wird der VTI Tunnel zum Cisco fehlerfrei aufgebaut ("Established"):
vti-status - Klicke auf das Bild, um es zu vergrößern

OSPF Routing Protokoll pfSense:

Über die Package Verwaltung der pfSense sind zuerst das Quagga-OSPF oder das FRR Paket zu installieren um das OSPF Routing zu aktivieren. Welches man nimmt ist reine Geschmackssache. Die Konfig beider OSPF Pakete im pfSense GUI ist sehr ähnlich. Hier im Beispiel wurde FRR verwendet.
OSPF aktivieren mit Logging
vtiospf1 - Klicke auf das Bild, um es zu vergrößern
Interfaces und OSPF Area zuweisen: (Hier der Einfachheit halber alles in die Backbone Area 0)
vtiospf2 - Klicke auf das Bild, um es zu vergrößern

OSPF Funktions und Routing Check:

Cisco R1:
Oben sieht man die automatisch erkannten OSPF Neighbors (R2 und pfSense) und unten die R1 Routing Tabelle. Mit "O" sind alle per OSPF gelernten dynamischen Routen aufgelistet !
Analog ist das mit dem gleichen Kommando auf dem Router 2 zu sehen.
Bei der pfSense per Mausklick im grafischen Setup unter OSPF Status:
Neighbor:
vtiospf4 - Klicke auf das Bild, um es zu vergrößern
OSPF Routing Tabelle:
vtiospf3 - Klicke auf das Bild, um es zu vergrößern
Last but not least die Firewall Routing Tabelle:
vtiospf5 - Klicke auf das Bild, um es zu vergrößern

Ein Ping Check der jeweiligen lokalen Interfaces alle 3 Geräte verläuft danach erfolgreich.


Weiterführende Links

Cisco Router Grundkonfiguration:
https://administrator.de/wissen/cisco-880-890-router-konfiguration-adsl- ...

RIP Protokoll Übersicht:
https://de.wikipedia.org/wiki/Routing_Information_Protocol
https://www.cisco.com/c/en/us/td/docs/ios-xml/ios/iproute_rip/configurat ...
https://wiki.mikrotik.com/wiki/Manual:Routing/RIP

Heterogene IPsec VPN Standort Kopplung unterschiedlicher Hersteller:
https://administrator.de/wissen/ipsec-vpn-praxis-standort-kopplung-cisco ...

Standort Site to Site IPsec VPN mit pfSense Firewall und Mikrotik Router mit dynamischer IP:
https://administrator.de/content/detail.php?id=501151&token=508#comm ...

Einfache IPsec Tunnel Konfig mit pfSense Firewall (kein dyn. Routing !):
https://administrator.de/content/detail.php?id=437826&token=307#comm ...

VPN IPsec Standort Kopplung mit Cisco VTI Tunnel Interface:
https://www.administrator.de/content/detail.php?id=332230&token=14#c ...

Mikrotik L2TP VPN für mobile Clients:
https://administrator.de/content/detail.php?id=562927&token=111#comm ...

Mikrotik VLAN Konfiguration:
https://administrator.de/wissen/mikrotik-vlan-konfiguration-router-os-ve ...

Mikrotik WLAN AP mit MSSID Konfiguration:
https://administrator.de/content/detail.php?id=370669&token=397#comm ...

OT: Mikrotik OpenVPN Konfig Details:
https://administrator.de/content/detail.php?id=359367&token=695#comm ...

Probleme mit pfSense und dynamischem Routing:
https://administrator.de/content/detail.php?id=397059&token=479
(Wer hier eine Lösung hat bitte PM !)
Mitglied: ITgustel
02.04.2020 um 13:36 Uhr
Hallo, könntest du das Beispiel noch um ein DHCP-Relay erweitern?
Ich scheitere gerade (in einem Mikrotik-zu-Mikrotik-VPN) an einem funktionierendem Relaying.
Bitte warten ..
Mitglied: aqui
03.04.2020, aktualisiert um 09:37 Uhr
Klar !
Etwas Geduld bitte damit ich das wasserdicht testen kann.

Eine Frage noch zu deinem Setup:
Nutzt du einen DHCP Server auf dem oder einem zentralen Mikrotik um andere Netze mit IPs zu versorgen oder hast du einen externen, zentralen DHCP Server wie z.B. einen Windows DHCP an einem Hauptstandort ?
Bitte warten ..
Mitglied: aqui
03.04.2020, aktualisiert um 18:24 Uhr
So, die Lösung ist relativ einfach und funktioniert absolut fehlerfrei:
Testdesign und Konfig ist identisch wie oben.

vpn - Klicke auf das Bild, um es zu vergrößern


Setup des DHCP Relay auf dem Router der Client Seite (vlan1 IP Segment):

dhcp1 - Klicke auf das Bild, um es zu vergrößern

Hier ist das Client Interface, die Interface IP Adresse und die IP Adresse des DHCP Servers anzugeben !

Konfig des DHCP Servers (hier ISC-DHCP):
Output der DHCP Leasing Datei:
Checks DHCP Client (HP Windows 10 Laptop):
Nun hast du was zu Basteln übers Wochenende !

Fazit:
Works as designed !
Bitte warten ..
Mitglied: tikayevent
16.05.2020 um 23:55 Uhr
Hallo @aqui,

ich habe die letzten Tage fleißig Hardwaretests gemacht, da ich das ganze bald für einen RZ-Interconnect aufbauen werde. Wir haben zwar eine L2-Direktverbindung zwischen beiden RZ, aber mein Vorgesetzter besteht auf eine Verschlüsselung und ich benötige ein Routingprotokoll.

Soweit kein Problem, ist ja nicht das erste Mal, dass ich sowas baue. Bisher auf LANCOM, aber da ich annähernd Gigabit erreichen muss, ist LANCOM raus.

Ich habe jetzt zig verschiedene Sachen probiert (Cisco, Huawei, Mikrotik, OPNsense*), aber immer in der Variante Tunnel und dafür Loopback-Interfaces auf beiden Seiten (LANCOM hat den Transportmode rausgenommen und damit lief es nie wirklich).
*bitte nienienie wieder

Ich habe den Mikrotik-Test mit zwei RB750Gr3 (vulgo hEX) gemacht und kommt damit auf etwa ein Drittel des online angegebenen IPSec-Durchsatzes. Also von den 470Mbit, die Mikrotik pur gemessen hat, komme ich so auf 170Mbit. Gemessen mit iPerf im TCP-Modus mit 20GB an Daten, zum Teil mit angepasster MTU auf 1360 oder 1380 Byte. Meine Konfiguration war an die Hardwarebeschleunigung des hEX angepasst.

Weißt du, welchen Durchsatz du mit dem Transportmodus erreichen kannst? Du sparst dir ja sogesehen einen Durchlauf durch den Router. Da wir vermutlich unterschiedliche Geräte haben, wäre hier auch das Verhältnis von Real zu Mikrotikmesswert sinnvoll.

Ich hab mir jetzt noch zwei RB4011...!§$!"§$!"$ bestellt, mit denen ich dann testen will, ob ich an die Gigabitmarke rankomme.

Gruß
@tikayevent

PS: Ich nutz OSPF statt RIP, aber das wird da wohl nichts ausmachen.
Bitte warten ..
Mitglied: aqui
17.05.2020, aktualisiert um 12:01 Uhr
Du sparst dir ja sogesehen einen Durchlauf durch den Router.
Na, ja nicht ganz, die IP Forwarding Entscheidung wird ja auch irgendwo gefällt, also geroutet wird schon auch und von der Encryption her ist es gleich. Man spart nur den zusätzlichen Tunnel Overhead und hat weniger MTU Probleme.
Aber um die Frage zu beantworten: Ich habe aktuell keine Praxiswerte mit iPerf3 usw. und orientiere mich an den offizellen Produkt bezogenen IPsec Durchsatzzahlen von Mikrotik. Generell sollte man immer darauf achten das es auf der Plattform IPsec Acceleration in Hardware gibt:
https://wiki.mikrotik.com/wiki/Manual:IP/IPsec#Hardware_acceleration
Bei deinen 4011ern ist das für alle Crypto Suites gegeben ! Damit machst du also nix falsch.
Die zu erwartenden IPsec Durchsatzzahlen siehst du HIER.
Damit erreichst du die Gigabit Marke allemal jedenfalls bei Frame Sizes zwischen 512 und 1400 Byte. Bei kleineren Framesizes geht das dann wie üblich in die Knie.
Ich nutz OSPF statt RIP, aber das wird da wohl nichts ausmachen.
Nein, ganz im Gegenteil. OSPF ist besser. Weniger Overhead, schnellere Konvergenz. Ich werde das im Tutorial beizeiten nochmal erweitern.
Bitte warten ..
Ähnliche Inhalte
LAN, WAN, Wireless

IPsec IKEv2 Standort VPN Vernetzung mit Cisco, pfSense (OPNsense) und Mikrotik

Anleitung von aquiLAN, WAN, Wireless1 Kommentar

1.) Allgemeine Einleitung: Dieses Tutorial ist eine kurze Ergänzung zum allgemeinen IPsec Site_to_Site_VPN_Tutorial hier im Forum. Dieses Tutorial schildert ...

Netzwerkmanagement

How To Mikrotik Netinstall

Anleitung von areanodNetzwerkmanagement

Jedes Mal wenn ich Netinstall längere Zeit nicht benutzt habe stolpere ich über die „Besonderheiten“ dieser Software. Das ist ...

Sicherheit

MikroTik-Router patchen, Schwachstelle wird ausgenutzt

Information von kgbornSicherheit

Am 23. April 2018 wurde von Mikrotik ein Security Advisory herausgegeben, welches auf eine Schwachstelle im RouterOS hinwies. Mikrotik ...

Firewall

Möglicherweise neue Sicherheitslücke in Mikrotik-Firmware

Information von LordGurkeFirewall3 Kommentare

Hallo zusammen, vor ein paar Monaten gab es ja bereits eine Sicherheitslücke in der Firmware von Mikrotik-Routern, über welche ...

Neue Wissensbeiträge
Monitoring

Unabhängiger Ansatz - IoT (frei von Cloud- oder Appzwang) - Hier mit Schaltsteckdosen

Anleitung von beidermachtvongreyscull vor 13 StundenMonitoring

Tach Kollegen, ich erzähle Euch mal von meiner Ausgangslage und den/m Problem(chen) Ich benutze ein NAS zur Lagerung meiner ...

Microsoft
Microsoft Advanced Threat Protection for Linux
Information von Dani vor 2 TagenMicrosoft

Microsoft Defender Advanced Threat Protection (MD ATP) support for Linux with kernel version 3.10.0-327 or later, including the following ...

Humor (lol)
! ! Today ist SysAdmin-Day ! !
Information von VGem-e vor 4 TagenHumor (lol)5 Kommentare

Moin, "Happy Birthday" an alle Systemadministratoren, Mausschubser, System-/EDV-Betreuer, SysOps etc!! Siehe auch. Edit (Video hinzugefügt): Gruß VGem-e

Exchange Server
Basic Authentication and Exchange Online
Information von Dani vor 5 TagenExchange Server

Today we are pleased to announce some new changes to Modern Authentication controls in the Microsoft 365 Admin Center, ...

Heiß diskutierte Inhalte
Google Android
Smartphone - Internes Radio auf Bluetooth Lautsprecher abspielen
Frage von emeriksGoogle Android22 Kommentare

Hi, vielleicht kann ja einer von Euch auch sowas beantworten. Ich habe hier ein Samsung Smartphone - S10 Lite. ...

Ausbildung
Wie wird man zum Systemadministrator?
gelöst Frage von DavidHergAusbildung19 Kommentare

Guten Abend zusammen, Ich hatte hier schon ein paar Fragen gestellt, und mir wurde super weiter geholfen! Ich mache ...

Windows Server
Denselben Port auf verschiedenen Netzwerkkarten nutzen
gelöst Frage von entchenbrotWindows Server17 Kommentare

Hi wir haben einen Server PC mit verschiedenen Netzwerkkarten als Art Gaming-Server und würden gerne ein Spiel in zwei ...

Cloud-Dienste
Cisco 8841 - Enter activation code
Frage von c0d3.r3dCloud-Dienste16 Kommentare

Guten Morgen, ich habe gerade von einem Mitarbeiter den Hinweis bekommen, dass sein Telefon (Cisco 8841) einen Welcome-Screen mit ...

Weniger Werbung?
Administrator Magazin
07 | 2020 In der Juli-Ausgabe beleuchtet das IT-Administrator Magazin den Themenschwerpunkt "Monitoring & Support". Darin zeigt die Redaktion unter anderem, wie Sie die Leistung von Terminalservern im Blick behalten und welche Neuerungen das Ticketsystem OTRS 8 mitbringt. Auch die Überwachung von USV-Anlagen darf nicht fehlen. In ...