aqui
Goto Top

Cisco WLAN Access Points 1142N, 2602I, 2702l für den Heimgebrauch umrüsten

article-picture

back-to-topVorbemerkungen


Bei vielen kommerziellen Anwendern werden WLANs erneuert und Access Points auf neuere und aktuelle Standards umgerüstet. Gerade mit der Freigabe des dritten 6Ghz WLAN Bandes wird sich dieser Trend noch verstärken. Die Folge ist, das bei Wiederverkäufern und Verkaufsplattformen wie z.B. eBay und Co. solche professionellen Premium Access Points vermehrt zu sehr günstigen Preisen um die 10 Euro auftauchen.
Die o.a. AP Modelle sind für den damaligen Stand der Technik Premium APs, was man ihnen schon anhand der Verarbeitung mit einem massiven Metallgehäuse äußerlich ansieht. Mit Antennen auf Keramiksubstrat, die ohne große Leistungsverluste senden, ließe sich die Liste an Pluspunkten beliebig erweitern. Kein Vergleich zu Billiganbietern in meist dünnen und wackeligen Plastikgehäusen mit verlustreichen Antennen auf billigem Epoxyd.
Die Technik ist mit 802.11n (max. 600 Mbit/s bei WiFi 4) zwar nicht mehr die Allerneueste, aber für einen Dual Radio AP der gleichzeitig das 2,4 GHz und das 5 GHz WLAN Band mit MSSID/VLAN Funktion, schnellem 802.11r Roaming, Band Steering sowie MIMO 2x3 supportet macht der Cisco auch in heutigen WLAN Netzen eine gute Figur. WebGUI zur Konfig, Gastnetz Segmentierung und sogar ein Radius Server sind ebenfalls an Bord. Genug Features also, sie in Heimnetzen, kleinen WLAN Umgebungen mit wenig Budget und moderaten Anforderungen wie Z.B. Schulen und Hotels, Cafes usw. erfolgreich einzusetzen.

Wer kann, sollte bevorzugt zum 2602 Modell oder besser 2702 (oder höher) greifen wegen der besseren 5 Ghz Performance.
Die folgende Anleitung gilt generell auch für die Cisco AP Modelle 1700/2600/2700/3500*/3600/3700, denn alle nutzen das gleiche Firmware Image mit dem Dateinamen "ap3g2-xxx" !
(*3502 Modelle nutzen "ap3g1-xxx" als Imagenamen die hier beschriebene Prozedur führt auch da zum Erfolg)

back-to-topWarum umrüsten?


Die Cisco Accesspoints sind primär für den Betrieb mit einem zentralen WLAN Controller (z.B. Cisco AIR-CT2504-5-K9) ausgelegt und kommen deshalb mit einem sehr abgespeckten Firmwareimage daher, dem sog. Lightweight Image. Man bezeichnet diesen Modus entsprechend dann auch als Lightweight Mode.
Für die Nutzung in kleinen WLANs oder Heimnetzen ist dieser Mode nicht geeignet, da man die APs allein und ohne den externen Controller nicht konfigurieren und betreiben kann.
Cisco bietet für diese Access Points aber parallel immer auch ein Firmware Image mit dem ein sog. Standalone Betrieb möglich ist und was so den Controller Zwang beseitigt.
Damit lassen sich die Accesspoints dann wie ein klassischer WLAN Access Point einfach über ein grafisches Webinterface ala FritzBox konfigurieren. Gleichzeitig bietet er auch das gewohnte CLI Konfig Interface.
Dieses Tutorial beschreibt die schnelle und unkomplizierte Firmware Umrüstung dieser Access Points in den Standalone Betrieb. Los gehts...

back-to-topSo wird's gemacht


Man benötigt einen Rechner mit TFTP Server, das Standalone Firmware Image und bei Bedarf einen preiswerten seriellen Terminal Adapter (9600 Baud N81) um am Konsolen Port des Access Points ggf. mitzuverfolgen was der AP so treibt. Diese seriellen Adapter oder Adapterkabel gibt es zuhauf bei den üblichen Versendern wie z.B. HIER.
Sie sind auch allgemein Standard für alle Netzwerkkomponenten verschiedener Hersteller die über eine serielle Schnittstelle gemanagt werden können. Eine Anschaffung lohnt also immer.
Als Terminal Programm nutzt man dann für Windows einen der Klassiker PuTTY oder TeraTerm. MacOS z.B. ZOC und für Linux minicom.
Die Schnittstellen Parameter lauten:
  • 9600 Baud
  • 8 Bits, keine Parity, 1 Stopbit
  • Keine Hardware oder Software Flow Control

Nach dem Booten in den Setup Modus erhält der AP automatisch eine Default IP Adresse von 10.0.0.1 /8 und sucht dann automatisch auf einem TFTP Server im Netz an das er angeschlossen ist nach einem Firmware Image mit dem Namen c1140-k9w7-tar.default (1142N) bzw. ap3g2-k9w7-tar.default (2000er und 3000er Modelle).
Er lädt dieses Image dann automatisch, flasht es in seinen internen Speicher und rebootet danach automatisch in den Standalone Modus.
Im neu gebooteten Standalone Mode sucht der Cisco AP sich dann, wie bei allen APs üblich, per DHCP eine Management IP Adresse im angeschlossenen Netzwerk. Er kann dann über diese Management IP Adresse einfach via Browser WebGUI oder auch via Telnet oder SSH Zugang konfiguriert werden.
Bitte beachten !:
Der SSH und Web Zugang funktionieren nach dem Reboot noch nicht, da die Konfig leer ist !! Es klappt nur mit Telnet z.B. mit PuTTY oder natürlich über die serielle Konsole sofern angeschlossen.
Damit loggt man sich per Telnet im Cisco ein, geht mit conf t in den Konfig Mode und gibt dort ein ip http server. Danach ist das Web GUI erreichbar. (Siehe auch den Hinweis von @Drohnald in den Thread Kommentaren !)

Als TFTP Server kommt hier der bekannte TFTP32_oder_TFTP64 zum Einsatz. Es gehen aber auch Alternativen wie z.B. Pumpkin oder für die Apple MacOS Fraktion TFTP_Server. Linux hat einen TFTP Server von sich aus an Bord.

back-to-topStatische IP setzen


Am Rechner mit dem TFTP Server setzt man eine statische IP Adresse die im gleichen Netzwerk liegen muss wie die Default IP des APs. Hier die 10.0.0.2 am Beispiel von Windows:
ci1

back-to-topTFTP Server installieren und starten


Wichtig ist das man das TFTP Server Dateiverzeichnis "Current Directory" auf das Verzeichnis setzt welches die Firmware Datei mit der Endung .default wie z.B. c1140-k9w7-tar.default enthält.
Wer im Internet nach dem original Firmware Namen z.B. "c1140-k9w7-tar.153-3.JD16.tar" oder auch "c1140-k9w7-tar.153- 3.JD17.tar" sucht bzw. ap3g2-k9w7-tar.153-3 für das 2602I Modell wird schnell fündig (z.B. hier) und muss diese Datei dann einfach auf den Default Namen:
  • c1140-k9w7-tar.default für den Cisco LAP1142N
  • ap3g2-k9w7-tar.default für die Cisco CAP2600, 2700, 3600 und 3700 Modelle
umbenennen.
Ein Check ob der Firmware Dateiname eine "7" enthält wie "..k9w7" zeigt immer das man das Standalone Image hat. Das Controller Image hätte hier eine "8" im Namen.
tf1
Windows User sollten zudem zwingend sicherstellen das in der lokalen Windows Firewall der TFTP Zugang auf den Rechner freigeschaltet ist.
Fehlt diese Erlaubnis in der lokalen Windows Firewall, dann schlägt das Booten der Firmware fehl, weil der TFTP Server nicht gefunden wird (Timeout). Unter Windows ein typischer Fehler für ein Scheitern des Updates ! Die Threaddialoge unten liefern weitere Infos dazu.
fw1
(Einige wenige 2602 Images (und nur 2602) haben im GUI einen "404 Error" wenn man die Konfig sichern will. Das ist aber rein nur im GUI und NICHT im CLI ! Über das CLI lassen sich die APs fehlerlos konfigurieren. (.JAB Suffixe im Firmware Namen sind ohne GUI Fehler.))

back-to-topCisco 1142N, 2602I und 2702l AP Netzwerk Verbindung


Primär arbeiten Premium Access Points immer mit aktivem PoE (Stromversorgung über das Netzwerkkabel) nach 802.3af oder 802.3at Standard, so auch die Cisco APs. sie besitzen aber ebenso einen separaten Netzteil Anschluss mit einem einfachen Standard Hohlstecker für den Betrieb ohne PoE. (+ auf dem Mittelpin).
Wer den AP ohne Netzteil erworben hat und auch kein PoE Switch sein eigen nennt, nimmt einen einfachen .af/.at konformen PoE_Injector oder ein simples Standard 48 Volt (Stecker) Netzteil wie z.B. HIER erhältlich. Jedes 48 Volt Netzteil mit Hohlstecker und + auf dem Mittelpin ist geeignet.
Achtung, der Hohlstecker muss die Abmessungen Ø 5,5 mm / 2,5 mm haben (Lochgröße 2,5mm) ansonsten passt der Stecker nicht.
Die Stromversorgung ist identisch wie sie auch im hiesigen Cisco_Telefon_Tutorial beschrieben ist.
1142n
Vorgehensweise zum Booten in den Flash Mode:
Zum automatischen Booten des Firmware Images hält man am AP den Mode Knopf gedrückt BEVOR man das Netzteil oder den PoE Switch bzw. PoE Injector anschliesst ! Erst dann mit dem PoE Switch verbinden oder Netzteil stecken.
Den Mode Knopf hält man weiter solange gedrückt bis die Status LED an der Front des APs die Farbe von blau blinkend auf rot wechselt und lässt ihn dann los. Das dauert ca. 20 Sekunden.
ap2600.
Der AP kontaktiert dann automatisch den TFTP Server im angeschlossenen Netzwerk und installiert das Image. Der gesamte Flashing Prozess dauert ca. 3-4 Minuten und darf keinesfalls unterbrochen werden.
Man kann dies parallel am fortschreitenden Ladebalken des TFTP Servers genau beobachten oder am seriellen Terminal Port über die dortigen Status Meldungen sofern dieser serielle Port angeschlossen ist.
progress
Bzw. serieller Konsol Port Output (hier etwas gekürzt wiedergegeben):
...
IOS Bootloader - Starting system.
Xmodem file system is available.

DDR values used from system serial eeprom.
Reading cookie from system serial eeprom...Done
Base Ethernet MAC address: f8:66:f2:44:5a:e4
Ethernet speed is 1000 Mb - FULL duplex
button is pressed, wait for button to be released...
button pressed for 27 seconds

process_config_recovery: set IP address and config to default 10.0.0.1
process_config_recovery: image recovery
image_recovery: Download default IOS tar image tftp:/ /255.255.255.255/c1140-k9w7-tar.default

examining image...
extracting info (283 bytes)
Image info: ...


Es ist möglich das in einigen Fällen der Ladebalken am TFTP keinen Fortschritt mehr anzeigt oder die serielle Konsole nach dem Bootprozess folgendes ausgibt:
Not enough free space to download image first w/o extracting
deleting existing version(s)...
Deleting current version: flash:/ap3g2-k9w8-mx.153-x.JXy...done.

Das bedeutet lediglich das mit dem aktuell geflashten Image der Platz im Flash Speicher zum Extrahieren der neuen Firmware zu klein ist und das das System dann automatisch das bestehende Altimage gelöscht hat.
Eine Wiederholung des Boot Prozesses installiert dann im 2ten Anlauf fehlerfrei das gewünschte Image.

back-to-topGrundkonfiguration Access Point


Ist der AP fertig geflasht und gebootet kann man via Netzwerk per Telnet (z.B. PuTTY) oder Browser (secure HTTPS und SSH nur mit entspr. Konfig !) auf den AP zur weiteren Konfiguration zugreifen.
Das Setup des APs ist dann schnell gemacht:
  • User "Cisco", Default Passwort: "Cisco" (C groß !)
  • SSID festlegen und eintragen und bei Bedarf auf VLAN ID mappen
  • WPA-2 Passwort festlegen
  • Wichtig: Den Universal Admin Mode deaktivieren
1142setup
Informationen zur Cisco AP Konfiguration von MSSIDs, also mehreren WLAN Netzen die VLAN IDs zugewiesen werden, im VLAN_Tutorial.
Das Tutorial hat diverse Praxis Setups zu MSSID Designs.
(Falls das Abspeichern der Settings im GUI mit einem "404 Error" quittiert wird, ist das ein bekanntes Verhalten einiger Firmware Images. Generell sind Images mit dem JAB Suffix nicht betroffen. Eine Konfig und die Sicherung über das CLI funktioniert aber immer fehlerlos. (Siehe Kommentar in der Thread Diskussion unten))

back-to-topBeispiel Konfigurationen für MSSID (VLAN) und dynamische VLANs (Radius)

https://administrator.de/contentid/647100#comment-1520714


back-to-topWeiterführende Links


Die Wand- oder Decken Montageplatte findet man unter folgendem Suchbegriff Cisco 69-2160-03 Access Point Mounting Bracket. eBay und Co. führt sie aber auch teilweise mit dem 1142N zusammen auf. Man kann sich aber auch mit einem kleinen Blumendraht pfiffig selber helfen wenn man ihn ohne diese Platte aufhängen möchte.

Cisco Datenblatt zu den 1140er und 2602I APs:
https://www.cisco.com/c/dam/global/de_de/assets/portal-content/produkte- ...
https://www.cisco.com/c/de_de/support/wireless/aironet-2600i-access-poin ...

Cisco Configuration Guide für Autonomous APs:
https://www.cisco.com/c/en/us/td/docs/wireless/access_point/atnms-ap-8x/ ...

Internet Links zu dem Thema:
http://exchange2013pikasuoh.blogspot.com/2015/08/convert-cisco-air-lap1 ...

Anfängerhürden bei einem MBSSID Setup (mehrere WLANs über einen AP) vermeiden:
https://administrator.de/content/detail.php?id=663236&token=607

MSSID/VLAN Tutorial:
https://administrator.de/tutorial/vlan-installation-routing-pfsense-mikr ...
Praxisbeispiel Gast WLAN mit Cisco AP:
https://administrator.de/tutorial/vlan-installation-routing-pfsense-mikr ...

2 IP Netzwerke per WLAN Verbindung koppeln (WLAN Mesh):
https://administrator.de/forum/2-cisco-air-lap1142n-e-k9-als-bridge-verb ...
https://administrator.de/tutorial/wlan-zwei-lan-ip-netzwerke-verbinden-1 ...

WLAN mit dynamischer VLAN Zuweisung:
https://administrator.de/tutorial/dynamische-vlan-zuweisung-wlan-u-lan-c ...

Content-Key: 647100

Url: https://administrator.de/contentid/647100

Ausgedruckt am: 06.10.2022 um 18:10 Uhr

Mitglied: StefanKittel
StefanKittel 03.02.2021 um 16:31:10 Uhr
Goto Top
Hallo,

gibt es die Controller vieleicht auch günstig.
Dann wären die Dinger optimal einzusetzen.

Ich gehe davon aus, dass die nicht so schnell kaputt gehen.

Stefan
Mitglied: aqui
aqui 03.02.2021, aktualisiert am 12.02.2021 um 09:29:48 Uhr
Goto Top
Ich gehe davon aus, dass die nicht so schnell kaputt gehen.
Bei dem mechanisch sehr stabilen Gehäuse und der damit verbundenen optimalen Kühlung tun sie das ganz sicher so schnell nicht... 😉
Mitglied: the-buccaneer
the-buccaneer 09.02.2021 um 02:21:08 Uhr
Goto Top
Blöde (oder doch nicht ganz so?) Frage:

Verbessere ich den WLAN Range und Durchsatz signifikant gegenüber einer ollen FB 7270? Ich hab da relativ wenig Plan.
An der FB wäre nen Port noch frei und Madame und Infant klagen über "Verbindungsprobleme"
(Frage ist "Stabilität". Dass es theoretisch schneller ist kann man an den Daten ablesen...)

Ich konnte diese "Ausfälle" bisher nicht nachvollziehen, aber nen Zehner wärs ja wert. face-wink

Aber auch für Kunden interessant. Preissensitiv sind sie alle. Sogar die Millionäre.... face-wink

CU
Buc
Mitglied: TomTomBon
TomTomBon 09.02.2021 um 08:42:55 Uhr
Goto Top
Moin

Ich bin auch am Überlegen face-wink

DeFakto habe Ich nur Zickereien mit den WLAN Anschlüssen der Fritzen.
Wobei, Ich nicht, sondern Sohne 1, Frau, Sohn 2...

Ich hatte deswegen auch ausgelagert auf einen AP.
Und habe jetzt von 1&1 mit dem neuen Anschluss eine neue Fritze bekommen.
Und mit der 7520 ähnliche Probleme..

Deswegen bin Ich am überlegen da diese Cisco AP wirklich gut sind.
Ich hatte dieses, oder einen Vorgänger, vor 6-7 Jahren in der Firma aufgebaut.
Ausgesucht hatte unser Netzwerk Spezi face-wink
Und sie waren wirklich gut.

Stahl ohne Ende verbaut in dem Gebäude, frei stehend und Luftig sollte es Ender der 90er sein.
--> Stahl.

Die WLAN Vorgänger Versuche waren Mikrowellen Schleudern face-wink
Mitglied: aqui
aqui 09.02.2021, aktualisiert am 31.10.2021 um 12:38:15 Uhr
Goto Top
Mit den optimierten Antennen und MIMO 2x3 sind sie technisch in jedem Falle besser ausgerüstet als die beiden FritzBox Antennen. Ein Versuch für 10 Euro wäre es ja allemal wert. face-wink
Generell ist die WLAN Reichweite damit deutlich besser als die der FB mit ihren einfachen Platinenantennen.
Mitglied: lcer00
lcer00 26.02.2021 um 19:06:02 Uhr
Goto Top
Hallo

@aqui Danke für den Tip.

Kurzes Feedback:

Auf Windows 10 hat die Firewall etwas rumgezickt. Zum Schluss war das Erlauben Netzwerkverkehrs für das Programm tftpd64.exe die Lösung. Nur TFPT Portbasiert hat das nicht geklappt. Vielleicht habe ich ja auch was übersehen.

Dann hat noch der Switch zugeschlagen! Wegen des POE-Stromanschlusses habe ich das über einen SG350X POE-Switch mit einem separaten VLAN für Laptop und AP geschaltet. Nachdem die Firmware geladen war, scheint das aktive Smartport-Feature den Cisco-AP als solchen erkannt zu haben und hat den Port von Access auf Trunk gesetzt. Da ich nicht VLAN 1 sondern anders VLAN genutzt hatte, passte das nicht und die Verbindung zum Webinterface (bzw. überhaupt zum Geräte per Netzwerkkabel) war nicht herzustellen. Hat ne Weile gedauert, bis ich die Ursache gefunden hatte.

Grüße

lcer
Mitglied: aqui
aqui 26.02.2021, aktualisiert am 27.03.2021 um 15:37:01 Uhr
Goto Top
Gut zu wissen...! Das liegt vermutlich daran das bei beiden CDP als Infrastruktur Protokoll im Default aktiv ist und die sich das gegenseitig mitteilen. Auf dem Cisco AP kann man mit no cdp enable dafür sorgen das das nicht passiert.
Mit lldp run sollte man dann immer ein Standard konformes Infrastruktur Protokoll aktivieren.
Gleiches gilt für die Cisco SG Switches wenn die mehrheitlich nicht in einer Cisco Umgebung laufen. CDP=Ausschalten und LLDP=anschalten.
Danke für das Feedback. 👍
Mitglied: Imenov
Imenov 02.03.2021 um 23:33:14 Uhr
Goto Top
Aber muss man dafür rechnen dass , Zertifikate bei 1140 meistens abgelaufen und deswegen AP nicht mehr supported by Cisco, und kommt weitere beschränkungen wie: altere Datum auf WLC oder Scwierigkeiten mit SSL Zertifikate (
Mitglied: aqui
aqui 03.03.2021, aktualisiert am 08.03.2021 um 12:31:03 Uhr
Goto Top
Nein, das ist nicht relevant denn die Zertifikate spielen keinerlei Rolle für den Standalone Betrieb. Einmal abgesehen davon das man sich self-signed Zertifikate jederzeit neu anlegen kann.
Wie bereits gesagt ist das für den Standalone Betrieb ohne WLC vollkommen irrelevant. Es geht hier im Tutorial nur um den Standalone Betrieb ohne Controller.
Mitglied: jonasgrafe
jonasgrafe 07.03.2021 um 16:06:00 Uhr
Goto Top
Welches Image habt ihr für den CAP2602I-E-K9 verwendet und wo habt ihr das gefunden?
Habe viele verschiedene gefunden, aber keins will bis jetzt so richtig (habe noch kein Consolenkabel)
ap3g2-k9w7-tar.153-3.JPJ4
ap3g2-k9w7-tar.153-3.JPJ3
ap3g2-k9w7-tar.153-3.JI5
ap3g2-k9w7-tar.153-3.JAB
Mitglied: aqui
aqui 07.03.2021 aktualisiert um 19:10:37 Uhr
Goto Top
Nimm die vom angegebenen Link oben die funktionieren (getestet) fehlerfrei.
Mitglied: jonasgrafe
jonasgrafe 07.03.2021, aktualisiert am 08.03.2021 um 13:12:55 Uhr
Goto Top
Ok, bis heute Nacht war nur ein Fehler auf der Seite und keine Datei vorhanden. Nun habe ich sie geladen und spiele sie nachher rüber.

Vielen Dank
Mitglied: aqui
aqui 08.03.2021, aktualisiert am 18.07.2022 um 19:55:17 Uhr
Goto Top
Einige wenige Firmware Images wie auch das derzeit Aktuellste für den 2600/2700er haben im GUI einen "404 Error" wenn man die Konfig sichern will. Das ist aber rein nur im GUI. (.JAB Suffixe im Namen sind ohne GUI Fehler.)
Der AP ist aber trotz GUI Fehler voll funktionsfähig und kann ganz normal und problemlos über das CLI konfiguriert werden.

Die folgenden Beispiele zeigen diverse Standard Konfigurationen für bestimmte WLAN Setups.
Den Beispiel Konfig Text sollte man ganz einfach vorab Cut and Pasten in einen einfachen Texteditor der Wahl wie Notepad oder Notepad++ usw. und dann zuerst anpassen auf die eigenen Belange (SSID, Passwörter, Hostname usw.).
Dann nimmt man eine einfaches Terminal Programm wie den Klassiker PuTTY und verbindet sich via Telnet, SSH oder die serielle Konsole auf den AP und geht mit enable und conf t in den Konfig Mode.
Dann pastet man einfach die angepasste Konfig ins Gerät. Das kann man auch blockweise machen z.B. immer mit 5 Zeilen oder pro Interface usw. So behält man idealerweise ggf. auftretende CLI Fehlermeldungen im Auge! 😉

back-to-top1.) SSID Konfiguration ohne VLAN Support

Eine einfache Konfig ohne MSSIDs (VLAN) sieht dann z.B. so aus:
!
service timestamps debug datetime msec
service timestamps log datetime localtime show-timezone year
service password-encryption
!
hostname cisco-ap
!
enable algorithm-type scrypt secret <password>
!
aaa new-model
!
aaa authentication login default local
!
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
dot11 ssid Bitschleuder
band-select
authentication open
authentication key-management wpa version 2
guest-mode
wpa-psk ascii test1234567
!
username admin privilege 15 algorithm-type scrypt secret <password>
!
lldp run
!
interface Dot11Radio0
description 2.4 GHz Radio
no ip address
!
encryption mode ciphers aes-ccm
!
ssid Bitschleuder
!
speed only-ofdm
antenna gain 0
station-role root
dot11 dot11r pre-authentication over-air
dot11 dot11r reassociation-time value 300
world-mode dot11d country-code DE both
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1
description 5 GHz Radio
no ip address
!
encryption mode ciphers aes-ccm
!
ssid Bitschleuder
!
speed throughput
antenna gain 0
peakdetect
no dfs band block
channel width 40-above
(channel width 80)
==> (Bei Modellen ab 2702l mit .11ac Support !)
channel dfs
station-role root
dot11 dot11r pre-authentication over-air
dot11 dot11r reassociation-time value 300
world-mode dot11d country-code DE both
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface GigabitEthernet0
description Lokales LAN
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
description LAN-WLAN Bridge
ip address dhcp client-id GigabitEthernet0
!
no cdp run
!
sntp server ntp0.fau.de


back-to-top2.) MSSID Konfiguration mit statischer VLAN Zuordnung

(Grundkonfig Kommandos der Übersicht halber wegeglassen)
!
dot11 ssid VLAN-1
vlan 1
band-select
authentication open
authentication key-management wpa version 2
mbssid guest-mode
wpa-psk ascii <password>
!
dot11 ssid VLAN-11
vlan 11
band-select
authentication open
authentication key-management wpa version 2
mbssid guest-mode
wpa-psk ascii <password>
!
interface Dot11Radio0
description 2.4 GHz Radio (VLAN1)
no ip address
!
encryption vlan 1 mode ciphers aes-ccm
encryption vlan 11 mode ciphers aes-ccm
ssid VLAN-1
ssid VLAN-11
mbssid
!
speed only-ofdm
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.11
description 2.4 GHz Radio (VLAN11)
encapsulation dot1Q 11

bridge-group 11
bridge-group 11 subscriber-loop-control
bridge-group 11 spanning-disabled
bridge-group 11 block-unknown-source
no bridge-group 11 source-learning
no bridge-group 11 unicast-flooding
!
interface Dot11Radio1
description 5 GHz Radio (VLAN1)
no ip address
!
encryption vlan 1 mode ciphers aes-ccm
encryption vlan 11 mode ciphers aes-ccm
ssid Native
ssid VLAN-11
mbssid
!
speed throughput
channel width 40-above
(channel width 80)
==> (Bei Modellen ab 2702l mit .11ac Support !)
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1.11
description 5 GHz Radio (VLAN11)
encapsulation dot1Q 11

bridge-group 11
bridge-group 11 subscriber-loop-control
bridge-group 11 spanning-disabled
bridge-group 11 block-unknown-source
no bridge-group 11 source-learning
no bridge-group 11 unicast-flooding
!
interface GigabitEthernet0
description LAN Port (VLAN 1,untagged)

no ip address
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface GigabitEthernet0.11
description LAN Port (VLAN 11,tagged)
encapsulation dot1Q 11

bridge-group 11
bridge-group 11 spanning-disabled
no bridge-group 11 source-learning
!
interface BVI1
ip address dhcp client-id GigabitEthernet0
!
bridge 1 route ip
!
sntp server ntp0.fau.de
!


back-to-top3.) AP mit Mac-Address Authentisierung u. dynamischen VLANs via Radius Server


service timestamps debug datetime localtime
service timestamps log datetime localtime year
!
hostname cisco-ap
!
enable algorithm-type scrypt secret <password>
username admin privilege 15 algorithm-type scrypt secret <password>
!
aaa new-model
!
aaa group server radius rad_mac
server name FreeRadius
!
aaa authentication login mac_methods group rad_mac
aaa authorization exec default local
!
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
dot11 vlan-name VLAN-10 vlan 10
dot11 vlan-name VLAN-20 vlan 20
!
dot11 ssid Cisco-AP
vlan 10
band-select
authentication open mac-address mac_methods
guest-mode
!
lldp run
!
interface Dot11Radio0
description 2.4 GHz Radio
no ip address
!
ssid Cisco-AP
!
dot11 dot11r pre-authentication over-air
dot11 dot11r reassociation-time value 300
world-mode dot11d country-code DE both
antenna gain 0
stbc
speed only-ofdm
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.10
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 subscriber-loop-control
bridge-group 10 spanning-disabled
bridge-group 10 block-unknown-source
no bridge-group 10 source-learning
no bridge-group 10 unicast-flooding
!
interface Dot11Radio0.20
encapsulation dot1Q 20
bridge-group 20
bridge-group 20 subscriber-loop-control
bridge-group 20 spanning-disabled
bridge-group 20 block-unknown-source
no bridge-group 20 source-learning
no bridge-group 20 unicast-flooding
!
interface Dot11Radio1
description 5 GHz Radio
no ip address
speed througput
!
ssid Cisco-AP
!
dot11 dot11r pre-authentication over-air
dot11 dot11r reassociation-time value 300
world-mode dot11d country-code DE both
antenna gain 0
no dfs band block
channel dfs
channel width 40-above
(channel width 80)
==> (Bei Modellen ab 2702l mit .11ac Support !)
station-role root
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio1.10
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 subscriber-loop-control
bridge-group 10 spanning-disabled
bridge-group 10 block-unknown-source
no bridge-group 10 source-learning
no bridge-group 10 unicast-flooding
!
interface Dot11Radio1.20
encapsulation dot1Q 20
bridge-group 20
bridge-group 20 subscriber-loop-control
bridge-group 20 spanning-disabled
bridge-group 20 block-unknown-source
no bridge-group 20 source-learning
no bridge-group 20 unicast-flooding
!
interface GigabitEthernet0
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface GigabitEthernet0.10
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 spanning-disabled
no bridge-group 10 source-learning
!
interface GigabitEthernet0.20
encapsulation dot1Q 20
bridge-group 20
bridge-group 20 spanning-disabled
no bridge-group 20 source-learning
!
interface GigabitEthernet1
no ip address
duplex auto
speed auto
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface BVI1
ip address dhcp client-id GigabitEthernet0
!
ip radius source-interface BVI1
no cdp run
!
radius-server attribute 32 include-in-access-req format %h
!
radius server FreeRadius
address ipv4 192.168.178.20 auth-port 1812 acct-port 1813
key geheim123
!
sntp server ntp0.fau.de
!
end


back-to-top4.) 802.1x (Username/Password) AP Konfig mit dynamischen VLANs via Radius Server Authentisierung

Hier muss 802.1x am WLAN Client aktiviert sein und der Radius Server enstpr. Username und Passwort gesetzt haben !
(Beispiel mit VLAN 1 und VLAN 10. Weitere VLANs ggf. hinzufügen !)
!
service timestamps debug datetime localtime
service timestamps log datetime localtime show-timezone year
!
hostname cisco-ap
!
enable algorithm-type scrypt secret <password>
username admin privilege 15 algorithm-type scrypt secret <password>
!
aaa new-model
!
aaa group server radius RADIUS
server name freeradius
!
aaa authentication login default local
aaa authentication login EAP group RADIUS
aaa authorization network default group RADIUS
!
clock timezone CET 1 0
clock summer-time CEST recurring last Sun Mar 2:00 last Sun Oct 3:00
!
dot11 vlan-name VLAN-10 vlan 10
dot11 vlan-name VLAN-20 vlan 20
dot11 vlan-name VLAN-99 vlan 99
!
dot11 ssid DynVLAN-Dot1x
band-select
vlan 10
band-select
authentication open eap EAP
authentication network-eap EAP
authentication key-management wpa version 2
guest-mode
!
lldp run
!
interface Dot11Radio0
description 2.4 GHz Radio
no ip address
!
encryption vlan 10 mode ciphers aes-ccm
!
encryption vlan 20 mode ciphers aes-ccm
!
encryption vlan 99 mode ciphers aes-ccm
!
ssid DynVLAN-Dot1x
!
station-role root
speed only-ofdm
dot11 dot11r pre-authentication over-air
dot11 dot11r reassociation-time value 300
world-mode dot11d country-code DE both
channel width 40-above
(channel width 80)
==> (Bei Modellen ab 2702l mit .11ac Support !)
bridge-group 1
bridge-group 1 subscriber-loop-control
bridge-group 1 spanning-disabled
bridge-group 1 block-unknown-source
no bridge-group 1 source-learning
no bridge-group 1 unicast-flooding
!
interface Dot11Radio0.10
description 2.4 GHz Radio (VLAN10)
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 subscriber-loop-control
bridge-group 10 spanning-disabled
bridge-group 10 block-unknown-source
no bridge-group 10 source-learning
no bridge-group 10 unicast-flooding
!
interface Dot11Radio0.20
description 2.4 GHz Radio (VLAN20)
encapsulation dot1Q 20
bridge-group 0
bridge-group 20 subscriber-loop-control
bridge-group 20 spanning-disabled
bridge-group 20 block-unknown-source
no bridge-group 20 source-learning
no bridge-group 20 unicast-flooding
!
interface Dot11Radio0.99
description 2.4 GHz Radio (VLAN99)
encapsulation dot1Q 99
bridge-group 99
bridge-group 99 subscriber-loop-control
bridge-group 99 spanning-disabled
bridge-group 99 block-unknown-source
no bridge-group 99 source-learning
no bridge-group 99 unicast-flooding
!
!
interface GigabitEthernet0
description Lokales LAN (PoE)
no ip address
bridge-group 1
bridge-group 1 spanning-disabled
no bridge-group 1 source-learning
!
interface GigabitEthernet0.10
description Lokales LAN (VLAN10 Tag)
encapsulation dot1Q 10
bridge-group 10
bridge-group 10 spanning-disabled
no bridge-group 10 source-learning
!
interface GigabitEthernet0.20
description Lokales LAN (VLAN20 Tag)
encapsulation dot1Q 20
bridge-group 20
bridge-group 20 spanning-disabled
no bridge-group 20 source-learning
!
interface GigabitEthernet0.99
description Lokales LAN (VLAN99 Tag)
encapsulation dot1Q 99
bridge-group 99
bridge-group 99 spanning-disabled
no bridge-group 99 source-learning
!
interface BVI1
ip address dhcp client-id GigabitEthernet0
!
no cdp run
!
radius server freeradius
address ipv4 10.1.1.147 auth-port 1812 acct-port 1813
key testing123
!
sntp server ntps1-0.cs.tu-berlin.de
!
end

Achtung: 5 Ghz Konfig der Übersicht halber wegelassen !! Muss entsprechend analog zu dem Beispiel bei der Mac Authentisierung auch gesetzt werden wie das 2,4 Ghz Interface.

back-to-top5.) Cisco APs als WLAN Bridge (Workgroup Bridge)

Diese Konfig verbindet ein remotes Netz via WLAN mit einem bestehenden AP. (WLAN Mesh)
https://administrator.de/forum/2-cisco-air-lap1142n-e-k9-als-bridge-verb ...

(Die Konfigs oben sind für eine für maximale WLAN Geschwindigkeit und schnelles Client Roaming gesetzt ! (2,4 GHz =speed only-ofdm, 5GHz =speed throughput)
Wer den AP mit maximaler Reichweite betreiben will/muss setzt den Speed Mode in beiden Radio Interfaces auf speed range !)
Mitglied: SvenPausN
SvenPausN 15.03.2021 um 12:16:09 Uhr
Goto Top
@ aqui

eine Verständnissfrage hab ich.

Ich hab deine Anweisungen bzgl standalone mit leichten Problemen durchgeführt.
Image geflasht und neu gestartet.

Den AP wollte ich danach übers WI konfigurieren.
Ich bekomm keinen Zugriff auf den AP

Über die Komandozeile bei Win10 finde ich den AP.

Ans Netz gehangen, LED grün, nochmal das Netzwerk gescannt, über die MAC identifiziert mit seiner neuen Netz-IP.

Muss ich zwingend um den AP zu konfigurieren über die serielle Konsolenschnittstelle gehen?
Oder gibts ne andre Möglichkeit das WI zu aktivieren?


Grüße
Sven
Mitglied: aqui
aqui 15.03.2021, aktualisiert am 28.03.2021 um 13:16:53 Uhr
Goto Top
Hi Sven,
Ich bekomm keinen Zugriff auf den AP
Nach den Flashen des neuen Standalone Images und dem anschliessenden Reboot des APs ist das Interface per Default immer im DHCP Client Mode. Sprich es bezieht also immer automatisch eine IP Adresse von einem lokalen DHCP Server der im Netz sein sollte. Ist kein DHCP Server da bekommt der AP dann keine IP und der Zugang ist dann natürlich nur über das serielle Terminal möglich. Klar, denn ohne IP Adresse kein WebGUI, Telnet oder SSH Zugang mit PuTTY.

Du musst also, wie du es ja auch richtig gemacht hast, immer im DHCP Server nachsehen welche IP Adresse dieser an den AP vergeben hat. Das ist dann auch die Ziel IP die man im Browser eingeben muss.
Wenn du ein Terminal dran hast kannst du die aktuelle IP des APs immer mit dem Kommando show ip int brief sehen.
Muss ich zwingend um den AP zu konfigurieren über die serielle Konsolenschnittstelle gehen?
Nein, natürlich nicht. Wenn du die AP IP Adresse kennst gehts per Default auch immer mit dem Browser oder per Telnet oder SSH Zugang mit PuTTY. Das Default Password ist "Cisco" (mit großem "C" !).
Mitglied: SvenPausN
SvenPausN 15.03.2021 um 15:19:02 Uhr
Goto Top
Dann hab ich was mit dem Flashen falsch gemacht.
Über die IP im Browser komm ich nich auf den AP.

Ich flash dann morgen früh nochmals und schau mal ob das gleiche Fehlerbild vorhanden ist.

Das Image für den Standalone hab ich mir unter deinem Link gezogen. Sollte so ja passen.

Grüße
Sven
Mitglied: aqui
aqui 15.03.2021 aktualisiert um 15:35:43 Uhr
Goto Top
Über die IP im Browser komm ich nich auf den AP.
Ist der AP denn überhaupt generell über diese IP pingbar ?
Hast du http:// genommen ?? Das WebGUI kann im Default nur HTTP und nicht HTTPS !
Mitglied: SvenPausN
SvenPausN 15.03.2021 um 18:50:26 Uhr
Goto Top
So,
AP hab ich soweit fix.
Inkl. 2.4 und 5.0 GHz SSID funktioniert fast alles.
Das fast ist für die Funktionalität aber ausschlaggebend.

Ich logge mich mit meinen Endgeräten in die WLAN´s des AP ein und bekomme keinen Internetzugriff mehr.
Ich geh stark davon aus, dass es nur ein verdammtes kleines Häkchen ist welches ich setzen muss.
Die Frage ist nur wo und welches.
Mitglied: aqui
aqui 15.03.2021 aktualisiert um 19:32:33 Uhr
Goto Top
Da die APs ja wie alle APs rein nur als simple Bridges arbeiten kann es also nur am LAN selber liegen an dem diese APs klemmen. Aus diesem LAN kommen ja per DHCP die IP Adresse, Gateway und DNS für die WLAN Clients die der AP nur 1 zu 1 auf die Funkschnittstelle durchreicht.
Vermutlich rennt also da im LAN schon was schief und nicht auf den APs.

Ein simples ipconfig (Windows) oder ein Screenshot der Client IP Settings hätten uns alle hier gleich weitergebracht anstatt erst nachzufragen. face-sad
Dann die üblichen Ping Checks:
  • Ping auf die Router IP
  • Ping auf einen nackte IP im Internet wie z.B. 8.8.8.8 (um DNS Fehlern aus dem Wege zu gehen)
  • Ping auf eine Hostadresse wie www.heise.de um auch den DNS zu checken.
Zu all dem leider keinerlei Info von dir.... face-sad
Auch hättest du mal mit dem Klassiker PuTTY eine simple Telnet oder SSH Session auf die IP des APs aufgemacht und über sein CLI mit show run einmal die Konfig abgezogen.
Auch damit hätten wir alle eine Möglichkeit gehabt dir zielführend zu helfen bzw. du hättest es mit der o.a. Konfig auch selber vergleichen können. Ohne all diese Infos können auch wir leider nur in die Kristallkugel sehen und rumraten...
Mitglied: SvenPausN
SvenPausN 15.03.2021 um 20:14:35 Uhr
Goto Top
Gemach gemach, morgen gibts mehr Infos.
Hab ja nur kurz drüber geschaut und wollt n Status durchgeben;)

Ich nehm mir morgen die Zeit und durchstöber mal alles...
Nachdem ich mal vom Router an bis zum AP alles kontrolliert hab.
Wenn’s irgendwo geblockt wird sollt ich’s finden👍🏼
Wenn nicht kommt meine Frage hier definitiv wieder😂
Euch n schönen Abend 🍷
Grüße
Sven
Mitglied: aqui
aqui 15.03.2021, aktualisiert am 16.03.2021 um 10:19:36 Uhr
Goto Top
Gemach gemach, morgen gibts mehr Infos.
Aaaahhhsooo ! Dann harren wir mal der Dinge....😉
Ggf. neuen Thread aufmachen um das Tutorial hier nicht unnötig aufzublähen...
https://administrator.de/content/detail.php?id=663236&token=495
Mitglied: lcer00
lcer00 15.03.2021 aktualisiert um 21:06:23 Uhr
Goto Top
Hallo,

ein Hinweis dazu doch noch:

Wenn man den AP über die GUI auf eine statische IP einstellt, wird das Default Gateway nicht gesetzt. Daher ist der AP dann nur noch im Subnetz seiner IP erreichbar. Um das zu beheben, muss man das Gateway über die Konsole (seriell/ssh) setzen.

Grüße

lcer
Mitglied: Kuemmel
Kuemmel 18.06.2021 um 18:43:17 Uhr
Goto Top
@aqui
Das von dir verlinkte Netzteil funktioniert leider nicht. Das ist ein Netzteil mit Hohlstecker Ø 5,5 mm / 2,1 mm, man benötigt allerdings ein Netzteil in Ø 5,5 mm / 2,5 mm-Dimension.

Gruß
Kümmel
Mitglied: aqui
aqui 18.06.2021 aktualisiert um 19:39:09 Uhr
Goto Top
Danke dir für den wichtigen Hinweis !!! 👍
Ich korrigiere das !
Das wäre ein Passendes mit Ø 2,5mm für das Loch:
https://www.reichelt.de/tischnetzteil-90-w-48-v-1-87-a-mw-gst90a48-p1710 ...
Da ist es aber IMMER preiswerter einen PoE Injector zu nehmen sofern man keinen PoE Switch hat. Diese Injektoren sind erheblich preiswerter und auch universaler als ein dediziertes Netzteil.
https://www.reichelt.de/power-over-ethernet-poe-high-power-injektor-tpli ...
Mitglied: Kuemmel
Kuemmel 24.06.2021 um 22:35:19 Uhr
Goto Top
@aqui
2 doofe Fragen, aber ich will die Config per SSH einspielen....
  • Wo in deiner Vorlage gibst du eigentlich den WLAN-Channel mit? Den sollte man ja fest zuweisen oder nicht????
  • Wofür sind die ganzen secrets? Fürs Login klar, aber wofür brauch man die anderen? Ich brauche doch nur einen für den Zugang und einen WPA Key?

Der Rest ist einleuchtend.

Kleiner Tipp noch am Rande:
Am besten die Info mit der fehlerhaften Firmware (404-Error im WebInterface) oben in die Beschreibung dazu packen, hab mich schon gewundert warum ich meine neue Firmware nicht zum fliegen bekomme! face-wink
Mitglied: aqui
aqui 25.06.2021 aktualisiert um 10:51:34 Uhr
Goto Top
Doofe Fragen gibts doch nicht, nur doofe Antworten ! 😉

Du hast recht, eine feste Kanalzuweisung fehlt oben, was aber gewollt ist. Der AP arbeitet dann im Auto Mode.
Sprich er scannt alle Kanäle, analysiert dort die Belegung und nimmt dann immer den am wenigsten belegten Kanal. Siehe dazu auch:
https://www.cisco.com/c/en/us/td/docs/wireless/access_point/15-3-3/confi ...
Damit ist immer sichergestellt das der AP in den am geringsten gestörten Kanälen arbeitet.
Wenn du also einen Kanal statisch setzen willst fügst du im Radio Interface noch folgendes Kommando dazu:
channel {frequency | least-congested | width [20 | 40-above | 40-below] | dfs}
Für 2,4 Ghz reicht die Kurzform channel <Frequenz> denn die Bandbreiten Einstellungen sind nur bei 5 Ghz supportet. Welche Channel Werte gelten kannst du, wie Cisco CLI üblich, mit channel ? abfragen.
Wofür sind die ganzen secrets?
Oben ist eine etwas wasserdichtere Zugangssteuerung geschildert die nicht die einfach_zu_knackenden Hash Passwörter benutzt und eine User basierte Zugangssteuerung aktiviert. Bei WLAN sollte man da immer besser auf Nummer sicher gehen.
  • enable algorithm-type scrypt secret <password> Ist das Enable Passwort um in den Privilegde Mode (Konfig Mode zu kommen.
  • Ohne aaa authentication login default local gibst du nur das Enable Passwort ein um in den Privileged Mode zu kommen. Es lässt dann aber jeden unauthorisiert auf den AP.
  • Mit dem o.a. Kommando passiert das nicht und jeder muss sich vorab mit Username und Passwort legitimieren: username admin privilege 15 algorithm-type scrypt secret <password> und dann um in den privileged Mode zu kommen (Konfig) nochmal das Enable Secret eingeben. Mit "banner" könntest du auch noch einen Login Banner senden. Sicher ist sicher... face-wink
  • wpa-psk ascii test1234567 sind pro SSID die WLAN Passwörter. Wenn du mit MSSIDs arbeitest benötigst du ja auch mehrere WPA Keys.

Hoffe das bringt etwas Licht ins Dunkel der Secrets für dich und die Tips setze ich natürlich um ?!
Mitglied: Drohnald
Drohnald 16.07.2021 um 17:53:28 Uhr
Goto Top
Hallo zusammen,
hat zwar ewig gedauert über tftp aber dann alles schön. Dachte ich.
Zwei Tipps noch:

1. Das Flashen ist fertig, wenn der AP dauerhaft grün leuchtet (warte trotzdem noch eine Weile face-smile )
2. Pingbar war das aber weder über ssh noch http zu erreichen. Lustigerweise aber über telnet! Also macht man folgendes:
mit putty und telnet auf die Möhre und mit Username/PW jeweils "Cisco" (C groß, keine " ") anmelden
->
(PW ist wieder "Cisco" mit C groß und ohne "")
->
in den Konfigurationsmodus

Nun muss das enable PW erst geändert werden sonst weigert sich Herr AP den http Server zu aktivieren.

Also ein

in die Konsole prügeln gefolgt von einem


und schon ist das Ding auch über
erreichbar face-smile

@aqui vielen Dank für deine tollen Wissensbeiträge!
Mitglied: aqui
aqui 16.07.2021 aktualisiert um 18:42:46 Uhr
Goto Top
Vielen Dank für dein Feedback ! 🙂
2. Pingbar war das aber weder über ssh noch http zu erreichen.
Das ist auch klar und hat 2 einfache Gründe.
  • Die Konfig ist ja absolut leer. Damit SSH klappt musst zuerst im Setup mit crypto key rsa ein Schlüssel erzeugt werden. Das klappt nur wenn man VORHER den DNS Domain Namen gesetzt hat mit z.B. ip domain name drohnald.home.arpa
  • Der Webzugriff ist ebenso, da völlig leere Konfig im Default, deaktiviert. Mit ip http server aktiviert man ihn im Setup. Mit ip https server statt ohne "s" wäre er sogar noch gesichert !
Und....danke für die 💐 !
Mitglied: Drohnald
Drohnald 16.07.2021 um 21:29:28 Uhr
Goto Top
Im Nachhinein völlig logisch, ich hatte nur die Anleitung so interpretiert, als wäre das per default alles frei:
"Er lädt dieses Image dann automatisch, flasht es in seinen internen Speicher und rebootet danach automatisch in den Standalone Modus.
Im neu gebooteten Standalone Mode sucht der 1142er AP sich dann, wie bei allen APs üblich, per DHCP eine Management IP Adresse im angeschlossenen Netzwerk. Er kann dann über diese Management IP Adresse einfach via Browser WebGUI oder auch via Telnet oder SSH Zugang konfiguriert werden."
Vll. kannst du das anpassen, für die nicht(mehr)-Cisco affinen Kollegen (so wie ich...)
Mitglied: aqui
aqui 17.07.2021 um 09:34:30 Uhr
Goto Top
Erledigt ! face-wink
Mitglied: schlis
schlis 18.08.2021 um 18:27:22 Uhr
Goto Top
Hallo,
funktioniert die Anleitung auch mit einem AIR-CAP2702I-E-K9 und kann ich die oben verlinkte Firmware für den AP nutzen?

Gruß
schlis
Mitglied: aqui
aqui 18.08.2021 aktualisiert um 19:36:18 Uhr
Goto Top
Ja, das Firmware Image ist identisch für die 2700i Modelle. Alle 1700/2700/2600/3600/3700 APs haben alle das gleiche Firmware Image was mit dem Dateinamen "ap3g2-xxx" beginnt.
https://www.cisco.com/c/en/us/td/docs/wireless/access_point/ios/release/ ...
(Siehe Tabelle 1.)
sup
Und die Flash Prozedur ist ebenfalls identisch !
Danke für den Hinweis, habs auch mal so ins Tutorial aufgenommen.
Mitglied: Benandi
Benandi 23.12.2021 aktualisiert um 14:44:32 Uhr
Goto Top
Hallo in die Runde,
Wer im Internet nach dem original Firmware Namen z.B. [...] ap3g2-k9w7-tar.153-3 für das 2602I Modell wird schnell fündig
ohne Wartungsvertag bietet Cisco selbst folgende Firmware an (kostenloser Account nötig):
https://software.cisco.com/download/home/286256843/type/284180979/releas ...
Aironet 2700i Access Point Release 15.3.3-JH ED (Early Deployment (ED) heißt "Software releases that provide new features and new platform support in addition to bug fixes. Cisco IOS CTED, STED, SMED, and XED are variations of ED software releases. ")

Alle 1700/2700/2600/3600/3700 APs haben alle das gleiche Firmware Image was mit dem Dateinamen "ap3g2-xxx" beginnt.
Da die Images identisch sind, kann man damit jedenfalls schon mal starten und sich keine Sorgen darüber machen, ob die Quelle integer ist.
(Eigentlich habe ich was für die 2800er gesucht, aber ab da gibt es wohl nur noch Mobility Express. Anderes Thema face-smile)

Edit: Hinweis auf kostenlosen Gastaccount für Download hinzugefügt
Mitglied: 2458269439
2458269439 09.04.2022 um 16:34:09 Uhr
Goto Top
Hallo zusammen,

ich habe die anleitung soweit gelesen und mir auch die Sache alle downgeloadet.

nun Irgendwie bekomme ich keine verbindet zwischen den AP und der TFTp Software. Firewall ist alles frei,
die IP an dem Lan-anschluss am PC habe ich auch geändert, leider alles ohne erfolg.

Angeschlossen wird der AP am PC wie netzteil und Consolen Steckplatz wie USB.

Jemand eine Idee ??

Danke vielmals für die Hilfe
Mitglied: aqui
aqui 09.04.2022 aktualisiert um 16:40:13 Uhr
Goto Top
Wenn du eine serielle Konsole dranhast kannst du dort einen Output sehen wenn der AP bootet ? Dort sollten in jedem Falle Boot Messages zu sehen sein wie ! (Serial: 9600 Baud, N,8,1)
IOS Bootloader - Starting system.
Xmodem file system is available.
DDR values used from system serial eeprom.
Reading cookie from system serial eeprom...Done

Mitglied: 2458269439
2458269439 09.04.2022 um 16:44:13 Uhr
Goto Top
Leider sehe ich nix face-sad
Mitglied: aqui
aqui 09.04.2022 aktualisiert um 16:51:05 Uhr
Goto Top
Nutzt du einen USB Seriell Adapter ??
Wenn ja hast du den getestet ob der fehlerfrei funktioniert indem du einmal Pin 2 und 3 (RX und TX Data) überbrückst und ein paar Tasten drückst ? Damit sendet das Terminal zu sich selbst und die Tasten sollten auf dem Schirm zu sehen sein.
Das zeigt dann das dein Terminal und der COM Port (Windows) fehlerfrei arbeiten.
Welches Terminal Prg und Kabel nutzt du ?
Auch wenn du nur erstmal den AP einschaltest sollten IMMER Boot Meldungen über das serielle Terminal ausgegeben werden !
Sind die Blinkmuster der Front LED so wie sie sein sollen ?
Mitglied: 2458269439
2458269439 09.04.2022 um 16:52:33 Uhr
Goto Top
Ja ein USB Seriell Adapter und zwar folgendes:
https://www.ebay.de/itm/223727783559?hash=item3417370e87:g:1RgAAOSw2YNgr ...
Überbrückt habe ich noch nichts aber ich werde es mal eben testen, mmal sehen ob hier was Passiert.
was Meinst du mit Terminal Prg und Kabel?
Mitglied: 2458269439
2458269439 09.04.2022 um 17:09:47 Uhr
Goto Top
wie sollen die Blinkmuster den sein?
Das RX am Kabel leucht kurz mal auf und dann wars das aber auch schon.

Sorry für die umstände bin da völlig neu drin face-smile
Mitglied: aqui
aqui 09.04.2022 aktualisiert um 17:19:45 Uhr
Goto Top
wie sollen die Blinkmuster den sein?
Nicht die am seriellen Port (das sind im übrigen auch keine !) sondern die Multicolor LED auf der Frontplatte des APs !!
ap2600.
Die ist mit dem Satz:
"bis die Status LED an der Front des APs die Farbe von blau blinkend auf rot wechselt und lässt ihn dann los. Das dauert ca. 20 Sekunden."
gemeint ! face-wink
Mitglied: 2458269439
2458269439 09.04.2022 um 17:22:17 Uhr
Goto Top
Also ich benutze Putty und das schreibt folgendes:
*Feb 1 13:49:50.415: %CAPWAP-3-DHCP_RENEW: Could not discover WLC. Either IP address is not assigned or assigned IP is wrong. Renewing DHCP IP.
Mitglied: 2458269439
2458269439 09.04.2022 um 17:32:59 Uhr
Goto Top
jetzt schreibt er mir folgendes:
IOS Bootloader - Starting system.
flash is writable
FLASH CHIP: Numonyx Mirrorbit (0089)
Xmodem file system is available.
flashfs[0]: 70 files, 9 directories
flashfs[0]: 0 orphaned files, 0 orphaned directories
flashfs[0]: Total bytes: 31997952
flashfs[0]: Bytes used: 21179904
flashfs[0]: Bytes available: 10818048
flashfs[0]: flashfs fsck took 20 seconds.
Reading cookie from SEEPROM
Base Ethernet MAC address: 4c:4e:35:03:3d:65
Ethernet speed is 100 Mb - FULL Duplex
button pressed for 20 seconds
process_config_recovery: set IP address and config to default 10.0.0.1
process_config_recovery: image recovery
image_recovery: Download default IOS tar image tftp://255.255.255.255/ap3g2-k9w7-tar.default

examining image...
DPAA Set for Independent Mode
DPAA_INIT = 0x0

%Error opening tftp://255.255.255.255/ap3g2-k9w7-tar.default (no such file or directory)ap
Mitglied: aqui
aqui 09.04.2022 aktualisiert um 18:20:16 Uhr
Goto Top
jetzt schreibt er mir folgendes:
Bingo ! Das sieht gut aus ! So sollte es aussehen ! 🙂
Ziegt das der AP physisch OK ist. Allerdings sollte statt der Error Meldung dann ein:
image_recovery: Download default IOS tar image tftp:255.255.255.255/ap3g2-k9w7-tar.default
examining image...
extracting info (283 bytes)
Image info: ... //

folgen. face-sad

Der Fehler zeigt das dein TFTP Server nicht erreichbar ist vom AP oder die IP Adresse des TFTP Rechners nicht stimmt oder die Schreibweise der Datei nicht stimmt.
Welches TFTP Programm nutzt du ?
Hast du das Root Verzeichnis des TFTPs (sofern tu TFTP64 nutzt) richtig auf das Verzeichnis eingestellt wo deine ap3g2-k9w7-tar.default Datei liegt ??
tftp
Auch ein Ping von deinem TFTP Rechner auf die IP 10.0.0.1 des AP muss möglich sein.
Mitglied: 2458269439
2458269439 09.04.2022 um 18:34:32 Uhr
Goto Top
Also ich habe das so gemacht wie beschrieben war.
Die rar datei entpackt auf dem Desktop in einen neuen Ordner Names APImage.
Diese habe ich auch so angegeben in der Dirrectory.

Die IP ändere ich von meinem PC lan anschluss auf 10.0.0.2 so wie es im Bild oben angegeben ist TCP/IP4
Mitglied: aqui
aqui 09.04.2022 um 19:16:32 Uhr
Goto Top
Kannst du die 10.0.0.1 pingen ??
Dann kann es nur noch ein Firewall Problem sein ! Nutzt du Windows ?
Wenn ja schalte temporär mal die Firewall aus
Mitglied: 2458269439
2458269439 09.04.2022 aktualisiert um 19:21:44 Uhr
Goto Top
Wie kann ich auf die 10.0.0.1 PIngen?
firewall war schon aus Trotzdem keine change, muss ich mit dem Internet verbunden sein PC oder AP?
muss ich ein kabel in den AP mit Internet stecken?
Mitglied: aqui
aqui 09.04.2022 um 19:23:31 Uhr
Goto Top
Wenn du Windows hast: Eingabeaufforderung mit "cmd" aufmachen und dort ping 10.0.0.1 eingeben. 😉
muss ich ein kabel in den AP mit Internet stecken?
Nein.
Der AP muss lediglich nur mit deinem PC verbunden sein mit einem Patchkabel oder über einen (PoE) Switch mehr nicht.
Mitglied: 2458269439
2458269439 09.04.2022 um 19:26:49 Uhr
Goto Top
Ping wird ausgeführt für 10.0.0.1 mit 32 Bytes Daten:
Antwort von 10.0.0.5: Zielhost nicht erreichbar.
Antwort von 62.155.244.166: Zielnetz nicht erreichbar.
Antwort von 62.155.244.166: Zielnetz nicht erreichbar.
Antwort von 62.155.244.166: Zielnetz nicht erreichbar.

Ping-Statistik für 10.0.0.1:
Pakete: Gesendet = 4, Empfangen = 4, Verloren = 0
(0% Verlust),
Mitglied: Kuemmel
Kuemmel 10.04.2022 um 09:43:08 Uhr
Goto Top
Zeig mal bitte deine IP-Einstellungen im Windows und dein TFTP-Fenster.
Mitglied: 2458269439
2458269439 10.04.2022 um 09:46:20 Uhr
Goto Top
Habs hin bekommen war ein gdefektes lan kabel zwischen Pc und ap
Mitglied: Kuemmel
Kuemmel 10.04.2022 um 09:50:18 Uhr
Goto Top
Sehr gut!
Mitglied: 2458269439
2458269439 10.04.2022 um 09:53:09 Uhr
Goto Top
Danke schön nochmal an alle ✌🏼
Mitglied: m.fessler
m.fessler 04.09.2022 um 23:07:11 Uhr
Goto Top
Danke für die Idee und die Anleitung!

Die Geräte sind ja am Ende ihres Produktzyklus oder schon knapp drüber.
Wie seht ihr da die Problematik bezüglich Sicherheitsupdates?
Oder ist das im privaten Umfeld wenn nicht gerade ein Scheunentor (Firmware bzw. im Standard selbst) gefunden wird zu verschmerzen?

Sind die ED (Early Deployment) Versionen "stabil genug" oder sollte lieber auf MD (Maintenance Deployment) Versionen gesetzt werden?

Wie schlagen sich eigentlich im direkten Vergleich die Ruckus Unleashed Dinger?
Die sind ja in der Bucht teils auch recht günstig zu bekommen.

Danke und Grüße,
Martin
Mitglied: aqui
aqui 05.09.2022, aktualisiert am 09.09.2022 um 15:07:44 Uhr
Goto Top
Ein guter Punkt. Allerdings ist die Gefahr das da noch Gravierendes kommt eher sehr gering, da WPA2 derzeit als sicher und ausgereift gilt. WPA3 werden sie sicher nicht mehr supporten aber das spielt im SoHo oder Privat erstmal keine so große Rolle da derzeit nur wenige Hardware bzw. Treiber es supportet.
In Bezug aufs Management wäre das dann SSH, HTTPS und SMTPv3. Auch da ist eher wenig zu erwarten denn die verwendeten Crypto Verfahren gelten alle als sicher. Alles in allem also der Impact eher sehr gering zumal es in den vergangenen Jahren keine gravierenden Security Warning in der Produktreihe gab die nicht kurzfristig gefixt wurden.
Das alles ist aber letztlich immer Ermessensache und wie hoch man seine eigene Security Anforderung setzt.
Für das Gros der SoHo und Privatkunden haben diese Punkte sowieso wenig bis keinen Stellenwert da meist ausschliesslich preisorientiert beschafft wird. Zudem haben diese typischen Hersteller keine langfristige und nachhaltige Support Policy wie das die Premiumhersteller mit Wartungsverpflichtungen haben weil die hier gänzlich anderen Anforderungen unterworfen sind.
Was die Releases anbetrifft macht man nichts falsch die von Cisco recommendeten Versionen zu verwenden, das sind die im Download Portal mit einem Stern gekennzeichneten. Bei solcher Firmware mit einer langen Patchhistorie ist aber auch von der latest und greatest stabiler Betrieb zu erwarten bzw. wird später eh MD Level erreichen.
Ruckus Unleashed hat natürlich den unschätzbaren Vorteil einen zentralen Controller gleich mit in der AP Firmware zu haben. Das ist ein wesentlicher Vorteil wenn man nicht nur 1 bis 3 APs hat sondern ein paar mehr. Daher wäre Ruckus auch wegen seiner Beamflex Technologie und der damit besseren Ausleuchtung deutlich im Vorteil.
Cisco supportet onboard Controller im AP nur in seinen Air Express Modellen.
Mitglied: unbelanglos
unbelanglos 09.09.2022 um 11:14:37 Uhr
Goto Top
Wie schaut es mit WPA3 OWE aus? (Opportunistic Wireless Encryption)
Mitglied: aqui
aqui 09.09.2022 um 15:12:52 Uhr
Goto Top
Supportet i.d. Ruckus FW Versionen: Unleashed: 200.8 and above, ZoneDirector: 10.3.0 and above., v/SmartZone: 5.2.0 and above.
Mitglied: Kuemmel
Kuemmel 17.09.2022 aktualisiert um 10:25:47 Uhr
Goto Top
Neue Erkenntnisse (ich hatte mal wieder Zeit):
Das Autonomous AP IOS ist seit 2020 end of life, wird also nur noch mit Sicherheitsupdates gepflegt. Der 404-Error rührt daher, da es Probleme mit den Zertifikaten gibt in neueren Firmwares. Die gute Nachricht: "Unofficially, 1600/2600/3600 share the same IOS as 1700/2700/3700/IW3700". Bedeutet: Auch mit einem 2602 kann man neuere Firmwares betreiben. Deren Web-GUI ist logischerweise genau so EoL, aber für die neueren Modelle gibt es Firmwares, die nicht von Anno kommen und eine funktionsfähige Web-GUI besitzen. Ich bin alle Cisco-Forenbeiträge (es gibt unzählige) die diesen Fehler betreffen durchgegangen, um eine gute Firmware zu finden, allerdings war keine wirklich zufriedenstellend von den genannten. Nach einiger Zeit bin ich auf einen japanischen Beitrag gestoßen, der eine Eierlegende-Wollmilchsau-Firmware nennt:
ap3g2-k9w7-tar.153-3.JI5.tar

Installiert man diese Firmware, hat man eine halbwegs aktuelle (Jahr 2019) Firmware mit funktionsfähigem Web-Interface. Vielleicht hilft diese Information dem ein oder anderen. Natürlich kann man den AP auch einfach per CLI konfigurieren, aber so können auch nicht ganz so technisch Affine Menschen den preiswerten AP konfigurieren.
Mitglied: Gajowy
Gajowy 21.09.2022 um 09:54:11 Uhr
Goto Top
Hallo zusammen, das Flashen war unproblematisch und ich komme auch über den Browser auf die GUI. Wenn ich aber im Easy Setup eine neue SSID anlege wird diese nicht ausgestrahlt. Ich bekommen keinen Fehler.. die neue SSID wird dann auch im SSID Manager angezeigt. Hat jemand eine Idee für mich?
ciscoap
Mitglied: lcer00
lcer00 21.09.2022 um 10:22:40 Uhr
Goto Top
Hallo,
Zitat von @Gajowy:

Hallo zusammen, das Flashen war unproblematisch und ich komme auch über den Browser auf die GUI. Wenn ich aber im Easy Setup eine neue SSID anlege wird diese nicht ausgestrahlt. Ich bekommen keinen Fehler.. die neue SSID wird dann auch im SSID Manager angezeigt. Hat jemand eine Idee für mich?

vielleicht "Broadcast SSID in Beacon" ? Du musst davon ausgehen, dass das Teil eben kein Consumer-Produkt ist, mit Easy-Einstellungen.

Grüße

lcer
Mitglied: aqui
aqui 21.09.2022 um 11:16:19 Uhr
Goto Top
Gehe in die dedizierten WLAN Einstellungen und setze die beiden Radios dort explizit auf enable. Oder nutze noch besser das CLI!
Fertige Konfigs zu allen WLAN Setups gibt es HIER plug and play zum Abtippen.
Mitglied: Gajowy
Gajowy 21.09.2022 um 13:58:31 Uhr
Goto Top
Zitat von @aqui:

Gehe in die dedizierten WLAN Einstellungen und setze die beiden Radios dort explizit auf enable. Oder nutze noch besser das CLI!
Fertige Konfigs zu allen WLAN Setups gibt es HIER plug and play zum Abtippen.

Danke. Tatsächlich konnte ich auch über CLI das SSID nicht aktivieren. Inzwischen habe ich aber die Lösung gefunden: diese war unter dem Menüpunkt: Network > Network Interface > Radio0-802.11N 2.4GHz und ggf. Radio1-802.11N 5GHz.
Mitglied: aqui
aqui 21.09.2022 aktualisiert um 15:02:42 Uhr
Goto Top
Tatsächlich konnte ich auch über CLI das SSID nicht aktivieren.
Da hast du dann wohl das falsche Kommando verwendet?! 🤔
Normalerweise reicht da ein simples no shut ! 😉
cisco-ap(config)#interface Dot11Radio0
cisco-ap(config-if)#no shut

Das gleiche dann nochmal für das 5GHz Radio Dot11Radio1.
Mitglied: Gajowy
Gajowy 22.09.2022 um 07:38:53 Uhr
Goto Top
Zitat von @aqui:

Tatsächlich konnte ich auch über CLI das SSID nicht aktivieren.
Da hast du dann wohl das falsche Kommando verwendet?! 🤔
Normalerweise reicht da ein simples no shut ! 😉
cisco-ap(config)#interface Dot11Radio0
cisco-ap(config-if)#no shut

Das gleiche dann nochmal für das 5GHz Radio Dot11Radio1.

Dann war es wohl doch Layer8 Problem. Bin davon ausgegangen, dass dies im Code oben schon drin steht.
Dankeschön!